20:43:03 <nirik> #startmeeting EPEL (2011-01-10)
20:43:03 <zodbot> Meeting started Mon Jan 10 20:43:03 2011 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:43:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:43:03 <nirik> #meetingname epel
20:43:03 <nirik> #topic init process/agenda
20:43:03 <zodbot> The meeting name has been set to 'epel'
20:43:17 <nirik> Any folks around for an epel meeting?
20:43:25 * tremble lurks
20:43:36 <derks> i'm here for epel meeting
20:43:42 <nirik> derks / tremble / dgilmore / abadger1999 / rsc ?
20:43:49 * abadger1999 lurking
20:43:51 * nirik doesn't really know who wants to be pingged. ;)
20:43:53 <jness> I'm here as well
20:44:15 <nirik> So, what do we have for topics? At least:
20:44:21 <nirik> * EPEL6 beta status
20:45:02 <nirik> any folks have others?
20:46:29 * nirik listens to crickets.
20:46:35 <nirik> #topic EPEL6 beta status
20:46:50 <nirik> so, before the holidays we were thinking of moving out of beta on 2011-01-11.
20:46:53 <nirik> thats tomorrow. ;)
20:47:08 <nirik> we still have broken deps.
20:47:15 <derks> do we know the status of centos 6?
20:48:02 * nirik isn't sure... last I saw was on the centos twitter feed.
20:48:25 <nirik> CentOS-6? not yet, were still looking at a couple of weeks for when its done. 4:01 PM Jan 7th
20:48:31 * nirik gets another phone call.
20:49:14 <nirik> #chair derks jness tremble
20:49:14 <zodbot> Current chairs: derks jness nirik tremble
20:49:24 * nirik has to deal with call... please go on with out me.
20:49:53 <derks> I guess waiting for centos on a new release isn't the same as delaying for point releases...
20:50:44 <nirik> I know there are a few things still in flux in epel...
20:50:51 <nirik> abadger1999 is pondering on turbogears.
20:50:57 <nirik> I'd like to look at Xfce 4.8
20:51:04 <nirik> we need to fix all the broken deps.
20:51:35 <nirik> so, I would personally be ok with pushing out a bit more.
20:51:37 <tremble> did we have a list of broken deps?
20:52:09 <nirik> it's posted to the list on each push as well as mailing the maintainer.
20:52:38 <derks> i haven't seen a broken deps report for epel beta in a while
20:52:52 <derks> err... i guess it is in the beta report
20:53:04 <nirik> it should be on the list every day. ;)
20:53:23 * derks was looking for 'broken deps' in the subject
20:54:38 <derks> are the maintainers of those packages emailed directly as well?
20:55:21 * derks reads above, answers own question
20:58:53 * dgilmore is here
20:59:33 * nirik is still on the phone.
20:59:36 <derks> dgilmore, nirik I think is tied up with a phone call
20:59:37 <derks> yeah
20:59:48 <nirik> #chair dgilmore
20:59:48 <zodbot> Current chairs: derks dgilmore jness nirik tremble
20:59:48 <dgilmore> ok
21:00:23 * dgilmore notes he will generally be unavailable the rest of this week
21:00:50 <derks> discussing EPEL 6 beta... was talked about going out of beta tomorrow (in previous meeting)... but that its looking like we need to push it back
21:01:21 <dgilmore> derks: i think at least for 1 week
21:01:44 <derks> what would be the process of resolving broken deps if the maintainers aren't responsive?
21:02:05 <derks> provenpackagers take over, or drop the packages?
21:02:16 <dgilmore> derks: we will need to move the packages to dist-6E-epel-testing-candidate
21:02:29 <dgilmore> and then the maintainers will need to create updates in bodhi
21:02:30 <tremble> open a bug, if no response ask a pp to help or ask for commit rights
21:02:38 <derks> right on
21:03:07 <dgilmore> derks: we will drop the packages until we have no broken dependecies
21:06:30 <nirik> ok, back now. ;)
21:06:46 <nirik> so, how about we start looking at the 25th for going out of beta?
21:07:22 <derks> sounds good to me
21:07:54 <derks> do we have something in place to automagically move all the broken deps to testing-candidate and open BZ trackers for them?
21:08:08 <nirik> not that I know of.
21:09:01 <nirik> it would probibly have to be manual.
21:09:48 <dgilmore> nirik: i wont be available that week at all to help
21:10:03 <nirik> dgilmore: oh right... when do you get back?
21:10:09 <nirik> I guess we could look at after fudcon...
21:10:18 <dgilmore> ill be at LCA that whole week
21:10:26 <dgilmore> i fly back for fudcon on the 28th
21:10:40 <dgilmore> next week im working from the brisbane office
21:10:45 <dgilmore> so i could help then
21:10:47 <nirik> we could look at the 18th... but then I think you are out then too?
21:10:49 <dgilmore> or after fudcon
21:10:52 <nirik> ah, ok.
21:11:24 <nirik> so 18th, or feb 8th I would say.
21:11:55 <nirik> we could ask for thoughts on list?
21:11:56 <dgilmore> im ok with either
21:12:15 <dgilmore> asking fo thoughts will lead to the latter date i think
21:12:30 <nirik> possibly.
21:12:36 <nirik> abadger1999: any thoughts?
21:12:57 <abadger1999> nirik: I'll flex to whatever everyone else wants.
21:12:58 <derks> waiting till the 8th should give sufficient time to iron out broken deps... compared to jan 18th
21:13:25 * abadger1999 has the feeling that nothing he decides will be ideal no matter how much time he gets to work on it.
21:13:36 <dgilmore> abadger1999: i agree
21:13:54 <nirik> it would be nicer for me to wait, but I have this feeling that if we keep waiting for things we will never get there. ;(
21:14:00 <dgilmore> derks: we cant resolve broken deps properlly until we stop the target from moving
21:14:05 <dgilmore> and only move it slowly
21:14:33 <derks> dgilmore, true
21:15:16 * dgilmore says we announce and scream as loud as we can. that on Jan 18 epel-6 will go ga and bodhi will be required
21:15:45 <dgilmore> we then retarget builds
21:16:05 <dgilmore> and move the tags broken packages are in
21:16:13 <dgilmore> mashing when we thing we have it right
21:16:20 <dgilmore> until we have it right
21:16:22 * nirik would be ok with that.
21:16:34 <dgilmore> its probably going to take a day or so to clean it all up
21:16:38 <nirik> I might untag the existing Xfce packages so I can push 4.8 in later.
21:16:51 <nirik> or try and get them in before then.
21:17:00 <dgilmore> nirik: :) get em in
21:17:09 <nirik> final release is the 16th.
21:17:31 <nirik> so, any objections to the 18th?
21:17:58 <derks> no objections
21:18:16 <dgilmore> nirik: lets make final freeze the 18th release will be a day or 2 later
21:18:41 <nirik> ok.
21:18:51 <dgilmore> we should make it clear there will be a freeze and make sure i's are dotted and t's crossed phase
21:19:03 <nirik> #agreed 2011-01-18 for final epel6 beta freeze, release to be a day or two later.
21:19:16 <nirik> it would be good to have a real release day, so we could announce it and generate some press.
21:19:26 <nirik> #undo
21:19:26 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x12c4e0d0>
21:19:39 <nirik> so, perhaps it would make since for the final freeze to be earlier?
21:21:17 <nirik> How about 13th for freezing, 18th for release?
21:21:45 <nirik> give us a few days to get the tree happy, a weekend for anyone to see any big issues, and then monday to get bodhi happy, tuesday to release?
21:21:45 <dgilmore> nirik: thats probably ok
21:22:12 <nirik> any objections to that proposed plan?
21:22:17 <derks> that's sounds like a good plan
21:22:56 <dgilmore> that means chainbuilds will only work until the 13th
21:23:00 <nirik> right.
21:23:04 <dgilmore> buildroot overrides after that
21:24:09 <nirik> and request to tag into the tree from the 13th-17th, on the 18th bodhi should be active as normal.
21:24:31 <nirik> sounds fine to me.
21:24:46 <nirik> someone want to write up a detailed thing and mail the list about it?
21:25:19 <dgilmore> i can
21:25:44 <nirik> dgilmore: excellent. thanks.
21:26:06 <nirik> #agreed will freeze 2011-01-13, then release 2011-01-18.
21:26:19 <nirik> #action dgilmore to notify list about the changes around beta->released version.
21:26:26 <nirik> Anything else on this topic?
21:27:00 <nirik> #topic Open Floor
21:27:05 <nirik> anything for open floor?
21:27:31 <nirik> Oh, I had one thing:
21:27:45 <nirik> do we want to do any epel related sessions or hackfests at fudcon?
21:27:50 <nirik> who all is going to make it there?
21:28:36 * nirik will be there.
21:28:51 <nirik> anyhow, I guess we are out of time. will close out in a few if nothing else comes up.
21:29:27 <nirik> Thanks for coming everyone!
21:29:30 <nirik> #endmeeting