16:01:49 <smooge> #startmeeting EPEL
16:01:49 <zodbot> Meeting started Fri Sep 19 16:01:49 2014 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:00 <smooge> #meetingname EPEL
16:02:00 <zodbot> The meeting name has been set to 'epel'
16:02:09 <smooge> #chair evolution smooge dgilmore nirik
16:02:09 <zodbot> Current chairs: dgilmore evolution nirik smooge
16:02:14 <dgilmore> hola amigos
16:02:18 <bstinson> hi all
16:02:22 <dgilmore> ¿como estas?
16:02:25 <kushal> Hi everyone.
16:02:26 <smooge> #chair bstinson
16:02:26 <zodbot> Current chairs: bstinson dgilmore evolution nirik smooge
16:02:55 <smooge> #info Greetings and roll call
16:03:06 <smooge> Hi everyone.. I see I am late with the topic item.
16:03:12 <orionp> Good morning
16:03:23 <gaurdro__> g'morning
16:03:29 <smooge> I need to get zodbot oped in this channel but at the moment we can work it as it is
16:03:40 <smooge> #topic Agenda
16:03:55 <smooge> #info Old Business?
16:04:02 <smooge> #info New Business?
16:04:16 <dgilmore> smooge: maybe we should get a trac and use tickets
16:04:18 <smooge> #info RHEL-5.11
16:04:35 <smooge> #topic EPEL security items for RHEL-5
16:04:48 <smooge> #topic website cleanup
16:04:54 <smooge> #topic other things
16:05:17 <smooge> and I am an idiot.. those are meant to be #info
16:05:25 <smooge> ok rolling back
16:05:30 <smooge> #topic Old Business
16:05:49 <smooge> I don't have any old business from previous meetings.
16:05:59 <smooge> but I easily forget :)
16:06:02 <smooge> anyone else?
16:06:02 <Evolution> I don't have any either.
16:06:25 <smooge> ok I think I will have some next week... as we will have stuff to do
16:06:30 <smooge> #topic New Business
16:06:46 <smooge> dgilmore, I agree with you. I think we need a trac
16:07:07 <Evolution> trac works.
16:07:08 <smooge> in the past we were supposed to use the releng one but I think that was when we were 100 packages and not much else
16:07:31 <dgilmore> smooge: i dont think so
16:07:43 <Evolution> would trello be a better fit?
16:07:47 <smooge> dgilmore, I was looking it up in old old old meeting notes
16:07:53 <Evolution> or is that non-free and thus unavailable?
16:07:57 <dgilmore> there is a separate epel-releng list and part of teh releng trac because Jesse wanted nothing to do with EPEL
16:08:43 <dgilmore> smooge: it was only ever for things needing releng attention for epel and was seperate because of Jesse
16:08:57 <dgilmore> smooge: maybe the old notes were poorly worded
16:09:05 <smooge> probably.
16:09:12 <Evolution> does it make sense to maintain the separation from fedora for epel?
16:09:26 <dgilmore> Evolution: no idea what trello is
16:09:30 <Evolution> has epel grown enough that it stands alone (despite sharing common infra)
16:09:40 <dgilmore> Evolution: ive long removed the seperation
16:09:45 <dgilmore> same for secondary arches
16:10:02 <Evolution> fair enough
16:10:03 <dgilmore> at least as releng goes
16:10:06 <smooge> Evolution, it is a larger download set of things than Fedora.. but it has a lot fewer people taking care of it.
16:10:09 <dgilmore> its just part of what we do
16:11:05 <dgilmore> Evolution: i suggest trac because we can get an instance at fedorahosted
16:11:10 <dgilmore> its tied into fas
16:11:13 <kushal> Evolution, trello will be scary for this usecase. A trac would be nice.
16:11:23 <dgilmore> people can file requests to be looked at
16:11:25 <bstinson> +1 for our own trac instance
16:11:33 * nirik is sorta kinda on now, but could drop anytime.
16:11:33 <Evolution> wfm
16:13:10 <smooge> okie dokie. I will put in an infra trac ticket to create an epel trac
16:13:41 <smooge> #action smooge will put in an infra trac ticket to create an epel trac
16:14:33 <smooge> any other new business?
16:15:13 <smooge> ok next topic
16:15:30 <smooge> #topic RHEL-5.11
16:15:47 <smooge> ok RHEL-5.11 was released this week. CentOS is burning coal to get their rebuild done.
16:16:01 <dgilmore> Evolution: get to work :P
16:16:33 <smooge> I think 5.11 was arrfab's tree but not sure. Evolution is just their pretty boy who shovels coal in a tight t-shirt for the cameras
16:16:43 <Evolution> dgilmore: all these meetings get in the way! ;-)
16:17:23 <dgilmore> Evolution: :P ive had almost nothing but meetings for 2 days, i hear you
16:17:27 <Evolution> it's both Arrfab and hughesjr doing it. and 5 has a separate (legacy) build system
16:17:55 <smooge> this is supposed to be the last RHEL-5 release. When 4 went into this state we wdiscussed how we would sunset and lock down new packages to it etc
16:18:36 <smooge> I started looking to see if we had documented the stuff in the wiki tree and then realized how many pages are listed as EPEL and got lost ina  tree of twisty turny passages
16:18:39 <smooge> none alike
16:18:40 <dgilmore> as in the last update with installers?
16:18:51 <Evolution> dgilmore: in theory, yes.
16:19:24 <dgilmore> there has not really been too many new epel 5 packages in awhile
16:19:38 <dgilmore> and the number of updates is a lot less than epel 6
16:19:41 <Evolution> and not many keeping up with the ones it has from the security email.
16:19:48 <dgilmore> :(
16:20:23 <smooge> yeah.. I had an idea last week on how we might help this
16:20:45 <Evolution> don't say docker.
16:20:58 <smooge> what if 1-2 steering committee members focused on a particular release
16:21:07 <smooge> sort of like shephards
16:22:09 <Evolution> is this what it feels like right before the bus hits you?
16:22:30 <smooge> so that problems on security, broken deps, packages which update others have a point person to deal with it
16:22:53 <smooge> well it doesn't have to be just steering committee people..
16:23:14 <smooge> I have been working on 5 because its the oldest and has the most work needed
16:23:25 <maxamillion> oh derp
16:23:30 * maxamillion catches up on backlog
16:23:32 <Evolution> smooge: are you thinking more of being wranglers to chase down people listed as maintainers, or sending emails about build deps?
16:23:47 <Evolution> or actually having committee members step in to take over packages?
16:24:02 <dgilmore> smooge: you're not that intimidating ;)
16:24:10 <smooge> I was looking at the first part. and if CM were proven packagers being able to help fix stuff
16:24:32 <dgilmore> having people to chase people and fix issues as a step of last resort is probably wise
16:24:36 <smooge> dgilmore, well I would use you but you are spread so thin I can see through you
16:24:50 * bstinson can put some time into this
16:24:52 <orionp> I think the big task to make sure packages have active maintainers
16:25:11 <maxamillion> orionp: +1
16:25:22 <dgilmore> this is true for fedora also
16:25:26 <smooge> orionp, yeah. but I am not sure we even do that in fedora :)
16:25:27 <Evolution> that's pretty much exactly it I think.
16:25:45 <dgilmore> I often get emails about packages because ive been the most active person, from doing mass rebuilds
16:26:12 * stahnma is late.
16:26:14 <stahnma> but here
16:26:14 <bstinson> are there EPEL-only provenpackagers?
16:26:18 <orionp> Man, the dgilmore guy does everything :)
16:26:29 <smooge> #topic New Business: Wrangling Relases
16:26:30 <maxamillion> so is the idea to have a subset of the group be provenpackagers that can kind of jump in where there aren't active packagers for some of these older items? is that something that should be in line with the new fedora security group?
16:26:31 <dgilmore> bstinson: there is not
16:27:20 <smooge> maxamillion, so I would like to start off with having people 'wrangle' I can get a group for people in it per release and badges
16:27:42 <Evolution> I see a potential risk in that, strictly from having committee members burn out. I don't think that outweighs the benefit.
16:27:48 <Evolution> just something to be mindful of.
16:27:59 <smooge> then from seeing how bad things are.. to see about provenpackagers helping out
16:28:03 <maxamillion> smooge: alright
16:28:30 <smooge> Evolution, well it is a starting point. I realize it will be a bus if we don't get enough people in the crowd to help out.
16:28:36 <stahnma> bstinson: I've only ever used my super provenpackager powers for EPEL...
16:28:49 <bstinson> Evolution: i think it would definitely have to be "best effort"
16:28:54 <stahnma> but I wouldn't classify myself as an active maintainer right now :(
16:29:04 <smooge> no no no.
16:29:09 <maxamillion> would it be appropriate to apply to be a provenpackager for the sake of helping with this effort or should I just let others who already have it be candidates to join up in the new group?
16:29:13 <smooge> we never ever ever use the word "best effort"
16:29:26 <Evolution> smooge: this is possibly an issue that the centos crowd could help out with, if we can swing more people from 'user' to 'builder'
16:29:27 <smooge> it doesn't mean what we think it means.
16:29:36 <rdieter> maxamillion: I think it's appropriate
16:29:40 <Evolution> as our users tend to not mind focusing on older stuffs.
16:29:48 <smooge> we use the words "doing a reasonable limited effort"
16:30:00 <maxamillion> smooge: +1
16:30:19 <maxamillion> I think "best effort" has an incorrect set of expectations along with it
16:31:07 * bstinson retracts
16:31:47 <maxamillion> that's just my opinion though, I'm certainly open to being told I'm wrong
16:31:49 <smooge> anyway.. back to topic.
16:31:52 <maxamillion> yeah, rgr
16:31:57 <dgilmore> maxamillion: you're wrong :P
16:31:59 <smooge> I would like to take 5
16:32:02 <maxamillion> dgilmore: \o/
16:32:32 <dgilmore> maxamillion: It is like walking a tightrope
16:32:46 * Jeff_S peeks in from the sidelines
16:33:01 <smooge> my job for 5 at this point is to get an idea of what is currently "broke" and then ...
16:33:43 <smooge> well then ... is the question
16:34:10 <smooge> so here is what I have so far with 5 and I need help from other committee members on what we should do
16:34:31 <smooge> we have multiple packages with broken deps due to packages being removed by maintainers
16:34:53 <smooge> we have a couple of packages which update stuff in 5.10
16:35:50 <smooge> we have multiple sets of packages which conflict with each other but do not seem to have 'conflict' tags. Though 5 may be old enough that yum doesn't tell me that but waits til it gets to file conflicts
16:36:30 <smooge> I figure once the EPEL trac is set up I am going to be putting in tickets for each of these but what should our general plan be?
16:36:49 <Evolution> so, assuming we come to a consensus on this (I like the plan) I think we need to communicate this rather loudly to the lists.
16:36:59 <maxamillion> smooge: I think that's a good idea, that way everyone knows where to look for what's in the queue and then can assign tickets to themselves if they want to take on a task
16:37:17 <rdieter> smooge: why trac vs. just filing packaging bugs in bugzilla?
16:37:47 <smooge> rdieter, because I have a hammer and I forgot I had a screwdriver too
16:37:53 <Evolution> rdieter: I think both. trac to keep tabs on things from a committee/admin perspective.
16:38:14 * rdieter hands smooge a protractor, go nuts!
16:38:52 <bstinson> trac is how we escalate to these meetings, correct?
16:39:00 <dgilmore> bstinson: correct
16:40:13 <smooge> ok I will come up with a step by step set of things to do.. something lke 1) find a problem that 'breaks' epel (package conflict, override, broken deps). 2) open a ticket in bugzilla on package, 3) open a ticket in trac listing bugzilla ticket. 4) get ticket on next meeting agenda, 5) get package fixed or removed 6) close ticket in bugzilla, 7) close ticket in trac
16:41:18 <smooge> dgilmore, rdieter does that meet better how we should do things ?
16:42:49 <smooge> checks to see if he fell off the net again
16:43:07 <Evolution> nah.
16:43:38 <Evolution> no, you didn't fall off. yes it makes sense to me. but you didnt' ask me so I didn't reply
16:43:43 <Evolution> :-P
16:43:57 <rdieter> something to consider that scales better long-term: dealing with pkgs with AWOL maintainers (or is this already dealt with reasonably well?)
16:44:08 <dgilmore> smooge: yeah
16:44:22 <smooge> rdieter, it isn't
16:44:50 <rdieter> ie, consider removing unmaintained packages
16:44:53 <smooge> rdieter, I would like to get that dealt with as it is part of the reason we have a lot of 'borked' stuff
16:45:47 <rdieter> <nod>, that's the real bigger problem here, isn't it?
16:45:55 <Evolution> so, one potential hazard of removing packages is that users don't follow lists.
16:45:58 <smooge> I am open to ideas on how we can tell if a packager isn't a Norwegian Blue Parrot or not
16:46:14 <Evolution> if we remove a package because no one's maintaining it, they'll simply see no updates for it and think all is well.
16:46:35 <Evolution> that said, I have a low tolerance for poor admins, and I'm 100% fine with removing insecure packages.
16:46:35 <rdieter> Evolution: cross that bridge when we get to it. :)
16:46:37 <smooge> Evolution, correct.. we have removed various packages in the past and gotten emails months/years later about stuff
16:47:17 <smooge> but I think that we should just say "subscribe to EPEL-announce and check out a monthly report on packages added and removed to each repository"
16:47:20 <rdieter> Evolution: probably nothing can be done really.  all options suck:  forcefully remove eol'd stuff, or leave it to rot
16:47:33 <Evolution> rdieter: I don't disagree.
16:47:55 <Evolution> rhel went the 'forcibly remove' option with oracle's java 1.5 a while back.
16:47:58 <rdieter> smooge's idea is the only/best real option
16:48:15 <Evolution> yeah.
16:48:28 <smooge> ok so back to what I was looking at. Does anyone want to help me on wrangling 6 and 7?
16:49:01 <Evolution> yeah. I'm fine with taking either one.
16:49:03 <bstinson> i can do some wrangling
16:49:06 <Evolution> my primary focus is currently 7
16:49:16 <Evolution> mostly because dockah
16:49:36 <rdieter> smooge: count me in, provenpackager muscle ready to flex as needed
16:50:02 <smooge> ok thanks.
16:50:08 <Evolution> by fedora standards I've only got packager training wheels.
16:50:17 <Evolution> and the paint's still drying on those.
16:50:25 <smooge> Evolution, I would say at this point having someone working on 7
16:50:44 <stahnma> I need to catch up on my own packages/bugs/security fixes
16:50:58 <stahnma> hoping to do that the week after next...since I'm traveling next week
16:51:08 <gaurdro> I'm not a packager, but take direction well and willing to help
16:52:14 <smooge> ok Evolution I am going to put you on 7.
16:52:18 <smooge> I will take 5.
16:52:55 <smooge> we can split 6 at the moment. For people helping out we have rdieter stahnma (on his own items) and gaurdro
16:53:27 <rdieter> where to start?  with broken dep reports?  (are there other sources of data?)
16:53:28 <smooge> gaurdro, if you could email me at smooge@gmail.com with your info if you have a fedora account name and such that would be useful.
16:53:56 <smooge> rdieter, I would start with the broken dep report. I need to fix it by making sure that epel-testing is included in it
16:53:56 <gaurdro> smooge, will do.
16:54:05 <rdieter> k
16:54:12 <smooge> well I need to create 2 reports.. one with and one without
16:54:37 <smooge> rdieter, after that I am working on a set of tools to find other problems
16:54:54 <rdieter> <mr_burns>excellent</..>
16:55:23 <smooge> I currently have a box with everything mirrored that I install centos-X in a mock tree and then see what happens when I do a yum install "*" with epel
16:55:42 <smooge> that is both slow, uses lots of disk space, and not very easy
16:56:46 <smooge> I am trying to get clean it up a bit by having "yum" only do the database updates and not do the file package installs
16:57:41 <smooge> that way we can automate the testing and make it not a 4 hour install just to see if a package causes problems or not
16:58:19 <smooge> but its at the "OMG its full of pythons" stage so may take a while to get done
16:59:13 <smooge> ok we are coming up to an hour and I don't want to keep people over that
16:59:35 <smooge> #topic Open Flood
17:00:08 <smooge> I had a bunch of other items on the agenda.. we have a TON of outstanding security bugs that the Fedora Security Team has put in for us.
17:00:38 * rdieter is proud of getting 4 closed recently (yesterday?)
17:00:43 <smooge> yay!
17:00:50 <Evolution> the bits I'd like to discuss are likely tot ake some time, and are probably best done on the list.
17:01:15 <Evolution> (integration options with centos packagers, user auth/sharing) etc.
17:01:22 <smooge> Evolution, ok open it up on the list and next meeting I will make sure it is our key item so we can summarize, vote if needed
17:01:50 <Evolution> sounds good.
17:02:14 <smooge> any other items from people? Warrior needs coffee badly
17:02:51 <maxamillion> bah, sorry ... got side tracked with work stuff ... will catch up on the backlog, but nothing further from me I need to nag people about
17:03:18 * nirik is back on line again, but no telling for how long. will read back.
17:03:20 <smooge> Ok I am going to close this. I want to thank everyone for coming and helping out. If people have suggestions on how I can run these meetings better or what we need to do, please let me know
17:03:38 <smooge> otherwise, have a good week and see you next Friday
17:03:45 <smooge> #endmeeting