18:00:21 <smooge> #startmeeting EPEL
18:00:21 <zodbot> Meeting started Wed Jan  3 18:00:21 2018 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:21 <zodbot> The meeting name has been set to 'epel'
18:00:21 <smooge> #meetingname EPEL
18:00:21 <zodbot> The meeting name has been set to 'epel'
18:00:21 <smooge> #chair smooge nirik Evolution bstinson avij
18:00:21 <smooge> #topic aloha
18:00:21 <zodbot> Current chairs: Evolution avij bstinson nirik smooge
18:00:34 <avij> hello
18:00:37 <nirik> hey.
18:00:38 <smooge> hi guys
18:00:45 <smooge> I sent out an agenda earlier..
18:01:09 * nirik is behind on email today... it's a deluge. ;(
18:01:10 <smooge> I don't know if we will have quorum
18:01:22 <smooge> so I will just cover the items
18:04:02 <smooge> #topic Peter Robinson's DTS enablement request
18:04:21 * bstinson is here, but also a little behind
18:05:00 <smooge> ಠoಠ
18:06:17 <smooge> so yesterday pbrobinson asked if/when we could have Developer Toolkit enabled in EPEL
18:06:34 <smooge> since this is blocking various things like chromium security updates and other packages
18:07:13 <smooge> I know there had been some questions about doing this so I wanted to get them cleared up if possible
18:07:16 <nirik> I think we talked about this before and were ok with it, as long as it was build time only, and only this one thing not every scl.
18:07:55 <smooge> so that is one thing that I am not clear on. is the DTS an scl? or just another channel with say gcc5 in it?
18:08:28 <nirik> I think it's a scl... but I could be wrong
18:09:42 <bstinson> yeah it's a software collection
18:09:44 <smooge> so one of my questions was going to be the CentOS team: Are these available in CentOS
18:10:50 <bstinson> yep! the SCL SIG works on all of that
18:10:50 <smooge> I am trying to avoid where we are building software which contributors can't build themselves because it is not easily available
18:11:41 <smooge> bstinson, ok thanks that is helpful as we will need to make sure that 'mock' configs can use it if needed
18:13:25 <smooge> ok I guess the next question is what is needed with koji/releng to make sure it works with the system cleanly and doesn't break fedora
18:15:33 <nirik> I think we just need whatever channel it's in added to our sync and then added to koji...
18:15:48 <nirik> the packages that use it would have to change their specs to enable/set it up...
18:15:54 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSccngqiq: siddharthvipul jskarvad Amita ▄▄▄▄▄▄▄▄▄,
18:15:59 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSfbfrdauhg: fab ledeni jskarvad ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
18:16:04 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSahgel: masta jskarvad rmartinelli ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
18:16:09 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSmwuelr: swati mrunge pkotvan ▄▄▄▄▄▄▄▄▄▄▄,
18:16:12 <bstinson> *sigh*
18:16:14 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSaaahabgur: swati plarsen jalalsfs_ ▄▄▄▄▄▄▄▄▄▄�
18:16:19 <mystuff412> ▄▄▄▄▄▄▄▄▄▄▄▄▄▄ A BUSY MEETING IS GOING ON NOW IN #/JOIN ITS A JOINT MEETING WITH THE DISCUSSION OF RE-ENSLAVEMENT OF NIGGERS..MESSAGE CHRONO OR VAP0R FOR DETAILSzzyqikghxx: siddharthvipul1 x3mboy porfiriopaiz ▄▄▄▄▄▄▄▄▄▄▄▄▄▄
18:16:40 <avij> that was quick
18:16:46 <bstinson> #link https://www.softwarecollections.org/en/scls/rhscl/devtoolset-7/
18:16:49 <nirik> they are getting faster at quashing them
18:17:19 <netSys> :/
18:17:19 <avij> #link http://mirror.centos.org/centos/7/sclo/x86_64/rh/devtoolset-7/
18:17:45 <netSys> Spam was detected
18:18:22 <smooge> avij, thanks
18:20:28 <smooge> OK so are we clear enough to go to a vote/approval on this or do we want to do this next week?
18:21:27 <smooge> my link seems to be slogged down at the moment.. so not sure if I am still on or not
18:22:01 <bstinson> i propose we take the next step, which is to talk to releng
18:22:30 <smooge> +1
18:23:38 <avij> indeed, +1
18:24:01 <smooge> nirik, ?
18:24:13 <nirik> sure, +1.
18:24:22 <nirik> as long as it's not pulling runtime into people's machines...
18:24:30 <smooge> #agreed <bstinson> i propose we take the next step, which is to talk to releng
18:25:11 <smooge> i will work with tibbs or someone else on fpc on how to write a policy to say that
18:25:46 <smooge> ok next item
18:25:51 <smooge> #topic Package blocking is no longer available in Fedora build system
18:26:29 <smooge> so in the past we used to be able to block various packages from being built in EPEL while allowing it to be built in other channels
18:27:03 <smooge> this allowed for us to not have to worry about kernel/glibc/some others from getting built and pushed into epel-testing
18:27:06 <nirik> huh? we should be able to block epel packages still... why did that go away?
18:28:06 <smooge> i went to ask if we could block certain packages for EPEL so we could get the packages which are in all shipped arches blocked. I was told that the new system doesn't have this capability. it is all or none
18:28:47 <nirik> that sounds wrong... koji can block packages per tag...
18:29:06 <smooge> nirik, I may have asked the question wrongly.
18:29:37 <nirik> if there's a package thats in epel, then lands in rhel, we can block it in epel just fine...
18:30:23 <bstinson> is this the "it's in base RHEL, but not for the alternate arches, so we need to build it" problem?
18:30:24 <smooge> I think when I asked people thought I was talking about it being stopped in our pkgs side versus in the koji side
18:30:57 <smooge> bstinson, well it sometimes is.. but we had a package which was in all of them get put in
18:31:33 <nirik> there should be a check on the new package creation that would say it's in rhel...
18:31:33 <smooge> I want to get them so they aren't getting put into epel-testing at all versus having to have someone find it, report it, we block or ask the maintainer not to do so
18:32:22 <smooge> there was some part of this system which doesn't exist in the pagure part.
18:32:34 <nirik> ah, perhaps it's not in the new tool?
18:32:45 <smooge> it may have been that part which was not there but I took it to be that was what blocked packages
18:33:17 <smooge> so if koji can block.. can we take the list of src.rpms which are common to all arches and have them blocked there?
18:34:07 <nirik> I suppose. why couldn't we just add the check to the new tool? that seems easier...
18:34:27 <nirik> "Sorry, this package is in RHEL and you are asking for a epel branch, go away"
18:34:40 <avij> that'd be awesome
18:34:52 <nirik> the old tool had that.
18:35:53 <smooge> I don't know. Who owns that tool for me to ask?
18:35:57 <nirik> yeah, the new one just doesn't.
18:36:05 <nirik> https://pagure.io/fedrepo_req
18:39:44 <nirik> smooge: want me to file a ticket ?
18:39:48 <nirik> or you want to?
18:39:57 <smooge> https://pagure.io/fedrepo_req/issue/124
18:40:07 <nirik> ha. fast. ;)
18:40:09 <smooge> please fix the language in it as needed
18:40:43 <smooge> I am trying to file tickets as soon as they come up.. otherwise I end up forgetting for a week and have to go through why did I want this
18:40:51 <nirik> yeah, good policy
18:41:18 <smooge> OK the next item was something tyll said about orphan reports
18:41:50 <smooge> #topic Whence ORPHAN reports
18:42:20 <smooge> since I didn't get the last topic right.. due to misunderstanding the current build system.. I am not sure I get why they aren't working now either :)
18:43:08 <smooge> but it seems that how a package is orphaned is different with the new fedrepo items so it is not clear how to report that they are orphaned unless against everything?
18:43:46 <smooge> nirik, does that sound correct or did I go with the wrong system :)
18:44:23 <nirik> yeah, src.fedoraproject.org has owners for packages... not per branch
18:44:35 <nirik> but we might be able to come up with some way to mark them...
18:45:40 <nirik> I think we might be able to use the override setup to mark them as orphan.
18:45:44 <smooge> ok cool
18:45:46 <nirik> is there anywhere this is being discussed?
18:46:15 <smooge> nirik, not that I know of. tyll mentioned it on a list in December when someone asked why there were no orphan reports
18:46:35 <smooge> beyond that I had not heard anything on the lists I am on.
18:46:37 <nirik> ok. I think I saw a ticket on it somewhere, can hunt for it.
18:47:06 <smooge> ok final item for todays meeting
18:47:15 <smooge> #topic Cleaning up duplicate packages between RHEL Extras and EPEL
18:47:42 <smooge> so an email came out last month on a lot of packages which were in RH Extras and EPEL.
18:48:08 <nirik> odd. I guess they added a bunch in 7.4?
18:48:13 <smooge> I didn't do anything more on it at the time due to travel and all.. but I would like to get it dealt with/commented on
18:48:24 <smooge> I am trying to see if they are continually adding stuff
18:50:02 <smooge> but yeah there were at least 15 duplicates
18:50:15 <smooge> ok that was all I had
18:50:25 <smooge> #topic Announcement: Python-3.6
18:50:43 <smooge> nirik, I saw this as I was scanning for the duplicates
18:52:16 <nirik> yeah. I didn't even know he was working on it, but hurray. ;)
18:52:54 <avij> (for the previous topic) stating the obvious, but all those RH Extras packages you mentioned are in the 'extras' repo in CentOS, I just verified.
18:54:07 <smooge> ok thanks avij
18:54:28 <smooge> nirik, what do we need to do to get them out of epel if that is all done?
18:54:39 <smooge> releng ticket I am guessing
18:54:57 <nirik> yep
18:55:58 <smooge> ok will clear up what they are and do so.
18:56:03 <smooge> alright
18:56:08 <smooge> #topic Open Floor
18:56:16 <smooge> Thank you all for coming today.
18:56:36 <smooge> if there is nothing else I will close this meeting shortly
18:56:46 <bstinson> Happy 2018 all!
18:56:51 <avij> the same
18:57:55 <smooge> See you all next week
18:57:59 <smooge> #endmeeting