18:01:05 <smooge> #startmeeting Fedora/CentOS EPEL meeting
18:01:05 <zodbot> Meeting started Wed Nov 14 18:01:05 2018 UTC.
18:01:05 <zodbot> This meeting is logged and archived in a public location.
18:01:05 <zodbot> The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:05 <zodbot> The meeting name has been set to 'fedora/centos_epel_meeting'
18:01:30 <smooge> #chairs smooge nirik bstinson Evolution avij
18:01:36 <smooge> #chair smooge nirik bstinson Evolution avij
18:01:36 <zodbot> Current chairs: Evolution avij bstinson nirik smooge
18:01:50 <nirik> morning
18:01:55 <avij> good evening
18:02:33 <smooge> #meetingname epel
18:02:33 <zodbot> The meeting name has been set to 'epel'
18:02:33 <pgreco> .hello
18:02:33 <zodbot> pgreco: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
18:02:57 <smooge> sorry for the delay.. the place I keep the meeting notes died this monring
18:03:14 <smooge> I have not seen/heard from bstinson today so I don't know if he can make it
18:03:35 <avij> 18:43 < bstinson> wfm2
18:03:43 <smooge> oh yeah sorry
18:03:48 <smooge> thanks..
18:03:49 <Evolution> sorry I'm late.
18:04:06 <smooge> ok so the main item for todays meeting is giving approval for a couple of items
18:04:44 * bstinson is here
18:05:10 <smooge> #proposal Approve unretiring golang so it can be built and replace deprecated el7 golang https://pagure.io/epel/issue/49
18:05:35 <smooge> #topic Approve unretiring golang so it can be built and replace deprecated el7 golang https://pagure.io/epel/issue/49
18:05:44 <smooge> geez cant type today
18:05:55 <Evolution> is golang out of rhel entirely now?
18:06:01 <smooge> so it is and it isn't
18:06:22 <smooge> it is still in the repositories but it isn't getting any more updates
18:06:43 <nirik> it's essentially dropped.
18:06:43 <smooge> I am guessing in a similar state as ansible2.?
18:07:14 <Evolution> if we're not going to conflict, and we're following the established epel rules, then yeah. +1
18:07:17 <avij> so .. is this going to use a different name?
18:07:52 <smooge> I don't think that was thought of. Is there a reason it should?
18:07:56 <bstinson> did the GO sig have their own discussion on this?
18:08:57 <bstinson> i have no concrete reason to NAK, but just a spidey sense that we should be careful here
18:08:58 <avij> smooge: in principle EPEL pkgs should not (conflict with/update) RHEL pkgs
18:09:18 <avij> if there was no golang at all in rhel 7.6 the situation would be straightforward
18:09:34 <smooge> well in this case it is one of those golang was in EPEL, then it got pulled into RHEL then it got dropped from RHEL.
18:09:40 <avij> but if RH keeps an unmaintained golang in 7.6 it's .. not good.
18:09:53 <Evolution> avij: see also ansible.
18:09:56 <nirik> RHEL never actually removes the packages from extras... which is anoying and strange...
18:10:08 <smooge> technically RH keeps an unmaintained ansible and every other package that they have done this in the past
18:10:09 <nirik> I don't know why
18:10:19 <smooge> because it would break contracts with customers
18:10:51 <smooge> or could potentially make customer X upset while leaving it there allows them to keep getting it years later
18:11:11 <smooge> depends on the customer
18:11:33 <avij> in any case, I'd be okay with EPEL's golang updating RHEL's neglected golang.
18:11:59 <smooge> My goal is to document all our allowed exceptions somewhere on the pagure site this week
18:12:20 <avij> I just wanted to get this exception on record
18:12:44 <smooge> and I want this exception to be recorded here and in the ticket.
18:12:49 <smooge> until that web page is done
18:13:46 <smooge> what is the syntax for a proposal for zodbot?
18:13:49 <nirik> yeah, it would be a lovely thing to document that stuff
18:14:44 <bstinson> i'm ok with updates from here. i wonder what the GO SIG's position is on the toolset though
18:14:47 <smooge> #proposal As golang is deprecated from RHEL7 extras, we approve the golang sig to unretire it in epel-7 branch.
18:15:00 <bstinson> since we're enabling those in special cases for EPEL packages as well
18:15:07 <smooge> so the person who made the proposal seems to be the golang sig lead
18:15:55 <smooge> do you want me to ask in the ticket and then we can approve in the ticket for it to be done?
18:17:04 <bstinson> +1 from me for unretiring
18:17:25 <avij> I don't think there's a #proposal command at all, but I +1 to that #proposal anyway
18:17:53 <nirik> yeah, nothing built in, you can use #agreed to record a accepted proposal tho
18:18:17 <smooge> are there any -1 on this?
18:19:24 <smooge> #agreed As golang is deprecated from RHEL7 extras, we approve the golang sig to unretire it in epel-7 branch.
18:20:15 <smooge> #topic Django update
18:20:18 <smooge> https://pagure.io/epel/issue/48
18:20:41 <smooge> This is basically the maintainer wanting to do a major update because the old version is EOL
18:21:26 <smooge> nirik, already said it was ok with him. bstinson avij Evolution any thoughts?
18:21:44 <bstinson> no objection from me, +1
18:22:04 <Evolution> nope. I'm good with it.
18:22:08 <Evolution> +1
18:22:14 <avij> +1
18:24:14 <smooge> #agreed Django update as outlined in ticket 48
18:25:19 <smooge> Ticket 47 is similar https://pagure.io/epel/issue/47
18:26:01 <smooge> This will be the last one for this meeting as my ability to focus due to pings is dropping exponentially. I will bring the rest up in email for people to approve in tickets
18:26:26 <smooge> #topic CentOS 7.6 status for people wanting to know
18:26:41 <Evolution> yeah, I'm okay with giving ngompa a +1 on this
18:26:45 <avij> yeah, that looks even easier, +1
18:27:03 <bstinson> +1 from me
18:27:18 <nirik> +1
18:27:52 <bstinson> and not only because having a packaged python-celery will make some personal projects easier :P
18:28:02 <smooge> bstinson, Evolution avij anything you wanted to say onit
18:28:16 <smooge> other than it will be ready when its ready :)
18:28:39 <Evolution> CR is imminent. there were a couple linking issues.
18:29:28 <avij> which have now been solved, to the best of my knowledge
18:29:49 <Evolution> yeah. everything I've checked has worked so far.
18:29:52 <smooge> Cool. There were some people who were waiting for pushing epel-testing to epel until 76 came out so I figured to give them info
18:29:56 <smooge> thank you all for that
18:30:04 <avij> I guess I can say that at the moment we're doing testing, instead of rebuilding stuff.
18:30:20 <Evolution> there are some packages for EPEL that need to be rebuilt for 7.6
18:30:38 <Evolution> given the impending CR, and to try to get things out for users faster, when can that start?
18:31:28 <avij> it'd be nice if those packages could be in epel-testing when C7.6 CR is out
18:31:33 <smooge> so I think tdawson filed a tracking bug on them
18:31:51 <smooge> at this point I would say they have had a week and proven packagers can do their thing.
18:32:05 <avij> so that way people should be able to update with a suitable combination of --enablerepo=cr and --enablerepo=epel-testing
18:32:19 <smooge> getting the updates into epel-testing would not break people in epel and allow what avij typed
18:32:30 <avij> yea
18:32:41 <nirik> yeah, they are. The ones people talked about were the mate packages?
18:33:11 <Evolution> yup.
18:33:11 <smooge> cinnamon was the others.. but they were retired
18:33:42 <smooge> I have a proposal on how to 'fix' that but want to write it in email versus trying to freeform it in meeting
18:34:19 <pgreco> smooge, just a question about that
18:34:34 <pgreco> caribou, now that it was obsoleted with <
18:34:34 <smooge> yep?
18:34:45 <pgreco> can/should we provide the newer version?
18:35:42 <smooge> I would expect that if cinnamon is to exist in EPEL it would be required that it was provided here. However.. the people doing that would need to also test to make sure it doesn't break existing GNOME items which obsoleted it
18:35:56 <pgreco> because I think it is the only real problem with cinnamon
18:36:24 <pgreco> I wouldn't expect it to break, since it is how it is done in fedora, but warrants an extensive test
18:36:57 <pgreco> the thing is that if we provide newer caribou, we could even unretire $current versions of cinnamon
18:37:03 <pgreco> until we can build the newer ones
18:37:45 <smooge> tdawson_, put in an email I didn't see until now that he will start rebuilding the ones he can tomorrow
18:38:17 <smooge> well I want to make sure someone is going to 'maintain/package' the items.
18:38:58 <smooge> that means someone needs to handle the bugzillas versus them going to the fedora maintainer who doesn't want to see them
18:39:50 <Evolution> wfm
18:40:21 <smooge> ok
18:40:28 <smooge> #topic Open Floor
18:40:44 <smooge> pgreco, how goes alternatives and such
18:42:57 <pgreco> smooge, not much there
18:43:11 <pgreco> as soon as we have cr for armhfp I'll push some of the pending builds
18:43:23 <pgreco> and try to solve the failing tests
18:43:45 <pgreco> I think I'll have some more news next week
18:43:52 <smooge> cool
18:44:12 <smooge> ok in that case I am done for this week. I will try to get things less on fire for next week
18:44:18 <smooge> thank you all for your time
18:44:23 <smooge> oh wait.
18:44:24 <avij> thanks smooge
18:44:26 <Evolution> thanks for running it.
18:44:54 <smooge> can we move this meeting to this timeslot for a while? I have an outstanding meeting at the previous hour
18:45:02 <avij> wfm
18:45:08 <bstinson> i'm ok with that
18:45:54 <smooge> ok thank you again. I will hopefully see you all next week.
18:46:00 <smooge> #endmeeting