17:59:59 <smooge> #startmeeting EPEL (2019-01-16)
17:59:59 <zodbot> Meeting started Wed Jan 16 17:59:59 2019 UTC.
17:59:59 <zodbot> This meeting is logged and archived in a public location.
17:59:59 <zodbot> The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:59:59 <zodbot> The meeting name has been set to 'epel_(2019-01-16)'
18:00:00 <smooge> #meetingname epel
18:00:00 <smooge> #topic Chair and Introductions
18:00:00 <zodbot> The meeting name has been set to 'epel'
18:00:00 <smooge> #chair avij bstinson Evolution nirik smooge pgreco
18:00:00 <zodbot> Current chairs: Evolution avij bstinson nirik pgreco smooge
18:00:12 <bstinson> hi all
18:00:23 <pgreco> hello
18:00:33 <avij> hi
18:00:39 <nirik> morning
18:03:15 <smooge> hello
18:03:20 <tdawson> Howdy
18:03:22 <smooge> Evolution may be asleep
18:03:45 <smooge> So next week there will be a talk given by me and Kevin on EPEL at devconf.
18:04:07 <smooge> I have found that the best way to either get pinged, have an outage, or a phone call is to open up the docs on it
18:04:25 <smooge> #topic Open Floor (because I have no agenda)
18:04:27 <nirik> ha
18:04:52 * bstinson prepares to sit in front and heckle^H listen for questions
18:05:09 <pgreco> gnome-shell-extension-dash-to-dock ?
18:05:20 <nirik> so I think for epel8 we need to ask some things of mbs folks... I'm going to try and do that before the talk. ;)
18:05:27 <pgreco> am I right that it should be removed?
18:05:45 <bstinson> nirik: a sit down with them would be helpful in general i think
18:05:53 <jsmith> I have lots of questions about EPEL 8, but I'm sure it's much too soon to be asking those :-)
18:05:59 <pgreco> I had filed this pre-7.6 https://pagure.io/epel/issue/44
18:06:12 <tdawson> On an old subject, rhel 7.6 packages that don't install ... I recently went through it again, and the list is much shorter now.   I'm hopefully going to fire up more bugzilla's for the few nodejs and golang packages that still don't install.
18:06:46 <smooge> #topic broken 7.6 packages
18:06:51 <smooge> ok we have an agedna
18:07:02 <smooge> first pgreco.
18:07:21 <smooge> jsmith, the answer is going to be 'modules'
18:07:26 <pgreco> smooge, basically what I saidk
18:07:31 <pgreco> said*
18:07:32 <smooge> pgreco, so is the package in RHEL now?
18:07:43 <smooge> I didn't see it
18:07:46 <pgreco> yes, they introduced a borked version in 7.5
18:07:50 <pgreco> and fixed it for 7.6
18:08:16 <smooge> ok then in that case it should be removed from EPEL
18:09:19 <smooge> and I need to write a document on what steps are needed to remove a package from EPEL
18:09:39 <pgreco> ok, this is as far as I can go
18:11:12 <tdawson> A document would be good, I've been sorta winging it, but they packages get removed.
18:11:26 <smooge> tdawson, nirik, next step is for me to put in a ticket in releng pagure to have it removed ?
18:12:10 <tdawson> I've been using fedpkg
18:13:40 <jsmith> smooge: Thanks... I think?!?
18:14:36 <smooge> ah because you have proven packager rights
18:15:00 <smooge> ok proposal
18:15:06 <tdawson> Oh, that's right ... ok ... then you probrubly need to go through pagure.
18:17:52 <smooge> The EPEL steering committee agrees that gnome-shell-extension-dash-to-dock is to be removed from EPEL because it is available in rhel-7-server-optional-rpms. We will first email besser82 to 'retire' the package in EPEL-7 and retire in general in 2 weeks otherwise.
18:18:11 <smooge> and I screwed up the syntax for a proposal
18:18:38 <smooge> nirik, bstinson avij tdawson pgreco ? help
18:18:39 <bstinson> +1
18:18:47 <pgreco> +1
18:19:02 <tdawson> +1
18:20:36 <smooge> +1
18:20:43 <nirik> +1 sorry had to step away for a sec
18:21:20 * smooge tries to find out if the syntax is #proposal #agree or #agreed
18:21:32 <bstinson> i believe it's #agreed
18:21:33 <avij> sure, +1
18:22:09 <smooge> #agreed The EPEL steering committee agrees that gnome-shell-extension-dash-to-dock is to be removed from EPEL because it is available in rhel-7-server-optional-rpms. We will first email besser82 to 'retire' the package in EPEL-7 and retire in general in 2 weeks otherwise.
18:22:50 <smooge> tdawson, any other packages on the broke list might need help?
18:23:40 <smooge> other wise I think I have one other item.. which I am not too sure on and then jsmith's
18:24:00 <smooge> #topic FESCO Ursa Major proposal
18:24:14 <tdawson> smooge: The python one's.  I'm not really sure what to do when the python2 stuff dissapears.  But I don't have the list in front of me, so I think I'll leave it for an email.
18:24:39 <smooge> ok thanks
18:25:57 <smooge> So earlier this week there was a FESCO meeting and EPEL needing Ursa Major for RHEL-8 was brought up. I think there were a couple of todo's for us from it
18:26:58 <smooge> I believe it is going to be policies for packages, lifetimes for packages and some formal packaging guidelines
18:27:22 <smooge> but I had to deal with a couple of fires during the meeting and didn't get the full details
18:28:30 <sgallagh> One important takeaway is that FESCo gave EPEL approval to stand Ursa Major up in infrastructure
18:28:44 <sgallagh> And to start getting it in shape for RHEL 8
18:28:49 <nirik> for beta/testiing purposes
18:28:52 <sgallagh> right
18:29:05 <bstinson> do we have a deadline to report back to FESCO on those items?
18:29:06 <sgallagh> (Not to be announced for general usage yet)
18:29:31 <smooge> I do not see us having time to do this until 2nd week of February
18:30:36 <smooge> bstinson, I don't know. sgallagh nirik?
18:30:51 <sgallagh> No deadline was specified.
18:30:53 <nirik> no deadline was discussed...
18:31:02 <sgallagh> We basically only voted to unblock EPEL 8
18:32:37 <smooge> so next week I expect is going to be a lot of meetings at BRNO, the next week will be fires we missed from that, and the week after that (first full week of feb) is get back on track week.
18:32:52 <bstinson> ok, i can probably help take a look at some of that
18:33:25 <pgreco> smooge, first full week in feb will be post fosdem
18:33:33 <pgreco> many people going back home, I think
18:34:01 <pgreco> don't know how that affects
18:36:42 <smooge> yeah. conferences do that
18:37:36 <smooge> sgallagh, are you the person who knows ursa-majors hardware/software/memory/etc requirements to set it up? Or is that someone else?
18:37:58 <sgallagh> Definitely not me, sorry :(
18:38:18 <sgallagh> I'd try threebean
18:38:40 <smooge> ok will see if the 2nd week of feb works for scheduling time to set up a devel/stg instance
18:39:21 <smooge> alright I think that is it at the moment on ursa-major
18:39:30 <smooge> #topic Open Floor (jsmith?)
18:40:03 <jsmith> I had a package in EPEL 6, that was removed from EPEL 7 because it was added to RHEL 7
18:40:32 <jsmith> I've opened a bugzilla request to update the version in RHEL 7, as it has known problems.
18:40:45 <jsmith> Never get any feedback, and the package never gets updated...
18:40:53 <jsmith> Any ideas on what we can do to avoid this in the future?
18:41:12 <jsmith> (Not so concerned about this particular package right now as much as I am about fixing the problem in general)
18:42:06 <smooge> well in general if it is in RHEL-7, we don't update/replace even if its broke
18:42:14 <smooge> well in general if it is in RHEL-X, we don't update/replace even if its broke
18:42:29 <smooge> in RHEL-8 we can 'fix' this by making everything a module
18:42:40 <tdawson> Usually the best way I know of is to have some customer file a bugzilla for it.
18:43:08 <smooge> so you could build your fixed version as a module and the customer could replace the RHEL one
18:43:18 <jsmith> OK...
18:43:37 <pgreco> my question would be, if RHEL has package XXX, we can't have XXXX, but can we have XXX0 which obsoletes XXX?
18:43:40 <smooge> but it won't replace it by default... they have to choose to replace it
18:44:22 <smooge> pgreco, in the past no. we are not supposed to do anything that would autobreak a system doing a yum update
18:44:35 <avij> pgreco: nope
18:44:58 <pgreco> thought so :(
18:46:00 <smooge> I believe that modules are probably the only fix other than having an EPEL-webreakyourstuff repo
18:46:20 <jsmith> OK, that's what I thought, but thanks for confirming my suspicions...
18:46:52 <smooge> what was the bugzilla. I can put the 'official' answer in there even if it is disheartening
18:49:53 <smooge> ok anything else.. or time to cal this meeting to a close?
18:50:07 <jsmith> smooge: https://bugzilla.redhat.com/show_bug.cgi?id=1554392
18:51:56 <smooge> ok thanks. will add after meeting
18:52:07 <avij> looks like RH should consider updating the package .. here's hoping.
18:52:42 <smooge> I am going to call this meeting to a close. Thnak you all for coming and we will look for you if possible next week at devconf
18:52:47 <smooge> #endmeeting