21:00:34 <tdawson> #startmeeting EPEL (2020-04-04)
21:00:34 <zodbot> Meeting started Fri Apr  3 21:00:34 2020 UTC.
21:00:34 <zodbot> This meeting is logged and archived in a public location.
21:00:34 <zodbot> The chair is tdawson. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:34 <zodbot> The meeting name has been set to 'epel_(2020-04-04)'
21:00:36 <tdawson> #meetingname epel
21:00:36 <zodbot> The meeting name has been set to 'epel'
21:00:37 <tdawson> #chair nirik tdawson bstinson Evolution pgreco carlwgeorge
21:00:37 <zodbot> Current chairs: Evolution bstinson carlwgeorge nirik pgreco tdawson
21:00:41 <tdawson> #topic aloha
21:00:46 <pgreco> hi
21:00:48 <carlwgeorge> howdy
21:01:26 <tdawson> Hi pgreco and carlwgeorge
21:02:46 * moto-timo joined (fas: ttorling)
21:02:57 <smooge> here
21:03:09 <tdawson> Hi moto-timo and smooge
21:03:22 * tdawson will wait two more minutes to see if more people make it.
21:03:44 * bstinson is lurking
21:04:28 <tdawson> Hi bstinson
21:05:11 <nirik> morning...
21:05:14 <nirik> wait... not morning
21:05:18 <tdawson> Hi nirik
21:05:24 <tdawson> And with that, we'll get started
21:05:28 <tdawson> #info EPEL-6 is End of Life in 2020-11. It will be moved to archives in 2020-12
21:05:29 <tdawson> #info THIS IS NOT A DRILL.
21:05:37 <tdawson> nirik: It's morning somewhere. :)
21:05:51 <nirik> true
21:06:05 <tdawson> Seven months ... whoo hoo.
21:06:11 * moto-timo no longer using epel-6
21:06:24 <moto-timo> but happy to get to the EOL
21:06:47 <pgreco> I still have a few to migrate, hopefully on time...
21:07:03 <tdawson> good luck
21:07:11 <tdawson> #topic EPEL-7
21:07:22 <tdawson> #info RHEL 7.8 is released
21:07:30 <moto-timo> i kind of liked the aloha
21:07:33 <moto-timo> lol
21:07:45 <tdawson> Thank you. :)
21:08:09 <tdawson> How long does it take before EPEL7 is building with the new packages?  Or is it already happening?
21:08:15 <pgreco> did anything break wrt 7.8?
21:08:25 <moto-timo> how are we doing in general in epel-7. I haven't been paying close attention. especially python3
21:08:36 <nirik> it already happened.
21:08:40 <tdawson> Cool
21:08:50 <pgreco> I didn't see anything big about this release
21:08:53 <nirik> there's likely some packages they added that were in epel, we should sort that out
21:08:59 <tdawson> I don't hear of anything big that would break ... so I'm hoping things go ok.
21:09:11 <pgreco> nirik: I didn't see any new packages
21:09:28 <pgreco> a big upgrade from glusterfs from 3.x to 6.x broke some builds in centos
21:09:29 <tdawson> I also haven't done my "will it install" testing.
21:10:01 <tdawson> ouch
21:10:05 <nirik> oh yeah, we are past that point int he cycle I guess.
21:10:58 <pgreco> I was surprised but the samba upgrade this late in the release
21:11:12 <carlwgeorge> the biggest thing i noticed was libselinux-python3 being added
21:11:22 <pgreco> but seems logic, trying to match 8
21:11:37 <pgreco> carlwgeorge: that will stop some complains....
21:11:54 <carlwgeorge> that's why i knew about it, i was one of the complainers
21:13:20 <tdawson> At this point, is there anything that we, in the EPEL community need to do?  Or than test if things install/work ?
21:13:41 <nirik> watch for things that are broken I guess...
21:13:47 <pgreco> doesn't look like it
21:14:17 <tdawson> I was going to run my "will it install" tests next week sometime, but not file bugs, just a big email to the -devel list.
21:14:28 <moto-timo> ++
21:14:37 <tdawson> I'll wait until CentOS 7.8 comes out before starting to file bugs.  Give people some time.
21:14:52 <moto-timo> I'll be testing at the CentOS 7.8 point
21:15:18 <tdawson> Cool
21:15:32 <tdawson> Anything else for 7 before we move to 8?
21:15:46 <cyberpear> which EPEL versions will be following the minor releases?
21:16:05 <nirik> cyberpear: the rhel minor releases? all of them do
21:17:29 <tdawson> cyberpear: EPEL tracks on the latest RHEL release.  We don't have things like EPEL 7.6 or 7.7.
21:17:57 <moto-timo> thank goodness... that would be a burden
21:17:58 <cyberpear> I mean the snapshot in tone
21:18:03 <cyberpear> *time
21:18:05 <tdawson> Many things still install on 7.6 or 7.5, but it's geared towards the latest.
21:18:18 * cyberpear digs thru email
21:19:17 <nirik> oh yeah, we never got to doing that on 7... but we were going to on 8...
21:19:25 <tdawson> Do you mean, when a new release comes out, do we put a snapshot/archive of what we had at that time?
21:19:29 <nirik> basically archive * at 8.1 and 8.2 and
21:19:32 <nirik> yeah
21:19:33 <cyberpear> I thought a few months back there were plans to snapshot EPEL before building latest minor releases
21:19:42 <cyberpear> yes
21:19:52 <moto-timo> that does seem helpful
21:20:35 <cyberpear> that way folks stuck on those can still install something even if old, or even CentOS until it's out
21:20:53 <tdawson> I don't know if we need to do that for 7.7/7.8 other than practice, but I know 8.1 to 8.2 is going to have a few major disruptions.
21:21:18 <cyberpear> (no new builds, but the old content still available)
21:21:20 <smooge> i was looking to do snapshots but we got more complaints from mirrors running out of space
21:21:40 <moto-timo> it's the window between RHEL and CentOS that is probably the main issue...
21:21:55 <cyberpear> can we put it the same place as Fedora archives?
21:21:55 <moto-timo> ah. bummer smooge
21:22:03 <smooge> then I got sidelined with moving fedora infrastructure to a new datacentre
21:22:21 <smooge> cyberpear, I was putting it in the Fedora archives
21:22:33 <cyberpear> (I know everyone is stretched thin.)
21:22:39 <moto-timo> and with the rest of your infinite spare time
21:22:43 <smooge> it is a manual process to do it though
21:22:50 * moto-timo knods
21:23:04 <cyberpear> ok, so the places mirroring that said "to much" sounds like...
21:23:07 <smooge> if someone wants to work out how to do it and help tdawson implement it I think people will be hapy
21:23:36 <cyberpear> I'll volunteer if someone can point me
21:23:43 <tdawson> I don't know if I have the permissions to be able to implement it.
21:24:17 <smooge> tdawson, you have my permission to tell nirik to implement it. He will tell me and I will find some time to do it
21:24:30 <tdawson> *laughs*  OK, sounds good.
21:24:33 <carlwgeorge> lol
21:24:34 <cyberpear> lol
21:24:53 <tdawson> So if we implement it, it needs to be in the archive area?  correct?
21:25:21 <moto-timo> seems like the reasonable compromise
21:25:31 <smooge> i would think so. only 3 sites mirror that
21:25:35 <cyberpear> I'd assume since it's not getting new builds.
21:26:10 <tdawson> nirik: smooge: Do you mind if we start with EPEL7, more for a test?  Or do you think we just stick with EPEL8, since that's what we originally talked about.
21:26:45 * nirik shrugs. Not sure it matters, I guess 7 is most affected right now
21:26:59 <moto-timo> +1
21:27:14 <tdawson> Sounds good.
21:27:15 <nirik> but wait, we are just doing a snapshot of existing rpms off to archive right? we aren't trying to point 7.7 installs to it automatically are we?
21:27:24 <smooge> so /pub/archive/epel/7 has an 'archive' from a couple of months ago
21:27:30 <nirik> ie, user has to find it and use it, not automatic
21:27:41 <tdawson> Correct, not automatic
21:27:47 <moto-timo> yeah, just insurance
21:27:47 <tdawson> But there if someone needs it.
21:28:11 <cyberpear> correct, but it would be good to update mirror manager to honor releasever
21:28:12 <pgreco> a snapshot from today in archive, nothing else
21:28:35 <cyberpear> (strictly optional, but convenient)
21:28:47 <pgreco> completely up to the user to point the repos there
21:28:49 <nirik> I think that would be a bad idea.
21:28:58 <pgreco> how so?
21:28:59 <carlwgeorge> pointing installs to the right place automatically sounds complicated
21:28:59 <nirik> (making it automatic I mean)
21:29:08 <cyberpear> MM knows about EPEL5, IIRC
21:30:07 <cyberpear> bare minimum for it to be useful is for the best to be online somewhere, even if extremely manual to hook it up
21:30:11 <nirik> it's a gigantic change in expectations/behavior. Right now people expect to be pointed at the latest content. If we change that people will silently be using old stuff that they didn't think they were using... it would cause confusion, compromises and doom
21:30:12 <pgreco> I think we all agree that we don't want automatic
21:30:32 <moto-timo> +1
21:30:35 <nirik> also do note that people can get anything from koji anytime they want
21:30:52 <nirik> but the archive seems not too hard to do as a nicety
21:31:01 <moto-timo> +1
21:31:02 <pgreco> this is just, "hey, we saved this for you in case you're stuck with version X"
21:31:33 <carlwgeorge> i'm sure once it exists my former employer will be making custom epel release packages to consume it on frozen centos installs
21:32:12 <cyberpear> right now EPEL 8 repos point to MM with $releasever, but MM doesn't honor it. if my system has 8.1 hard coded, EPEL fails
21:32:14 <smooge> my original idea was to just have the 2nd tuesday of every couple of months 'sync' over EL6/7/8 and run the update-archive script
21:32:24 <smooge> then when it breaks blame microsoft
21:32:38 <cyberpear> lol
21:32:48 <tdawson> *laughs*
21:33:25 <tdawson> #assign cyberpear will work with tdawson to get details for snapshot of EPEL7 worked out.
21:33:31 <tdawson> #assign cyberpear will work with tdawson to get details for snapshot of EPEL7 worked out.
21:33:32 <tdawson> #assign tdawson will work with mirik and smooge to do snapshot of EPEL7
21:33:34 <tdawson> #info snapshot will be just be snapshot, no automatic moving of users there.
21:33:49 <tdawson> *sighs*  lots of typos there. :(
21:34:12 <tdawson> #undo
21:34:13 <zodbot> Removing item from minutes: INFO by tdawson at 21:33:34 : snapshot will be just be snapshot, no automatic moving of users there.
21:34:15 <tdawson> #undo
21:34:15 <zodbot> Removing item from minutes: INFO by tdawson at 21:07:22 : RHEL 7.8 is released
21:34:39 <tdawson> #info RHEL 7.8 is released
21:34:45 <tdawson> #info snapshot will be just be snapshot, no automatic moving of users there.
21:34:56 <tdawson> sorry ... still a bit new to this. :)
21:34:58 <cyberpear> https://fedoraproject.org/wiki/EPEL/Changes/Release_based_package_lifetimes
21:35:11 <cyberpear> that was related, but different, I think
21:35:58 <tdawson> Yep
21:36:47 <tdawson> I'm going to move on.  cyberpear you and I can talk about this later.
21:36:55 <tdawson> #topic EPEL-8
21:37:23 <tdawson> With the -devel stuff in place, as we go through the issues related to missing packages, do we open the CentOS bugs on behalf of the person who filed the EPEL issue, or do we simple tell them about the procedure and let them file the bug?
21:37:50 <tdawson> I keep going back and forth on this.
21:37:56 <nirik> I'd say ask them to...
21:38:06 <bstinson> my preference would be to advise them of the procedure
21:38:10 <nirik> they have more incentive to follow up, etc.
21:38:26 <nirik> where we might forget/get sidetracked... oh SHINY!
21:38:31 <moto-timo> agreed. lazy me wants the automatic, but... procedure is saner
21:38:32 <pgreco> yeap
21:39:02 <carlwgeorge> does having the bug in the centos bug tracker actually make a difference?
21:39:05 <tdawson> OK, simple enough.  I'll put a note in each of those issues.
21:39:07 <moto-timo> main thing would be that it's clearly documented somewhere and easy to point to
21:39:11 <bstinson> carlwgeorge: it does
21:39:29 <tdawson> carlwgeorge: That's how CentOS knows what packages to put in there.
21:40:07 <carlwgeorge> not hard to look in both places.  if we were staring from scratch, i'd say sure stick to one.
21:40:29 <bstinson> i'm happy to link to EPEL issues to string the threads together. but we need full information (devel package requested, what the devel package is used to build) in bugs.centos.org
21:40:35 <carlwgeorge> it just feels like a bad user experience to say "file an issue here" then "no wait do it over here"
21:40:47 <smooge> i feel bad about this also
21:41:10 <moto-timo> agreed, but complicated
21:41:18 <smooge> I was originally told to get people to file in bugzilla.redhat.com. Then I was told that was not needed and to take a list of packages for EPEL to rebuild
21:41:35 <smooge> tdawson, you do whatever you need on this and use the first envelope
21:41:46 <tdawson> I'm fine filing the bugs  In fact, I almost started doing it before I stopped myself.
21:42:47 <tdawson> Maybe I'll do a combination.  I'll tell them where to file it, and if they don't have a centos bug account, I'll file it for them.
21:43:15 <nirik> thats what I do with bugs usually...
21:43:22 <tdawson> OK
21:43:25 <moto-timo> note to self: get a centos bug account
21:43:27 <nirik> ask them to file upstream, if they don't want to, I do it.
21:43:40 <tdawson> Oh, we're running short, and I have two more things.
21:43:59 <tdawson> #info https://pagure.io/fedora-infrastructure/issue/8690 Can't build module with dependency on module in RHEL
21:44:01 <tdawson> .ticket 8690
21:44:02 <zodbot> tdawson: Issue #8690: Can't build module with dependency on module in RHEL - fedora-infrastructure - Pagure.io - https://pagure.io/fedora-infrastructure/issue/8690
21:44:11 <tdawson> Do we know how this is coming along?
21:44:27 <tdawson> I've talked to merlinm but didn't know if he was needed or not.
21:44:46 <nirik> well, I have 0 idea how to solve it... so someone else is needed for sure.
21:45:11 <pgreco> can the user add some tag inheritance when building a module?
21:45:41 <nirik> mbs does that, but here it has no idea what to add to the buildroot.
21:45:41 <tdawson> pgreco: It's a matter of pulling in the module for RHEL.  They just aren't there, whether they tag or not.
21:46:18 <pgreco> right, but default modules (untagged from rhel) should be already there
21:46:30 <pgreco> and epel modules should have the tags
21:46:35 <nirik> not that mbs knows
21:46:57 <pgreco> not in mbs, in koji
21:47:57 <nirik> mbs is building the module. the module says "hey, I buildrequire this other module". mbs says "what? no module I know of... sorry"
21:48:15 <tdawson> Sounds like merlin's expertise is needed.  I'll send an email with nirik and mboddu, and the issue, get the conversation started.
21:48:29 <nirik> yeah, I don't know what the plan was to make it work.
21:48:47 <pgreco> nirik, that's why I'm asking if the user can add tag to his own module
21:48:52 * moto-timo bites tongue
21:49:01 <pgreco> so koji could add the inheritance
21:49:19 <pgreco> without involving mbs
21:49:20 <nirik> how would the user know what to tag?
21:49:32 <pgreco> look for it in koji
21:49:41 <pgreco> not easy, I know
21:49:42 <nirik> our rhel8 repo has no modular repodata in it.
21:49:49 <nirik> it's a flat pile of rpms
21:50:09 <pgreco> ok, I'm talking about epel modules depending on epel modules
21:50:19 <pgreco> not depending on rhel modules
21:50:22 <nirik> ah, I was talking about epel modules depending on rhel modules
21:50:37 <pgreco> so looks like I misunderstood the problem :)
21:50:40 <moto-timo> which is what the issue was
21:50:45 <tdawson> Yep, the ticket is about using RHEL modules.
21:50:56 <nirik> yeah, epel modules should work... because mbs knows about them...
21:51:08 <tdawson> Sorry for rushing this, but I really wanted to get to the last issue.
21:51:17 <tdawson> #topic General Issues
21:51:19 <tdawson> #info https://pagure.io/epel/issue/101 Policy for stalled EPEL requests
21:51:20 <tdawson> .ticket 101
21:51:21 <zodbot> tdawson: Issue #101: Fedora Infrastructure Change Freeze - fedora-infrastructure - Pagure.io - https://pagure.io/fedora-infrastructure/issue/101
21:51:34 <nirik> so, we actualy used to have a policy on this back in the pkgdb days.
21:52:19 * jsmith lurks because he's passionate about his particular topic
21:52:51 <tdawson> I remember being able to ask to be the EPEL package owner, and it was just a matter of someone pressing a button and it was so.
21:53:22 <nirik> huh...
21:53:33 <tdawson> nirik: smooge: do either of you remember what the policy was in the pkgdb days?
21:53:37 <nirik> the one I see on the wiki isn't what I remember... :)
21:53:41 <nirik> "If the maintainer does not act on the bug within 2 weeks, the proposed EPEL maintainer should bring it up with the EPSCO committee to see if they can see why it is not happening or if some other process needs to be followed. [There are some packages which are always exceptions and can need extra rules to follow.] "
21:54:43 <cyberpear> must one become a fedora packager prior to being able to maintain EPEL packages?
21:54:58 <moto-timo> of course
21:55:26 <tdawson> Although, your first package can be an EPEL package, but you still need to follow those proceedures.
21:55:31 <nirik> I recall it was something like... if N weeks with no answer the requestor is added as a co-maintainer and the branch is granted.
21:55:56 <moto-timo> weird that zodbot picked up the wrong ticket
21:56:29 <cyberpear> (btw, I found it https://fedoraproject.org/wiki/EPEL/Changes/Minor_release_based_composes )
21:56:38 <tdawson> Sorry ... https://pagure.io/epel/issue/101
21:56:45 <moto-timo> I found it, thanks
21:57:08 <nirik> "ticket" is for infrastructure tickets. I think there's a 'epel' one for epel tickets.
21:57:21 <tdawson> .epel 101
21:57:22 <zodbot> tdawson: Issue #101: Policy for stalled EPEL requests - epel - Pagure.io - https://pagure.io/epel/issue/101
21:57:26 <moto-timo> :)
21:57:30 <tdawson> Ahhh ... cool
21:57:52 <moto-timo> so, if someone then becomes co-maintainer--- there is nothing stopping them from committing to the non epel branches is there?
21:58:02 <tdawson> Anyway, we don't need to figure out the policy today, but should we pursue this and make it easier.
21:58:06 <nirik> anyhow, this is a balance between acting too fast for a maintainer thats busy or away and never getting any answer... I'm not sure what the best timelimit might be
21:58:19 <moto-timo> some folks in the past got very upset about me "touching their packages"
21:58:20 <nirik> moto-timo: nope. Not currently
21:58:24 <tdawson> moto-timo: correct, if someone is already a co-maintainer, they can do the branch.
21:58:40 <moto-timo> I don't have an issue. And those people aren't active anymore
21:58:46 <nirik> answer: They are NOT your packages. ;) You are simply watching after them for the fedora/epel community.
21:58:51 <moto-timo> indeed
21:59:00 <nirik> yeah, there are always some people...
21:59:17 <moto-timo> The propsal seems good to me
21:59:17 <nirik> anyhow, I guess discuss on list? vote next week?
21:59:21 <moto-timo> shameless plug
21:59:24 <cyberpear> I think per branch ACLs are incoming shortly
21:59:39 <nirik> 2 weeks sound reasonable? or should it be more?
21:59:39 <moto-timo> #link https://bugzilla.redhat.com/show_bug.cgi?id=1819818
21:59:40 <tdawson> Yep, I agree, discuss on list and vote next week ... or two weeks.
21:59:58 <nirik> hum, this might also be anoying to process for releng.
22:00:00 <moto-timo> any help or advise appreciated, as I haven't done the epel-8 packaging dance yet
22:00:50 <moto-timo> because releng would have to manually add the co-maintainer?
22:00:51 <tdawson> nirik: Yep, we have to get rel-eng into this, or at least make it a process that works with what they already have.
22:00:56 <nirik> I'm not sure how we can make this non manual, but we should try. :)
22:01:07 <tdawson> Yep.
22:01:13 <moto-timo> they have enough to do
22:01:20 <nirik> yeah because it means checking a bugzilla bug for time and no answer from maintainer and then processing it.
22:01:39 <tdawson> #action tdawson will send email to epel-devel about ticket 101, starting the conversation to figure out how to do it.
22:01:43 <nirik> we are looking at making unretire more automatic, this might fit in with that
22:02:46 <tdawson> How many people are going to be here next week?  It's a work holiday in many countries.
22:03:30 <pgreco> I still have 1 more week quarantine here in Arg..., so I'll be here
22:03:46 * cyberpear will jump in if available
22:03:55 <moto-timo> FWIW I'll be here
22:04:04 <pgreco> but yeah, I had forgotten about Group Friday
22:04:10 <pgreco> *Good
22:04:27 * moto-timo locked down for another month
22:04:48 * nirik should be around yeah
22:04:58 <carlwgeorge> i'll be here
22:05:08 <tdawson> Looks like we should still have it then.  Sounds good.
22:05:27 <cyberpear> #link https://lists.fedoraproject.org/archives/list/epel-devel@lists.fedoraproject.org/thread/FSBNJOCFQ65SK4SEGWC3RV6YKKXKVFNG/
22:05:38 <tdawson> Thanks everyone for coming, and contributing to the conversations.
22:05:48 <tdawson> We'll talk to you next week, if not sooner.
22:05:55 <tdawson> #endmeeting