21:00:17 <tdawson> #startmeeting EPEL (2020-05-08)
21:00:17 <zodbot> Meeting started Fri May  8 21:00:17 2020 UTC.
21:00:17 <zodbot> This meeting is logged and archived in a public location.
21:00:17 <zodbot> The chair is tdawson. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:17 <zodbot> The meeting name has been set to 'epel_(2020-05-08)'
21:00:18 <tdawson> #meetingname epel
21:00:18 <zodbot> The meeting name has been set to 'epel'
21:00:20 <tdawson> #chair nirik tdawson bstinson Evolution pgreco carlwgeorge
21:00:20 <zodbot> Current chairs: Evolution bstinson carlwgeorge nirik pgreco tdawson
21:00:21 <tdawson> #topic aloha
21:00:36 <pgreco> hi everybody!
21:00:40 * moto-timo joins
21:00:41 <nirik> afternoon.
21:01:14 <tdawson> Hi pgreco
21:01:19 <tdawson> Hi moto-timo and nirik
21:01:49 <nirik> how's things tdawson
21:01:57 <rsc> Hi
21:02:30 <tdawson> Fairly good.  I just finished a couple of high workload tasks, so I might have more spare time.
21:02:34 <tdawson> Hi rsc
21:02:48 <pgreco> spare time? what's that?
21:03:28 <nirik> not sure.
21:04:03 <tdawson> Ha!  Means I can spend more time in general EPEL things. :)
21:04:53 <pgreco> oh, you mean the time you use to work on things you don't get paid for, ok ;)
21:05:01 <tdawson> :)
21:05:02 <carlwgeorge> howdy yall
21:05:07 <tdawson> Hi carlwgeorge
21:05:18 <tdawson> pgreco: You saw that huh. :)
21:05:58 <tdawson> #topic Old Business
21:06:00 <tdawson> #info python38-rpm-macros brought into EPEL8.2 buildroot
21:06:01 <tdawson> .epel 103
21:06:03 <zodbot> tdawson: Issue #103: python38-rpm-macros brought into EPEL8.2 buildroot - epel - Pagure.io - https://pagure.io/epel/issue/103
21:06:11 <tdawson> I think this one should be quick.
21:06:53 <tdawson> The resolution is currently going to be, to remove the BuildRequires that was causing the issue.
21:07:24 <tdawson> That was the proposal by the person who originally put it in there.
21:08:16 <nirik> so, +1 to solved problems. ;)
21:08:20 <tdawson> Side effect: If using _python3 and expect it to point to 3.8, need to add python38-rpm-macros as a build dependency.
21:08:45 <tdawson> Yep ... since we talked about it last week, I just through I'd bring up the resolution.
21:09:05 <tdawson> Moving on ...
21:09:12 <tdawson> #info What to do with epl8-playground
21:09:33 <tdawson> This one's a little bigger ... and I was/am hoping that bstinson is around.
21:09:49 <nirik> I don't think hes had time to put anything together.
21:10:13 <moto-timo> what is this "time" you speak of ;P
21:10:18 <tdawson> Understood. :)
21:10:27 * bstinson comes back from a netsplit
21:10:47 <bstinson> i have the skeleton of the proposal done, but nothing meaningful to report back yet
21:11:04 <tdawson> bstinson: Do you have a quick summary, overview, or would you rather wait.
21:11:35 <bstinson> i'll try to come with something next meeting
21:11:52 <tdawson> bstinson: Sounds good.
21:12:14 <tdawson> #info "What to do with epel8-playground" postponed until next meeting.
21:12:44 <tdawson> #info EPEL-6 is End of Life in 2020-11. It will be moved to archives in 2020-12
21:12:45 <tdawson> #info THIS IS NOT A DRILL.
21:13:02 <tdawson> One week closer]
21:13:13 <tdawson> #topic EPEL-7
21:14:01 <tdawson> Did we want to talk about the python34 discussion, or is that discussion going well via email?
21:14:27 <pgreco> tdawson: Miro just posted something on epel 103...
21:15:25 <nirik> I think let it keep going for a bit more...
21:15:40 <tdawson> Hmmm ... yep
21:17:19 <tdawson> So, looks like the solution to epel 103 continues, but we're close at least.
21:17:51 <tdawson> The email thread "What to do about python 3.4 in EPEL7" appears to be winding down as well ... I think.
21:19:03 <tdawson> Does anyone think we need to discuss either of these in more detail in this meeting?
21:20:00 <nirik> IMHO we should wait for next week... but if others wantt we can
21:20:15 <tdawson> Sounds good.
21:20:32 <tdawson> #topic EPEL-8
21:20:53 <tdawson> pgreco: you had something for this I believe.
21:21:07 <pgreco> yes, zstd was finally released in 8.2
21:21:22 <pgreco> the branch was dead.package for epel8 but not for playground
21:21:34 <pgreco> and aside from that, the package is still in the repos
21:22:18 <tdawson> Those have always just magically disapeared in the past.  So I don't know the proceedure.
21:22:32 <pgreco> I guess the playground thing happened because when the onwner pushed the dead.package, also deleted the package.cfg
21:22:39 <pgreco> I thing magically means smooge
21:22:45 <tdawson> :)
21:22:52 <nirik> yeah, when dead.package happenns they get blocked in koji.
21:23:04 <nirik> and then the next updates push they disappear because they are blocked
21:23:30 <carlwgeorge> some background https://bugzilla.redhat.com/show_bug.cgi?id=1806759
21:23:52 <carlwgeorge> i gave the maintainer a heads up about it coming in 8.2, but they just retired it in epel8 immediately
21:24:19 <pgreco> I just saw the dead package commit was 3 months ago
21:24:39 <nirik> thats not ideal
21:24:49 <carlwgeorge> should the maintainer (or a proven packager) run the retire command on the epel8-playground branch now too?
21:25:06 <tdawson> I just verified, it's still in regular epel repo.
21:25:22 <pgreco> yeap, checked before the meeting
21:25:59 <pgreco> I think merging epel8 to epel8-playground (either maintainer or proven) should work, at least for the git part
21:26:17 <nirik> yeah, it should.
21:26:27 <nirik> not sure why it wasn't bllocked. I can do so manually...
21:26:36 <carlwgeorge> but that wouldn't blacklist it in koji for that branch, correct?
21:26:54 <pgreco> 2 different problems
21:27:02 <carlwgeorge> iirc the retire doc points out that you have to run that command for all the branches, not merge
21:27:44 <pgreco> if the maintainer was using playground automagically through package.cfg
21:27:55 <nirik> well, the listener just waatches commits and if it sees one with dead.package in it...
21:28:15 <pgreco> making it dead package would have split them
21:28:23 <tdawson> OK, I just ran the retire command for epel-playground.
21:28:23 <pgreco> I guess..
21:28:30 <nirik> would someone be willing to file a releng ticket on this ? we can get it sorted, but I am not sure I want tto do it on the fly right here.
21:29:19 <pgreco> I can do that
21:31:03 <tdawson> #action pgreco creating a releng ticket to track removing zstd from epel and epel-playground
21:31:37 <carlwgeorge> fyi, the rhel maintainer is aware that people that had the epel 1.4.4 won't get the rhel 1.4.2, and plans to rebase in the next release so people are using the rhel package
21:31:57 <tdawson> As far as I know, zstd was the only new RHEL 8.2 package in EPEL8, correct?
21:32:13 <tdawson> carlwgeorge: That will be nice.
21:32:32 <carlwgeorge> let me check what i had to do in centos, one sec
21:33:02 <pgreco> nirik: https://pagure.io/releng/issue/9442
21:33:04 <carlwgeorge> whois
21:33:46 <pgreco> carlwgeorge: is it the same maintainer in rhel and epel?
21:34:01 <nirik> not sure, I haven't looked.
21:34:09 <carlwgeorge> nope
21:35:29 <carlwgeorge> i'll check the rest of the stuff that i had to add-pkg on to build for centos 8.2 and file bugzillas for them
21:35:35 <carlwgeorge> whois and dwarves so far
21:37:48 <tdawson> Hmm ... the two things I thought were going to take alot of time didn't.
21:37:52 <tdawson> Anything else for EPEL8?
21:38:54 <tdawson> #topic General Issues / Open Floor
21:39:26 <carlwgeorge> https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm is a release behind and doesn't include epel-modular
21:40:15 <nirik> we had something thatt was suppposed to update that, I guess it's not...
21:40:26 <nirik> infraastructure ticket? :)
21:41:16 <carlwgeorge> sure
21:42:41 <tdawson> Anything else?
21:43:44 <pgreco> not here
21:44:08 <tdawson> Thanks for everyone coming this week.
21:44:18 <tdawson> Have a good weekend.
21:44:26 <tdawson> #endmeeting