#fedora-blocker-review: Fedora 20 Blocker Review 4.5

Meeting started by adamw at 17:01:32 UTC (full logs).

Meeting summary

  1. Roll call (adamw, 17:01:45)
  2. Introduction (adamw, 17:04:06)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:04:07)
    2. We'll be following the process outlined at: (adamw, 17:04:07)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:04:08)
    4. The bugs up for review today are available at: (adamw, 17:04:08)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:04:17)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:04:18)
    7. https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria (adamw, 17:04:18)
    8. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria (adamw, 17:04:18)
    9. https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria (adamw, 17:04:20)
    10. 9 Proposed Blockers (adamw, 17:04:30)
    11. 16 Accepted Blockers (adamw, 17:04:30)
    12. 7 Proposed Freeze Exceptions (adamw, 17:04:30)
    13. 13 Accepted Freeze Exceptions (adamw, 17:04:30)
    14. roshi will secretarialize, thanks (adamw, 17:04:56)

  3. (1008732) LUKSError: luks device not configured (adamw, 17:05:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1008732 (adamw, 17:05:09)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:05:09)
    3. AGREED: 1008732 is rejected as a blocker as it requires you to fiddle around with partitions prior to running anaconda, and anaconda team is on record as not being willing to block on that kind of case (adamw, 17:18:34)

  4. (1038847) SizeNotPositiveError: spec= param must be >=0 (adamw, 17:20:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1038847 (adamw, 17:20:08)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:20:08)
    3. AGREED: #1038847 is accepted as a blocker per "When using the custom partitioning flow, the installer must be able to: ... Reject or disallow invalid disk and volume configurations without crashing." (adamw, 17:26:14)

  5. (1038969) DeviceCreateError: ('lvcreate failed for fedora/swap: running lvm lvcreate -L 819m -n swap fedora failed', 'fedora-swap') (adamw, 17:26:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1038969 (adamw, 17:26:20)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:26:20)
    3. AGREED: #1038969 is accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration." (adamw, 17:32:45)

  6. (1039288) GB in interface is 1000*1024*1024 bytes which is neither binary nor decimal (adamw, 17:33:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039288 (adamw, 17:33:10)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:33:10)
    3. AGREED: #1039288 is rejected as a blocker, if the report is accurate this obviously ought to be fixed, but doesn't have any consequences significant enough to violate any criteria. also rejected as FE as it's too late to change something like this which could break other things (adamw, 17:37:47)

  7. (1039292) Assigning partition to disk with not enough free space causes custom partition interface to become unusable (adamw, 17:38:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039292 (adamw, 17:38:06)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:38:06)
    3. AGREED: #1039292 is accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration." (adamw, 17:45:23)

  8. (1039491) ValueError: new size same as old size (adamw, 17:45:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039491 (adamw, 17:45:31)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:45:31)
    3. AGREED: insufficient information available on #1039491 for now, it was not immediately reproducible: delaying decision until wednesday, greenlion will try to come up with a reliable reproducer (adamw, 17:53:20)

  9. (1035801) [abrt] control-center-3.10.2-2.fc20: _g_log_abort: Process /usr/bin/gnome-control-center was killed by signal 6 (SIGABRT) (adamw, 17:53:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035801 (adamw, 17:53:37)
    2. Proposed Blocker, control-center, NEW (adamw, 17:53:37)
    3. AGREED: #1035801 is rejected as a blocker, considered beyond 'basic functionality', but accepted as an FE as the fix looks straightforward and would avoid a potential crasher bug in lives (adamw, 17:59:16)

  10. (1025072) libstdc++/58800 (the bug, not the fix) just got backported to Fedora 19 and 20 (adamw, 17:59:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1025072 (adamw, 17:59:25)
    2. Proposed Blocker, gcc, NEW (adamw, 17:59:25)
    3. AGREED: not yet sufficient information on #1025072: we have a list of all packages built with affected gcc, but we do not yet know which contain the affected function(s). we will try to come up with a precise list and then re-evaluate (adamw, 18:06:45)

  11. (1038109) [ms] typo in territory and locale for Malay language (causes error when selecting Malay in the language selection screen in Anaconda) (adamw, 18:08:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1038109 (adamw, 18:08:18)
    2. Proposed Blocker, langtable, ON_QA (adamw, 18:08:18)
    3. AGREED: #1038109 is accepted as a blocker as a conditional violation of criterion "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." in the case of selecting Malay (adamw, 18:10:52)

  12. (1039662) hang on launch when existing installation is LVM thin provisioning on LUKS (adamw, 18:13:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039662 (adamw, 18:13:25)
    2. AGREED: #1039662 looks like there is a real problem but cmurf lost the image that reproduces it and cannot immediately recreate it; we will delay the determination until we can say whether it's plausible to block on the bug (can reproduce it again, or tell what's going on from the trace) (adamw, 18:20:01)

  13. (1026079) Crashes with "error: [Errno 101] Network is unreachable" in GeoIP with IPv6-only network connection (adamw, 18:21:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1026079 (adamw, 18:21:33)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 18:21:34)
    3. AGREED: #1026079 is accepted as a freeze exception issue. there is some sentiment that it could be promoted to a blocker if 'geoloc=0' does not work around the issue, we should ask the reporter to check. (adamw, 18:34:25)

  14. (1039168) Disallow non-ASCII characters in encryption passwords (adamw, 18:34:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039168 (adamw, 18:34:55)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 18:34:55)
    3. AGREED: #1039168 is accepted as a freeze exception issue as a safe change here would significantly improve our robustness against bugs in passphrase entry in various places, but we will only take a simple fix that demonstrably is limited to the codepath for creating a new encrypted volume (adamw, 18:45:01)

  15. (1039185) When configuring both 'native' and US layout for a layout that cannot input ASCII, US should be first in the list (adamw, 18:45:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039185 (adamw, 18:45:14)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 18:45:14)
    3. AGREED: #1039185 is accepted as an FE issue, but we should double-check with more native users of affected languages that this is what they expect (adamw, 18:53:51)

  16. (1039511) Selection of tmpfs filesystem is broken (adamw, 18:54:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1039511 (adamw, 18:54:02)
    2. Proposed Freeze Exceptions, anaconda, ASSIGNED (adamw, 18:54:02)
    3. AGREED: #1039511 is accepted as a freeze exception issue, this is obviously bad installer behaviour that can't be fixed post-release (adamw, 18:56:54)

  17. (1027365) [abrt] bluez-5.10-2.fc20: _IO_default_xsputn: Process /usr/libexec/bluetooth/bluetoothd was killed by signal 11 (SIGSEGV) (adamw, 18:57:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027365 (adamw, 18:57:04)
    2. Proposed Freeze Exceptions, bluez, NEW (adamw, 18:57:04)
    3. AGREED: #1027365 is accepted as a freeze exception issue, crasher in a common desktop function that may well be used on lives. (adamw, 19:05:50)

  18. (1031850) Custom partitioning screen rendering broken at 1024x768 in Russian (F20 Final TC1) (adamw, 19:05:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1031850 (adamw, 19:05:56)
    2. Proposed Freeze Exceptions, gtk3, NEW (adamw, 19:05:56)
    3. AGREED: #1031850 is accepted as a freeze exception issue - obviously cannot be fixed with an update and sucks if you're a russian partition pokemon with a low-res screen, but we're looking for a very safe fix (adamw, 19:09:42)
    4. http://soepic.pl/stor/items/0f74ec7008cfceb8f.jpg (Viking-Ice, 19:09:42)

  19. (1027947) Cannot change a partition's size, then return it to the original size (adamw, 19:12:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027947 (adamw, 19:12:20)
    2. Accepted Blocker, anaconda, ASSIGNED (adamw, 19:12:20)
    3. kparal has detailed the various broken cases in c#40, will split the bug into multiple reports when BZ is co-operating, other than that, we are simply waiting on anaconda team for fixes (adamw, 19:21:20)

  20. (983110) several autostart apps (e.g. polkit-kde, kmix) and logout/shutdown countdown fails (adamw, 19:22:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=983110 (adamw, 19:22:33)
    2. Accepted Blocker, glib2, ASSIGNED (adamw, 19:22:33)
    3. we'll come back (adamw, 19:23:01)

  21. (1035536) Final spin-kickstarts build required for Fedora 20 GA (adamw, 19:23:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035536 (adamw, 19:23:09)
    2. Accepted Blocker, spin-kickstarts, MODIFIED (adamw, 19:23:09)
    3. as of now no new spin-kickstarts build is needed or expected to be needed, but we'll keep an eye out (adamw, 19:25:08)

  22. (983110) several autostart apps (e.g. polkit-kde, kmix) and logout/shutdown countdown fails (adamw, 19:26:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=983110 (adamw, 19:26:29)
    2. Accepted Blocker, glib2, ASSIGNED (adamw, 19:26:29)
    3. a build with a workaround for this bug is currently running, we have a reasonable belief that it may be sufficient to address it without causing other problems (adamw, 19:31:01)

  23. (1000893) Desktop Live is oversized (larger than 1 GB) (adamw, 19:33:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1000893 (adamw, 19:33:51)
    2. Accepted Blocker, LiveCD, NEW (adamw, 19:33:51)
    3. we're not sure what changed in TC5 to cause the image to go back over size, but we do have a fix we can pull in for the next build (adamw, 19:36:52)

  24. Open floor (adamw, 19:40:16)


Meeting ended at 19:52:53 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (366)
  2. cmurf (169)
  3. Viking-Ice (147)
  4. kparal (75)
  5. nirik (54)
  6. roshi (40)
  7. greenlion (40)
  8. jreznik (36)
  9. dan408_ (22)
  10. pwhalen (12)
  11. Kevin_Kofler (10)
  12. pschindl (9)
  13. zodbot (8)
  14. brunowolff (7)
  15. danofsatx-dt (6)
  16. ignatenkobrain (2)
  17. mkrizek (2)
  18. rdieter (1)


Generated by MeetBot 0.1.4.