#fedora-blocker-review: F20-blocker-review
Meeting started by kparal at 17:00:19 UTC
(full logs).
Meeting summary
- Roll Call (kparal, 17:00:19)
- Introduction (kparal, 17:03:25)
- Our purpose in this meeting is to review
proposed blocker and nice-to-have bugs and decide whether to accept
them, and to monitor the progress of fixing existing accepted
blocker and nice-to-have bugs. (kparal,
17:03:25)
- We'll be following the process outlined
at: (kparal,
17:03:25)
- https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
(kparal,
17:03:25)
- The bugs up for review today are available
at: (kparal,
17:03:27)
- http://qa.fedoraproject.org/blockerbugs/current
(kparal,
17:03:29)
- The criteria for release blocking bugs can be
found at: (kparal,
17:03:33)
- https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria
(kparal,
17:03:35)
- https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria
(kparal,
17:03:37)
- https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria
(kparal,
17:03:39)
- 10 Proposed Blockers (kparal,
17:03:43)
- 8 Accepted Blockers (kparal,
17:03:45)
- 2 Proposed Freeze Exceptions (kparal,
17:03:47)
- 12 Accepted Freeze Exceptions (kparal,
17:03:49)
- (1008732) LUKSError: luks device not configured (kparal, 17:03:59)
- https://bugzilla.redhat.com/show_bug.cgi?id=1008732
(kparal,
17:04:03)
- Proposed Blocker, anaconda, NEW (kparal,
17:04:05)
- AGREED: 1008732 -
RejectedBlocker AcceptedFreezeException - This is a fringe use case
that might not hit many users. We will add it to CommonBugs and warn
users they should not change the state of partitions (unlock them)
before starting the installer, or do the same use the Rescan button.
Timely patch will be considered. (kparal,
17:17:11)
- (1040352) Cannot change a standard partition's size, then return it to the original size (kparal, 17:17:27)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040352
(kparal,
17:17:28)
- Proposed Blocker, anaconda, NEW (kparal,
17:17:28)
- AGREED: 1040352 -
RejectedBlocker AcceptedFreezeException - This is inconvenient, but
can be easily worked around by hitting Reset All. A patch will be
considered. (kparal,
17:23:02)
- (1040413) Cannot change a logical volume's size twice, then return it to the original size (kparal, 17:23:25)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040413
(kparal,
17:23:25)
- Proposed Blocker, anaconda, NEW (kparal,
17:23:25)
- AGREED: 1040413 -
RejectedBlocker - This is inconvenient, but can be easily worked
around by hitting Reset All. (kparal,
17:27:39)
- (1040422) Standard partitions can't be enlarged (kparal, 17:27:53)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040422
(kparal,
17:27:53)
- Proposed Blocker, anaconda, NEW (kparal,
17:27:53)
- AGREED: 1040422 -
RejectedBlocker - This is probably a UI issue failing to inform the
user properly what can and what cannot be achieved. It's not
possible to redesign UI to fix this in a short time. If this really
affects real cases where there is enough contiguous space for
resize, please propose again. (kparal,
17:34:45)
- (1040438) LV partitions can't be enlarged (kparal, 17:34:55)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040438
(kparal,
17:34:55)
- Proposed Blocker, anaconda, NEW (kparal,
17:34:55)
- AGREED: 1040438 -
RejectedBlocker - This is probably a UI issue failing to inform the
user properly what can and what cannot be achieved. Anaconda doesn't
support LV resize when there is no free space in the VG. Will be
added to CommonBugs. (kparal,
17:37:22)
- (1040445) resize attempts ignored for LVs already scheduled for reformat (kparal, 17:37:35)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040445
(kparal,
17:37:35)
- Proposed Blocker, anaconda, NEW (kparal,
17:37:35)
- AGREED: 1040445 -
RejectedBlocker RejectedFreezeException - This is inconvenient, but
can be worked around using the Reset All button, or resized in
advance before assigning a mount point. Will be added to
CommonBugs. (kparal,
17:46:28)
- (1039491) "ValueError: new size same as old size" if you set a volume to 'Shrink' but do not change its size, in Reclaim Space (kparal, 17:48:29)
- https://bugzilla.redhat.com/show_bug.cgi?id=1039491
(kparal,
17:48:29)
- Proposed Blocker, anaconda, POST (kparal,
17:48:29)
- AGREED: 1039491 -
RejectedBlocker AcceptedFreezeException - This is inconvenient, but
quite unlikely to hit. It also doesn't present any user data loss. A
patch will be considered. (kparal,
17:55:33)
- (1040012) SizeNotPositiveError: spec= param must be >=0 (kparal, 17:55:56)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040012
(kparal,
17:55:57)
- Proposed Blocker, anaconda, POST (kparal,
17:55:57)
- https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-December/007768.html
(adamw,
17:59:21)
- AGREED: 1040012 -
AcceptedBlocker - Violates the criterion "Any installer mechanism
for resizing storage volumes must correctly attempt the requested
operation.". In this case anaconda crashes for certain partition
sizes. (kparal,
18:07:04)
- (1039292) Assigning partition to disk with not enough free space causes custom partition interface to become unusable (kparal, 18:08:42)
- https://bugzilla.redhat.com/show_bug.cgi?id=1039292
(kparal,
18:08:42)
- Accepted Blocker, anaconda, NEW (kparal,
18:08:42)
- dlehman has a fix for this one, with 'zero
risk' (kparal,
18:10:19)
- (1025072) libstdc++/58800 (the bug, not the fix) just got backported to Fedora 19 and 20 (kparal, 18:12:47)
- https://bugzilla.redhat.com/show_bug.cgi?id=1025072
(kparal,
18:12:47)
- Proposed Blocker, gcc, NEW (kparal,
18:12:47)
- AGREED: 1025072 -
RejectedBlocker - No critical packages are affected. The affected
packages don't seem to be crashing frequently. Will be fixed in
updates. (kparal,
18:16:06)
- (1021749) Review Request: php-symfony - PHP framework for web projects (kparal, 18:16:11)
- https://bugzilla.redhat.com/show_bug.cgi?id=1021749
(kparal,
18:16:11)
- Proposed Blocker, Package Review, ON_QA
(kparal,
18:16:11)
- http://fpaste.org/60889/38678601/
(adamw,
18:20:14)
- http://fpaste.org/60889/38678601/
is php* on the DVD (adamw,
18:20:47)
- AGREED: 1021749 -
AcceptedFreezeException - this is at least FE. blocker status
depends on whether it affects any package on the DVD; we will
determine and update status after the meeting (kparal,
18:29:23)
- http://paste.fedoraproject.org/60892/13867865/
(nirik,
18:29:42)
- (1040536) cloud kickstart: switch order of console kernel command line params to make log show up in openstack. (kparal, 18:31:07)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040536
(kparal,
18:31:07)
- Proposed Freeze Exceptions, spin-kickstarts,
NEW (kparal,
18:31:07)
- AGREED: 1040536 -
AcceptedFreezeException - This improves situation for cloud
deployments and presents no risk to other products. (kparal,
18:33:19)
- (1038847) SizeNotPositiveError: spec= param must be >=0 - "1" as size of encrypted partition (kparal, 18:42:53)
- https://bugzilla.redhat.com/show_bug.cgi?id=1038847
(kparal,
18:42:53)
- Accepted Blocker, anaconda, POST (kparal,
18:42:53)
- seems to be fixed, it would be great to have
more verification. the updates.img is the same as for 1040012,
therefore containing contentious fixes (kparal,
18:48:51)
- if people could run installs with
http://vpodzime.fedorapeople.org/f20_blockers_updates.img against
all kinds of disks (esp. different sized disks and partitions) and
check 'reclaim space' it'd be helpful (kparal,
18:49:46)
- (1039292) Assigning partition to disk with not enough free space causes custom partition interface to become unusable (kparal, 18:49:56)
- https://bugzilla.redhat.com/show_bug.cgi?id=1039292
(kparal,
18:49:56)
- Accepted Blocker, anaconda, NEW (kparal,
18:49:56)
- (1024223) fedup 19->20 failed with DVD iso upgrade (kparal, 18:50:43)
- https://bugzilla.redhat.com/show_bug.cgi?id=1024223
(kparal,
18:50:43)
- Accepted Blocker, fedup-dracut, ASSIGNED
(kparal,
18:50:43)
- seems to be fixed, we need a new fedup for F19
and pull newer fedup-dracut to RC1 (kparal,
18:52:15)
- (1020112) Fedora 20 alpha DVD is not recognized as bootable disk on Apple G5 (kparal, 18:53:08)
- https://bugzilla.redhat.com/show_bug.cgi?id=1020112
(kparal,
18:53:11)
- AGREED: 1020112 -
AcceptedFreezeException - This improves situation for Apple
G5 (kparal,
18:56:10)
- (1000893) Desktop Live is oversized (larger than 1 GB) (kparal, 18:56:41)
- https://bugzilla.redhat.com/show_bug.cgi?id=1000893
(kparal,
18:56:41)
- Accepted Blocker, LiveCD, MODIFIED (kparal,
18:56:41)
- adamw did a test build, we should be under
limit (kparal,
18:58:45)
- (1026860) lvm2: services specified with SYSTEMD_WANTS are not started for some LVM volumes (kparal, 18:59:03)
- https://bugzilla.redhat.com/show_bug.cgi?id=1026860
(kparal,
18:59:03)
- Accepted Blocker, lvm2, MODIFIED (kparal,
18:59:03)
- there is an older systemd fix (which was
reverted later) and a newer lvm build. the current approach is
probably to use systemd fix in a release and push lvm build to
updates (kparal,
19:04:03)
- (1038969) DeviceCreateError: ('lvcreate failed for fedora/swap: running lvm lvcreate -L 819m -n swap fedora failed', 'fedora-swap') (kparal, 19:10:25)
- https://bugzilla.redhat.com/show_bug.cgi?id=1038969
(kparal,
19:10:25)
- Accepted Blocker, python-blivet, POST
(kparal,
19:10:25)
- seems to be fixed, more verification would be
handy (kparal,
19:11:12)
- (1035536) Final spin-kickstarts build required for Fedora 20 GA (kparal, 19:15:17)
- https://bugzilla.redhat.com/show_bug.cgi?id=1035536
(kparal,
19:15:17)
- Accepted Blocker, spin-kickstarts,
MODIFIED (kparal,
19:15:17)
- there will be a new build soon and it will need
testing and karma (kparal,
19:16:19)
- https://admin.fedoraproject.org/updates/FEDORA-2013-23185
needs testing (kparal,
19:19:42)
- Open Floor (kparal, 19:26:27)
- 1040650 - ValueError: invalid target size request (kparal, 19:34:51)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040650
(kparal,
19:34:58)
- AGREED: 1040650 -
AcceptedBlocker - We're worried that this happens not only for empty
partitions, but also for somewhat filled parttions shrunk to minimal
size, which violates "Custom partitioning: Reject or disallow
invalid disk and volume configurations without crashing." If the
developers are certain this is not true, the status can be
re-evaluated. (kparal,
19:57:58)
- https://bugzilla.redhat.com/show_bug.cgi?id=1040444
(kparal,
20:02:40)
- http://vpodzime.fedorapeople.org/f20_blockers_updates.img
(cmurf,
20:12:27)
- http://www.happyassassin.net/extras/updates-1040012.img
(adamw,
20:17:55)
Meeting ended at 20:29:16 UTC
(full logs).
Action items
- (none)
People present (lines said)
- kparal (376)
- adamw (364)
- cmurf (277)
- Viking-Ice (229)
- nirik (102)
- greenlion (89)
- jreznik (64)
- roshi (47)
- dlehman (30)
- ignatenkobrain (13)
- zodbot (10)
- RemiFedora (9)
- bcl (7)
- brunowolff (7)
- pschindl (7)
- mkolman (6)
- richard_ (3)
- mkrizek (1)
- danofsatx (1)
- greenlion_ (1)
Generated by MeetBot 0.1.4.