16:01:00 <roshi> #startmeeting F21-blocker-review
16:01:00 <zodbot> Meeting started Wed Aug  6 16:01:00 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:14 <roshi> #meetingname F21-Blocker-Review
16:01:14 <zodbot> The meeting name has been set to 'f21-blocker-review'
16:01:21 <roshi> #topic Roll Call
16:01:29 <roshi> who's around for some blocker review?
16:01:35 * satellit listening
16:03:11 <roshi> danofsatx-dt said he would be late
16:04:15 <roshi> we can't do anything until we have more people - and with flock that might not happen :)
16:16:17 <roshi> well, want to wait another 10 minutes and then call it satellit ?
16:17:02 <satellit> ok
16:17:58 <satellit> note dashboard now shows both f21 and rawhide livCD builds thanks to threebean
16:18:23 <roshi> awesome
16:19:41 <satellit> latest f21 boot.iso cannot resolve files for any DE but server...: ( 0806)
16:24:57 <roshi> well, I think we call it
16:25:07 <roshi> thanks for coming satellit :)
16:25:23 <satellit> thanks for running the meeting
16:25:24 <roshi> we'll continue the testing onslaught over in #fedora-qa
16:25:42 <roshi> haha - I'd hardly call this running :)
16:25:48 <danofsatx-dt> I'm here finally
16:25:48 <roshi> but np :)
16:25:55 <roshi> just as we were going to call it
16:26:06 <satellit> : )
16:26:25 <roshi> well, we have the three we need
16:26:47 <roshi> #topic Introduction
16:26:48 <roshi> Why are we here?
16:26:48 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:26:52 <roshi> #info We'll be following the process outlined at:
16:26:54 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:26:57 <roshi> #info The bugs up for review today are available at:
16:26:59 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:27:02 <roshi> #info The criteria for release blocking bugs can be found at:
16:27:04 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:27:07 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:27:10 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:27:13 <roshi> only two blockers to review
16:27:14 <roshi> #topic (1127103) Workstation image compose sometimes fails due to filesystem consistency issues (caused by sssd library being held open)
16:27:17 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1127103
16:27:20 <roshi> #info Proposed Blocker, distribution, NEW
16:27:46 <danofsatx-dt> "sometimes" is kind of vague
16:29:01 <roshi> yeah - but it's more than "rarely"
16:29:10 <roshi> which leads me to +1 if images can't build
16:29:42 <roshi> the bug we're looking at is: https://bugzilla.redhat.com/show_bug.cgi?id=1127103
16:29:47 <danofsatx-dt> well, this is kind of obvious. if there is no image, it is obviously a blocker, whether we want it to be or not. we can't release what doesn't exist.
16:30:00 <roshi> true
16:30:26 <roshi> you can see the blockers we'll be going through, here: https://qa.fedoraproject.org/blockerbugs/milestone/21/alpha/buglist
16:30:42 <roshi> and the SOP for this meeting is here: https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:31:02 <roshi> votes?
16:31:08 <danofsatx-dt> +1
16:31:36 <satellit> +1 if I can vote  needed for release
16:31:42 <roshi> satellit bartmon nanonyme ?
16:31:52 <roshi> for sure you can vote satellit :)
16:33:29 <nanonyme> +1 if not rare
16:33:33 <roshi> proposed #agreed - 1127103 - AcceptedBlocker - This conditionally violates all the criteria related to live images.
16:34:05 <roshi> ack/nack/patch?
16:34:30 <nanonyme> I'm confused by the wording conditionally violates. Is that official terminology?
16:34:43 <danofsatx-dt> ack...need dgilmore's expertise to fix.
16:34:43 <roshi> I don't think so
16:35:01 <roshi> we've used that term in the past - and it's in adamw's report
16:35:09 <satellit> ack
16:35:34 <nanonyme> Okay. ack then
16:35:40 <roshi> proposed #agreed - 1127103 - AcceptedBlocker - This is a conditional violation of all Alpha criteria related to live images.
16:35:43 <roshi> that more clear?
16:36:00 <danofsatx-dt> well, alpha critera is "Release-blocking images must boot". If the image doesn't exist, it doesn't boot, therefore fail.
16:36:22 <roshi> well - these don't even get *created*
16:36:29 <roshi> since the build fails
16:36:59 <roshi> ack/nack/patch?
16:37:06 <danofsatx-dt> ack
16:37:07 <satellit> ack
16:37:24 <roshi> #agreed - 1127103 - AcceptedBlocker - This is a conditional violation of all Alpha criteria related to live images.
16:38:03 <roshi> anyone want to secretarialize?
16:38:29 <roshi> #topic (1127033) Fedora-server installation doesn't prompt for creation of user after installation
16:38:32 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1127033
16:38:35 <roshi> #info Proposed Blocker, initial-setup, NEW
16:38:55 <satellit> is this a feature of server?
16:39:01 <danofsatx-dt> punt, wait for clarification from Server WG on whether this is desired behavior.
16:39:05 <roshi> I don;t know
16:39:17 <roshi> but adam is right that it doesn't actually *violate* the criteria
16:39:41 <roshi> so even after reporting it I'm leaning -1 on this
16:39:45 <danofsatx-dt> I don't think it's a blocker - server is deployed with FreeIPA by default, which is what would handle the users.
16:40:33 <roshi> -1 from me
16:40:45 <danofsatx-dt> -1
16:40:57 <satellit> -1  awaiting clarification
16:42:57 <roshi> proposed #agreed - 1127033 - RejectedBlocker - There is no clear violation of Alpha Criteria. If this isn't desired functionality, re-propose with Server criteria.
16:43:21 <danofsatx-dt> ack
16:43:37 <satellit> ack
16:43:53 <roshi> #agreed - 1127033 - RejectedBlocker - There is no clear violation of Alpha Criteria. If this isn't desired functionality, re-propose with Server criteria.
16:44:27 <roshi> that's all the proposed blockers
16:44:42 <roshi> move through the accepted to make sure they're getting the TLC they need :)
16:44:53 <roshi> #topic (1109603) dracut unable to boot 3.16 most of the time
16:44:53 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1109603
16:44:53 <roshi> #info Accepted Blocker, cloud-initramfs-tools, NEW
16:46:29 <roshi> I talked to phwalen about this and he said it's being worked on - and there is recent comments
16:47:12 <roshi> so moving onto the next unless someone has issues with that
16:47:23 <danofsatx-dt> nope, move on
16:47:26 <roshi> #topic (1123845) Server presets not applied in systemd scriptlets
16:47:26 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1123845
16:47:27 <roshi> #info Accepted Blocker, fedora-release, NEW
16:47:51 <danofsatx-dt> I haven't been able to test this one, since cockpit still isn't being enabled by default.
16:48:10 <danofsatx-dt> which to me means it's still broken as of 08/04
16:48:23 <roshi> well - it's being worked on
16:48:32 <roshi> it doesn't look like a fix has been agreed on though
16:48:39 <danofsatx-dt> yeah, read that
16:49:38 <roshi> nothing for us to do here - moving on :)
16:49:54 <roshi> #topic (1088933) update grubby to support device tree options for arm
16:49:57 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1088933
16:49:59 <roshi> #info Accepted Blocker, grubby, POST
16:50:40 <danofsatx-dt> no action in 2+ weeks...is it fixed?
16:50:43 * danofsatx-dt can't test this one
16:51:11 <roshi> I can't either - but my serial cable should be here soon so I can poke at it
16:51:14 <pwhalen> no changes here, hopefully after flock. small change the patch needed
16:51:32 <roshi> sweet - thanks pwhalen :)
16:51:35 <pwhalen> Dennis has been a little busy
16:51:51 <roshi> so it would seem :)
16:52:14 <roshi> have we perfected the cloning technology to get more of him?
16:52:46 <roshi> proposed #action - danofsatx-dt to perfect cloning technology or a hyberbolic time chamber
16:52:51 <pwhalen> we keep ending up with less desirable clones
16:53:13 <roshi> hrm
16:53:16 <roshi> that's no good
16:53:42 <roshi> well, we can move to the next since pwhalen is tracking this :)
16:54:04 <roshi> #topic (1110758) SELinux prevents cockpit from working on Fedora 21
16:54:06 <danofsatx-dt> I prefer the time chamber to cloning. world is already over-populated
16:54:07 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1110758
16:54:10 <roshi> #info Accepted Blocker, selinux-policy-targeted, NEW
16:54:18 <roshi> fair enough
16:54:25 <roshi> get on it then :p
16:54:33 * roshi has always wanted a time chamber...
16:54:41 * danofsatx-dt has been tinkering with it for 30+ years ;)
16:55:27 <roshi> looks like things are moving forward on this
16:55:29 <danofsatx-dt> ok, what is the context supposed to be for /usr/libexec/cockpit* ?
16:55:39 * roshi doesn't know
16:56:02 <danofsatx-dt> I see the same thing on my system as comment #26
16:56:30 <danofsatx-dt> but the correct context isn't listed in the bz, unless stefw's comment #25 is the correct one
16:57:12 <roshi> yeah
16:57:33 <roshi> but it's moving forward - we don't need to poke anyone on it
16:57:46 <roshi> danofsatx-dt: if you have spare cycles and can test for them, let them know though
16:57:50 <danofsatx-dt> yeah, stefw and sgallagh are leading the charge on this one
16:58:08 <danofsatx-dt> have been. I have a shiny new 08/05 boot.iso I need to play with.
16:58:34 <roshi> there's a shinier 08/06 boot.iso for you to test with as well :)
16:58:40 <roshi> move on then?
16:58:42 <roshi> last one
16:58:49 <danofsatx-dt> I know, but my repohost ran out of space last night :(
16:59:02 <roshi> bah - space
16:59:18 <roshi> #topic (1044778) wandboard uboot missing serial line speed in console environment variable
16:59:21 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1044778
16:59:23 <roshi> #info Accepted Blocker, uboot-tools, NEW
16:59:40 <danofsatx-dt> someone needs poked. but whom?
16:59:58 <roshi> I would assume this is just lagging due to flock
17:00:03 <roshi> adam already poked it
17:00:09 <roshi> pwhalen: anything on this one?
17:00:52 <pwhalen> right.. dgilmore is rebasing to a new version, waiting for that release
17:01:02 <pwhalen> imagine after flock
17:01:09 <roshi> sounds good
17:01:20 <roshi> care to annotate that in the bug - or is that not needed?
17:01:47 <pwhalen> not quite sure the details, would prefer he update it
17:01:54 <roshi> works for me
17:02:12 <roshi> well, that's it for today methinks
17:02:20 <roshi> #topic Open Floor
17:02:28 <pwhalen> we can talk about it again next meeting, he'll be around then
17:02:58 <roshi> works for me :)
17:03:21 <roshi> I'm pretty sure he could work 24/7 for a couple years and not run out of things to do
17:03:33 <pwhalen> i missed the other arm issue - https://bugzilla.redhat.com/show_bug.cgi?id=1109603
17:03:47 <roshi> that was the one I asked you about yesterday
17:03:57 <pwhalen> going to update the bz, seems to be resolved with dracut-modules-growroot removed from the latest images
17:03:59 <pwhalen> right
17:04:05 <roshi> good to hear
17:04:42 <pwhalen> we just need an alternative, not familiar with cloud-init, but seems to suggest it may work
17:06:08 <danofsatx-dt> yay
17:06:24 <roshi> I'm not that familiar with dracut
17:06:34 <roshi> but good that it's getting worked on and progress made
17:06:38 <danofsatx-dt> dracut scares me. I panic when I see it.
17:07:20 <roshi> well, that's all folks - unless anyone has anything else
17:07:29 * roshi sets the fuse
17:07:40 * danofsatx-dt runs, but doesn't run
17:08:08 * roshi wonders how many meetings we have in a Super-position of ended and not ended
17:08:26 <danofsatx-dt> bunches. or none. depends on who's looking, and from what angle.
17:09:00 <danofsatx-dt> I swear, Schroedinger was stoned.
17:09:18 <roshi> yeah - and his poor cat
17:09:58 <satellit> that is what the time machine is needed for
17:10:38 <roshi> true
17:10:43 <roshi> well, thanks for coming folks!
17:11:03 <roshi> #endmeeting