15:59:23 <roshi> #startmeeting F21-blocker-review
15:59:23 <zodbot> Meeting started Wed Aug 27 15:59:23 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:23 <roshi> #meetingname F21-blocker-review
15:59:23 <zodbot> The meeting name has been set to 'f21-blocker-review'
15:59:24 <roshi> #topic Roll Call
15:59:33 <roshi> who's around for some blockery goodness?
15:59:33 <sgallagh> .hellomynameis sgallagh
15:59:34 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:59:37 <kparal> hello
15:59:51 * satellit listening
15:59:57 <roshi> .hellomynameis roshi
16:00:00 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
16:00:18 * kparal pokes pschindl adamw
16:00:22 * nirik is lurking around
16:00:26 * pschindl is here (but just for 45 minutes)
16:00:29 <adamw> whoops, sorry
16:00:33 <adamw> ahoyhoy
16:00:39 <roshi> #chair kparal adamw sgallagh
16:00:39 <zodbot> Current chairs: adamw kparal roshi sgallagh
16:01:06 * pwhalen is here
16:01:19 <roshi> for those with deep philosophical questions....
16:01:22 <roshi> #topic Introduction
16:01:22 <roshi> Why are we here?
16:01:22 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:01:26 <roshi> #info We'll be following the process outlined at:
16:01:29 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:01:31 <roshi> #info The bugs up for review today are available at:
16:01:34 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:01:36 <roshi> #info The criteria for release blocking bugs can be found at:
16:01:39 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:01:42 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:01:58 <roshi> for the first blocker we have:
16:01:59 <roshi> #topic (1127280) OSError: [Errno 2] No such file or directory
16:01:59 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1127280
16:02:00 <roshi> #info Proposed Blocker, anaconda, NEW
16:02:17 <amita> hi roshi
16:02:26 <amita> hi all
16:03:01 <kparal> I think we can safely close this one. I have done many installations and I haven't seen it recently
16:03:31 <roshi> hey amita :)
16:03:43 <roshi> good to hear kparal
16:03:49 <kparal> do we have a secretary person btw?
16:03:56 <roshi> not as of yet
16:04:38 <roshi> any volunteers?
16:04:43 <adamw> i can do it
16:04:50 <kparal> thanks
16:04:58 * kparal is too tired today
16:05:25 * sgallagh is is busily filing potential blocker-bugs while testing TC4
16:05:56 <roshi> proposed #agreed - 1127280 - RejectedBlocker - This issue seems to have resolved itself. Propose anew if it crops back up
16:06:09 <kparal> ack
16:06:26 <kparal> I'm not even sure we need to say rejected
16:06:30 <kparal> but works for me
16:06:40 <pschindl> ack
16:07:04 <roshi> me either, but saying it's not a blocker almost == rejected in my vernacular
16:07:21 <roshi> any more ack/nack/patch?
16:07:38 <danofsatx> ack
16:07:47 <sgallagh> ack
16:07:51 <danofsatx> oh, I'm here btw
16:07:58 <roshi> #agreed - 1127280 - RejectedBlocker - This issue seems to have resolved itself. Propose anew if it crops back up
16:08:06 <roshi> welcome danofsatx :)
16:08:25 * satellit big delay on freenode...
16:08:29 <roshi> #topic (1085846) [FAILED] Failed to start Login Service.
16:08:29 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1085846
16:08:30 <roshi> #info Proposed Blocker, glibc, NEW
16:09:25 <kparal> so, this could be resolved as well
16:09:31 <kparal> but it would be nice to have some confirmation
16:09:37 <adamw> yeah, +1 to close this
16:09:37 <adamw> seems like it really was caused by the other
16:09:38 <adamw> oh, note that if you hit the same bug again you'd get a different result now (a clearer and earlier failure)
16:09:38 * satellit_e FYI Testing https://fedoraproject.org/wiki/Test_Results:Fedora_21_Nightly_2014_08_Install
16:10:00 * satellit sorry big delay....
16:11:01 <roshi> so different verse same as the first then?
16:11:24 <roshi> proposed #agreed - 1085846 - RejectedBlocker - This issue seems to have resolved itself. Propose anew if it crops back up
16:12:01 <pschindl> ack
16:12:02 <kparal> ack
16:12:23 <sgallagh> ack
16:12:32 <roshi> #agreed - 1085846 - RejectedBlocker - This issue seems to have resolved itself. Propose anew if it crops back up
16:12:44 <roshi> #topic (1102241) [RFE] libguestfs should detect OSTree (project-atomic) qcow2 disk image
16:12:47 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1102241
16:12:50 <roshi> #info Proposed Blocker, libguestfs, NEW
16:14:10 <kparal> c2 has explanation
16:15:13 <sgallagh> If it's preventing image generation of a blocking media, that seems pretty straightforward.
16:15:22 <roshi> that's what I was thinking
16:15:23 <kparal> I guess so
16:15:59 <kparal> and project atomic is now official product, therefore covered by criteria?
16:16:05 <kparal> I don't see much into cloud stuff
16:16:26 <roshi> I'm not sure if atomic is blockerable
16:16:40 <adamw> dgilmore: ping
16:16:45 <adamw> seems like you should know about this one
16:16:46 <roshi> the normal cloud images, yes - but not sure on atomix
16:17:26 <imcleod> I can speak to this.
16:18:03 <imcleod> It is blocking atomic images only.  It will require a non-trivial change to libguestfs, oz/factory or both.  We have a workaround for the time being but it is sub-optimal in that it turns off package auditing in the image.
16:18:30 <imcleod> Last I heard, dgilmore and adamw had agreed this could more off of the Alpha blocker list but I will defer to them.
16:18:37 <imcleod> Given that adamw is here.... :-)
16:18:46 <adamw> i don't recall agreeing anything :P
16:19:02 <adamw> if we have a workaround that allows the image to be generated i think that would pretty clearly make it notablocker
16:19:03 <kparal> is atomic image an official part of the Fedora Cloud product?
16:19:35 <roshi> the contingency plan if things can't get fixed in time was to not have an atomic image
16:19:51 <roshi> https://fedoraproject.org/wiki/Changes/Atomic_Cloud_Image#Contingency_Plan
16:20:04 * sgallagh attempts to summon jzb to the meeting.
16:20:05 <imcleod> We have at least some successful atomic image builds using our workaround.
16:20:05 <imcleod> http://koji.fedoraproject.org/koji/taskinfo?taskID=7449176
16:21:02 <sgallagh> If we reject this as a blocker, does FE make sense? (Also read: will effort be made to fix it if it's not a blocker?)
16:21:08 <adamw> if the workaround is now implemented 'permanently' in releng such that composes can be expected to succeed, i'd say we drop blocker status.
16:21:25 <roshi> if there's a workaround, it's not really blocking
16:21:30 <roshi> adamw++
16:21:30 <adamw> sgallagh: it depends if we think it's worth making freeze exceptions for 'package auditing', i guess.
16:21:30 <imcleod> Effort is already being made to fix it.  Workaround is the current default for builds AFAIK.
16:21:59 <adamw> (though i'm not sure if it even applies - freeze only applies to packages, if the 'fix' would be some kind of releng change, FE status may be irrelevant.)
16:22:10 <imcleod> adamw: Note that even if this weren't an issue, we still don't have "package auditing" turned on/available anyway.  That has some work left to be done as well.
16:22:21 <imcleod> adamw: It's more of a roadmap item as I understand it.
16:22:41 <imcleod> adamw: Which would again argue against blocking for an enabling component of a feature not yet written.
16:23:02 * kparal nods
16:23:20 <roshi> -1
16:23:31 <sgallagh> ok, so I don't see any blocking criteria being violated, then (given the workaround)
16:23:35 <sgallagh> -1 blocker
16:23:45 <adamw> yup, -1 blocker.
16:23:59 <danofsatx> -1
16:24:49 <roshi> proposed #agreed - 1102241 - RejectedBlocker - This doesn't directly violate any specific criteria and a workaround is already in place as a default for generating the images
16:24:51 <pwhalen> -1 blocker
16:24:58 <sgallagh> Ack
16:25:03 <pwhalen> ack
16:25:38 <kparal> ack
16:25:45 <adamw> ack
16:26:08 <roshi> #agreed - 1102241 - RejectedBlocker - This doesn't directly violate any specific criteria and a workaround is already in place as a default for generating the images
16:26:19 <roshi> #topic (1112387) [abrt] initial-setup: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, ...
16:26:24 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1112387
16:26:26 <roshi> #info Proposed Blocker, selinux-policy, NEW
16:27:34 <pwhalen> this is preventing initial-setup-graphical from running, when in permissive it runs ok.
16:28:38 <kparal> +1
16:28:38 <roshi> well, selinux needs to be enforcing after an install - so +1 blocker
16:28:50 <sgallagh> Agreed. +1 blocker
16:28:53 <pwhalen> +1
16:29:23 <pschindl> +1 blocker
16:30:18 <danofsatx> +1
16:30:52 <adamw> um
16:31:08 <roshi> proposed #agreed - 11123387 - AcceptedBlocker - This bug violates the Alpha Criteria "Expected installed system boot behaviour."
16:31:10 <adamw> say you created a user during install
16:31:12 <adamw> hold, please
16:31:15 <roshi> kk
16:31:25 <adamw> what happens? does initial-setup fail to run, but boot complete and let you log in?
16:31:31 <adamw> if so i'm not sure this is an alpha blocker
16:31:36 <pwhalen> user creation is done in initial-setup
16:31:41 <adamw> if it hangs the init sequence, it is
16:31:46 <adamw> pwhalen: oh, for ARM, right.
16:31:52 <pwhalen> :)
16:32:26 <adamw> +1 then
16:32:31 <adamw> sorry, forgot that bit
16:32:37 * jreznik will join you soon after my meeting ends...
16:32:50 <roshi> proposed #agreed - 11123387 - AcceptedBlocker - This bug violates the Alpha Criteria "Expected installed system boot behaviour."
16:33:00 <pwhalen> ack
16:33:00 <danofsatx> ack
16:33:14 <roshi> should I put the bits about arm only has i-s as a means of creating a user?
16:33:49 <kparal> ack
16:34:05 <sgallagh> ack
16:34:09 <roshi> #agreed - 11123387 - AcceptedBlocker - This bug violates the Alpha Criteria "Expected installed system boot behaviour."
16:34:33 <roshi> that's all the proposed blockers, sgallagh you get through any of your bugs for us to look at?
16:34:48 <sgallagh> Two and I'm writing up the third-and-final one now
16:35:04 <roshi> bz #'s?
16:35:07 <sgallagh> https://bugzilla.redhat.com/show_bug.cgi?id=1134504
16:35:22 <sgallagh> https://bugzilla.redhat.com/show_bug.cgi?id=1134504
16:35:26 <sgallagh> Whoops, duplicate
16:35:30 <sgallagh> https://bugzilla.redhat.com/show_bug.cgi?id=1134507
16:36:10 <roshi> #topic 1134504 [cockpit] Cockpit does not start automatically on Fedora Server Alpha TC4
16:36:31 <roshi> #info Proposed Blocker, cockpit, NEW
16:36:51 * roshi thinks he manually created the right info there...
16:37:17 <roshi> +1 blocker
16:37:30 <roshi> for Server Cockpit has to be running and working
16:38:24 <kparal> +1 per criterion
16:38:27 <danofsatx> +1
16:38:50 <jreznik_> is it really fedora issue or just network issue? anyone can check?
16:39:06 <sgallagh> jreznik: We're discussing 1134504 right now
16:39:18 <sgallagh> *507 is the next one
16:39:37 <roshi> yeah
16:39:59 <jreznik_> sgallagh: oh, I clicked on the link without thinking :) sorry, I was confused the title does not correspond to description, sorry :)
16:40:24 <jreznik_> link was missing roshi :)
16:40:48 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1134504
16:41:07 <roshi> ah - yeah
16:41:22 * roshi thought meetbot/zodbot treated all links as #link
16:41:37 <jreznik_> that's why I blindly clicked on the other one :)
16:41:50 <jreznik_> +1 blocker
16:41:54 <roshi> proposed #agreed - 1134504 - AcceptedBlocker - This bug directly violates the Alpha Cockpit management interface criteria.
16:42:03 <adamw> ack
16:42:10 <sgallagh> Ack (arguable conflict of interest as submitter)
16:42:20 <danofsatx> ack
16:42:39 <roshi> ack is just to the wording I wrote, not blockery-ness (so no conflict IMO :) )
16:42:49 <roshi> #agreed - 1134504 - AcceptedBlocker - This bug directly violates the Alpha Cockpit management interface criteria.
16:43:04 <roshi> #topic (1134507) [anaconda] Installing Fedora Server F21 Alpha TC4 from network tree crashes
16:43:07 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1134507
16:43:09 <roshi> #info Proposed Blocker, anaconda, NEW
16:43:13 <roshi> there - that should be everything
16:43:16 <danofsatx> +1 blocker
16:43:19 <sgallagh> So two points here:
16:43:40 <sgallagh> 1) This may or may not be our issue. It's *possible* that this is partial fallout from the ongoing TWC outage
16:43:58 <sgallagh> 2) I'm not certain if the netinstall tree is considered blocking media by the Workstation WG
16:44:20 <kparal> sgallagh: have you tried proper fedora repo instead of TC4 repo?
16:44:33 <roshi> I've seen this one as well
16:44:37 <kparal> because I'm not even sure whether it should work at all
16:44:42 <roshi> was having similar repo issues with workstation netinst
16:44:53 <sgallagh> kparal: I spoke to Kalev about it and he was working on fixing it
16:45:07 <danofsatx> it works from boot.iso, but not from product iso's
16:45:08 <sgallagh> So I'm reasonably certain it's *supposed* to work
16:45:14 <kparal> alright
16:45:27 <kparal> because the package set is very limited iirc
16:45:55 <roshi> trying to repro now
16:46:11 <adamw> i believe dgilmore mentioned something about this
16:46:25 <adamw> oh, no, i was thinking of cloud
16:47:42 <adamw> that criterion needs a bit of a rework
16:47:45 <sgallagh> According to the WS tech spec, their only supported medium is the live ISO
16:48:05 <adamw> there's also https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria#Remote_package_sources
16:48:11 <sgallagh> So probably this isn't a blocker (but maybe FE since it hurts testing?)
16:48:12 <adamw> "When using the dedicated installer images, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. The network install image must default to a valid publicly-accessible package source. "
16:48:23 <adamw> no, this ought to be a blocker, if the criteria don't cover it they need rewriting
16:48:30 <sgallagh> ok
16:48:45 <roshi> +1 blocker, IMO according to the above criteria
16:49:01 <adamw> the pre-.next intent is that 'network install works at alpha', basically
16:49:16 <kparal> +1
16:49:29 <adamw> it's reasonable to translate that for post-.next as 'network install works for Products for which it's a supported mechanism', which is clearly is for server
16:49:39 <roshi> network install should be the backup "I know this will work if other methods fail" method
16:49:41 <adamw> i think it's OK to take it as +1 under the criterion i mentioned, +1 for that
16:50:19 <adamw> if the bug traces out to the mirrors it's not necessarily release blocking (as it can be fixed without changing the images), but at present we don't know that, it could well be a bug in the installer.
16:50:52 * sgallagh realizes he confused himself with the third BZ I filed here.
16:51:03 <sgallagh> This one is clearly a blocker.
16:51:06 <adamw> ah :P
16:51:28 <roshi> proposed #agreed - 1134507 - AcceptedBlocker - This bug violates the "Remote package sources" Alpha criteria.
16:51:30 <sgallagh> Sorry, I filed all of these in the last hour during the meeting.
16:51:40 <roshi> no worries sgallagh :)
16:51:56 <roshi> keeping multiple related bugs in your head and separate is no trivial task
16:52:39 <kparal> ack
16:52:42 <sgallagh> Ack (for the record)
16:53:22 <roshi> #agreed - 1134507 - AcceptedBlocker - This bug violates the "Remote package sources" Alpha criteria.
16:53:32 <roshi> #topic (1134524) F21 Workstation Alpha TC4 netinstall does not offer correct environment
16:53:34 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1134524
16:53:37 <roshi> #info Proposed Blocker, distribution, NEW
16:54:25 <sgallagh> So this is where I meant I'm not sure if it's a blocking media.
16:54:34 * sgallagh gets his story straight this time...
16:54:37 <roshi> makes sense now :)
16:54:57 <roshi> I feel like netinst was meant to be the fallback install method - if DVD or whatnot fails
16:54:59 <sgallagh> I did however talk to Kalev and he's working on fixing it, so there's certainly an implication that it's broken, possibly in a way I haven't detected
16:55:31 <adamw> workstation tech spec or prd (I forget which) explicitly listed only the live image as supported media (at laest last time I chjecked)
16:55:40 <adamw> but iirc dgilmore was lobbying them to care about netinst
16:55:41 <sgallagh> Yes, as I referenced above
16:55:46 <jzb_> hi all
16:55:51 <jreznik_> yeah, for workstation only lives are blocking
16:56:23 <jreznik_> but we should make sure netinst is usable for all products - but will be the result of installation using netinst product like? that's the question
16:56:24 <roshi> +1 for caring about netinst
16:56:48 * sgallagh is wary of the blockerbugs crew creating new release criteria on the spot
16:56:57 <kparal> so now we will have several netinst images and the only difference will be the package set selected by default?
16:57:06 * danofsatx agrees w/ sgallagh
16:57:30 <adamw> kparal: they may each offer different package sets, not just select different ones by  defualt
16:57:31 <jreznik_> sgallagh: well, .next criteria will need some time to settle down
16:57:34 <adamw> i'm kinda losing track, though
16:57:37 <roshi> I don't want to fabricate criteria out of thin air, but I think someone should help with the lobbying regarding netinst
16:57:52 <adamw> i believe the idea is that the server netinst will only offer Server roles, for e.g.
16:58:07 <kparal> from QA perspective, I'm horrified
16:58:08 <adamw> roshi: blocker process really isn't for lobbying, it should be for implementing settled procedure
16:58:09 <sgallagh> adamw: They each have an install tree limited to the set of the package sets they include
16:58:27 <sgallagh> However, any of them can also be pointed to the Everything tree and, well, there you fo
16:58:29 <sgallagh> *go
16:58:31 <roshi> oh yeah - I was meaning we should have this discussion for sure somewhere, sometime
16:58:44 <roshi> but the criteria are what they are and that's what we can vote against here
16:58:49 <adamw> sgallagh: right, i'm considering the 'default' setup. can't each tree have custom comps too?
16:59:00 <sgallagh> No
16:59:05 <adamw> ah, ok. hrm.
16:59:07 <sgallagh> Comps is universal at this time
16:59:08 <adamw> anyhoo
16:59:13 <sgallagh> (And hopefully will stay that way)
16:59:15 <adamw> as the criteria are written, this *is* a blocker, of course ;)
16:59:21 <adamw> but arguably that's unintentional (and my fault)
16:59:32 <danofsatx> .fire adamw
16:59:32 <zodbot> adamw fires adamw
16:59:40 <adamw> btw, booting the tc4 server netinst right now I get "Error setting up base repository"...
16:59:56 <roshi> yeah, as the criteria are written now - this is a blocker IMO
17:00:07 <sgallagh> adamw: That's not the same error as installing from virt-manager pointing at the install tree.
17:00:12 <roshi> yeah - you get that with workstation and server adamw
17:00:13 <sgallagh> I hadn't gotten to that one yet...
17:00:16 <kparal> if Workstation team is unsure whether to support netinst, I don't think we should block on it
17:00:26 <adamw> sgallagh: i'm using virt-manager. (uefi vm, though, as that's the window I happened to have open.)
17:00:54 <sgallagh> adamw: virt-manager opening the netinst.iso or pointing directly at the tree?
17:01:06 <adamw> sgallagh: booting the server netinst iso from tc34.
17:01:07 <adamw> tc4*
17:01:10 <roshi> we're just voting if it violates the criteria as they are written *now*
17:01:38 <adamw> roshi: i think it's reasonable to consider that the criterion is clearly an f20 hangover
17:01:51 <adamw> (i was actually drafting an email to revise it in the background)
17:02:14 <roshi> sure
17:02:48 <adamw> https://fedoraproject.org/wiki/Workstation/Technical_Specification#Installation_methods_and_media still states nothing about netinst
17:03:00 <danofsatx> which criteria does it violate?
17:03:10 * danofsatx still doesn't see it
17:03:46 <danofsatx> oh, duh....
17:03:49 <roshi> the workstation netinst doesn't allow for the installation of it's own default package set -but netinst isn't listed as a media the WG wants to support
17:04:15 <adamw> i'd suggest we punt on this for now and use it as an opportunity to clarify the status of netinst wrt workstation
17:04:24 <sgallagh> Hooray for cognitive dissonance!
17:04:25 <roshi> +1 punt
17:04:26 <adamw> (i just pinged kalev in #fedora-desktop, though)
17:04:45 <danofsatx> whether they want to support it or not, the criteria currently state "When using the dedicated installer images, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. The network install image must default to a valid publicly-accessible package source."
17:05:03 <roshi> yeha - that's the discussion now danofsatx
17:05:10 <adamw> danofsatx: yes, but it's not like there was some kind of project-wide consensus that Workstation Must Care About NetInstall behind that criterion.
17:05:10 <danofsatx> it doesn't do that, so +1 blocker AS CURRENTLY WRITTEN. if they don't want to support it, criteria needs revised.
17:05:21 <adamw> danofsatx: it's purely a hangover from F20 that we missed considering in the criteria revision.
17:05:23 <sgallagh> Of course, that *does* mean that a valid way to resolve this BZ is to kill off the netinst.iso from the download site
17:05:31 <roshi> that criteria doesn't clearly transfer from the F20 world to the F21 world
17:05:42 <adamw> standing on it would seem to be a case of excessively favouring procedure/bureaucracy over, you know, actual sanity.
17:06:00 <danofsatx> well, there is that, too....
17:06:01 <sgallagh> Then it's impossible to *have* a "dedicated installer image"
17:06:04 <adamw> it was written when the product we shipped was not at all the same thing as the one we're building now, with reference to that product, not this one.
17:06:19 <adamw> sgallagh: releng seem weirdly reluctant to do that kind of thing
17:06:50 <sgallagh> adamw: Well, the reluctance is to not publishing the netinst trees
17:06:53 <adamw> sgallagh: like, whenever you talk to dgilmore about it he's like "well, the build process has to generate a network install image, so they have to have one." me: "but can't we just generate it then throw it away?" him: "no."
17:07:00 <sgallagh> Because they're created as a by-product of the live creation anyway
17:07:01 <adamw> but maybe i'm misremembering, i dunno.
17:07:26 <sgallagh> That doesn't mean we have to ship a mechanism dedicated to reading from that tree, though
17:07:26 <roshi> +1 punt with intent to revisit the criteria and decide this afterwards (with input from the workstation WG)
17:07:37 <adamw> <kalev> adamw: so, my take on this is that I would really like to have a single installation media for Workstation, only the live USB / dvd
17:07:43 <adamw> <kalev> but I also do understand that in some environments, the PXE boot and netinstall are necessary, especially corporate installations
17:07:43 <adamw> what I'm envisioning in the future is that we should have a single netinstall for the whole of Fedora, where one could select server or workstation
17:07:49 <adamw> <kalev> but for F21, I think we'll just have to make do with what we have and make the workstation-specific netinstall work
17:07:49 <adamw> so I don't mind having it as a blocking bug
17:08:16 <adamw> still, i think it'd be good to punt and get a clear documented agreement from the whole team
17:08:17 <roshi> that's what I'd want as well, a global netinst where you can select whatever product you want (server or workstation)
17:08:21 <adamw> still, sounds like they incline to accepting it
17:08:36 <adamw> roshi: it seems like it's what everyone wants and always has been, but for some reason we didn't put any priority on doing it? ah well
17:08:58 <adamw> (it would be tricky to have stuff like the differing default filesystems work, of course)
17:09:27 <roshi> so, votes on a punt for more global agreement?
17:09:50 <sgallagh> Yeah, I'd prefer not to hinge this on a single Workstation WG member's response.
17:10:08 <danofsatx> +1 punt
17:10:13 <jreznik_> +1 punt
17:10:30 <sgallagh> +1 punt
17:10:47 <sgallagh> #action sgallagh to bring this up on the Workstation mailing list.
17:10:49 <kparal> +1
17:10:52 <roshi> proposed #agree - 1134524 - Punt - The criteria and this bug require more discussion before a decision can be made. Will revisit.
17:10:59 <roshi> *#agreed
17:11:02 <sgallagh> Ack
17:11:59 <kparal> ack
17:11:59 <adamw> ack
17:12:09 <roshi> #agreed - 1134524 - Punt - The criteria and this bug require more discussion before a decision can be made. Will revisit.
17:12:25 <roshi> that's all our proposed blockers
17:12:36 <roshi> any issues with moving onto accepted blockers?
17:13:16 * roshi takes silence as consent (mwahahaha!)
17:13:17 <roshi> #topic (1127103) Workstation image compose sometimes fails due to filesystem consistency issues (caused by sssd library being held open)
17:13:20 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1127103
17:13:23 <roshi> #info Accepted Blocker, distribution, NEW
17:14:56 <sgallagh> This appears to be resolved, but the bug hasn't been updated
17:15:04 <roshi> that's what I'm seeing
17:16:27 <kparal> we already agreed to close this last time, didn't we?
17:16:53 <roshi> sgallagh: In any case, this bug will be closed imminently
17:17:01 <roshi> c12
17:17:14 <roshi> sgallagh you want to close this?
17:17:31 <sgallagh> roshi: I'll confirm with dgilmore first, then yes
17:17:36 <roshi> sounds good
17:17:40 <roshi> next
17:17:42 <sgallagh> #action sgallagh to confirm the resolution of the bug and close it
17:17:58 <roshi> #topic (1109603) dracut unable to boot 3.16 most of the time
17:17:58 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1109603
17:17:59 <roshi> #info Accepted Blocker, dracut, NEW
17:18:12 <adamw> i asked pbrobinson about this last week i think
17:18:24 <pwhalen> ive no updates, this isnt happening on current images
17:18:32 <adamw> <pbrobinson> vaguely, it seems to have gone away at the moment but I don't believe it's fixed, i think it's just that we don't have a debug kernel. It seems to be timing between the kernel and the blkid stuff
17:18:32 <adamw> but I think it's some what out of my depth
17:19:11 <pwhalen> if it appears again, i would be happy to reopen, provide the logs
17:19:11 <adamw> if we can take 'doesn't happen with release kernels' as a working hypothesis i'd suggest dropping blocker status, as from now on f21 is on release kernels (aiui)
17:19:33 <pwhalen> adamw, +1
17:20:02 <roshi> makes sense to me
17:21:01 <roshi> any issues with that from anyone?
17:21:49 <roshi> proposed #agreed - 1109603 - RejectedBlocker - Dropping blocker status from this bug due to the use of release kernels from here on out for F21.
17:22:04 * roshi isn't sure if "RejectedBlocker" is right for that, but went with it anyways
17:22:45 <adamw> ack
17:23:02 <adamw> yeah, it feels weird to me, sometimes i just 'un-propose' them
17:23:07 <pwhalen> ack
17:23:14 <kparal> ack
17:23:18 <adamw> maybe we should do that here, it effectively gives us the ability to re-propose it without saying we were *wrong*, or something
17:23:49 <roshi> proposed #agreed - 1109603 - Un-proposed - Dropping blocker status from this bug due to the use of release kernels from here on out for F21.
17:24:05 <roshi> that saner?
17:24:35 <roshi> or "more sane," for grammar people
17:25:28 <pwhalen> wfm
17:25:44 <roshi> #agreed - 1109603 - Un-proposed - Dropping blocker status from this bug due to the use of release kernels from here on out for F21.
17:25:53 <roshi> 4 more accepted blockers to go through
17:26:04 <roshi> #topic (1123845) Server presets not applied in systemd scriptlets
17:26:04 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1123845
17:26:05 <roshi> #info Accepted Blocker, fedora-release, ON_QA
17:26:27 <adamw> sorry, /me multitasking
17:27:06 <roshi> np
17:27:15 <roshi> I wasn't aware of a time when you weren
17:27:20 <roshi> weren't
17:27:31 <roshi> looks resolved, sgallagh?
17:27:54 <sgallagh> roshi: I was attempting to verify this when I hit the blockers we already discussed
17:28:14 <sgallagh> I'll try to verify this later today, but I expect it's working
17:28:24 <sgallagh> (Cockpit *tried* to start, so that's highly indicative)
17:28:25 <roshi> sounds good
17:28:46 <roshi> #action sgallagh to verify status of this bug and document accordingly
17:28:58 <roshi> anything else for this one?
17:29:52 <adamw> https://lists.fedoraproject.org/pipermail/desktop/2014-August/010365.html for the workstation netinst status discussion
17:31:03 <roshi> thanks for starting that
17:31:28 <sgallagh> adamw: Thanks. That's one #action off my back :)
17:32:02 * roshi finds more #actions to load on sgallagh :p
17:32:20 <roshi> next bug then?
17:32:22 * sgallagh wonders when he gets to put down his mountain.
17:32:41 <roshi> #topic (1088933) update grubby to support device tree options for arm
17:32:44 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1088933
17:32:46 <roshi> #info Accepted Blocker, grubby, POST
17:33:02 <roshi> it's mountains all the way down, from what I can tell sgallagh :(
17:34:41 <adamw> sgallagh: mountain works are projected to continue through 2078
17:36:01 <roshi> looks like this is just waiting on someone to give dgilmore some more time
17:36:15 <roshi> danofsatx: how goes the research on the hyperbolic time chamber?
17:36:18 <roshi> or the cloning?
17:36:30 <danofsatx> 2bz
17:36:49 <danofsatx> school+work+wife/kids+kitchen remodel = notimefordan
17:37:37 <roshi> lol - so it would seem
17:37:41 <adamw> danofsatx: you know what'd help with that? a time chamber
17:38:00 <danofsatx> hell, I'd be happy with a healthy back at this point
17:38:03 <roshi> fine to move onto the next bug? (since it just seems to need time)
17:38:33 <adamw> i think so, though it worries me how long it's been sitting there
17:39:05 <roshi> is there anyone else who can fix it?
17:42:49 <adamw> pwhalen?
17:48:05 <roshi> I can ask pwhalen about it later, or dgilmore
17:48:13 <adamw> yeah, moving on for now
17:48:16 <roshi> #action roshi to track progress on this bug down
17:48:23 <roshi> #topic (1127450) Black screen after userless installation of KDE live
17:48:26 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1127450
17:48:29 <roshi> #info Accepted Blocker, initial-setup, ON_QA
17:48:31 <satellit> BZ 1127450 looked fixed to me - see last 2 comments
17:48:34 <roshi> this looks to be resolved but not updated
17:48:50 <roshi> what satellit said :)
17:49:17 <roshi> so this one just needs closed
17:49:19 <roshi> I can close it
17:49:36 <roshi> unless anyone has any issues with this'
17:49:46 <roshi> then onto the last accepted blocker
17:52:51 <roshi> moving on then :)
17:52:59 <roshi> #topic (1110758) SELinux prevents cockpit from working on Fedora 21
17:53:03 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1110758
17:53:05 <roshi> #info Accepted Blocker, selinux-policy-targeted, VERIFIED
17:53:45 <sgallagh> Shouldn't VERIFIED imply "off this list"?
17:54:01 <kparal> I guess it should
17:54:43 <adamw> no, not really
17:55:00 <adamw> well, when used the way we usually use it (/me hasn't opened the bug yet)
17:55:43 <adamw> it's usually used when Bodhi is in effect - we set bugs to VERIFIED when we know they're fixed but the fix hasn't been pushed stable or included in a build yet
17:55:48 <sgallagh> Ah
17:56:05 <adamw> as bodhi isn't in use yet there isn't really much need for VERIFIED
17:56:08 <adamw> if it's fixed just close it
17:56:08 <danofsatx> gotta run, class
17:56:14 <roshi> later danofsatx
17:56:29 <sgallagh> I'll verify and close it today
17:56:34 <adamw> thanks
17:56:45 <adamw> if there are issues with upgrade that should be filed separately (and nominated as beta blocker)
17:57:00 <roshi> onto the two accepted FE's?
17:57:05 <roshi> thanks sgallagh
17:57:16 <sgallagh> #action sgallagh to reverify and close
17:57:42 <roshi> this is why you have the mountian, you keep actioning yourself :p
17:57:53 <roshi> alright, first FE
17:57:54 <roshi> #topic (1116291) [en_US] imsettings-qt pulls in imsettings on Workstation Live causing: can't use any input method in gtk applications for en_US.utf8 locale
17:57:57 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1116291
17:58:00 <roshi> #info Accepted Freeze Exceptions, spin-kickstarts, VERIFIED
17:59:44 <roshi> looks fixed according to c12
18:02:48 <adamw> closed it.
18:02:53 <roshi> sweet
18:03:05 <roshi> thanks
18:03:06 <roshi> #topic (1044778) wandboard uboot missing serial line speed in console environment variable
18:03:10 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1044778
18:03:12 <roshi> #info Accepted Freeze Exceptions, uboot-tools, NEW
18:05:06 <roshi> any movement on this discussion kparal?
18:06:27 <adamw> i dunno if we need to push fe's along
18:06:32 <adamw> if they happen they happen if they don't, it's fine
18:06:49 <roshi> in that case, we're done
18:07:13 * kparal wakes up
18:08:05 <kparal> can't say really anything to it
18:08:32 <kparal> but yeah, it's just a FE
18:09:02 <roshi> yeah, no worries - just thought I'd check since we were here
18:09:22 <roshi> anyone need time for open floor or can I close out the meeting?
18:10:52 * roshi sets the quantum fuse in a superposition of both on and off
18:11:54 * jreznik_ hopes it's not going to cause any issues with time as it flows, not to go back to start of this meeting :)
18:13:00 * satellit_e it is a 2D hologram...
18:13:29 <roshi> well, once we get the quantum relay up and working we can get reports from ourselves in the alternate universes
18:13:45 <roshi> time should be ok, I have it air-gapped right now
18:13:48 <roshi> :)
18:15:09 <jreznik_> ok, thanks roshi for mtg, see you next time!
18:15:43 <roshi> np
18:15:50 <roshi> #endmeeting