16:01:58 <roshi> #startmeeting F21-blocker-review
16:01:58 <zodbot> Meeting started Wed Sep 17 16:01:58 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:01 <roshi> #meetingname F21-blocker-review
16:02:01 <zodbot> The meeting name has been set to 'f21-blocker-review'
16:02:04 <roshi> #topic Roll Call
16:02:08 * roshi is here, obviously
16:02:08 * kparal is here
16:02:20 * danofsatx es ahi
16:02:26 <roshi> that was a copy-paste, wonder why there was an extra #
16:02:26 * satellit afk
16:02:46 <sgallagh> .hellomynameis sgallagh
16:02:47 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:02:48 <roshi> #chair kparal danofsatx satellit_e adamw tflink  sgallagh
16:02:48 <zodbot> Current chairs: adamw danofsatx kparal roshi satellit_e sgallagh tflink
16:02:55 * pschindl is here
16:03:11 <roshi> #chair pschindl
16:03:11 <zodbot> Current chairs: adamw danofsatx kparal pschindl roshi satellit_e sgallagh tflink
16:03:22 <roshi> #topic Introduction
16:03:22 <roshi> Why are we here?
16:03:23 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:03:26 <roshi> #info We'll be following the process outlined at:
16:03:29 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:03:31 <roshi> #info The bugs up for review today are available at:
16:03:34 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:03:36 <roshi> #info The criteria for release blocking bugs can be found at:
16:03:39 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:03:42 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:03:44 * pwhalen is here
16:03:45 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:04:08 <roshi> #chair pwhalen
16:04:08 <zodbot> Current chairs: adamw danofsatx kparal pschindl pwhalen roshi satellit_e sgallagh tflink
16:04:17 <roshi> well, we've got one proposed blocker
16:04:33 <roshi> #topic (1142862) Installation progress is not redrawn in KDE
16:04:33 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1142862
16:04:33 <roshi> #info Proposed Blocker, anaconda, NEW
16:05:53 <adamw> it worked for me in a KDE live install yesterday, I think
16:06:02 <kparal> interesting
16:06:16 * adamw tests again
16:06:27 <sgallagh> kparal: Was this a physical system or VM?
16:06:35 <roshi> would this fall under the caveat documented in "showstoppers?"
16:06:36 <kparal> sgallagh: both tested, both problematic
16:07:34 <kparal> can somebody try real quick?
16:07:53 <pwhalen> seeing something similar with vnc installs on arm, the progress bar doesnt get redrawn at all unless you move to the useradd or rootpaswd screen. eventually when its finished reboot does come up but the var itself remains 'unfinished'
16:07:59 * roshi doesn't have KDE downloaded
16:08:22 <pwhalen> s/var/bar
16:08:29 <kparal> that could be the same issue
16:09:24 * adamw is looking at the install progress screen in a VM now...
16:09:33 <roshi> downloading now, gonna take 10 minutes or so though
16:10:01 <kparal> if it works for adamw, it's not a generic bug
16:10:02 * satellit on i7 here with USB installer to HD saw user and root at top and it did finidh for reboot (live i386 I think) do not remember the bar at bottom sorry
16:10:16 <adamw> kparal: odd we're both testing in VMs, though. is your VM SPICE or VNC?
16:10:18 <kparal> adamw: how many CPUs do you have allocated?
16:10:19 <pwhalen> i checked on an x86 vm and it was okay. the arm issue isnt kde specific, occurred with either workstation or server
16:10:30 <adamw> pwhalen: is that just the progress bar, though? not the entire screen?
16:10:31 <kparal> adamw: spice and qxl
16:10:43 <pwhalen> the bottom banner keeps refreshing
16:10:43 <adamw> kparal: same here. 2 CPUs and 2GB of RAM
16:10:53 <adamw> pwhalen: kparal seems to say the entire screen is not visible
16:10:59 <pwhalen> just the progress bar is locked
16:11:09 <pwhalen> ah, missed that
16:11:18 <kparal> the screenshot shows what's visible
16:11:25 <kparal> it doesn't change for the whole installation period
16:11:50 <pwhalen> indeed different
16:11:59 * jskladan is late to the party, but here :)
16:12:06 <kparal> haha, now I see it
16:12:20 <kparal> I don't know what changed
16:12:29 <adamw> sounds like maybe an intermittent bug?
16:12:35 <roshi> the bug is scared of too many people looking at it at the same time
16:12:38 <roshi> stage fright
16:12:49 <kparal> could be. but affecting machines regardless of hardware
16:13:47 <pwhalen> I just added a screen from tc7, but this also appears in rc1
16:14:40 <adamw> my instinct would be commonbugs for both
16:14:56 <roshi> sesms intermittent
16:15:00 <roshi> seems, even
16:15:10 <roshi> +1 commonbugs
16:15:16 <roshi> -1 blocker
16:15:23 <sgallagh> -1 blocker
16:15:29 <sgallagh> Yeah, commonbugs makes sense
16:15:44 <pwhalen> -1 blocker, +1 common bugs
16:15:53 <kparal> it depends on how often we'll see it, but yeah, it seems to be the best approach right now
16:16:12 <adamw> yeah, let's keep an eye out in the rest of testing
16:16:34 <roshi> who wants to secretarialize?
16:16:46 <pschindl> -1 blocker, +1 FE
16:16:52 * roshi wants to get that word accepted into the Oxford english dictionary
16:16:52 <adamw> i can
16:16:56 <adamw> =)
16:17:55 <sgallagh> I'm -1 on FE as well, for the record. Any change made to anaconda is potentially destabilizing at this point.
16:18:02 <roshi> proposed #agreed - 1142862 - RejectedBlocker - This bug seems to only manifest it self at random intervals and the installation doesn't *fail.* Will document as Common Bug and keep an eye out going forward.
16:18:18 <roshi> s/it self/itself
16:18:47 <kparal> ack
16:19:01 <pwhalen> ack
16:19:04 <adamw> ack
16:19:10 <pschindl> ack
16:19:11 <kalev> ack
16:19:16 <sgallagh> ack
16:19:17 <jskladan> ack
16:19:23 * amita joins late
16:20:20 <roshi> #agreed - 1142862 - RejectedBlocker - This bug seems to only manifest it self at random intervals and the installation doesn't *fail.* Will document as Common Bug and keep an eye out going forward.
16:20:30 <roshi> onto the FEs
16:20:49 <roshi> it's the Day of the Freeze Exception, it seems
16:21:09 <roshi> 11 of them
16:21:09 <sgallagh> Half of these seem to be "non-blocking spin is over its size maximum"
16:21:10 <roshi> #topic (1136050) add ppc64le as supported architecture for crash package
16:21:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1136050
16:21:15 <roshi> #info Proposed Freeze Exceptions, crash, ON_QA
16:21:24 <roshi> true
16:21:52 <kalev> how does it look right now, does the current RC look like it's going to be shipped?
16:22:03 <kalev> might not even have to go through the freeze exceptions if that's the case
16:22:56 * adamw whistles at the ceiling
16:23:05 <adamw> kalev: i refuse to believe it till we see it...
16:23:11 <kalev> :)
16:23:20 <roshi> I could see it happening, but I'm also not a betting man :p
16:23:23 * satellit USB installs work
16:23:55 * satellit lives that I tested
16:24:27 <kalev> netinstalls are no longer blocking for alpha, as per fesco decision
16:24:53 <adamw> the oversize issues don't matter that much
16:25:21 <roshi> I don't see a reason to not allow this FE, but it doesn't seem to break anything on a primary arch
16:25:30 <adamw> the libvirt fix is nice but i don't know if we'd want to pull it into a last-minute respin
16:25:41 <adamw> oh, we're doing the FEs?
16:25:46 <adamw> i was still in 'should we bother' mode
16:25:53 <roshi> that was what I was doing
16:26:02 <roshi> no idea what the rest of you guys were doing :p
16:26:25 * jreznik_ is here a bit late, the same meeting as every wednesday :)
16:26:29 <adamw> well, the fix is a new release, so it's clearly not just an arch change
16:26:33 <roshi> do we want to not go through the FEs and just get back to testing?
16:26:43 <adamw> if crash is included in any images i'd be -1 at this point
16:26:57 <adamw> unless anyone sees anything on the FEs they'd really want to pull into a last-minute RC2, that'd be my vote
16:27:11 <adamw> if we wind up slipping we can do an out-of-cycle review on friday or something to catch any we want
16:27:24 <kalev> I have tons of things I would want to pull in if we slip for one more week, but none if we ship tomorrow
16:27:32 <roshi> same here
16:27:56 <roshi> I'd almost do a blanket -1 FE unless we slip and then do a meeting on Friday to go through stuff
16:28:19 <jreznik_> yep, let's be conservative with changes this time
16:28:40 <roshi> aside from the oversize stuff, I guess - but that's less of an issue
16:28:51 <kalev> could do a mini-FE meeting at go-no/go time if we end up slipping
16:28:54 <adamw> roshi: the oversize stuff can skip for now, it's fine
16:29:00 <adamw> kalev: it wouldn't be so 'mini' :P
16:29:03 <kalev> :P
16:29:15 <roshi> yeah - 11 is a bit much for mini
16:29:34 <roshi> what we could do, is vote on the bugs under the presumption that votes will count if slippage occurs
16:29:37 <adamw> anyhoo, i'm +1 to skipping review for now
16:29:46 <adamw> roshi: that's a lot of wasted time if we wind up shipping, though
16:29:49 <adamw> time we could spend testing
16:29:53 <adamw> we still have a lot of matrix to fill out
16:29:57 <kalev> I'm +1 to skipping too, most of my votes would depend on if we slip or not and we don't know that yet
16:30:02 <sgallagh> +1 skip
16:30:09 <roshi> +1 skip
16:30:22 <roshi> so, endmeeting and roll on with testing?
16:31:00 <jreznik_> for that kde bug above, I saw it today with QXL/Spice, not with VNC/Cirrus and we had similar "it looks like locked-up" for years on KDE spin if my memory serves well... so maybe document it - use VNC/Cirrus
16:31:20 <adamw> jreznik_: it wfm with spice
16:31:32 <adamw> seems intermittent though
16:31:49 <roshi> end meeting or review accepted blockers?
16:33:09 * jreznik_ needs docking station, running out of batter, be back in moment
16:34:09 <kparal> nobody wants to say "review accepted blockers"
16:34:10 <adamw> i don't see anything needing review in accepted blockers
16:34:17 <adamw> i think we know where we are on netinst
16:34:25 <adamw> anaconda does seem to be DTRT, we need mirrormanager fixing
16:34:37 <adamw> though i probably should test the metadata-collision with hand-made repo definitions...
16:34:44 <roshi> well, then lets call it and get back to testing
16:34:54 <jreznik_> and fesco agreed on netinst ticket, thanks sgallagh
16:36:16 <roshi> well, I'll set the fuze
16:36:27 <roshi> anything else anyone wants to bring up?
16:36:38 <kalev> pzzzzzzzz...... (that's the noise a fuse does when burning from one end)
16:37:16 * satellit where is mate spin?
16:38:58 <roshi> no idea satellit_e
16:39:16 <satellit> it failed in koji
16:40:27 <roshi> well, thanks for coming folks!
16:40:34 <roshi> #endmeeting