16:03:55 <pschindl> #startmeeting F21-blocker-review
16:03:55 <zodbot> Meeting started Wed Nov 19 16:03:55 2014 UTC.  The chair is pschindl. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:02 <pschindl> #meetingname F21-blocker-review
16:04:02 <zodbot> The meeting name has been set to 'f21-blocker-review'
16:04:10 <pschindl> #topic Roll Call
16:04:22 <kparal> a new leader has arrived! :-)
16:04:27 * kparal is here
16:04:30 <sgallagh> .hello sgallagh
16:04:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:04:35 * pschindl is improvising
16:04:40 <jskladan> I, for all, welcome our alien overlord!
16:04:49 <pschindl> how is here for some fun?
16:05:12 <pschindl> #chair kparal jskladan
16:05:12 <zodbot> Current chairs: jskladan kparal pschindl
16:05:18 <jskladan> pschindl: s/how/who/ ?
16:05:18 <pschindl> *who
16:05:31 <kparal> lest wsap lettres fro soem fnu!
16:05:48 <roshi> .hello roshi
16:05:48 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
16:05:50 <pschindl> yes, sry. I just returned from gym. My brain is recovering right now
16:05:52 <sgallagh> kparal: That only works if the first and last letters remain the same
16:06:10 <kparal> sgallagh: nah, that's just for beginners
16:06:33 <kparal> I guess adamw is still on PTO today
16:06:47 <roshi> yeah, I think this is the last day though
16:07:17 <kparal> if somebody else wants to secretarialize, that would be great, I'm quite busy trying to report one more blocker bug ;)
16:07:28 <roshi> I can do it this time around :)
16:07:28 * oddshocks pops in
16:07:53 <pschindl> #chair roshi sgallagh
16:07:53 <zodbot> Current chairs: jskladan kparal pschindl roshi sgallagh
16:08:01 <pschindl> #topic Introduction
16:08:04 <pschindl> Why are we here?
16:08:06 <pschindl> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:08:08 <pschindl> #info We'll be following the process outlined at:
16:08:10 <pschindl> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:08:12 <pschindl> #info The bugs up for review today are available at:
16:08:14 <pschindl> #link http://qa.fedoraproject.org/blockerbugs/current
16:08:16 <pschindl> #info The criteria for release blocking bugs can be found at:
16:08:18 <pschindl> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:08:20 <pschindl> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:08:22 <pschindl> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:08:28 <pschindl> #info 9 Proposed Blockers
16:08:31 <pschindl> #info 6 Accepted Blockers
16:08:33 <pschindl> #info 11 Proposed Freeze Exceptions
16:08:35 <pschindl> #info 3 Accepted Freeze Exceptions
16:09:06 <kparal> no one can say QA is not productive
16:09:22 <kparal> but the developers are slow with fixing stuff! ;)
16:09:26 <pschindl> first blocker (0/9)
16:09:30 <pschindl> #topic (1162856) Missing high contrast icon
16:09:32 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1162856
16:09:34 <pschindl> #info Proposed Blocker, fedora-logos, NEW
16:10:06 <pschindl> I looked at this one and it's missing on TC2
16:10:10 <kparal> haven't we discussed this already?
16:10:12 <pschindl> so I'm +1
16:10:19 <pschindl> this one is another one.
16:10:24 <kparal> ah
16:10:26 <pschindl> But it's the same
16:10:28 <kparal> right, proposed two days ago
16:10:44 <kparal> oh, see my comment 2
16:10:50 <pschindl> There 3 icons which break criterion
16:10:57 <kparal> I believe this is already accepted transitively
16:11:34 <kparal> does someone remember exactly how Blocks: works when it comes to blocker bugs?
16:12:30 <kparal> since it was already proposed, I think we can just say 'accepted, because it blocks an existing blocker'
16:13:03 <pschindl> proposed #agreed - 1162856 - AcceptedBlocker - This bug blockes another blocker bug.
16:13:20 <roshi> it blockes because the criteria say the specification has to be met
16:13:28 <roshi> and high contrast is part of that specification
16:14:10 <pschindl> or I can put there the same thing as we put to the other one blocker of this kind
16:14:22 <roshi> that's what I would do
16:14:38 <kparal> either way
16:15:00 <roshi> "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.
16:15:00 <sgallagh> I slightly prefer pschindl's proposal
16:15:01 <pschindl> proposed #agreed - 1162856 - AcceptedBlocker -  This bug is a clear violation of the Final criterion: All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.
16:15:20 <roshi> ack
16:15:27 <sgallagh> That's fine too. Ack
16:15:53 <pschindl> come on, give me some acks :)
16:16:04 <roshi> .moar acks pschindl
16:16:04 <zodbot> here pschindl, have some more acks
16:16:14 <pschindl> #agreed - 1162856 - AcceptedBlocker -  This bug is a clear violation of the Final criterion: All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.
16:16:33 <pschindl> 1/9 check :)
16:16:38 <pschindl> #topic (1165430) Fedora-repos needs updating for f21 final
16:16:40 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165430
16:16:42 <pschindl> #info Proposed Blocker, fedora-repos, ON_QA
16:17:11 <pschindl> There are already two +1
16:17:19 <sgallagh> +1 blocker
16:17:38 <roshi> yeah, and I think the update for this just needs one more karma
16:17:40 <roshi> +1
16:17:53 <oddshocks> +1 from me, seems straightforward
16:18:05 <kparal> maybe we should remove the pictures from criteria, they are funny when copied :)
16:18:12 <kparal> +1
16:18:36 <pschindl> proposed #agreed - 1165430 - AcceptedBlocker - This bug violates the final criterion: A Package-x-generic-16.pngfedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned Package-x-generic-16.pnggeneric-release package must be available in the release repository.
16:18:40 <pschindl> patch?
16:18:44 <kparal> please do :)
16:18:54 <roshi> :)
16:19:15 <kparal> strip all Package-x-generic-16.png
16:19:40 <pschindl> ok :(
16:19:42 <pschindl> proposed #agreed - 1165430 - AcceptedBlocker - This bug violates the final criterion: A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned generic-release package must be available in the release repository.
16:19:55 <kparal> OTOH, it was the criterion _verbatim_, right? :)
16:20:03 <kparal> ack
16:20:06 <sgallagh> ack
16:20:08 <roshi> ack
16:20:19 <pschindl> #agreed - 1165430 - AcceptedBlocker - This bug violates the final criterion: A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned generic-release package must be available in the release repository.
16:20:24 <pschindl> tadaaaaaa 2/9
16:20:33 <pschindl> #topic (1165261) ipa-server-install fails when restarting named
16:20:35 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165261
16:20:37 <pschindl> #info Proposed Blocker, freeipa, POST
16:21:12 <pschindl> I'm trying that one right now.
16:21:56 <sgallagh> pschindl: Hmm?
16:22:24 <kparal> not a trivial fix it seems
16:22:34 <sgallagh> Oh, that reminds me: the Server WG approved a set of Final Criteria at yesterday's meeting.
16:22:50 <kparal> I assume freeipa is in the domain controller role
16:22:55 <kparal> so this violates the criterion
16:22:59 <roshi> +1
16:23:01 <sgallagh> It's basically identical to the proposal https://lists.fedoraproject.org/pipermail/server/2014-November/001551.html
16:23:14 <sgallagh> I haven't had a chance to add it to the official criteria yet
16:23:43 <kparal> sgallagh: does it change something in this case?
16:24:02 <kparal> i.e. affect the blocker status
16:24:04 <sgallagh> kparal: No, but I should note that it was proposed specifically with those in mind
16:24:15 <sgallagh> (The DNS requirement is new to these)
16:25:29 <kparal> so, it seems to be a clear violation
16:25:42 <sgallagh> Yes
16:25:47 <sgallagh> +1 blocker (for the record)
16:26:47 <pschindl> Ok. I'm +1, but where can I find that criterion (for proposal)?
16:27:45 <pschindl> proposed #agreed - 1165261 - AcceptedBlocker -  Violates Fedora Server criterion that the Domain Controller role must be installable and DNS must work after install.
16:27:45 <kparal> there is something here: https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Domain_controller_role
16:27:53 <pschindl> or is this enough?
16:27:58 <kparal> but it's not exactly what is cited in the bugzilla
16:28:28 <kparal> and it's not exactly from the linked proposal either
16:28:59 <kparal> so we should find a matching one, I believe
16:29:07 <jskladan> kparal: patch then?
16:29:19 <kparal> yes, but not sure what to put there
16:30:30 <pschindl> sgallagh: do you have some idea what to put there?
16:30:36 <sgallagh> Just a sec
16:30:56 <sgallagh> I think the current proposal is accurate
16:31:07 <roshi> the beta roles criteria: Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully started, stopped, brought to a working configuration, and queried.
16:31:07 <sgallagh> The problem is just that the criteria hasn't been added to the page yet
16:31:10 <sgallagh> I'll do that today.
16:33:11 <pschindl> proposed #agreed - 1165261 - AcceptedBlocker - This bug violates the beta roles criteria: Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully started, stopped, brought to a working configuration, and queried.
16:34:48 <kparal> ack
16:34:50 <roshi> ack
16:34:54 <jskladan> ack
16:35:16 <pschindl> #agreed - 1165261 - AcceptedBlocker - This bug violates the beta roles criteria: Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully started, stopped, brought to a working configuration, and queried.
16:35:19 <pschindl> 3/9
16:35:27 <pschindl> #topic (1164492) Please drop libvirt 'default' network dependency for F21 GA
16:35:30 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1164492
16:35:32 <pschindl> #info Proposed Blocker, gnome-boxes, NEW
16:37:31 <oddshocks> hm
16:38:25 <oddshocks> AFAICT, still seems to be an issue
16:38:52 <oddshocks> does anyone see a spot where anyone has asserted that boxes would be able to handle this issue properly?
16:39:33 <kparal> we can't mandate that boxes dependency is dropped, but we can mandate that the problem must be resolved somehow
16:39:44 * oddshocks nods
16:39:58 <kparal> I think this is basically just one way to solve https://bugzilla.redhat.com/show_bug.cgi?id=1146232
16:40:03 <kparal> which is already a final blocker
16:40:10 <kparal> accepted
16:41:01 <kparal> so, I don't know what's the best way to do here wrt to our QA bureaucracy
16:41:15 <kparal> but yes, this is one of the ways how to resolve that blocker
16:42:00 <roshi> I think it violates the "Defualt applications must work" criteria for workstation, regardless
16:42:24 <pschindl> If this is only one way to solve another blocker, then I'm -1. One blocker which addresses this problem should be enough. Or not?
16:42:31 <kparal> Cole's assumption is that boxes will work without libvirt networking installed
16:44:01 <kparal> I think I would simply remove the blocker proposal, because Cole hasn't realized that 1146232 is already a blocker, which covers the same thing
16:44:18 <roshi> yeah
16:44:19 <pschindl> -1
16:44:34 <roshi> it looks like when 1146242 gets fixed this won't be an issue anymore
16:44:37 <roshi> -1
16:44:41 <kparal> but we should explain inside that bug report that this is one of the ways how to resolve it (IIUIC), so they should consider it, and ideally fast
16:44:53 <pschindl> So we can move to next one and pretend that this one wasn't proposed? :)
16:45:08 <jskladan> yay!
16:45:35 <kparal> I think formally it doesn't matter whether we do "rejected blocker", or "remove blocker proposal"
16:45:50 <kparal> the latter seems a bit nicer, though :)
16:46:24 <pschindl> proposed #agreed - 1164492 - RejectedBlocker - This bug tryes to solve the same issue as bug 1146232 which is already blocker.
16:46:25 <kparal> the explanation and a usual discussion link should be of course put there
16:46:32 <jskladan> ack
16:46:35 <kparal> pschindl: tries
16:46:47 <pschindl> kparal:  thanks :)
16:46:52 <kparal> ack
16:46:59 <pschindl> proposed #agreed - 1164492 - RejectedBlocker - This bug tries to solve the same issue as bug 1146232 which is already blocker.
16:47:22 <kparal> ack again
16:47:28 <jskladan> ack? I guess?
16:47:40 <kparal> jskladan: think carefully
16:47:57 <jskladan> kparal: /me is not really sure, that one was a gamechanger...
16:48:02 <pschindl> another acks? (besides two acks from kparal and half one from jskladan)?
16:48:46 <pschindl> #agreed - 1164492 - RejectedBlocker - This bug tryes to solve the same issue as bug 1146232 which is already blocker.
16:48:49 <roshi> ack
16:48:55 <pschindl> I knew it :)
16:49:02 <pschindl> 4/9
16:49:04 <kparal> facepalm
16:49:13 <pschindl> #topic (1165425) bcl accidentally pushed a diagnostic 'bcl was here' test for product.img
16:49:15 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165425
16:49:17 <pschindl> #info Proposed Blocker, lorax, MODIFIED
16:49:48 <pschindl> I like that string and I wouldn't mind to have it in logs :)
16:50:13 <kparal> heh, this one's funny
16:50:27 <kparal> bcl would be everywhere after F21 release :D
16:51:31 <roshi> I don't know if I would block on it, but for sure FE
16:51:32 <kparal> it's good that he used something polite as a logging message. not everybody does that :)
16:51:35 <kparal> -1/+1
16:51:49 <sgallagh> -1 blocker, +1 FE
16:51:50 <roshi> since we don't have a "bcl can't be mentioned in logs" criteria :p
16:51:56 <kparal> :D
16:52:01 <roshi> -1/+1 (if it wasn't obvious)
16:53:19 <pschindl> proposed #agreed - 1165425 - RejectedBlocker AcceptedFreezeException - This could be a good example of 'why should you check if you removed all debugging prints' but it will be better to remove it :)
16:54:11 <roshi> lol
16:54:48 <roshi> patch: Since this doesn't violate a specific criteria it can't block, but we accept it as a freeze exception.
16:55:00 <roshi> patch: Since this doesn't violate a specific criterion it can't block, but we accept it as a freeze exception.
16:55:26 <kparal> sounds better
16:55:29 <pschindl> proposed #agreed - 1165425 - RejectedBlocker AcceptedFreezeException - Since this doesn't violate a specific criterion it can't block, but we accept it as a freeze exception.
16:55:33 <pschindl> :(
16:55:37 <kparal> ack
16:56:14 <roshi> ack
16:56:37 <pschindl> another acks (or do you think my version is better?)
16:56:44 <pschindl> ack from me for roshi proposal :)
16:57:08 <pschindl> #agreed - 1165425 - RejectedBlocker AcceptedFreezeException - Since this doesn't violate a specific criterion it can't block, but we accept it as a freeze exception.
16:57:11 <pschindl> 5/9
16:57:20 * jreznik_2nd is again on his call, will join you later
16:57:26 <pschindl> #topic (1164889) support TLS 1.1 and later
16:57:28 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1164889
16:57:30 <pschindl> #info Proposed Blocker, openldap, NEW
16:57:53 <pschindl> jreznik_2nd: hurry there are only 4 more left. You will miss it!
16:58:39 <pschindl> The only question here is only if we consider this functionality to be basic.
16:58:57 <sgallagh> pschindl: Well, I'd like to push for one or two of the FEs to get discussed too (in part because they're basically ready to get into the RC composes)
16:59:24 <sgallagh> Anyway, this one breaks FreeIPA and therefore is a chain reaction into at least the Domain Controller criteria
16:59:28 <sgallagh> so +1 blocker
17:00:43 <roshi> yeah
17:00:44 <roshi> +1
17:01:04 <pschindl> heh, sry I was thinking about different bug.
17:01:13 <pschindl> +1 here :)
17:02:17 <sgallagh> /me disappears for five minutes to bring lunch back to his desk.
17:02:32 <kparal> +1 per criteria
17:02:34 <jskladan> +1
17:02:43 <oddshocks> +1
17:02:45 * roshi is cooking bacon for breakfast :)
17:02:53 * danofsatx-work shows up way late
17:03:09 <roshi> welcome danofsatx-work :)
17:03:13 <oddshocks> danofsatx-work: it's too late -- we've had to cancel the entire Fedora project
17:03:16 <pschindl> proposed #agreed - 1164889 - AcceptedBlocker - This bug violates the final creterion for fedora server:  "The Domain Controller must be capable of serving LDAPS (LDAP encrypted with SSL) over port 636. This should be validated by the use of the ldapsearch tool."
17:03:58 <roshi> yep, and it's all your fault :p
17:04:10 <jskladan> ack
17:04:10 <roshi> ack
17:04:26 <oddshocks> ack
17:04:32 <danofsatx-work> ack
17:04:40 <pschindl> #agreed - 1164889 - AcceptedBlocker - This bug violates the final creterion for fedora server:  "The Domain Controller must be capable of serving LDAPS (LDAP encrypted with SSL) over port 636. This should be validated by the use of the ldapsearch tool."
17:04:45 <danofsatx-work> roshi: ack thppppppt!
17:04:50 <pschindl> 6/9
17:04:58 <pschindl> #topic (1163694) ValueError: new size will not yield an aligned partition
17:05:01 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1163694
17:05:03 <pschindl> #info Proposed Blocker, python-blivet, NEW
17:05:26 * kparal asked dlehman to join us
17:05:45 <kparal> there is some more info in https://bugzilla.redhat.com/show_bug.cgi?id=1165714
17:06:31 <kparal> according to the last comment, I should have probably moved the blocker nomination to 1165714
17:08:10 <kparal> IIUIC, if the current partition is not aligned, anaconda crashes, or might crash, depending on steps taken
17:09:02 <roshi> I hesitate to vote +1 on something without clear reproduction steps
17:09:13 <roshi> but I'd hate for this stuff to happen at GA
17:09:18 <kparal> IIUIC, if the current partition is not aligned, anaconda crashes, or might crash, depending on steps taken
17:09:23 <kparal> dlehman: is that correct? ^^
17:10:01 <kparal> talking about 1163694 and 1165714
17:10:08 <kparal> the blocker nomination can be moved to 1165714
17:10:47 <roshi> I'm fine with moving the nomination
17:11:58 <dlehman> kparal: right. if you cancel/revert a scheduled resize on a partition that was not initially end-aligned you'll hit the bug
17:12:31 <dlehman> the fix is simple and safe
17:12:38 <kparal> dlehman: what are your thoughts on blocker status for this one?
17:13:08 <dlehman> it should probably block the final release since we support endless disk selection twiddling
17:13:21 <kparal> ok
17:13:33 <kparal> dlehman: thanks
17:13:37 <kparal> +1 here
17:13:47 <jskladan> ^^
17:13:55 <kparal> pschindl: when proposing, please use 1165714
17:14:07 <kparal> I'll move the nomination now
17:14:10 <roshi> +1
17:14:20 <pschindl> kparal: ok
17:14:28 <roshi> I'll ignore 1163694 in my secretarializing
17:15:15 <pschindl> proposed #agreed - 1165714 - AcceptedBlocker - This violates the final criterion: Any installer mechanism for resizing storage volumes must correctly attempt the requested operation.
17:15:25 <jskladan> ack
17:15:25 <roshi> ack
17:15:26 <kparal> ack
17:15:39 <pschindl> #agreed - 1165714 - AcceptedBlocker - This violates the final criterion: Any installer mechanism for resizing storage volumes must correctly attempt the requested operation.
17:15:45 <pschindl> 7/9
17:15:54 <pschindl> #topic (1163660) Unable to create OpenSSH Key with seahorse
17:15:56 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1163660
17:15:58 <pschindl> #info Proposed Blocker, seahorse, POST
17:16:16 <pschindl> pschindl:  The only question here is only if we consider this functionality to be basic.
17:16:29 <sgallagh> /me reads
17:16:32 <pschindl> I was thinking about this bug.
17:17:00 <sgallagh> This isn't a blocker, IMHO
17:17:06 <kparal> well, we considered creating gpg key a basic function
17:17:12 <sgallagh> do we?
17:17:13 <kparal> and blocked on it a few weeks ago
17:17:16 <sgallagh> ...
17:17:23 <pschindl> Than I'm +1
17:17:32 <kparal> I can find the bug
17:17:33 <sgallagh> But it's a bug only in Seahorse, not creating an SSH key on the console
17:18:10 <kparal> sgallagh: comment 1 has the criterion cited, this is about basic functionality test
17:18:28 <kparal> it's our call to resolve what is a basic functionality and what is not
17:18:38 <roshi> I think we do
17:18:57 <roshi> seems like a clear violation to me
17:18:58 <kparal> but we accepted a similar bug about gpg keys generation broken
17:19:21 <sgallagh> kparal: I don't think this necessarily qualifies as basic functionality of Seahorse.
17:19:28 * roshi doesn't use seahorse - but if I was a GUI user I'd want that as basic functionality, especially on a *workstation*
17:19:33 <sgallagh> I think it's very important, but not necessary to Seahorse's operation
17:20:00 <sgallagh> So I still think it's a great FE, but I wouldn't block on it if this was the last thing holding up a release.
17:20:02 <kparal> seahorse is basically a gnome keyring + ssh + gpg key manager
17:20:20 <kparal> so, it can be argued that adding an ssh key is a basic functionality
17:20:36 <roshi> yeah, seahorse is the workhorse for keys in gnome, aiui
17:20:49 <kparal> found it, here's a reference: https://bugzilla.redhat.com/show_bug.cgi?id=1153676
17:20:52 <kparal> accepted blocker
17:21:43 <sgallagh> kparal: I think "all GPG is broken" vs. "generating new SSH keys is broken" is a difference of an order of magnitude
17:21:51 <roshi> for sure
17:22:06 <roshi> but if you're a dev using workstation and you can't generate you ssh keys?
17:22:07 <kparal> well, the comment 0 then specifies:
17:22:08 <kparal> 2. Attempt to (a) change the expiration date of the key, or (b) sign it with another key, using Seahorse
17:22:21 <kparal> creating a gpg key actually worked at that time
17:22:59 <sgallagh> /me sighs
17:23:27 <kparal> for consistency, I believe this should be +1
17:23:36 <sgallagh> The argument is largely academic, since they've already fixed it. I'm just wary of getting to a point where that criterion means that everything is a blocker.
17:24:07 <roshi> I guess I just see it as "does the default app have a button to do foo? Does that button work? No? Ok, block." as my interpretation of the default functionality criteria
17:24:08 <kparal> it might get tricky sometimes, I admit
17:25:00 <danofsatx-work> +1 blocker.
17:25:10 <kparal> for a photo viewer, I wouldn't block on e.g. exif metadata adjustment problems. just on picture display problems
17:25:16 <kparal> but seahorse is a key manager
17:25:22 <pschindl> +1 from me.
17:25:26 <kparal> creating a key is a basic operation
17:25:29 <sgallagh> kparal: OK, fair enough.
17:25:35 <sgallagh> I'm convinced: +1 blocker
17:25:41 <pschindl> proposed #agreed - 1163660 - AcceptedBlocker - Ability to create OpenSSH Key is considered as basic functionality of seahorse. So this violates the final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. *Basic functionality means that the app must
17:25:43 <pschindl> at least be broadly capable of its most basic expected operations"
17:25:44 <sgallagh> I just *really* don't like this criterion as written
17:26:03 <kparal> pschindl: that got split, but doesn't matter
17:26:04 <danofsatx-work> I'll need to verify, but if it works like kwallet, the first time you try to save a password, it will ask you to generate a key to encrypt the DB. if that is broken, then we have a pop up that does not work.
17:26:11 <kparal> ack
17:26:21 <jskladan> ack
17:26:24 <danofsatx-work> ack
17:26:25 <roshi> ack
17:26:33 <pschindl> #agreed - 1163660 - AcceptedBlocker - Ability to create OpenSSH Key is considered as basic functionality of seahorse. So this violates the final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. *Basic functionality means that the app must at least
17:26:35 <pschindl> be broadly capable of its most basic expected operations"
17:26:48 <pschindl> 8/9 - the last one is:
17:26:53 <pschindl> #topic (1162068) High Xorg cpu usage during F21 beta install prevents installation
17:26:55 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1162068
17:26:57 <pschindl> #info Proposed Blocker, xorg-x11, NEW
17:28:19 <kparal> I have seen other reports of problems with T61. all solved by https://bugzilla.redhat.com/show_bug.cgi?id=1148493
17:28:30 <kparal> this OP has X61, so not sure whether it's the same problem
17:28:36 <kparal> but could be
17:29:12 <kparal> I think we've been successful in punting once, we can do it again and ask the reporter to test with a new TC/nightly with updated intel drivers
17:29:41 <kparal> ah, it's the same VGA
17:29:45 <kparal> X61 and T61
17:29:51 <pschindl> kparal: +1 I don't like this bug. I'm not sure if we could convince someone to test fix.
17:29:54 <kparal> so it will be most probably solved by that intel update
17:30:19 <pschindl> +1 punt
17:30:39 <roshi> I'm fine with punting
17:30:41 <sgallagh> +1 punt
17:30:54 <danofsatx-work> +1 punt, I can't reproduce
17:32:04 <pschindl> proposed #agreed - 1162068 - Punt - It is possible that this bug was already resolved. We will wait for more information again.
17:32:17 <roshi> ack
17:32:35 <pschindl> ack/nack/patch?
17:33:11 <kparal> I already asked OP to test with today's nightly
17:33:17 <kparal> it should have the updated intel driver inside
17:33:23 <kparal> ack
17:33:32 <danofsatx-work> ack
17:33:56 <sgallagh> ack
17:34:01 <pschindl> #agreed - 1162068 - Punt - It is possible that this bug was already resolved. We will wait for more information again.
17:34:38 <pschindl> That was the last proposed blocker.
17:34:59 <pschindl> At which proposed FE we want to look right now?
17:35:12 <sgallagh> pschindl: The cockpit and FreeIPA ones, please
17:35:44 <pschindl> ok. So first one is:
17:35:47 <pschindl> #topic (1161775) No Fedora branding for Cockpit in Fedora 21 Server
17:35:49 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1161775
17:35:51 <pschindl> #info Proposed Freeze Exceptions, cockpit, NEW
17:36:13 <sgallagh> oof, one moment. BRB
17:37:22 <kparal> branding changes should be safe, sounds reasonable
17:39:39 <sgallagh> back
17:39:47 <sgallagh> Yeah, no code change involved.
17:40:01 <kparal> +1
17:40:07 <pschindl> +1 from me too
17:40:19 <roshi> +1 here
17:40:19 <sgallagh> +1
17:41:06 <pschindl> proposed #agreed - 1161775 - AcceptedFreezeException - Branding shouldn't bring any problems.
17:42:05 <sgallagh> ack
17:42:07 <kparal> ack
17:42:45 <pschindl> #agreed - 1161775 - AcceptedFreezeException - Branding shouldn't bring any problems.
17:42:47 <danofsatx-work> ack
17:43:07 * danofsatx-work is lagging, sorry
17:43:24 <pschindl> #topic (1165674) getkeytab control implementation uses incorrect asn1 encoding
17:43:26 <pschindl> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165674
17:43:28 <pschindl> #info Proposed Freeze Exceptions, freeipa, NEW
17:44:15 <sgallagh> So this is a non-trivial fix, but one that will result in backwards-incompatible behavior and thus would be problematic for a post-release update
17:45:54 <kparal> hmm, this is potentially quite risky, I assume
17:45:55 <roshi> that's how I read it
17:46:55 <sgallagh> /me summons simo
17:50:56 <simo> hi
17:51:18 <kparal> simo: hello. how risky is that update when it comes to introducing new bugs?
17:51:20 <sgallagh> simo: We're discussing 1165674
17:51:44 <kparal> and a second question, is a fix available right now?
17:52:00 <kparal> meaning updated package
17:52:01 <simo> kparal: low risk
17:53:19 <sgallagh> kparal: No, it hasn't been built into a package yet
17:53:50 <kparal> I think we should take it only if it is incorporated into TCs very soon
17:54:01 <kparal> it would be a much greater risk soon before final release
17:54:14 <sgallagh> I agree
17:54:15 <roshi> I'd like to see it in a TC to test the fix
17:54:19 <simo> kparal: much greater risk based on what ?
17:54:28 <sgallagh> simo: risk to the schedule
17:54:34 <simo> I see
17:54:39 <sgallagh> If it lands tomorrow and breaks something, we have time to fix it
17:54:40 <simo> well I have 2 blockers too
17:54:41 <simo> so ..
17:54:46 <roshi> is the package updated already and not in a TC or is it not fixed anywhere yet?
17:54:57 <roshi> ah
17:55:00 <roshi> nvm, I can read
17:55:02 <roshi> I swear :)
17:55:12 <simo> fixes for all blockers and freeze exceptions are being reviewed upstream
17:55:19 <simo> we should be able to build packages soon
17:55:35 <roshi> sweet
17:55:38 <sgallagh> simo: "soon" is Friday? Monday?
17:55:49 <simo> I hope it can be tomorrow
17:55:54 <sgallagh> ok
17:55:55 <kparal> sounds good
17:56:12 <kparal> +1, "soon" condition (as usual, anyways:)
17:56:22 <roshi> +1
17:56:33 <sgallagh> +1
17:56:53 <sgallagh> Condition: if it doesn't land by Monday (in time for the next TC), revisit?
17:57:09 <roshi> wfm
17:58:33 <pschindl> proposed #agreed - 1165674 - AcceptedFreezeException - Update addressing this bug is considered as Freeze exception. If the update won't be available in Monday, we can revisit.
17:58:50 <roshi> patch
17:59:32 <pschindl> Patches welcome
17:59:37 <roshi> We will consider a fix for this if the updated package is available by Monday 2014-11-24. If not, we can revisit at the next meeting.
17:59:57 <pschindl> proposed #agreed - 1165674 - AcceptedFreezeException - We will consider a fix for this if the updated package is available by Monday 2014-11-24. If not, we can revisit at the next meeting.
18:00:11 <pschindl> roshi: Thank you.
18:00:19 <roshi> np :)
18:00:45 <sgallagh> ack
18:00:49 <roshi> ack
18:01:22 <pschindl> #agreed - 1165674 - AcceptedFreezeException - We will consider a fix for this if the updated package is available by Monday 2014-11-24. If not, we can revisit at the next meeting.
18:01:45 <pschindl> ok, I can't find any other fe for freeipa and cockpit.
18:01:57 <sgallagh> I think that's all the ones that are currently proposed
18:01:59 <pschindl> So do you want to go through another FE?
18:02:14 * pschindl doesn't
18:02:17 <kparal> all of them, I suppose
18:02:17 <sgallagh> But simo mentioned he has another Blocker proposal coming soon (related to a CVE bug, so probably an auto-blocker)
18:02:20 <kparal> we're in a freeze
18:02:41 <pschindl> ah. OK.
18:03:03 <pschindl> Than I'd like to ask someone to continue with meeting, I have to leave in few minutes.
18:03:52 <roshi> I can take over if someone wants to secretarialize
18:03:58 <roshi> or kparal, can you take over?
18:04:01 <kparal> I'll take over
18:04:17 * roshi sees what you did there :p
18:05:01 <kparal> #topic (1143981) artifacts on two background sizes
18:05:01 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1143981
18:05:01 <kparal> #info Proposed Freeze Exceptions, f21-backgrounds, NEW
18:05:01 <pschindl> Thanks
18:05:56 <roshi> +1
18:06:00 <kparal> +1
18:06:46 <kparal> jskladan: do we still have you?
18:07:37 <jskladan> nah, I'm on my way to the cinema, long ping longer pong...
18:07:51 <kparal> sgallagh: still available for FEs?
18:08:00 <sgallagh> Yes
18:08:08 <jreznik_2nd> +1
18:08:08 <kparal> great
18:08:11 <sgallagh> Splitting time with FESCo though
18:08:29 <kparal> oh, I'm the one that should #propose now
18:09:01 <kparal> proposed #agreed - 1143981 - AcceptedFreezeException - This is a low risk change.
18:09:09 <sgallagh> ack
18:09:22 <roshi> ack
18:09:32 <kparal> ack
18:09:35 <kparal> #agreed - 1143981 - AcceptedFreezeException - This is a low risk change.
18:09:44 <kparal> #topic (1155228) put variant-specific gfx in img dirs for correct product
18:09:44 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1155228
18:09:44 <kparal> #info Proposed Freeze Exceptions, fedora-logos, NEW
18:11:16 * pschindl has to leave now. Enjoy the rest of the meeting!
18:11:27 <kparal> pschindl: not funny!
18:11:31 <kparal> too late
18:11:38 <sgallagh> OK, so with the latest changes, this should hopefully be a low-but-not-insignificant risk
18:11:51 <kparal> I still haven't found who and where proposed it
18:12:00 <roshi> yeah, reading now
18:12:05 <kparal> ah, last comment, no explanation
18:12:19 <sgallagh> stickster proposed it
18:12:33 <kparal> pfrields will not get a cookie
18:12:46 <sgallagh> It's arguably a blocker, but I think the idea was to leave it an FE in case we have to abort near the end.
18:12:56 <sgallagh> /me summons mattdm
18:13:07 <roshi> I guess I lean +1
18:13:14 <roshi> with how I understand it now, anyways
18:13:36 <jreznik_2nd> sgallagh: yep, I think this should be blocker but I'm ok with FE
18:13:52 <mattdm> is here
18:14:04 <mattdm> are we talking about graphics?
18:14:13 <sgallagh> (01:11:37 PM) sgallagh: OK, so with the latest changes, this should hopefully be a low-but-not-insignificant risk
18:14:13 <sgallagh> (01:12:46 PM) sgallagh: It's arguably a blocker, but I think the idea was to leave it an FE in case we have to abort near the end.
18:14:17 <kparal> I haven't had time to read the 50 comments, obviously, but I'll trust jreznik here
18:14:36 <sgallagh> mattdm: What's the status on this?
18:14:52 <kparal> mattdm: the question is a) how much we want it? and b) what can break?
18:14:55 <sgallagh> I'm getting nervous; can we guarantee an updated package by Monday?
18:15:08 <mattdm> we are waiting for graphics to be added to fedora-logos by the package maintainer
18:15:11 <mattdm> (spot)
18:15:12 <sgallagh> kparal: If we get it wrong, it means a respin of the compose.
18:15:29 <sgallagh> So that means a minimum loss of eight hours.
18:15:29 <mattdm> but fortunately, it can be almost 99% tested without respinning the image
18:15:38 <sgallagh> OK, that's good
18:15:49 <mattdm> because that's basically its design use case :)
18:15:59 <mattdm> for the livecd, it has to go on the cd
18:16:19 <mattdm> (that is, inside the live image)
18:16:39 <mattdm> for server/cloud, if it's in the compose environment, it will be picked up
18:17:02 <mattdm> (i assume that this means eg fedora-install-server.ks)
18:17:28 <kparal> so +1, but it should be done soon, ideally before TC3 request
18:18:10 <sgallagh> mattdm: Would you accept the condition "Accepted as long as it's built and included by Monday to be included in Tuesday's TC"?
18:18:26 <mattdm> kparal: spot is going to try to get to the images tonight, and i'll immediately update the productimg packages to match. we'll need karma for those, and possibly the minor kickstart changes
18:18:41 <mattdm> sgallagh *I* am good with that
18:18:56 <mattdm> I think the workstation WG would be disappointed -- can't speak for them really
18:19:19 <sgallagh> mattdm: Well, I'm not willing to make this a blocker at this point.
18:19:42 <sgallagh> And I don't want to be messing around with this too close to the RCs either
18:20:17 <mattdm> I'm hoping to have it done _tomorrow_ in any case
18:21:20 <sgallagh> mattdm: works for me
18:21:26 <sgallagh> I'm available to test and give karma
18:21:42 <sgallagh> +1 FE
18:21:50 <roshi> so +1 with in by Monday
18:23:05 <jreznik_2nd> +1 FE
18:23:30 <kparal> proposed #agreed - 1155228 - AcceptedFreezeException - This is accepted if the updated package is available soon enough, before TC3 compose request.
18:23:38 <kparal> or should I mention Monday instead?
18:23:50 <sgallagh> I think it's fine as-is
18:23:56 <roshi> I can put monday in a note on the bug
18:24:41 <roshi> ack
18:24:58 <sgallagh> ack
18:27:15 <kparal> #agreed - 1155228 - AcceptedFreezeException - This is accepted if the updated package is available soon enough, before TC3 compose request.
18:27:32 <kparal> #topic (1145264) F21 desktop livecd ISO volume ID is truncated, doesn't fit version number
18:27:32 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1145264
18:27:32 <kparal> #info Proposed Freeze Exceptions, koji, NEW
18:28:57 <kparal> +1, breaking virt tools is pretty inconvenient
18:29:13 <jreznik_2nd> +1
18:29:43 <roshi> yeah
18:29:53 <roshi> though it seems there isn't really a fix anyone is too happy with
18:29:56 <roshi> just a least bad fix
18:30:02 <oddshocks> +1
18:30:02 <kparal> again, there's a potential for some disaster here. dracut or usb conversion tools might stop working
18:30:03 <sgallagh> Yeah, and it can't be resolved post-release, so +1 FE
18:30:20 <sgallagh> kparal: At the same time, a bunch of tools already aren't working that should be
18:30:27 <kparal> yes
18:30:32 <roshi> +1 FE, but we need to be able to test the fix quick
18:30:54 <sgallagh> Same as the previous one, then? Ask for it to land before TC3?
18:31:11 <roshi> yeah, I guess
18:31:22 <roshi> gonna be a busy rest of the week for people
18:31:33 <kparal> proposed #agreed - 1145264 - AcceptedFreezeException - Breaking virt tools is very inconvenient, accepted. Please provide the fix as soon as possible, ideally before TC3 compose request.
18:31:56 <roshi> ack (will add date to bug)
18:32:16 <sgallagh> ack
18:33:35 <kparal> ack
18:33:38 <kparal> #agreed - 1145264 - AcceptedFreezeException - Breaking virt tools is very inconvenient, accepted. Please provide the fix as soon as possible, ideally before TC3 compose request.
18:33:52 <kparal> #topic (1161637) Review Request: gnome-shell-extension-background-logo - Background logo extension for GNOME Shell
18:33:52 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1161637
18:33:52 <kparal> #info Proposed Freeze Exceptions, Package Review, NEW
18:34:02 <roshi> how many more do we have?
18:34:18 <kparal> I see 4 more, plus this one
18:34:38 <sgallagh> This is basically another branding one
18:34:50 <sgallagh> I've been following this, it should be landing by tomorrow afternoon
18:34:59 <roshi> +1
18:35:15 <sgallagh> I'm +1 FE (it's trivial to back out; just drop the package from comps)
18:35:15 <kparal> is this really an extension that will overlay a fedora logo over any of my wallpapers?
18:35:32 <kparal> and it's going to be enabled by default?
18:35:32 <sgallagh> kparal: No, it's actually smart enough to only overlay the default wallpaper :)
18:35:40 <roshi> I would think it's only on install, right?
18:36:17 <kparal> sounds over-engineered
18:36:19 <kparal> sigh
18:37:02 <kparal> +1
18:37:06 * jreznik_2nd is not happy about this overlayed logo but it's workstation wg guys decision...
18:37:09 <jreznik_2nd> so +1 FE
18:37:10 <kparal> (but I don't like it!)
18:37:28 * jreznik_2nd does not use gnome so he's not affected but does not like it neither
18:37:29 <kparal> heh, with the first gnome-shell crash, all extensions are disabled anyway
18:37:34 <kparal> so nobody will see it :)
18:37:42 <jreznik_2nd> :)
18:38:15 <kparal> proposed #agreed - 1161637 - AcceptedFreezeException - This seems low risk and "improves" branding.
18:38:43 <roshi> patch to remove the quotes :p
18:38:55 <kparal> hmm
18:39:07 <kparal> proposed #agreed - 1161637 - AcceptedFreezeException - This seems low risk and adjusts branding.
18:39:20 <roshi> honestly, I don't know why this new bg doesn't just get updated the same way as the other productized gfx bug
18:39:26 <roshi> haha
18:39:32 <kparal> btw, why not change the wallpaper itself?
18:39:38 <kparal> the image
18:39:42 <roshi> really not a fan are you kparal :p
18:39:45 <roshi> that was my thought
18:39:54 <mkolman> hey, logos are serious business! :)
18:40:13 <mkolman> and icons - especially the high contrast ones! :)
18:40:27 <kparal> ack/nack/patch?
18:40:49 <sgallagh> kparal: The plain image can't be branded because the wallpapers have to be redistributable
18:40:53 <sgallagh> (For Remixes)
18:41:05 <kparal> sgallagh: two versions then?
18:41:27 <sgallagh> /me shrugs
18:41:36 <sgallagh> People more involved than I am settled on this approach.
18:41:47 <sgallagh> I'm willing to trust them
18:41:48 <roshi> ack
18:41:51 <sgallagh> anyway, ack
18:42:16 <kparal> #agreed - 1161637 - AcceptedFreezeException - This seems low risk and adjusts branding.
18:42:19 <jreznik_2nd> kparal: I thought we're going to have two versions but this is probably better, affects only workstation product
18:42:52 <kparal> jreznik_2nd: I happen to use it, not fan of additional effects and performance hogs :/
18:43:03 <kparal> #topic (1161883) Headphones not detected by pulseaudio
18:43:04 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1161883
18:43:04 <kparal> #info Proposed Freeze Exceptions, pulseaudio, ON_QA
18:45:01 <kparal> so, we have sound criteria
18:45:10 <kparal> https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Working_sound
18:45:26 <kparal> this is broken for every headphones
18:45:31 <kparal> probably not speakers?
18:45:36 <roshi> my headphones work fine...
18:45:51 <sgallagh> roshi: Are you already running -25?
18:45:59 <kparal> roshi: have you plugged them after boot, or before boot?
18:46:26 <roshi> $ rpm -q pulseaudio
18:46:28 <roshi> pulseaudio-5.0-10.fc21.x86_64
18:46:37 <kparal> "This affects the normal speakers, too." comment 4
18:46:40 <sgallagh> Ah, older than the bug was introduced.
18:46:52 <roshi> ah, not -25
18:47:14 <roshi> besides, looks like it's fixed
18:47:15 <kparal> comment 8 is interesting
18:47:15 <sgallagh> roshi: It was introduced with -24 IIUC
18:47:18 <sgallagh> And fixed in -25
18:47:37 * roshi hasn't updated this box in a week or two (or more
18:47:38 <roshi> )
18:47:50 <kparal> I think this could actually be a blocker in certain cases
18:47:56 <roshi> same here
18:48:10 <kparal> so let's give it at least +1 FE :)
18:48:41 <roshi> yeah
18:48:42 <roshi> +1
18:49:42 <kparal> proposed #agreed - 1161883 - AcceptedFreezeException - This seems to mostly affect headphones, in some cases even speakers. Accepted as a freeze exception.
18:50:10 <sgallagh> nack, I think you're right about it being a blocker
18:50:15 <sgallagh> I'm trying to find the right criterion
18:50:24 <kparal> the one I linked I believe
18:50:31 <sgallagh> Oh, I missed that...
18:50:55 <kparal> however, it's going to be more difficult in this case, we should find out in which cases it really fails
18:51:09 <sgallagh> "It is meant to cover bugs which completely prevent sound playback from working in any hardware configuration."
18:51:34 <sgallagh> I think "inserting headphones" qualifies...
18:51:49 <roshi> I would as well
18:52:14 <kparal> hmm, a hardware without headphones works OK... ;)
18:52:41 <sgallagh> I'm counting this as "spirit of the law" rather than "letter of the lase"
18:52:48 <sgallagh> s/lase/law/
18:52:55 <roshi> that's how I tend to lean as well
18:53:03 <kparal> ok, I'm fine with that
18:53:14 <sgallagh> +1 blocker
18:53:15 <roshi> +1 blocker
18:53:36 * roshi is going to have to split his time between this and the cloud meeting in a couple minutes
18:53:39 <roshi> just as a heads up
18:53:40 <kparal> proposed #agreed - 1161883 - AcceptedBlocker - This violates Beta criterion "The installed system must be able to play back sound with gstreamer-based applications."
18:53:48 <roshi> ack
18:54:06 <roshi> unless we wanted to put a note as to why we elevated it to blocker instead of FE
18:54:23 <kparal> you can do that as a side comment
18:54:34 <roshi> will do
18:54:36 <kparal> sgallagh: ack?
18:54:43 <sgallagh> ack
18:54:46 <kparal> ack
18:54:49 <kparal> #agreed - 1161883 - AcceptedBlocker - This violates Beta criterion "The installed system must be able to play back sound with gstreamer-based applications."
18:54:58 <kparal> 3 more
18:55:00 <kparal> #topic (1135720) sugar-runner fails to start sugar-desktop in installed x86_64 Workstation f21 Alpha TC5
18:55:00 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1135720
18:55:00 <kparal> #info Proposed Freeze Exceptions, sugar-runner, NEW
18:55:07 <kparal> hmm, we have only 5 minutes left
18:55:17 <sgallagh> Is there another meeting in here?
18:55:21 <kparal> no
18:55:26 <kparal> we just have a 3 hour limit
18:55:30 <kparal> to stay sane
18:55:30 <sgallagh> /me can continue
18:55:38 <sgallagh> It's only three more
18:55:46 <kparal> yeah, we can do it
18:55:55 <sgallagh> If we still had a dozen...
18:56:42 <kparal> this seems restricted to only sugar, therefore safe
18:56:44 <kparal> +1
18:57:33 <kparal> thoughts?
18:57:44 * roshi catches up
18:57:47 <sgallagh> They don't actually have a fix yet
18:57:52 <roshi> had to look up the right bug to block on
18:57:54 <sgallagh> They have a workaround that involves hard-coding a resolution
18:58:04 <kparal> sgallagh: yes, but that's their call...
18:58:10 <satellit_e> desktop file needs --resolution set
18:58:23 <sgallagh> Well, I'm just *slightly* concerned that it might turn out to require a GDM patch
18:58:32 <sgallagh> Which becomes more risky.
18:58:33 <kparal> satellit: do you intend to do other changes, or just .desktop file change?
18:58:56 <kparal> satellit_e: ^^
18:58:57 <satellit_e> this is all needed
18:59:10 <sgallagh> ok, +1 FE then
18:59:14 <jreznik_2nd> +1 FE
18:59:15 <roshi> +1 if it's just the .desktop change
18:59:17 <satellit_e> pbrobinson found problem
18:59:38 <kparal> proposed #agreed - 1135720 - AcceptedFreezeException - As long this is just a simple desktop file change, it's not risky for Fedora products, and thus accepted.
18:59:44 <roshi> ack
19:00:04 <sgallagh> ack
19:00:06 <kparal> ack
19:00:07 <kparal> #agreed - 1135720 - AcceptedFreezeException - As long as this is just a simple desktop file change, it's not risky for Fedora products, and thus accepted.
19:00:15 <kparal> #topic (1145281) collaboration does not work in f21-Alpha-RC1 in SoaS spin
19:00:15 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1145281
19:00:16 <kparal> #info Proposed Freeze Exceptions, telepathy-salut, NEW
19:00:38 <satellit_e> info no fix yet for this
19:01:03 <kparal> satellit_e: do you expect to have a fix for this soon?
19:01:13 <satellit_e> probably no
19:01:19 <kparal> what's the point of FE then?
19:01:49 <kparal> if we don't know what it affects, it's difficult to vote on it
19:02:07 <satellit_e> maybe wishfull thinking    related to jabber server we use
19:03:06 <sgallagh> satellit_e: Is there any reason to believe that it couldn't be solved as a zero-day update?
19:03:11 <kparal> satellit_e: ok. can we just remove the FE proposal, and can you add it back if you have a fix ready?
19:03:14 <satellit_e> I understand mesh networking works
19:03:29 <kparal> btw, you don't need to specify criteria when asking for FEs :)
19:03:31 <satellit_e> k
19:03:52 <sgallagh> kparal: Well, it's helpful to justify why you want it as an FE instead of an update stream
19:04:03 <sgallagh> s/an/in/
19:04:07 <kparal> sure, it's great to have a justification
19:04:16 <sgallagh> But yeah, -1 FE for now
19:04:20 <kparal> I just meant there's no need to invent new criteria or something
19:04:36 <kparal> let's do it this way:
19:04:37 <kparal> #info FE proposal removed from 1145281
19:05:13 <kparal> #topic (1135546) [abrt] virt-manager: g_socket_constructed(): python2.7 killed by SIGTRAP
19:05:13 <kparal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1135546
19:05:13 <kparal> #info Proposed Freeze Exceptions, virt-manager, ON_QA
19:05:51 <sgallagh> This is a true pain in the neck with wide impact. I've tested the fix myself.
19:05:54 <sgallagh> +1 FE
19:06:55 <kparal> sgallagh: have you tested the fix yet?
19:07:34 <sgallagh> kparal: Yes, and I gave positive karma
19:08:13 <roshi> +1
19:08:18 <kparal> virt-manager is not part of the default install. is there a benefit in pushing this to stable rather then using updates repo?
19:08:21 <roshi> though I haven't seen this one
19:08:32 <sgallagh> kparal: I thought Workstation was shipping it by default
19:08:34 <sgallagh> Did that change?
19:08:46 <kparal> virt-manager? not on their Live image
19:08:52 <kparal> boxes is there I believe
19:08:56 <roshi> I thought they shipped boxes
19:09:36 <kparal> I don't have problem with +1, because it's not part of the default install, it's pretty safe. I just wonder whether it makes sense to give FE at all
19:09:44 <roshi> yeah
19:09:54 <roshi> I don't think so, actually
19:10:24 <sgallagh> Let me verify that it's not on any of the media
19:10:32 <kparal> ok
19:11:38 <roshi> this can be fixed with updates easily
19:11:51 <sgallagh> OK, it's included on the Server DVD as part of the Virtualization group
19:12:10 <sgallagh> It's not a default package, but it's selectable during anaconda
19:12:12 <roshi> virt-manager, the GUI?
19:12:52 <sgallagh> Like I said, we don't install it by default, but it's plausible that someone might end up with it installed from the DVD
19:13:01 <kparal> +1 in that case
19:13:15 <roshi> I stand with my original +1 then
19:13:22 <roshi> (man, thought I was rid of it...)
19:13:53 <sgallagh> It's low-risk at least
19:14:03 <kparal> proposed #agreed - 1135546 - AcceptedFreezeException - virt-manager is a part of Server DVD, and it would great to have this crash fixed. It's not installed by default, so the change should be quite safe.
19:16:20 <sgallagh> ack
19:16:30 <kparal> roshi: ack?
19:16:40 <roshi> ack
19:16:46 <roshi> sorry - two meetings :)
19:16:55 <kparal> no problem
19:16:55 <kparal> ack
19:16:58 <kparal> #agreed - 1135546 - AcceptedFreezeException - virt-manager is a part of Server DVD, and it would great to have this crash fixed. It's not installed by default, so the change should be quite safe.
19:17:07 <kparal> and that's all!
19:17:26 <kparal> thanks for coming everyone
19:17:37 <sgallagh> When's the next one? :)
19:17:47 <roshi> np! Thanks for taking over
19:18:10 <kparal> next one is probably next monday or wednesday
19:18:13 <kparal> see you
19:18:19 <kparal> #endmeeting