16:03:15 <adamw> #startmeeting F21-blocker-review
16:03:15 <zodbot> Meeting started Mon Dec  1 16:03:15 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:20 <adamw> #meetingname F21-blocker-review
16:03:20 <zodbot> The meeting name has been set to 'f21-blocker-review'
16:03:26 <adamw> #topic Roll Call
16:03:27 * pschindl is here
16:03:29 <nirik> morning everyone.
16:03:38 * roshi is here
16:03:39 * satellit listening
16:03:40 <pschindl> Good afternoon :)
16:03:47 <adamw> who's around to review some blocker bugs?
16:03:47 * jreznik is here, the weather outside is that bad, blocker review meeting sound like warm and nice place to be
16:03:57 <sgallagh> I'm here
16:04:28 * smccann is here
16:04:47 * kparal trying to convince anaconda devs to come and join us ;)
16:05:23 <brunowolff> I'll try to help today.
16:05:25 <danofsatx-work> ok, quick openstack P2P meeting just ended
16:05:47 <danofsatx-work> P2P = someone standing at my desk asking for direction
16:06:20 <adamw> jreznik: inorite? i nearly froze to death just opening my apartment door yesterday...and it only opens into a corridor
16:06:37 <nirik> it's a baulmy 23F here. ;)
16:06:39 <adamw> #chair tflink nirik sgallagh
16:06:39 <zodbot> Current chairs: adamw nirik sgallagh tflink
16:06:59 * adamw tries to remember how this thing works
16:07:00 <jreznik> adamw: all public transport collapsed today in Brno :)
16:07:11 <kparal> I heard that happens in Canada. and polar bears, in your corridor, too
16:07:44 <kparal> or maybe it was a comics
16:07:49 <adamw> kparal: those deadbeats just won't stop hanging around, begging for seals
16:08:01 <sgallagh> It's an oddball 57F in Westford today.
16:08:04 <danofsatx-work> was 68F when I left this morning. it's currently 49F at my house, but the cold front isn't here in town yet where it's 65F.
16:08:08 <jreznik> but I know, with our sligtly bellow zero, we feel like the whole world is going to freeze... central europeans :)
16:08:10 <sgallagh> Compared to 22F yesterday...
16:08:21 <adamw> #topic The weather
16:08:40 <roshi> 20F now, 65F yesterday
16:08:42 <roshi> go figure
16:08:55 <danofsatx-work> yup. and I still don't have any firewood.
16:09:24 <adamw> #info in weather news, it is cold enough in Brno that people enjoy being at a blocker meeting as long as it's inside, polar-bear-in-corridor cold in Canada, an 'oddball' 57F (whatever those weird made-up American numbers mean) in Westford, and 20F in whichever bit of the middle of America it is Roshi lives in
16:10:01 <adamw> #info and 49F for danofsatx, which is what people in Texas think is cold.
16:10:17 <adamw> #topic Introduction
16:10:17 <adamw> Why are we here?
16:10:17 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:10:17 <adamw> #info We'll be following the process outlined at:
16:10:17 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:10:19 <adamw> #info The bugs up for review today are available at:
16:10:21 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:10:23 <adamw> #info The criteria for release blocking bugs can be found at:
16:10:23 * danofsatx-work spent yesterday putting up Christmas decorations in shorts and a t-shirt
16:10:25 <adamw> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:10:29 <adamw> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:10:31 <adamw> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:11:24 <sgallagh> /me would like to state for the record that I'm going to oppose any new FEs at this point. I want RC2 to be Final, please.
16:11:43 <kparal> sgallagh: does that including the branding bug?
16:11:47 <kparal> *include
16:11:50 <sgallagh> kparal: I think that's probably a blocker
16:11:53 <kparal> nope
16:12:04 <kparal> at least I didn't mark it as such
16:12:08 <adamw> let's decide that when we get there :P
16:12:08 <sgallagh> It's a significant impact to usability.
16:12:14 <kparal> I agree
16:12:24 <sgallagh> (And an extremely low-risk fix)
16:12:26 <jreznik> but could be that one FE accepted, even if not blocker
16:12:29 <kparal> but hey, worse bugs were rejected as blockers before, so I no longer try :P
16:12:33 <adamw> #info 4 Proposed Blockers
16:12:34 <adamw> #info 5 Accepted Blockers
16:12:34 <adamw> #info 7 Proposed Freeze Exceptions
16:12:34 <adamw> #info 17 Accepted Freeze Exceptions
16:12:50 <jreznik> sgallagh: don't use that words - low risky :D
16:13:03 <kparal> putting in branding was low risky
16:13:13 * satellit workstation and server had branded anaconda left screens for me
16:13:15 <sgallagh> kparal: No, it wasn't. But let's move on
16:13:16 <adamw> actually i don't think anyone said it was, they just decided we were going to do it anyway
16:13:30 <adamw> satellit: it's not that the branding doesn't work, it's that it works...TOO WELL
16:13:34 <adamw> but we'll get there. settle down, folks.
16:13:34 <adamw> #topic (1169019) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 11: ordinal not in range(128)
16:13:34 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1169019
16:13:34 <adamw> #info Proposed Blocker, anaconda, MODIFIED
16:13:47 <nirik> +1 blocker.
16:14:32 <adamw> yeah, these ones are fairly straightforward
16:14:44 <kparal> I'm not too happy about the fix, because LANG can have potentially different syntax than LC*, but hopefully it won't break anything else, like spins or something
16:14:49 <kparal> +1 to blocker, sure
16:14:56 <danofsatx-work> +1
16:15:01 <adamw> i didn't go through running every language and exhaustively documenting where it crashes, but it seems reasonable to take the two bugs I filed as meaning 'crashes all over the damn shop in non-English'
16:15:01 <roshi> +1
16:15:13 <sgallagh> +1 blocker
16:15:18 <jreznik> +1 blocker, /me will never understand how python works with locales/encoding blabla
16:15:27 <sgallagh> Though I agree; the fix doesn't make me happy
16:15:52 <nirik> so this is purely a spins-kickstart fix? or that + anaconda?
16:16:05 <kparal> it's in liveinst, thus anaconda
16:16:21 <kparal> I don't think the fix involves anything else, we can ask
16:16:31 <nirik> ok
16:17:05 * kparal asking
16:17:25 <kparal> <vpodzime> kparal: no, that's all that is needed
16:17:29 <kparal> (liveinst patch)
16:17:32 <nirik> ok, cool.
16:17:34 <adamw> proposed #agreed - 1169019 - accepted blocker - any language with translated size units is likely to crash all over the place in live installs, this violates any 'successful installation' criterion
16:17:39 <nirik> ack
16:17:42 <kparal> ack
16:17:44 <roshi> ack
16:17:45 <pschindl> ack
16:17:55 <danofsatx-work> ack
16:18:06 <adamw> #agreed - 1169019 - AcceptedBlocker - any language with translated size units is likely to crash all over the place in live installs, this violates any 'successful installation' criterion
16:18:17 <adamw> #agreed - 1169019 - AcceptedBlocker - any language with translated size units is likely to crash all over the place in live installs, this violates any 'successful installation' criterion
16:18:37 <adamw> oh, roshi are you secretarializing?
16:19:29 <roshi> yep
16:21:10 <adamw> #info roshi will secretarialize
16:21:17 <adamw> #topic (1169023) Many translations missing from anaconda 21.48.18 and 21.48.19
16:21:17 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1169023
16:21:17 <adamw> #info Proposed Blocker, anaconda, MODIFIED
16:21:35 <nirik> +1 blocker
16:21:57 <kparal> +1
16:22:02 <danofsatx-work> +1
16:22:11 <pschindl> +1
16:22:41 <jreznik> +1 blocker, affects many translations even translations that should be complete
16:22:45 <roshi> +1
16:22:52 <sgallagh> +1 blocker
16:22:57 <adamw> proposed #agreed - 1169023 - AcceptedBlocker - this is a clear violation of the criterion requiring translations be present
16:23:03 <nirik> ack
16:23:05 <jreznik> ack
16:23:09 <danofsatx-work> ack
16:23:13 <pschindl> ack
16:23:16 <sgallagh> ack
16:24:08 <roshi> ack
16:24:12 <kparal> ack
16:24:20 <adamw> #agreed - 1169023 - AcceptedBlocker - this is a clear violation of the criterion requiring translations be present
16:24:53 <adamw> #topic (1167965) logvol swap --recommended fails
16:24:53 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1167965
16:24:53 <adamw> #info Proposed Blocker, python-blivet, VERIFIED
16:25:08 <adamw> this one was accepted as an FE and fixed in RC1, I think, so discussing it becomes a bit academic
16:25:29 <nirik> yeah...
16:25:41 <nirik> just move it to an accepted fe and go on?
16:25:46 <sgallagh> nirik: +1
16:26:03 <roshi> works for me
16:26:11 <nirik> ie, drop blocker since it's kinda moot.
16:26:43 <roshi> will
16:26:46 <roshi> will do
16:27:19 <adamw> #agreed this was fixed and the fix tested in RC1, so we decided to drop it from blocker consideration as the question is mostly moot
16:27:32 <adamw> #topic (1168748) Need final Fedora 21 build of spin-kickstarts
16:27:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1168748
16:27:32 <adamw> #info Proposed Blocker, spin-kickstarts, ON_QA
16:27:50 <nirik> this is kinda waiting on if we do a rc2 or not.
16:28:00 <nirik> which, after the above 2 blocker adds, we are.
16:29:32 <nirik> so, I would say spin what we have currently and submit update... unless there's any FE's that need spins-kickstarts changes.
16:29:56 <adamw> well, it's a blocker by policy
16:30:15 <nirik> right. so, yeah, +1 blocker definitely.
16:30:37 * nirik sees no fe's off hand that need any spin-kickstarts changes.
16:30:41 * handsome_pirate stumbles in
16:30:41 * danofsatx-work was away....damn users again
16:31:00 * handsome_pirate doesn't know how productive he'll be
16:31:07 * handsome_pirate just put away a bottle of rum.
16:31:18 <danofsatx-work> +1
16:31:24 <sgallagh> This looks like a +1 blocker by the numbers
16:31:28 <roshi> +1 on this blocker
16:31:43 <jreznik> +1
16:32:59 <adamw> handsome_pirate: well, get it out again. ;)
16:33:30 <sgallagh> ... and share
16:33:36 <adamw> proposed #agreed - 1168748 - this is a clear blocker under the criterion requiring a spin-kickstarts build that matches the release, but note it does not block image compose, as the package does not appear on the images.
16:33:45 <handsome_pirate> Ew
16:34:00 <pschindl> ack
16:34:04 <handsome_pirate> ack
16:34:06 <roshi> ack
16:34:28 <adamw> #agreed - 1168748 - this is a clear blocker under the criterion requiring a spin-kickstarts build that matches the release, but note it does not block image compose, as the package does not appear on the images.
16:35:00 <danofsatx-work> ack (late)
16:35:11 <adamw> ok, that's all the blockers, let's move on to proposed FEs
16:35:12 <adamw> sgallagh, prime your -1 bot now...
16:35:14 <adamw> #topic (1167658) custom partitioning: after you press Done for the first time, Reset All stops working
16:35:15 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1167658
16:35:15 <adamw> #info Proposed Freeze Exceptions, anaconda, NEW
16:35:18 <nirik> -1
16:35:26 <sgallagh> -1
16:35:38 <sbueno> no on that one from everyone on the anaconda team
16:35:59 <adamw> yeah, it kinda sucks but getting too late to play with it
16:36:07 <nirik> there's no clear fix, it's a corner case, document and reject. ;)
16:36:07 <adamw> sbueno: note we're voting FE not blocker now
16:36:17 <sbueno> adamw, yeah i know
16:36:22 <adamw> the workaround for documentation is fairly clear - 'sorry, you lost all your lives, reboot and start over'
16:36:24 <roshi> -1
16:36:38 <sgallagh> /me plays the Mario death-sound
16:36:45 <handsome_pirate> -1
16:36:56 <handsome_pirate> Would be nice to have a fix, but ...
16:36:57 <kparal> since there's no patch, maybe there's no sense in discuss it at all
16:37:03 <jreznik> yep
16:37:04 <kparal> *discussing
16:37:05 <danofsatx-work> -1
16:37:13 <adamw> proposed #agreed - 1167658 - RejectedFreezeException - this is obviously a bit annoying, but it's too late for speculative FEs now, anaconda team doesn't have a clear fix for it, and it is workaroundable
16:37:16 <sgallagh> Yeah, can we just auto-ignore any that aren't already in POST/MODIFIED?
16:37:24 <danofsatx-work> ack
16:37:25 <kparal> ack
16:37:32 <handsome_pirate> ack
16:37:41 <kparal> sgallagh: I think that makes sense
16:37:46 <sgallagh> adamw: ack
16:37:47 <nirik> ack
16:38:02 <roshi> ack
16:38:15 <roshi> sgallagh: sgtm
16:38:23 <pschindl> ack
16:38:31 <adamw> #agreed - 1167658 - RejectedFreezeException - this is obviously a bit annoying, but it's too late for speculative FEs now, anaconda team doesn't have a clear fix for it, and it is workaroundable
16:38:44 <adamw> well, sometimes the statuses are lies, but I can skip any we don't have fixes lined up for if you like
16:39:09 <sgallagh> adamw: You and your "saying what I meant instead of what I said"
16:39:09 <nirik> it doesn't take long to reject... but whatever works.
16:39:23 <adamw> #info we will vote only on FEs that look like there's some kind of fix waiting to go, given the point we're at in the c ycle
16:39:37 <nirik> I'd hate to miss something important, but hopefully we won't since they are just fe's
16:39:37 <adamw> #topic (1168118) Custom UEFI layout with /boot/efi on second disk fails: is_valid_stage1_device not called on disks after the first
16:39:38 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1168118
16:39:38 <adamw> #info Proposed Freeze Exceptions, anaconda, MODIFIED
16:39:53 <adamw> so you might all want to start out by assuming -1 on this one, since i wrote the fix for it ;)
16:39:55 * kparal just asked vpodzime about this, I think he worked on it based on adamw patch
16:39:59 <adamw> but srsly!
16:40:24 <kparal> <vpodzime> kparal: a fix for that is applied to anaconda-21.48.19-1, but adamw posted some improvements for it
16:40:27 <adamw> kparal: my initial proposed fix is in 21.19, i have a somewhat-improved version in review now which i'd kinda prefer to go in 21.20
16:40:29 <sgallagh> tl;dr: What's the impact, in brief?
16:40:40 <adamw> so the scenario is this
16:40:47 <adamw> you boot a UEFI install with two disks
16:40:54 <adamw> you go to custom partitioning, and put /boot/efi on the second disk
16:41:03 <adamw> anaconda complains your layout is invalid because it doesn't have a /boot/efi
16:41:46 <adamw> you can work around it by going into the 'Full disk summary and bootloader' screen and selecting the second disk as the boot disk, but only *after* you create the /boot/efi partition (at least in my testing), and none of the errors you get indicate the problem
16:41:51 <nirik> so, what do the improvements get us? and are they very invasive?
16:42:07 <sgallagh> adamw: That sounds to me like a relatively sane Common Bugs entry.
16:42:11 * kparal invited vpodzime to join us
16:42:26 <adamw> sgallagh: the thing that worries me is the initial condition is very confusing and you might not get to common bugs for it'
16:42:32 <adamw> and the fix _is_ relatively low impact, i think
16:42:44 * handsome_pirate is thinking +1 for this one
16:42:48 <handsome_pirate> +1
16:42:55 <kparal> dlehman: do you have an idea how risky this patch is?
16:43:12 <sgallagh> I'm sticking with -1 so far, unless someone from anaconda says on the record "there's no way this will break anything else"
16:43:21 <adamw> nirik: with (either) fix, if you're installing to a platform that uses a partition as /boot, and you don't explicitly specify a boot disk, and there's a valid stage1 target partition on any selected disk, anaconda will use that instead of going into an error state
16:43:30 <kparal> vpodzime: hey
16:43:30 <vpodzime> kparal: done
16:43:34 * dlehman hasn't been following along, has to catch up
16:43:40 <danofsatx-work> -1 FE, +1 Common Bugz
16:43:41 <kparal> vpodzime: could you tell us how risky this patch can be?
16:44:01 <kparal> do you think it's reasonable to add it to RC2?
16:44:20 <nirik> which anaconda was in rc1 again?
16:44:22 * nirik looks
16:44:24 <vpodzime> the original patch adamw posted seems to be safe
16:44:24 <sgallagh> Noting that some of us are highly-resistant to any risk at all at this point.
16:44:28 <adamw> i could see a very unlikely corner case where the first version of the patch might possibly have caused a crash, but the second version i think is pretty safe.
16:44:35 <dlehman> adamw: so it defaults to same disk as /boot instead of first disk?
16:44:36 <adamw> (even the corner case for the first one was pretty absurd.)
16:44:44 <adamw> dlehman: it's not about /boot , /boot is stage2 target
16:45:05 <adamw> dlehman: it's about /boot/efi on UEFI , primarily
16:45:16 <adamw> also fixes /boot/uboot on omapARM (not that i can test that) and prepboot on PPC64 (I tested that...took all afternoon in a vm)
16:45:23 <dlehman> so it's about stage1 devices that are partitions
16:45:26 <adamw> yeah
16:45:38 <dlehman> and it picks the disk containing a potential stage1 instead of the first disk?
16:45:46 <vpodzime> exactly
16:45:53 <adamw> the first disk in the existing order that looks like it contains a valid stage1 target partition, if there is one
16:46:04 <adamw> as long as the user hasn't explicitly nominated a boot disk
16:46:23 <dlehman> so people who have multiple installs or otherwise want to preserve their existing stage1 will have to pay attention?
16:46:49 <adamw> well, i'm not sure it necessarily makes things worse there
16:47:19 <adamw> say you have a /boot/efi on disk1 and you create a new one on disk2, in the current case we'd use the one on disk1...
16:47:33 <adamw> well, in my case we would too, actually
16:47:37 <adamw> it's a rather icky area honestly
16:48:36 <adamw> dlehman: for the mounted partition case, actually, i think no, there's no possible 'have to pay attention;
16:48:37 <roshi> sounds like it
16:48:41 <nirik> so, the first cut of this was in -19? which we need for other things already anyhow?
16:48:52 <adamw> because if they didn't want to use that partition as the stage1 target they wouldn't set it as the mount point, would theey?
16:49:00 <sgallagh> the statement "it's a rather icky area honestly" does not incline me towards changing from a -1/Common Bugs vote...
16:49:08 <adamw> when you say 'this partition is /boot/efi' what you are *doing* is selecting it as the stage1 target device
16:49:15 <adamw> that's the only reasonable understanding of that action
16:49:19 <handsome_pirate> hrm
16:49:39 <dlehman> if this bug existed in f20 I think that it's a bit late to be proposing it as a blocker for f21 now
16:49:46 <vpodzime> I thought about the use cases described here and didn't come up with any potential issue
16:49:47 <roshi> I'll default to what the anaconda guys think for this one
16:49:57 <roshi> for my vote anyways
16:50:01 <nirik> s/blocker/freeze exception/ ;)
16:50:03 <adamw> it's slightly more questionable for the prepboot-type case (where the stage1 target is a non-mounted partition) but even there i think it's sane behaviour, we already pick a default if you don't explicitly pick a disk, we're just picking a better default
16:50:05 <sgallagh> dlehman: Not a blocker
16:50:06 <sgallagh> FE
16:50:08 <adamw> dlehman: it's proposed as an FE
16:50:30 <kparal> the question is whether to include it in RC2 or not
16:50:55 <adamw> i do honestly think it's worth fixing the UEFI case
16:51:05 <vpodzime> I agree with adamw here
16:51:11 <adamw> this bug could be a reasonable explanation for several times we've seen people have trouble with UEFI installs and gone 'well huh, that shouldn't be happening'
16:51:53 <dlehman> I'll defer to those who have been working on it for a while. My head is nowhere near bootloaders and I can't seem to steer it that way.
16:51:55 <adamw> i don't think it makes much sense to expect people to understand they have to select a 'boot disk' for the UEFI case, when we've been carefully explaining that the thing they need is a /boot/efi partition
16:51:56 <adamw> but, hey.
16:52:22 <dlehman> the point of selecting a boot disk is to tell us where to put the stage1 device
16:52:31 <sgallagh> adamw: I don't disagree that it's bad behavior. I just haven't heard convincingly that the fix won't cause other issues.
16:52:42 <adamw> dlehman: the thing is it's an odd concept when the stage1 target is a partition, it just doesn't map well
16:52:43 <sgallagh> And at this point, in that situation, I'd rather defer it.
16:53:06 <dlehman> adamw: it maps better than any other platform-agnostic model I've seen.
16:53:06 <adamw> sgallagh: i'm really pretty confident in saying it won't cause anything that would make someone unhappy in the UEFI case.
16:53:13 <vpodzime> sgallagh: it makes no change on platforms that have no special stage1 devices
16:53:21 <adamw> dlehman: oh sure, it's just that being platform agnostic is inherently weird with bootloaders
16:53:23 <kparal> sgallagh: well, it's still monday...
16:53:31 <kparal> ;)
16:53:40 <sgallagh> kparal: Do you *want* to be in hero-testing mode?
16:53:57 <adamw> so for the record here's precisely what the change affects:
16:53:58 <nirik> I guess I'm +0.5...
16:54:01 <kparal> there's so little I wouldn't do for our users...
16:54:07 <adamw> on BIOS it's effectively a no-op
16:54:10 <roshi> same here
16:54:16 <sgallagh> adamw: As I said, if someone from anaconda is willing to say "I doubt this will cause any new issues", I'll vote +1
16:54:24 <adamw> on UEFI it is in effect but like I said I'm really pretty sure it's a good change
16:54:27 <sgallagh> If no one is comfortable making that statement, I don't want to include it
16:54:32 <vpodzime> I doubt this will cause any new issues
16:54:43 <sgallagh> OK, then.
16:54:44 <kparal> there you go! :)
16:55:05 <sgallagh> I'm satisfied with that. +1 FE
16:56:01 <kparal> +1
16:56:12 <roshi> +1
16:56:13 * danofsatx-work is still -1
16:56:14 <jreznik> vpodzime convinced me, +1
16:56:22 <kparal> adamw: how much tested is the new version of your fix?
16:56:22 <nirik> +0.5
16:56:52 <handsome_pirate> +1
16:57:00 <adamw> kparal: i tested it in quite a few scenarios (the affected one, guided, custom-auto, with both two and only one disk) on UEFI, did a sanity test on BIOS, and tested the affected scenario on PPC64
16:57:01 <nirik> the reporter tested it and found it fixed the issue
16:57:20 <adamw> the initial reporter tested that it fixed his issue on Mac (his first test would've been with v1 of the patch, his most recent test with v2)
16:58:02 <nirik> anyhow, sounds like we are mostly FE+ ?
16:58:14 <nirik> aside from danofsatx-work. :)
16:58:18 <sgallagh> Well, danofsatx-work appears to still be unconvinced.
16:58:24 * danofsatx-work always was a rebel
16:58:25 <adamw> that guy needs more rum
16:58:26 <sgallagh> I think we usually strive for consensus?
16:58:31 <adamw> sgallagh: well, we try and get close.
16:58:38 <adamw> what can i do to consense you, dan?
16:58:39 <dlehman> I'm amused by your optimism.
16:58:42 * adamw mails rum
16:59:48 <danofsatx-work> It just doesn't feel right. Accept it as +∞/-1 and move on
17:00:17 <handsome_pirate> adamw:  I drank it ll!
17:00:34 <adamw> #info anyone who wants to buy rum, don't bother going to look. handsome_pirate drank it all.
17:01:29 <adamw> proposed #agreed 1168118 - AcceptedFreezeException - people are understandably worried about tweaking this at this point, but the affected case is clearly bad behaviour and would be good to improve, and there's a reasonable consensus the patch is unlikely to cause bugs or unexpected behaviour changes.
17:01:43 <sgallagh> ack
17:01:48 <danofsatx-work> abstain
17:01:49 <nirik> ack
17:01:56 <roshi> ack
17:01:58 <sgallagh> (aside from your spelling of "behavior" ;-) )
17:02:05 <handsome_pirate> ack
17:02:19 <roshi> you can still ack/nack danofsatx-work - you're just acking the wording and that it made sense as a sentence :p
17:02:42 <handsome_pirate> sgallagh:  Agreed, adamw is using that weird non-Murican spelling
17:02:44 <danofsatx-work> I know
17:02:56 <handsome_pirate> 'cause 'Murica!
17:03:04 <adamw> #agreed 1168118 - AcceptedFreezeException - people are understandably worried about tweaking this at this point, but the affected case is clearly bad behaviour and would be good to improve, and there's a reasonable consensus the patch is unlikely to cause bugs or unexpected behaviour changes.
17:03:14 <adamw> goddamn it you'll take the Queen's spelling and you'll like it
17:03:29 <adamw> #topic (1168717) Missing python-lxml BuildRequires
17:03:29 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1168717
17:03:29 <adamw> #info Proposed Freeze Exceptions, anaconda, POST
17:03:42 <adamw> this one seemed a bit odd
17:03:54 <adamw> vpodzime: dlehman: do you know about it? does it affect any actual package builds?
17:04:09 * handsome_pirate wonders why it wouldn't make builds fail.
17:04:28 <adamw> also the 'steps to reproduce'
17:04:43 <adamw> package BuildRequires: aren't about people running 'make' in checked out git repositories...
17:04:53 <sgallagh> -1 FE
17:05:04 <danofsatx-work> -1
17:05:21 * adamw would like to understand the bug before -1ing it, but clearly tends to -1
17:05:34 <sbueno> it's needed for the anaconda help files
17:05:49 <sgallagh> sbueno: "this target is not run in the build system"
17:06:33 <sgallagh> That strongly implies that this change doesn't have any effect on the built RPMs (at least in a way that couldn't be solved post-release)
17:06:36 <sgallagh> Do you disagree?
17:06:50 <adamw> is this why clicking Help in anaconda never works?
17:07:12 <sbueno> it would if we could generate the help content files ;)
17:07:27 <danofsatx-work> there's a help button in Anaconda?
17:07:29 <sgallagh> sbueno: Are they generated at *runtime*?
17:07:31 <roshi> haha
17:07:33 <roshi> yeah, top right
17:07:41 <sbueno> sgallagh, no
17:07:55 <roshi> but if it works, then we have to *test* it
17:07:57 * roshi ducks
17:08:07 <handsome_pirate> roshi:  +1!!!
17:08:56 * handsome_pirate wonders how we can cover making anaconda work in the future?
17:09:20 <roshi> I'd lean more +1 if it made the help button work
17:09:31 <adamw> so it does kind of suck that every time you click Help in anaconda you just get that placeholder
17:09:33 <adamw> doesn't look great
17:09:40 <roshi> yeah
17:09:42 <mkolman> this one just blows up during tarball generation
17:09:51 <mkolman> if you don't have python-lxml installed
17:09:51 <adamw> but i'd be a bit worried about the scenario where we 'fix' it and it turns out some content in the actual help pages crashes the renderer, or something silly like that
17:09:52 <mkolman> that's it
17:10:13 <adamw> mkolman: right, but then that means we have to use tarballs without the real help files, so we get anaconda package builds without help...right?
17:10:21 <adamw> or is there more to that story?
17:10:22 <mkolman> and the help button should already work just fine BTW
17:10:24 <brunowolff> I clicked on help when doing a live install last weekend and it seemed to work (at least when the network was set up).
17:10:28 <adamw> oh, k.
17:10:30 <mkolman> nope
17:10:44 <adamw> maybe i'm just unlucky with the screens I click it on
17:10:49 <adamw> Welcome and hub both give the placeholder
17:11:00 <mkolman> RC1 ?
17:11:08 <mkolman> that should not happen
17:11:09 <adamw> yeah
17:11:16 <adamw> keyboard, network, they're all placeholding
17:11:16 <brunowolff> I believe I was on one of the storage related screens.
17:11:21 <adamw> but if this bug doesn't fix that, anyway, i'm -1
17:11:30 <mkolman> I checked with I think TC2 or TC4
17:11:40 * handsome_pirate isn't getting anything but placeholders
17:11:40 <mkolman> and every screen had help
17:11:46 * handsome_pirate is testing with RC1
17:11:51 <handsome_pirate> just spun up a vm
17:11:57 <adamw> could be another booboo in vpodzime's build?
17:12:03 <sgallagh> Yeah, I see the placeholder on all screens on a Workstation Live
17:12:12 <mkolman> handsome_pirate: can you check the contents of /usr/share/anaconda/help/en-US/ ?
17:12:16 <handsome_pirate> So, if this fixes that, I'm +1.  This is something we really ought to fix.
17:12:24 <handsome_pirate> mkolman:  One sec
17:12:29 <sgallagh> handsome_pirate: I think we already covered above that it doesn't address that
17:12:43 <adamw> memo to self: don't ever do an anaconda tarball build without lots of help
17:12:45 <vpodzime> adamw: nope, I pulled-in and built the help files
17:12:48 <handsome_pirate> sgallagh:  Sorry, was spinning up a vm to test and not reading :)
17:13:14 <adamw> so anyway, what's the actual benefit of fixing *this* FE bug?
17:13:15 <handsome_pirate> mkolman:  Nothing there; server netinst image
17:13:18 <sgallagh> /me remains -1 at this point.
17:13:21 <adamw> if it doesn't fix something significant in the images, i'm -1
17:13:35 * danofsatx-work just realized he doesn't have RC1 builds here.
17:13:59 <adamw> mkolman: vpodzime: handsome_pirate: let's discuss the missing-help in #anaconda for now, we can propose a blocker/FE for discussion later in the meeting if appropriate
17:14:03 <mkolman> handsome_pirate: there must be at least the placeholders
17:14:42 <nirik> -1
17:15:00 <roshi> -1
17:15:35 <vpodzime> adamw: okay, so the help contents are only in the 19 build
17:15:46 <adamw> proposed #agreed 1168717 - RejectedFreezeException - we're still not entirely clear on what this bug is for, but it seems fairly clear that fixing it won't magically make the release images better, so rejected.
17:15:47 <vpodzime> (thus not in RC1)
17:16:13 <roshi> ack
17:16:16 <sgallagh> ack
17:16:24 <jreznik> ack
17:16:28 <danofsatx-work> ack
17:16:32 <handsome_pirate> mkolman:  Aye, placeholders are there, but that's it
17:16:47 <kparal> ack
17:17:08 <adamw> #agreed 1168717 - RejectedFreezeException - we're still not entirely clear on what this bug is for, but it seems fairly clear that fixing it won't magically make the release images better, so rejected.
17:17:25 <adamw> for the record, looks like the help texts are missing from RC1 due to a tarball generation mistake, should be fixed for RC2
17:17:36 <adamw> #topic (1169332) Widget colors in anaconda totally changed in RC1, some widgets hardly visible
17:17:37 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1169332
17:17:37 <adamw> #info Proposed Freeze Exceptions, fedora-productimg-workstation, ASSIGNED
17:17:44 <adamw> hey, time for the fun one ;)
17:17:57 <sgallagh> ok
17:18:07 <mkolman> I'll strongly advice to use a build that has the help content in place
17:18:12 <sgallagh> Short version: the productimg packages added a few lines of CSS to position the logos
17:18:32 <sgallagh> The expectation was that these would be merged with the existing CSS, but instead they were replacing it
17:18:47 <sgallagh> I have packaged up a workaround for this that copies in the original CSS as well
17:18:48 <brunowolff> In my case I clicked on the word help, which might be different than what you guys are talking out. I had a browser point to some generic anaconda help links that didn't end up answering the questions I had.
17:19:05 <kparal> +1 here
17:19:17 <kparal> I think custom part is most problematic
17:19:20 <sgallagh> The risk is extremely low, as all it's doing is putting something back that should have remained there
17:19:24 <nirik> Is this only workstation?
17:19:29 <nirik> or all?
17:19:30 <kparal> nirik: all products
17:19:30 <sgallagh> nirik: No, it's all
17:19:37 * danofsatx-work will take sgallagh's recommendation on this one
17:19:38 <nirik> ok. +1 reluctantly.
17:19:50 <handsome_pirate> +1
17:19:55 <sgallagh> Yeah, I don't love it either, but it's fix this or drop the branding
17:20:01 <jreznik> for usability issues +1 but not happy about it
17:20:02 <pschindl> +1
17:20:04 <adamw> +1 for this, the combination of the effects is pretty bad
17:20:05 <sgallagh> And I think the latter is more likely to break crap at this point than fixing it
17:20:18 <roshi> +1
17:20:19 <danofsatx-work> +1
17:20:24 <adamw> if it makes anyone happier, think about the fact that we've been testing the *other* css all the way through release validation
17:20:33 <adamw> if we don't +1 this, we'd be signing off on releasing some code we'd barely tested
17:20:41 <adamw> the change here is to return the stuff we've been testing all along
17:20:55 <sgallagh> adamw: almost
17:21:18 <sgallagh> the only slight difference is the logo positioning
17:21:32 <sgallagh> But I would categorize that as "barely registering" on the risk scale
17:22:16 <adamw> well, if we don't accept this fe we still get the logo positioning change, right? we just lose all the other bits that have previously been included. anyhow, we have the votes
17:22:31 <sgallagh> adamw: Yeah, that's a correct statement
17:23:04 <adamw> proposed #agreed 1169332 - AcceptedFreezeException - the combination of broken elements here leads to a significantly degraded user experience, and is a clear regression from all previous tested composes
17:23:08 <handsome_pirate> ack
17:23:10 <sgallagh> ack
17:23:18 <danofsatx-work> ack
17:23:42 <jreznik> ack
17:24:00 <adamw> #agreed 1169332 - AcceptedFreezeException - the combination of broken elements here leads to a significantly degraded user experience, and is a clear regression from all previous tested composes
17:24:09 <adamw> #topic (1166607) hawtjni: Spit runtime into subpackage
17:24:09 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1166607
17:24:09 <adamw> #info Proposed Freeze Exceptions, hawtjni, ON_QA
17:24:28 <sgallagh> adamw: That will need a compose override since we can't *realistically* test it (beyond hacking it into a live_
17:24:36 <sgallagh> (Still discussing the previous one)
17:24:45 <adamw> sgallagh: sure, no problems.
17:25:10 <sgallagh> ok, I had this one proposed, but I investigated it and the gains are not worth it.
17:25:13 <sgallagh> -1 FE
17:25:17 <nirik> so, -1 sure.
17:25:20 <danofsatx-work> -1
17:25:34 * handsome_pirate wonders why this is a thing
17:25:37 <handsome_pirate> -1
17:25:42 <pschindl> -1
17:25:56 <roshi> -1
17:26:13 <sgallagh> handsome_pirate: It's part of the long depchain for FreeIPA
17:26:34 <sgallagh> The hope was that it would cut down some of the deps and reduce the image size.
17:26:37 <adamw> proposed #agreed 1166607 - RejectedFreezeException - the benefits from this are not worth the risk of taking it at this point
17:26:41 <kparal> ack
17:26:42 <sgallagh> It only ended up saving a couple dozen megs
17:26:46 <roshi> ack
17:26:54 <sgallagh> ack
17:26:54 <pschindl> ack
17:27:00 <nirik> ack
17:27:04 <handsome_pirate> ack
17:27:14 <danofsatx-work> aCK
17:27:31 <adamw> #agreed 1166607 - RejectedFreezeException - the benefits from this are not worth the risk of taking it at this point
17:27:44 <adamw> #topic (1150384) unicode_start is not started on boot
17:27:44 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1150384
17:27:44 <adamw> #info Proposed Freeze Exceptions, systemd, ON_QA
17:27:56 <adamw> wish someone had caught this earlier...
17:28:18 <adamw> it seems a bit late to start fiddling, but otoh it sounds like kind of a bad bug
17:28:19 <kparal> hmm, I have reported this years ago
17:28:21 * satellit missed new 1169440?
17:28:22 <adamw> anyone have any more details?
17:28:31 <adamw> satellit: we're not done yet
17:28:35 <sgallagh> kparal: Was it fixed and regressed?
17:28:43 <kparal> I don't think so
17:28:48 <kparal> it was probably not fixed
17:28:49 * nirik voted in bug
17:28:52 <sgallagh> If not, it's a continuing bug and I'm -1 to blocking on it here
17:29:11 <sgallagh> Sorry, not a blocker, but you get my point
17:29:46 <sgallagh> I'm wary of including any new systemd build at this point, since we never know what else is coming with it
17:30:20 <danofsatx-work> -1
17:30:20 <kparal> as a non-english user, I'm not happy about this. but including new systemd right now is risky
17:30:34 <vpodzime> and there is an easy workaround
17:30:37 <jreznik> -1
17:30:46 <kparal> so I guess -1 is more appropriate now
17:31:06 <sgallagh> One moment
17:31:13 <kparal> and it's true it has been broken in the past
17:31:28 <sgallagh> OK, so I just looked into the systemd tree
17:31:35 <nirik> 216-12 only has a fix for this.
17:31:37 <sgallagh> It *is* just this one patch that is going into -12
17:31:40 <nirik> correct
17:31:48 <sgallagh> And RC1 had -11
17:31:58 <sgallagh> Does that change anyone's opinion?
17:32:09 <sgallagh> (I'm moving from -1 to +/- 0)
17:32:45 <kparal> sgallagh: can you link the patch?
17:32:59 <sgallagh> one moment
17:33:04 * nirik is +1 still.
17:33:42 <sgallagh> http://paste.fedoraproject.org/155540/45518714
17:33:52 <sgallagh> (I can't remember the dist-git cgit address offhand...)
17:34:19 <sgallagh> Looks like it adds a single action: reset vconsole state when changing console drivers
17:35:20 <sgallagh> /me doesn't feel qualified to decide if this is dangerous or not
17:35:36 <kparal> me neither
17:35:45 <kparal> but it doesn't look that bad
17:36:27 <sgallagh> kparal: Famous last words ;-)
17:36:41 <adamw> what could possibly go wrong
17:36:46 * adamw really hates both choices here
17:37:07 <sgallagh> Well, *it couldn't get any worse*.
17:37:41 <sgallagh> /me tries to find halfline.
17:39:45 <adamw> what's karma on -12 look like?
17:40:18 <sgallagh> adamw: It's at +1
17:40:25 <sgallagh> Only karma is from the reporter of the bug we're discussing
17:41:06 <sgallagh> I'm going to move to a +0.5 on the grounds that it will be really easy to revert and respin if it turns out to cause problems.
17:41:16 <roshi> true
17:41:23 <sgallagh> (unlike many other systemd updates which carry lots of changes)
17:41:45 <adamw> so long as it doesn't go to stable we don't need to do anything to the package, just respin RC3 without the package in bleed. anyhow
17:41:48 <sgallagh> I think the benefit is worth the risk
17:42:18 <roshi> yeah, unicode support really *should* be there w/o needing a workaround
17:42:38 <danofsatx-work> keyword = should
17:42:56 <roshi> well, I'm not in a position to say "must" :p
17:43:09 <sgallagh> roshi: anyone can *say* it.
17:43:18 <roshi> haha
17:43:24 <roshi> fair enough
17:43:29 <adamw> ok, fiiiine, reluctant +1
17:43:42 <kparal> I'm OK with it
17:44:14 <roshi> +1
17:44:24 <danofsatx-work> -|- 1
17:44:37 <sgallagh> danofsatx-work: EPARSE
17:44:52 <vpodzime> I'd really like to see this fixed as I believe it has been broken since systemd came to Fedora
17:44:53 <danofsatx-work> hmmm....that was s'posta be an iffy +
17:45:01 <adamw> sgallagh: I think that's a +1 while riding a segway
17:45:15 <sgallagh> /me snorts
17:45:34 <sgallagh> Anyone want to come out against it?
17:46:08 <roshi> not me
17:46:11 <adamw> proposed #agreed 1150384 - AcceptedFreezeException - we're obviously reluctant to touch systemd this late, but the change is very limited and the bug seems fairly bad for many non-US users (and even some US users who speak those furrin languages).
17:46:23 <nirik> ack
17:46:27 <roshi> ack
17:46:51 <sgallagh> ack
17:46:53 <danofsatx-work> ack
17:46:57 <adamw> #agreed 1150384 - AcceptedFreezeException - we're obviously reluctant to touch systemd this late, but the change is very limited and the bug seems fairly bad for many non-US users (and even some US users who speak those furrin languages).
17:46:57 <sgallagh> patch
17:47:01 <sgallagh> never mind
17:47:07 <adamw> oh, sorry
17:47:16 <kparal> ack
17:47:17 <adamw> i can #undo if it's important?
17:47:18 <danofsatx-work> you already voted, sgallagh, too late
17:47:21 <sgallagh> It's not.
17:47:25 <adamw> rgr
17:47:26 <adamw> #topic (1168404) velocity has a runtime dependency on junit
17:47:26 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1168404
17:47:26 <adamw> #info Proposed Freeze Exceptions, velocity, ON_QA
17:47:46 <sgallagh> Same as the hawtjni one. -1 FE
17:47:57 <nirik> -1
17:47:57 <sgallagh> Didn't have the impact we wanted and isn't important enough to risk
17:48:01 <kparal> -1
17:48:17 <roshi> -1
17:48:48 <danofsatx-work> -1
17:49:55 <adamw> proposed #agreed 1168404 - RejectedFreezeException - the benefit of this change is not worth the risk of taking it at this point.
17:50:05 <roshi> ack
17:50:21 <danofsatx-work> ack
17:51:04 <kparal> ack
17:51:18 <sgallagh> ack
17:52:34 <adamw> #agreed 1168404 - RejectedFreezeException - the benefit of this change is not worth the risk of taking it at this point.
17:53:01 <danofsatx-work> arewedone?
17:53:07 <adamw> i believe someone had another one to add
17:53:19 <roshi> satellit: ^^
17:53:20 <adamw> was that you?
17:53:23 <adamw> oh, satellit
17:53:31 <roshi> pretty sure it was him
17:53:41 <satellit_e> https://bugzilla.redhat.com/show_bug.cgi?id=1150384
17:53:56 <kparal> 1169440 appeared
17:53:59 <satellit> no it is on FE list if refresh
17:54:28 <kparal> wait, satellit and satellit_e is not the same person?
17:54:42 <roshi> o.O
17:54:47 <satellit> -e is my workstation test PC
17:54:58 <adamw> fedora has many satellites
17:55:00 <kparal> so there is just one you! ok
17:55:01 <nirik> is this possibly just related to the translations? or they are there but rendered wrong?
17:55:03 <adamw> including the orbital laser death ray
17:55:10 <sgallagh> adamw: Shhh, they're not supposed to know about those
17:55:12 <satellit> rendering I think
17:55:35 <satellit> only in liveinst in SoaS does it occur
17:55:35 <adamw> #topic (1169440) SoaS anaconda is missing font does not display some language samples on first screen
17:55:36 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1169440
17:55:36 <adamw> #info Proposed Freeze Exceptions, spin-kickstarts, NEW
17:55:41 <kparal> satellit: I don't see any screenshot
17:55:53 <satellit> sorry late entry
17:55:57 <adamw> nirik: I don't think so, i think it's likely missing fonts, but let me grab an image and see
17:56:14 <nirik> but what fonts? ;)
17:56:21 <sgallagh> Possibly another artifact of the vpodzime release?
17:56:34 <sgallagh> satellit: Did it work properly on TC4?
17:56:37 <adamw> satellit: do you have a final TC4 image around? is that one OK?
17:56:56 <satellit> It is important as sugar is used in many 3rd world countries
17:57:24 <satellit> I have seen it in all testing lately but did not appreciate problem
17:57:57 <sgallagh> satellit: When did you first see it?
17:58:01 <sgallagh> Which compose?
17:58:23 <satellit> several versions ago....need to go back and check  sorry
17:58:41 <sgallagh> That's fine, just needed to rule something out
17:58:57 <sgallagh> There was a bad anaconda and I was hoping this could be traced to that
17:59:24 <vpodzime> sgallagh: anaconda's tarball doesn't contain fonts
17:59:32 <sgallagh> OK, good to know
17:59:39 * satellit it has been there for quite while when think back...
17:59:54 <satellit> so kickstart?
18:00:37 * adamw testing
18:03:37 * adamw confirms the bug in rc1
18:03:38 <adamw> checking tc4
18:04:10 <adamw> if the only change required to fix this is to add fonts to the SoaS live kickstart i could be +1
18:04:47 <roshi> same here
18:04:55 <adamw> yeah, broken in tc4 too
18:04:58 <adamw> so i'm guessing it's fonts
18:05:15 <adamw> i'll add a note to the bug of what languages seem to be missing characters
18:05:41 <sgallagh> +1 conditional on it being constrained to the SoaS kickstart. -1 for any other reason without re-review.
18:05:46 <nirik> so this bug would be up to pbrobinson to track down fonts? or is there some way to know what we are missing?
18:06:20 <nirik> also, if we accept this we should make sure we wait on making the final spin-kickstarts package until these commits are done.
18:06:45 <vpodzime> lorax templates include the font packages used for squashfs.img
18:06:56 <vpodzime> (I mean non-live)
18:07:04 <adamw> nirik: i can take a swing at it, i'm good at that sort of thing.
18:07:08 <nirik> ok.
18:07:15 <satellit> thanks...
18:07:19 <nirik> +1 here provided we can get it quickly. ;)
18:07:42 <danofsatx-work> +1
18:07:45 <roshi> +1
18:07:57 * adamw votes same as sgallagh, +1 if only change is to SoaS kickstart (or maybe comps, but not if it requires too much time we wouldn't need otherwise)
18:08:15 <danofsatx-work> but wait - SoaS is non-blocking. I realize this is a regression, but....
18:08:41 <sgallagh> danofsatx-work: This isn't a blocker bug
18:08:43 <nirik> this is FE... not blocker
18:09:04 <sgallagh> danofsatx-work: Basically we're saying "if it can only break SoaS, go for it"
18:09:10 <danofsatx-work> understood....
18:10:19 <adamw> if we have to change anything outside of SoaS, we're not doing it
18:10:34 <adamw> note the impact of this isn't just the anaconda welcome screen
18:10:39 <nirik> and if it takes too long and we want to do a rc2 and it's not done... too bad.
18:10:40 <adamw> if the fonts are missing it means the live won't be usable in those languages
18:11:17 <sgallagh> note: given that everything else on the blocker list looks to be ready to go, I'm going to push for an RC2 compose sometime today.
18:11:28 <roshi> sounds like a plan to me
18:11:37 * satellit soas does have a way to change languages and keyboards in control panel once it starts
18:11:40 <adamw> oh, for sre.
18:12:02 <nirik> we need an anconda build with the things we accepted.
18:12:05 <adamw> yeah
18:12:22 <nirik> and can probibly push some more stuff stable from fe's
18:12:25 <nirik> (that were in rc1)
18:12:35 <adamw> i'll be on it, after this meeting
18:12:40 <adamw> do we want to go through accepted blockers?
18:12:59 <nirik> anything worrying?
18:13:00 <adamw> i don't think there was anything much to look at there
18:13:05 <roshi> are we going to have an #agreed for this soas one?
18:13:09 <sgallagh> They're all either MODIFIED, ON_QA or VERIFIED
18:13:12 <sgallagh> So we're probably oka
18:13:18 <adamw> i think all the ones prior to the meeting are VERIFIED
18:15:18 <danofsatx-work> I see 2 "NEW" in accepted FEs
18:15:36 <sgallagh> proposed #agreed AcceptedFreezeException We will accept a fix for SoaS if it is constrained to SoaS.
18:15:47 <danofsatx-work> 1098735 and 1135720
18:15:47 <adamw> whoops, sorry
18:15:51 <adamw> forgot i didn't close this one
18:15:51 <sgallagh> danofsatx-work: Not our problem. If they aren't fixed, too bad, so sad.
18:15:54 <adamw> danofsatx-work: that doesn't matter.
18:15:57 <nirik> ack
18:16:00 <danofsatx-work> ack
18:16:03 <adamw> patch
18:16:07 <danofsatx-work> ok, no prob
18:16:07 <adamw> (bug number not mentioned)
18:16:11 <roshi> ack
18:16:12 <sgallagh> adamw: Ah, whoops
18:16:21 <adamw> proposed #agreed - 1169440 - AcceptedFreezeException - we will accept a fix for SoaS if it is constrained to SoaS.
18:16:27 <roshi> ack
18:16:27 <sgallagh> ack
18:16:29 <danofsatx-work> ack that onw
18:16:33 <nirik> ack
18:16:47 <kparal> ack
18:19:21 <adamw> #agreed - 1169440 - AcceptedFreezeException - we will accept a fix for SoaS if it is constrained to SoaS.
18:19:46 <adamw> #info all open accepted blockers from before this meeting were VERIFIED, do not need to be reviewed
18:19:59 <adamw> so I believe we're now all set to get RC2 out the door, thanks very much for all the work from everyone
18:20:07 <adamw> #topic Open floor
18:20:10 <adamw> any other business?
18:20:11 <sgallagh> OK, so all that's left appears to be to ask the anaconda folks to build .20 and get it out
18:20:16 <roshi> I have none
18:20:30 <roshi> not for a blocker meeting anyways :)
18:20:32 <sgallagh> Then file an RC2 compose request
18:22:28 <danofsatx-work> that's an adamw action item. We're done ;)
18:23:38 <adamw> sgallagh: that and look at the soas FE.
18:24:00 <adamw> also get the final version of the stage1 patch reviewed and acked and tested...don't worry, it's all in hand. :P
18:24:00 <sgallagh> adamw: I'd recommend doing that in parallel to the anaconda builds.
18:24:13 <sgallagh> Because frankly, I don't see a huge value in delaying everything else for it
18:24:30 <adamw> sgallagh: we don't have a dgilmore for ~5 hours anyway.
18:24:39 <sgallagh> But it's in your capable hands now.
18:24:53 <satellit> soas is still listed on blocker bugs as proposed
18:24:53 <adamw> thanks for coming, everyone! ending meeting in a minute or two
18:25:03 <sgallagh> satellit: It takes 30 minutes
18:25:05 <adamw> satellit: the page updates every half an hour, be patient.
18:25:14 <satellit> thanks  sorry
18:30:37 <adamw> #endmeeting