16:03:59 <roshi> #startmeeting F23-blocker-review
16:03:59 <zodbot> Meeting started Mon Jul 13 16:03:59 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:59 <roshi> #meetingname F23-blocker-review
16:03:59 <zodbot> The meeting name has been set to 'f23-blocker-review'
16:04:00 <roshi> #topic Roll Call
16:04:11 * kparal is here
16:04:24 <adamw> ahoyhoy
16:04:29 * garretraziel is here
16:04:38 <roshi> #chair kparal adamw garretraziel
16:04:38 <zodbot> Current chairs: adamw garretraziel kparal roshi
16:04:42 <kparal> new blood!
16:04:51 <roshi> prepare the altar!
16:05:00 <roshi> welcome garretraziel :)
16:05:04 <adamw> again? i only just got the stains off from the last time.
16:05:16 <roshi> such is life adamw ...
16:05:22 <roshi> shoulda used OxyClean
16:05:27 <roshi> #topic Introduction
16:05:27 <roshi> Why are we here?
16:05:27 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:05:31 <roshi> #info We'll be following the process outlined at:
16:05:33 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:05:36 <roshi> #info The bugs up for review today are available at:
16:05:38 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:05:41 <roshi> #info The criteria for release blocking bugs can be found at:
16:05:43 <roshi> #link https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria
16:05:46 <roshi> #link https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria
16:05:49 <roshi> #link https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria
16:05:52 <roshi> gonna be a shorter meeting, 2/0/1 for proposed blockers
16:06:05 * satellit listening
16:06:07 <roshi> but I figure it's good to start getting back into the swing of things
16:06:12 <roshi> #chair satellit
16:06:12 <zodbot> Current chairs: adamw garretraziel kparal roshi satellit
16:06:25 <roshi> onto the Alpha blockers!
16:06:26 <roshi> #topic (1236937) fstab is malformed, system doesn't assemble correctly at boot
16:06:29 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1236937
16:06:32 <roshi> #info Proposed Blocker, anaconda, NEW
16:06:55 * danofsatx is here, apparently
16:07:03 * lbrabec is listening
16:07:33 <adamw> this seems to be affecting UEFI installs, right?
16:07:45 <adamw> i meant to reproduce and confirm it but didn't get around to it yet
16:07:58 <roshi> looks like it affects bios as well
16:08:02 <adamw> but sounds from the bug like we have confirmation
16:08:08 <roshi> yeah
16:09:01 <roshi> though, I think "All release-blocking images must boot in their supported configurations" is a better criteria
16:09:14 <adamw> no, it isn't
16:09:18 <adamw> that refers to the images specifically.
16:09:26 <adamw> this bug affects installed systems, not the images we release.
16:09:27 <roshi> oh, right
16:09:47 <adamw> cmurf's criterion seems good enough for me
16:10:04 <roshi> works for me
16:10:06 <roshi> +1
16:10:21 <adamw> assuming the bug is confirmed as described, +1
16:10:50 <garretraziel> it looks like a blocker, +1
16:10:54 <kparal> +1
16:10:59 <roshi> proposed #agreed - 1236937 - AcceptedBlocker Alpha - This bug is a clear violation of the following Alpha criteria: "The installed system must be able to download and install updates with the default console package manager."
16:11:10 <kparal> grub is definitely not updated, confirmed by twohot
16:11:24 <kparal> ack
16:11:30 <adamw> ack
16:11:38 <roshi> #agreed - 1236937 - AcceptedBlocker Alpha - This bug is a clear violation of the following Alpha criteria: "The installed system must be able to download and install updates with the default console package manager."
16:11:48 <roshi> #topic (1208092) Mock should not umount my mounts
16:11:48 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1208092
16:11:48 <roshi> #info Proposed Blocker, mock, NEW
16:12:25 <garretraziel> why is this a blocker?
16:12:44 <danofsatx> it blocks iso generation according to dgilmore
16:12:46 <nirik> because it causes compose tools to not work
16:12:51 <garretraziel> oh, ok
16:13:12 <adamw> this is what's breaking boot.iso generation?
16:13:32 <nirik> quite possibly yeah. new pungi needs this to work.
16:13:49 <adamw> i'd be +1 if it's for sure breaking image generation...
16:13:54 <adamw> be nice to be certain, though.
16:13:57 <adamw> dgilmore still in his meeting?
16:14:15 <nirik> he's running the releng meeting and asking the mock maintainers to fix this bug right now. ;)
16:16:05 <roshi> if it breaks image generation, +1
16:16:20 <adamw> i guess i trust dgilmore, so +1.
16:16:32 <adamw> note: I've just filed https://bugzilla.redhat.com/show_bug.cgi?id=1242586 as an automatic blocker (for nightly lives failing to boot)
16:16:42 <danofsatx> +1
16:16:55 <danofsatx> so noted
16:16:58 <garretraziel> +1
16:17:06 <lbrabec> +1
16:17:41 <roshi> proposed #agreed - 1208092 - AcceptedBlocker - As this bug breaks image generation, it is accepted as a blocker.
16:17:52 <kparal> ack
16:17:54 <danofsatx> ack
16:18:01 <kparal> do we have a secretary?
16:18:05 <roshi> #agreed - 1208092 - AcceptedBlocker - As this bug breaks image generation, it is accepted as a blocker.
16:18:12 <roshi> kparal: you win the prize!
16:18:15 <roshi> :p
16:18:19 <roshi> no, we don't yet
16:18:35 <adamw> congratulations, kparal
16:18:41 <kparal> hmmm
16:18:49 * danofsatx votes for kparal
16:19:02 <kparal> any volunteers with more spare time than I currently have?
16:19:06 <roshi> you said the secret passphrase :p
16:19:17 <roshi> I can do it after the meeting if others don't want to/have time
16:19:17 <adamw> fiiiine, i'll do it
16:19:23 <roshi> thanks adamw
16:19:24 <kparal> thanks :)
16:19:54 <roshi> we have no proposals for Beta, so skipping onto the Final proposal
16:19:56 * kparal juggling too many tasks at once atm
16:19:57 <roshi> #topic (1224561) lvm2 can't be installed with generic-release
16:20:00 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1224561
16:20:02 <roshi> #info Proposed Blocker, lvm2, ASSIGNED
16:20:22 <danofsatx> that wasn't there earlier....
16:20:47 <brunowolff> I added it during the qa meeting.
16:20:55 <danofsatx> sneaky...
16:21:19 <kparal> we don't have an exact criterion for this, I think
16:21:35 <roshi> I don't think we do either
16:22:01 <kparal> but it's close to any other branding criterion, I'd say
16:22:06 <kparal> or the generic-release one
16:22:06 <adamw> hum, new meetbot doesn't apparently give us log links until the meeting is finished :(
16:22:11 <adamw> so can't really secretarialize on the fly
16:22:25 <kparal> adamw: unfortunately that's right
16:22:26 <danofsatx> munge the date, they're there
16:22:30 * roshi always used backscroll
16:22:32 <brunowolff> It's been out there for a while. I don't like the requirement on an activate friendly preset file, but given that they are doing that they should find a way to make it work with generic-release.
16:22:50 * kparal wanted to file a meetbot RFE but forgot
16:23:57 * danofsatx doesn't have an opinion on this one
16:25:00 <nirik> adamw: meetbot-raw has the raw logs.
16:25:05 <roshi> which products use generic-release?
16:25:08 <brunowolff> Dennis did add a preset file to generic-release, but they can't just do an or requires so some work is needed.
16:25:25 <adamw> nirik: oh, didn't know about that.
16:25:34 <adamw> brunowolff: just depend on system-release .
16:25:47 <adamw> that's what virtual provides are for.
16:26:36 <brunowolff> IMO there shouldn't be any dependency at all. There client should just do something reasonable if the service isn't running already.
16:27:14 <adamw> we don't need to thrash that out here, really, point is it's viable to fix the bug, one way or another.
16:27:35 <nirik> roshi: none.
16:27:42 <roshi> ah
16:27:43 * danofsatx has to run
16:27:48 <nirik> it's a placeholder/example for people who remix fedora
16:27:51 <danofsatx> mark me down for +1 on adam's bug
16:27:54 <adamw> so the criterion we have is "A Package-x-generic-16.pngfedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned Package-x-generic-16.pnggeneric-release package must be available in the release repository."
16:28:23 <adamw> nirik: however, as it stands, this bug basically means you can't do a remix that works properlyu
16:28:25 <brunowolff> I agree, but it hasn't moved for a while, and I think it is something we want for final. I doubt much generic-release testing happens before then.
16:28:36 <nirik> adamw: indeed.
16:28:47 <adamw> well, unless you have your -release package provide fedora-release , i guess.
16:29:12 <adamw> the criterion we have doesn't really require it to be possible to do remixes. i'm not sure if we need that to be a release-time requirement or not...
16:29:22 <nirik> we should definitely fix it, but I don't think it's super urgent. we can't even produce our own images right now, not sure how as remix would. :)
16:29:32 <brunowolff> Sorry about the image mentions, I did a copy and paste and didn't notice the images were included until too late.
16:29:33 <adamw> it's one of those areas where we have limited real-world usage so it's all a bit theoretical
16:29:55 <adamw> nirik: well, it's only proposed as a final blocker.,
16:30:31 * nirik is fine with final for sure.
16:31:39 <adamw> we don't really have a criterion for it, though. the question would be if we ought to i guess.
16:32:22 <roshi> I'd hate for spins to be broken at GA, so I think a criteria for this would be good
16:32:42 <adamw> roshi: this isn't about spins, but remixes...
16:32:49 <adamw> spins use the fedora-release packages.
16:33:01 <brunowolff> My thought was that the spirit of the mentioned criteria was that it would be usable was implied by being required to be in repository.
16:33:08 <adamw> i guess it'd affect korora
16:33:12 <roshi> oh
16:33:29 <roshi> for some reason I was interchanging those two term in my head
16:33:46 <roshi> as I don't think about them often (just because I don't see them come up very often)
16:33:50 <adamw> brunowolff: that's a *bit* more of a leap than i'm comfortable with, personally i'd prefer to have an explicit criterion (or an explicit update to that criterion)
16:33:54 <adamw> if we're going to block on it
16:34:16 <roshi> I'm -1 as it stands
16:34:19 <adamw> roshi: yeah, there just aren't terribly many remixes, really. korora is one, i think. fedlet technically is one.
16:34:33 <roshi> but would be ok with a new criterion though if it's deemed important enough
16:34:40 <roshi> pidora?
16:34:42 <adamw> i guess i'd be OK with punting if someone wnats to propose revising the criteria to cover it
16:34:46 <adamw> roshi: probably
16:35:04 <adamw> seems like the kind of thing that could benefit from a considered mailing list discussion rather than a quick IRC call
16:35:13 <roshi> yeah
16:35:32 <roshi> -1 to blockeriness, +1 to interested parties starting a mailing list discussion on criteria
16:36:20 <brunowolff> How quickly do those remixes come out? This is something that can be fixed after release, but could cause delays for remixes.
16:36:23 <nirik> adamw: +1 for mailing list
16:36:52 <roshi> proposed #agreed - 1224561 - RejectedBlocker Final - This bug doesn't violate any current criteria. Parties interested in remixes and this bug should start a discussion on list regarding the drafting of a potential criteria to cover this case.
16:38:20 <kparal> ack
16:38:41 <garretraziel> ack
16:38:53 <adamw> brunowolff: right, that's the kinda thing we'd want to think about - does it actually make sense to block the fedora release on remixes being possible, do we want to make sure you can do a remix from the frozen final release packages, etc.
16:39:18 <adamw> well, i was gonna say punt, but -1 and repropose if criteria change is ok, i guess.
16:39:25 <adamw> someone want to volunteer to start a thread about it?
16:40:01 <brunowolff> I guess that would be me. On the test list?
16:40:04 <roshi> I don't follow the remixes close enough to really weigh in on it
16:40:17 <roshi> +1 to brunowolff starting it
16:40:39 <brunowolff> I am not sure which lists remix people would read
16:40:59 <roshi> perhaps start it on the list, and then CC maintainers from the remixes
16:41:16 <brunowolff> Maybe spins would be better than test?
16:42:30 <adamw> devel?
16:42:35 <roshi> I'll leave that up to you, can discuss further in #fedora-qa
16:42:43 <roshi> as I think we've determined if this is a blocker right now
16:42:49 <adamw> huh
16:42:49 <adamw> there is apparently a fedora-remixes mailing list
16:42:56 <adamw> https://lists.fedoraproject.org/pipermail/remixes/
16:42:57 <roshi> good place to start
16:43:01 <adamw> last mail: march 2014 :)
16:43:31 <roshi> votes, ack/nack/patch?
16:45:01 <brunowolff> OK, I'll join the remixes list and start a discussion there. I may copy the original message to another list or two with a note about going to the remix list.
16:45:15 <roshi> brunowolff: that would work nicely I think
16:45:16 <adamw> ack
16:45:27 <garretraziel> ack
16:45:39 <roshi> #agreed - 1224561 - RejectedBlocker Final - This bug doesn't violate any current criteria. Parties interested in remixes and this bug should start a discussion on list regarding the drafting of a potential criteria to cover this case.
16:45:45 <roshi> #topic Open Floor
16:45:52 <roshi> anybody have anything for open floor?
16:46:06 <roshi> Council meeting is going to be starting here in 15 minutes
16:46:19 <roshi> https://www.youtube.com/watch?v=552P7TXRt7w if you want to watch it
16:46:44 <roshi> and I think it'll be transcribed in #fedora-meeting if you don't want to load the youtubes
16:47:37 <adamw> i'm working on the live boot bug with a hint from bcl
16:48:24 <roshi> good to know
16:48:32 * roshi sets the fuse...
16:48:33 <roshi> 3...
16:49:43 <roshi> 2...
16:49:53 <roshi> 1...
16:50:41 <roshi> thanks for coming folks!
16:50:45 <roshi> #endmeeting