#fedora-blocker-review: F23-blocker-review

Meeting started by adamw at 16:05:49 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:05:49)
  2. Introduction (adamw, 16:08:38)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:08:38)
    2. We'll be following the process outlined at: (adamw, 16:08:38)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:40)
    4. The bugs up for review today are available at: (adamw, 16:08:40)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:44)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:44)
    7. https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria (adamw, 16:08:46)
    8. https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria (adamw, 16:08:48)
    9. https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria (adamw, 16:08:50)
    10. 6 Proposed Blockers (adamw, 16:10:15)
    11. 6 Accepted Blockers (adamw, 16:10:15)
    12. 4 Proposed Freeze Exceptions (adamw, 16:10:15)
    13. 0 Accepted Freeze Exceptions (adamw, 16:10:17)

  3. (1245423) TypeError: nothing connected to functools.partial(<pyanaconda.ui.gui.utils.timed_action.<locals>.TimedAction object (adamw, 16:12:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1245423 (adamw, 16:12:39)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:12:39)
    3. AGREED: 1245423 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction" (adamw, 16:19:42)

  4. (1225957) Regression: GFileMonitor doesn't react to "mv some-file watched-file" (adamw, 16:19:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1225957 (adamw, 16:19:50)
    2. Proposed Blocker, glib2, NEW (adamw, 16:19:50)
    3. AGREED: 1225957 - AcceptedBlocker Beta - clear violation of "after system installation the Cockpit web management interface must be running and accessible on its default port (9090)" (adamw, 16:24:54)

  5. (1249304) UnboundLocalError: local variable 'e' referenced before assignment (adamw, 16:25:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1249304 (adamw, 16:25:08)
    2. Proposed Blocker, python-blivet, ON_QA (adamw, 16:25:08)
    3. AGREED: 1249304 - defer decision - it's unclear how serious or how commonly encountered this bug is, and a fix is already pending, so we'll hope to see it gone by next meeting (adamw, 16:34:14)

  6. (1252052) blivet.errors.DeviceError: ('cannot replace active format', 'fedora_dhcp45-root') (adamw, 16:34:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1252052 (adamw, 16:34:21)
    2. Proposed Blocker, python-blivet, MODIFIED (adamw, 16:34:21)
    3. AGREED: 1252052 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction" (adamw, 16:39:22)

  7. (1253787) AttributeError: 'int' object has no attribute 'convertTo' (adamw, 16:39:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1253787 (adamw, 16:39:31)
    2. Proposed Blocker, python-blivet, MODIFIED (adamw, 16:39:31)
    3. AGREED: 1253787 - AcceptedBlocker Beta - clear violation of "When using the custom partitioning flow, the installer must be able to: ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions." (adamw, 16:44:57)

  8. (1250942) clicking on buttons on error pop-up doesn't work (adamw, 16:45:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1250942 (adamw, 16:45:05)
    2. Proposed Blocker, python-meh, NEW (adamw, 16:45:05)
    3. AGREED: 1250942 RejectedBlocker AcceptedFreezeException Beta - as things stand our call is that this is probably not quite common enough to block (it's a conditional criterion violation, so it's a judgment call). We may revise this later if it turns out to be more common than we thought (adamw, 16:59:44)

  9. (1252756) repository definition nor product branding works with nfsiso (roshi, 17:04:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1252756 (roshi, 17:04:53)
    2. Proposed Blocker, anaconda, NEW (roshi, 17:04:55)
    3. AGREED: - 1252756 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources." (roshi, 17:13:16)

  10. (1252902) inst.repo=hd: is not working (roshi, 17:13:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1252902 (roshi, 17:13:34)
    2. Proposed Blocker, anaconda, POST (roshi, 17:13:34)
    3. AGREED: - 1252902 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources." (roshi, 17:16:03)

  11. (1254687) DNF does not display any translations (roshi, 17:16:07)
    1. Proposed Blocker, dnf, POST (roshi, 17:16:07)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=1254687 (roshi, 17:16:10)
    3. AGREED: - 1254687 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use." (roshi, 17:19:14)

  12. (1250414) media check fails on DVD/netinst - "configured resource limit was exceeded" (roshi, 17:19:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1250414 (roshi, 17:19:21)
    2. Proposed Blocker, dracut, ON_QA (roshi, 17:19:23)
    3. AGREED: - 1250414 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "Validation of install media must work correctly for all release-blocking images." (roshi, 17:22:57)

  13. (1236034) many fonts missing in fontconfig cache after installation, forced refresh needed (roshi, 17:23:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1236034 (roshi, 17:23:13)
    2. Proposed Blocker, fontconfig, VERIFIED (roshi, 17:23:15)

  14. (1249336) [abrt] setroubleshoot-server: util.py:291:<module>:ImportError: No module named sepolicy (roshi, 17:24:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1249336 (roshi, 17:24:10)
    2. Proposed Blocker, setroubleshoot, MODIFIED (roshi, 17:24:12)

  15. (1236034) many fonts missing in fontconfig cache after installation, forced refresh needed (roshi, 17:25:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1236034 (roshi, 17:26:02)
    2. Proposed Blocker, fontconfig, VERIFIED (roshi, 17:26:04)
    3. AGREED: - 1236034 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (roshi, 17:29:02)

  16. (1249336) [abrt] setroubleshoot-server: util.py:291:<module>:ImportError: No module named sepolicy (roshi, 17:29:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1249336 (roshi, 17:29:12)
    2. Proposed Blocker, setroubleshoot, MODIFIED (roshi, 17:29:15)
    3. AGREED: - 1249336 - AcceptedBlocker Final - This bug is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (roshi, 17:33:42)

  17. (1240802) Can't unlock an encrypted root partition using caps lock key (roshi, 17:33:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1240802 (roshi, 17:33:55)
    2. Proposed Blocker, systemd, NEW (roshi, 17:33:57)
    3. AGREED: - 1240802 - RejectedBlocker Final - While this bug is very odd and annoying, the workaround is easy and doesn't seem to happen enough to warrant blocking the release for it. (roshi, 17:41:45)

  18. (1250737) systemd-tmpfiles-setup.service fails on 23 Alpha RC1 Server (roshi, 17:41:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1250737 (roshi, 17:42:00)
    2. Proposed Blocker, systemd, POST (roshi, 17:42:03)
    3. AGREED: - 1250737 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present." We would prefer an actual fix to merely relabeling this error as a warning. (roshi, 17:48:52)

  19. (1254658) systemctl seems not to be translated at all (roshi, 17:49:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1254658 (roshi, 17:49:05)
    2. Proposed Blocker, systemd, NEW (roshi, 17:49:05)
    3. AGREED: - 1254658 - RejectedBlocker Final - While it would be great to have translations for this, none currently exist upstream so this doesn't actually violate the criterion. (roshi, 17:56:44)

  20. (1199252) default html mime configuration (roshi, 17:56:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1199252 (roshi, 17:56:56)
    2. Proposed Blocker, xfce4-session, ASSIGNED (roshi, 17:56:56)
    3. AGREED: - 1199252 - AcceptedBlocker Final - As Xfce is the desktop environment for arm this violates the following Final criterion: "Each application in the default system menu layout should launch without crashing and withstand basic usage. Bugs should be filed in any case where this does not happen" (roshi, 18:09:47)

  21. Open Floor (roshi, 18:11:13)


Meeting ended at 18:13:47 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (178)
  2. roshi (154)
  3. sgallagh (92)
  4. pschindl (27)
  5. danofsatx (21)
  6. garretraziel (17)
  7. pwhalen (10)
  8. kparal (9)
  9. zodbot (7)
  10. tflink (6)
  11. nirik (4)


Generated by MeetBot 0.1.4.