#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:01:59 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:59)
    1. coremodule to secretarialize (adamw, 16:02:51)

  2. Introduction (adamw, 16:07:59)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:59)
    2. We'll be following the process outlined at: (adamw, 16:07:59)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:00)
    4. The bugs up for review today are available at: (adamw, 16:08:00)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:04)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:06)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:08:08)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:08:10)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:08:12)
    10. 9 Proposed Blockers (Beta) (adamw, 16:08:22)
    11. 8 Proposed Blockers (Final) (adamw, 16:08:30)
    12. 2 Accepted Blockers (Beta) (adamw, 16:08:35)

  3. (1371338) pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('ens3',) (adamw, 16:11:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1371338 (adamw, 16:11:18)
    2. Proposed Blocker, anaconda, VERIFIED (adamw, 16:11:18)
    3. AGREED: 1371338 - AcceptedBlocker (Beta) - this violates Alpha criterion "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." (adamw, 16:15:08)

  4. (1372868) F25 Alpha-2 Installer Fails if DVD-ROM is on Silicon Image 3114 SATA Controller (adamw, 16:15:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1372868 (adamw, 16:15:46)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:15:46)
    3. ACTION: adamw to send out call for optical media testing in re 1372868 (adamw, 16:18:28)
    4. AGREED: 1372868 - punt (delay decision) - we're not yet sure exactly how this is failing or how much hardware may be affected; we have asked the reporter for more info and will also put out a call for optical media testing (adamw, 16:23:54)

  5. (1366775) /usr/libexec/gnome-settings-daemon is hammering CPU after login tring to connect to local printing service (adamw, 16:24:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366775 (adamw, 16:24:06)
    2. Proposed Blocker, cups, NEW (adamw, 16:24:06)
    3. AGREED: 1366775 - change to proposed Final blocker, punt (delay decision) on accepting it - we generally agreed this doesn't violate the criteria sufficiently to be considered a Beta blocker. we're more open to considering it a Final blocker, but there seem to be several unclear points we want to clarify before deciding (adamw, 16:38:06)

  6. (1374852) /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64 missing from Fedora 23 (adamw, 16:38:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374852 (adamw, 16:38:13)
    2. Proposed Blocker, fedora-repos, ON_QA (adamw, 16:38:13)
    3. https://fedoraproject.org/wiki/QA:Testcase_upgrade_dnf_previous_server (tenk, 16:42:20)
    4. AGREED: 1374852 - AcceptedPreviousRelease - violates "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." (adamw, 16:46:46)

  7. (1373169) Can't login again after logout. (adamw, 16:47:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1373169 (adamw, 16:47:02)
    2. Proposed Blocker, gnome-session, NEW (adamw, 16:47:03)
    3. AGREED: 1373169 - punt (delay decision) - we're pretty sure this will be accepted as a blocker, but we'd just like to have kparal check he's really running into the same case as pavel, and have a few other people confirm it happens for them too (adamw, 17:08:49)

  8. (1373134) initial-setup doesn't run on ARM with: "pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('eth0',)" (adamw, 17:09:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1373134 (adamw, 17:09:21)
    2. Proposed Blocker, initial-setup, NEW (adamw, 17:09:21)
    3. AGREED: 1373134 - close as duplicate of 1371338 - they had the same cause and are fixed by the same fix (adamw, 17:14:26)

  9. (1374810) initial-setup fails - TypeError: unhashable type: 'list' (adamw, 17:14:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374810 (adamw, 17:14:35)
    2. Proposed Blocker, initial-setup, NEW (adamw, 17:14:35)
    3. AGREED: 1374810 - AcceptedBlocker - violates Alpha criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." for the release-blocking ARM images, where i-s is the only user creation mechanism (adamw, 17:20:56)

  10. (1374864) initial-setup is not completable (adamw, 17:37:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374864 (adamw, 17:37:20)
    2. Proposed Blocker, initial-setup, NEW (adamw, 17:37:20)
    3. AGREED: 1374864 - AcceptedBlocker (Beta) - this violates "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system" in the case of an ARM system with no network connection, which we agreed is severe enough to constitute a blocker (adamw, 17:37:37)

  11. (1374334) Error setting partition type after formatting (adamw, 17:37:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374334 (adamw, 17:37:56)
    2. Proposed Blocker, storaged, NEW (adamw, 17:37:56)
    3. AGREED: 1374334 - move to proposed Final blocker, punt (delay decision) - this should have been proposed for Final, not Beta, under the criterion cited. we believe it may have been fixed, so we will delay the decision to re-test and clarify the report (adamw, 17:53:31)
    4. that's all proposed Beta blockers, moving onto proposed Final (adamw, 17:54:03)

  12. (1374321) file-roller has all actions disabled under wayland (adamw, 17:54:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374321 (adamw, 17:54:42)
    2. Proposed Blocker, file-roller, NEW (adamw, 17:54:42)
    3. AGREED: 1374321 - AcceptedBlocker (Final) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" (adamw, 17:58:54)

  13. (1373933) object selection and edit freezes libreoffice for several seconds (adamw, 17:58:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1373933 (adamw, 17:59:00)
    2. Proposed Blocker, libreoffice, NEW (adamw, 17:59:00)
    3. AGREED: 1373933 - AcceptedBlocker (Final) - this constitutes a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test", as it's impossible to do basic work in Impress or Draw (adamw, 18:03:55)

  14. (1372300) GDM does not use the keyboard layout which is selected (adamw, 18:04:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1372300 (adamw, 18:04:11)
    2. Proposed Blocker, mutter, NEW (adamw, 18:04:11)
    3. https://openqa.fedoraproject.org/tests/33863 (adamw, 18:08:01)
    4. AGREED: 1372300 - punt (delay decision) - it's not entirely clear if this is a problem after a default Russian install or only after tweaking the keyboard layout order post-install; we will wait for kparal to test further and report (adamw, 18:13:06)
    5. https://phab.qadevel.cloud.fedoraproject.org/T842 (adamw, 18:16:02)

  15. (1374600) Can't change display's resolution on Gnome Wayland (adamw, 18:16:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374600 (adamw, 18:16:20)
    2. Proposed Blocker, mutter, ASSIGNED (adamw, 18:16:20)
    3. AGREED: 1374600 - RejectedBlocker - the issue here is that there was an X11 workaround to make non-native resolutions available on laptop displays; this isn't really 'basic functionality' for the resolution switching applet, which is doing all it's supposed to do, and so this is rejected as a blocker. (adamw, 18:29:01)

  16. (1370459) SELinux is preventing udisksd from 'read' accesses on the blk_file sr0. (adamw, 18:29:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370459 (adamw, 18:29:17)
    2. Proposed Blocker, selinux-policy, NEW (adamw, 18:29:17)
    3. AGREED: 1370459 - AcceptedBlocker (Final) - this violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" in the case of gnome-disks on a system with an optical drive; it may have other consequences too, but that's sufficient for blocker status (adamw, 18:38:14)

  17. (1370136) glibc update corrupts display of a running system (adamw, 18:38:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370136 (adamw, 18:38:23)
    2. Proposed Blocker, systemd, POST (adamw, 18:38:24)
    3. http://koji.fedoraproject.org/koji/buildinfo?buildID=796090 claims to have fixed this (adamw, 18:40:55)
    4. AGREED: 1370136 - AcceptedBlocker (Final) - this can be considered a conditional violation of Alpha criterion "The installed system must be able to download and install updates with the default console package manager" and also Final "All known bugs that can cause corruption of user data must be fixed or documented at Common F25 bugs", as it can cause the user to reboot before the update completes, breaking the system and risking data loss (adamw, 18:49:10)

  18. (1374371) systemctl set-default doesn't work at all (adamw, 18:49:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374371 (adamw, 18:49:27)
    2. Proposed Blocker, systemd, POST (adamw, 18:49:27)
    3. AGREED: 1374371 - RejectedBlocker (Final) - this doesn't violate any existing criterion and we didn't see any need to add a new one; it's really just a small convenience tool that updates the target of a symlink, which you can easily do manually instead, and the functionality is not that commonly used in any case (adamw, 18:59:06)

  19. (1266484) spice + fedora wayland VM + spice-vdagent + resize-guest == flickering display (adamw, 18:59:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1266484 (adamw, 18:59:20)
    2. Proposed Blocker, xorg-x11-drv-qxl, NEW (adamw, 18:59:20)
    3. AGREED: 1266484 - punt (delay decision) - we're not entirely clear on the circumstances in which this bug happens or the difficulty of the workaround(s); kparal tested live in the meeting and did not see the bug in an F25-on-F25, Wayland-on-Wayland test. will ask for more info in bug (adamw, 19:13:08)
    4. we're over time, so skipping the accepted blockers (adamw, 19:13:26)

  20. Open floor (adamw, 19:13:30)


Meeting ended at 19:22:22 UTC (full logs).

Action items

  1. adamw to send out call for optical media testing in re 1372868


Action items, by person

  1. adamw
    1. adamw to send out call for optical media testing in re 1372868


People present (lines said)

  1. adamw (303)
  2. cmurf (165)
  3. kparal (149)
  4. pwhalen (28)
  5. coremodule (22)
  6. tenk (18)
  7. pschindl (14)
  8. zodbot (10)
  9. sgallagh (1)
  10. mboddu (1)
  11. fmuellner (1)
  12. satellit (1)
  13. dgilmore (1)


Generated by MeetBot 0.1.4.