17:02:25 <adamw> #startmeeting F28-blocker-review
17:02:25 <zodbot> Meeting started Mon Mar  5 17:02:25 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:25 <zodbot> The meeting name has been set to 'f28-blocker-review'
17:02:28 <adamw> #meetingname F28-blocker-review
17:02:28 <zodbot> The meeting name has been set to 'f28-blocker-review'
17:02:31 <adamw> #topic Roll Call
17:02:36 <adamw> morning folks, who's around for blocker review fun?
17:03:39 * satellit listening
17:03:42 <frantisekz> .hello2
17:03:43 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
17:04:42 <adamw> sgallagh: nirik: kparal: sumantro: tflink: ping
17:04:49 * kparal is here
17:04:54 <sgallagh> Not today, sorry. Swamped.
17:05:56 <kparal> perhaps coremodule is also around?
17:06:29 * tflink is here
17:08:22 <adamw> looks like it's the qa gang :P
17:10:59 <adamw> alrighty
17:11:10 <adamw> #chair tflink kparal
17:11:10 <zodbot> Current chairs: adamw kparal tflink
17:11:18 <adamw> #topic Introduction
17:11:18 <adamw> Why are we here?
17:11:18 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:11:18 <adamw> #info We'll be following the process outlined at:
17:11:20 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:11:21 <adamw> #info The bugs up for review today are available at:
17:11:23 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
17:11:26 <adamw> #info The criteria for release blocking bugs can be found at:
17:11:28 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
17:11:30 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria
17:11:32 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria
17:12:40 <adamw> we have:
17:12:42 <adamw> #info 4 Proposed Blockers
17:12:42 <adamw> #info 5 Accepted Blockers
17:12:45 <adamw> (for beta)
17:12:55 <adamw> anyone volunteer to secretarialize?
17:14:28 * tflink can
17:14:32 <kparal> nah, frantisekz is the volunteer
17:14:40 <kparal> frantisekz: you're welcome
17:14:57 * tflink certainly isn't going to stop someone else from doing it :)
17:15:25 <frantisekz> ... -_- , it was pretty long since last blocker meeting, will leave it to somebody else for now :D
17:15:38 <kparal> I'll guide you
17:16:12 <adamw> #info gestalt entity consisting of kparal and frantisekz will secretarialize
17:16:24 <adamw> alrighty, moving onto the proposed Beta blockers
17:16:30 <adamw> #topic (1551096) anaconda fails to run on live images in current F28 / Rawhide
17:16:30 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1551096
17:16:30 <adamw> #info Proposed Blocker, anaconda, MODIFIED
17:16:48 <adamw> this ought to be fixed when the next compose completes sometime in 2067, but for now, i'd say it's an obvious blocker
17:16:55 <adamw> so, +1
17:17:03 <frantisekz> yep, surely +1
17:17:18 <kparal> +1
17:17:37 <Lailah> Hi
17:17:44 <satellit> +1
17:17:47 <Lailah> .fas Lailah
17:17:47 <zodbot> Lailah: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
17:17:48 <tflink> +1
17:17:58 <Lailah> Sorry that I'm so late
17:22:58 <adamw> sorry
17:23:02 * adamw got distracted again...
17:23:46 <adamw> proposed #agreed 1551096 - AcceptedBlocker (Beta) - this is an obvious violation of "The installer must run when launched normally from the release-blocking images"
17:23:52 <tflink> ack
17:23:55 <kparal> ack
17:23:56 <Lailah> ack
17:23:58 <adamw> Lailah: no problem
17:24:01 <adamw> #agreed 1551096 - AcceptedBlocker (Beta) - this is an obvious violation of "The installer must run when launched normally from the release-blocking images"
17:24:04 <satellit> ack
17:24:07 <adamw> #topic (1551664) Panel appears at top of screen, is very incomplete
17:24:07 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1551664
17:24:07 <adamw> #info Proposed Blocker, plasma-desktop, NEW
17:26:01 <tflink> assuming I understand correctly, +1
17:26:11 <Lailah> That looks very odd.
17:26:18 <kparal> +1
17:26:20 <frantisekz> +1
17:26:24 <Lailah> +1
17:27:00 <adamw> tflink: nothing much to understand, just see the screenshot :)
17:27:12 <adamw> kde should have a fairly 'normal' panel with launcher and stuff on it, it...doesn't
17:27:29 <tflink> ah, for some reason, I thought it was a bug about the one thing that shows up
17:27:51 <Lailah> Which thing?
17:28:06 <adamw> proposed #agreed 1551664 - AcceptedBlocker (Beta) - clear violation of "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional", as several intended default elements of the panel, including key ones like the app launcher, are missing or invisible
17:28:25 <kparal> ack
17:28:31 <satellit> ack
17:28:52 <tflink> ack
17:28:55 <frantisekz> ack
17:29:27 <tflink> Lailah: the "default" bit in the upper left hand corner
17:30:18 <Lailah> Well, it shouldn't be there. Not alone at least. I mean, usually there's more in the desktop than just a  "default".
17:30:27 <adamw> i mean, the bug is really about both
17:30:28 <Lailah> ack
17:30:39 <adamw> the weird thing that *is* there shouldn't be there, and the normal thing that isn't there *should* be there. :P
17:30:42 <adamw> #agreed 1551664 - AcceptedBlocker (Beta) - clear violation of "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional", as several intended default elements of the panel, including key ones like the app launcher, are missing or invisible
17:31:02 <adamw> #topic (1551653) Composes taking nearly a day and a half to complete
17:31:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1551653
17:31:03 <adamw> #info Proposed Blocker, pungi, NEW
17:31:36 <adamw> so this hits the rarely-used 'other reasons why things can block the release besides violating the criteria' text
17:31:49 <tflink> +1
17:31:51 <adamw> but i think it's a pretty solid case: i don't think we can reasonably achieve a release with a compose process that takes 32 hours.
17:32:03 <tflink> any idea what the cause is?
17:32:12 <adamw> i'm betting 'modularity'.
17:32:20 <adamw> but, we'll see. lsedlar is looking into it, apparently.
17:32:35 <adamw> i only found out about this when i woke up 90 minutes ago, so i'm playing catch-up here.
17:33:26 <nirik> It looks like it's when it's trying to multiarch the modular repo...
17:33:33 <nirik> but yeah, not sure. ;)
17:34:15 <kparal> +1
17:34:16 <Lailah> Give me a moment to read, please, I didn't see the messages
17:34:30 <frantisekz> +1
17:35:01 <Lailah> Okay, yes, +1
17:37:05 <adamw> proposed #agreed 1551653 - AcceptedBlocker (Beta) - this is considered to block the release on the basis that it "hinders execution of required Beta test plans or dramatically reduces test coverage", as per https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria#Beta_Blocker_Bugs
17:37:12 <frantisekz> ack
17:37:21 <tflink> ack
17:38:06 <kparal> ack
17:38:11 <adamw> #agreed 1551653 - AcceptedBlocker (Beta) - this is considered to block the release on the basis that it "hinders execution of required Beta test plans or dramatically reduces test coverage", as per https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria#Beta_Blocker_Bugs
17:38:12 <adamw> <frantisekz> ack
17:38:14 <adamw> heh
17:38:31 <frantisekz> :D
17:38:32 <adamw> #topic (1551677) FreeIPA server deployment fails with "This entry already exists" error
17:38:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1551677
17:38:32 <adamw> #info Proposed Blocker, freeipa, NEW
17:39:02 <adamw> so i just found this one this morning
17:39:16 <adamw> but looks pretty solidly like a blocker. this is about the fifth different reason for freeipa deployment to fail this cycle..
17:39:56 <kparal> +1
17:39:59 <tflink> +1
17:40:00 <Lailah> +1
17:40:01 <frantisekz> +1
17:41:56 <adamw> proposed #agreed 1551677 - AcceptedBlocker (Beta) - clear violation of "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried" for the domain controller role
17:42:06 <tflink> ack
17:42:15 <frantisekz> ack
17:42:27 <kparal> ack
17:43:29 <Lailah> ack
17:43:39 <adamw> #agreed 1551677 - AcceptedBlocker (Beta) - clear violation of "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried" for the domain controller role
17:43:47 <adamw> that's all the proposed blockers i have; anyone know of anything else we should consider?
17:44:52 <tflink> nothing I know of
17:45:29 <Lailah> I think I mentioned something in the mailing list, but I still don't know where to file the bug.
17:45:41 <adamw> Lailah: which bug was this again, sorry?
17:45:50 * adamw is trying to keep track of a lot...
17:46:11 <Lailah> In some HP laptops Fedora Workstation may boot but have no input, or not boot at all.
17:46:35 <Lailah> Spins work fine so far, at least the ones I tested.
17:46:52 <adamw> ah. i think that may have been a known issue - at least the 'no input' part
17:47:02 <adamw> Lailah: does https://bugzilla.redhat.com/show_bug.cgi?id=1547691 sound like the same thing?
17:47:03 <Lailah> Oh. I see.
17:47:14 <Lailah> Let me check...
17:47:14 <adamw> if so, it should be resolved in new composes, when we get one...
17:47:48 <Lailah> Not completely.
17:47:53 <kparal> adamw: switch topic?
17:48:17 <Lailah> I tried Workstation as live and not even the keyboard works, but no GDM because it was live.
17:48:41 <kparal> #topic Open Floor - HP issues
17:49:13 <adamw> thanks kparal
17:49:29 <Lailah> There's really no input at all.
17:49:45 <adamw> Lailah: hum, okay. can you try it with the next compose, when one finally completes, and if it's still a problem, file the bug against mutter (that's as good a guess as any) and propose it as a blocker?
17:49:50 <Lailah> Cursor doesn't move, whether is a mouse or a touchpad, and no keyboard
17:49:53 <adamw> if the component is wrong, don't worry, we'll figure that out and change it.
17:50:04 <adamw> well, either mutter or kernel. either is a reasonable guess.
17:50:08 <Lailah> Okay, sure. I'll do so adamw.
17:50:12 <adamw> thanks a lot
17:50:28 <Lailah> But the spins have the same kernel, isn't it?
17:50:32 <Lailah> Spins work well.
17:51:02 <frantisekz> mutter is it then probably
17:51:13 <Lailah> I installed KDE and XFCE without an issue. And I know someone who couldn't boot Workstation but installed Mate.
17:51:43 <adamw> ah, yeah. then yes, go with mutter.
17:51:45 * satellit tried everthing netinstall?
17:56:40 <kparal> am I lagging or is nothing happening? :)
17:57:29 <Lailah> I was wondering the same
17:57:40 <adamw> sorry, me being distracted again
17:57:47 <adamw> i was looking through the accepted blockers to see if we needed to discuss any
17:58:16 <adamw> i think not really, maybe just it'd be good if someone can confirm whether https://bugzilla.redhat.com/show_bug.cgi?id=1524700 is still an issue
17:58:27 <adamw> and we should re-test https://bugzilla.redhat.com/show_bug.cgi?id=1530428
17:58:54 <kparal> #topic Open Floor
17:59:32 <Lailah> I don't know those bugs adamw , I can't tell.
18:01:00 <satellit> any fix in sight for https://bugzilla.redhat.com/show_bug.cgi?id=1524700  instal from fmw usb to external usb HD ?
18:02:21 <adamw> satellit: that's one i just mentioned, it'd be good to confirm if it's still happening
18:02:28 <adamw> satellit: is it still happening on recent composes?
18:02:42 <satellit> ok will test for it.....
18:03:17 <satellit> next compose of lives
18:03:54 <Lailah> Okay
18:04:53 <adamw> thanks
18:05:04 <adamw> assuming it's still happening, i don't know any more about a fix than is written in the bug :(
18:05:11 <adamw> but it's a blocker, so it's gonna have to get fixed
18:05:32 <adamw> #info of the accepted blockers, it'd be good to re-test #1524700 and #1530428 with recent composes
18:05:39 <adamw> ok, so i think that's all
18:05:42 <adamw> anything else?
18:07:51 <Lailah> Not that I know of.
18:08:53 <adamw> alrighty then
18:08:57 <adamw> thanks for coming, everyone
18:08:58 * adamw sets fuse
18:09:17 <frantisekz> thanks for leading the meeting adamw
18:09:31 <kparal> frantisekz: thanks for secretarializing. you see, no reason to be shy
18:09:38 <frantisekz> I hopefully filled everything fine to the bugzillas :D
18:09:50 <kparal> you can do it again next time, to get some practice
18:10:06 <Lailah> I agree
18:10:29 * adamw will check it was correct
18:10:32 <adamw> thanks again!
18:10:36 <adamw> #endmeeting