16:01:32 <adamw> #startmeeting F28-blocker-review
16:01:32 <zodbot> Meeting started Mon Mar 12 16:01:32 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:32 <zodbot> The meeting name has been set to 'f28-blocker-review'
16:01:32 <adamw> #meetingname F28-blocker-review
16:01:32 <adamw> #topic Roll Call
16:01:32 <zodbot> The meeting name has been set to 'f28-blocker-review'
16:01:36 <adamw> .fire mboddu
16:01:36 <zodbot> adamw fires mboddu
16:01:51 <adamw> morning folks, who's around for the meeting? except mboddu. obvs. :P
16:01:52 * pwhalen is here
16:01:59 * satellit listening
16:02:00 * lruzicka is here
16:02:02 * suprith4989 is here
16:02:09 * puiterwijk is here for once
16:02:16 * lbrabec is here
16:02:36 <roca> hello
16:02:42 * kparal is here
16:02:47 * kalev is here
16:02:52 <frantisekz> .hello2
16:02:53 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:03:00 * kparal waves at lbrabec
16:03:15 * coremodule is here! Willing to secretarialize as well.
16:03:21 <roca> .hello2
16:03:22 <zodbot> roca: roca 'Luis Roca' <luisroca@protonmail.com>
16:04:11 <adamw> thanks for coming, everyone
16:04:26 <adamw> #chair pwhalen kparal
16:04:26 <zodbot> Current chairs: adamw kparal pwhalen
16:04:40 <adamw> impending boilerplate alert!
16:04:40 <adamw> #topic Introduction
16:04:41 <adamw> Why are we here?
16:04:41 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:04:41 <adamw> #info We'll be following the process outlined at:
16:04:41 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:04:43 <adamw> #info The bugs up for review today are available at:
16:04:45 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:04:47 <adamw> #info The criteria for release blocking bugs can be found at:
16:04:49 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:04:51 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria
16:04:53 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria
16:04:55 <adamw> #info coremodule will secretarialize
16:04:57 <adamw> thanks coremodule
16:05:08 <coremodule> no problem!
16:05:56 <adamw> for Beta, we have:
16:05:57 <adamw> #info 4 Proposed Blockers
16:05:57 <adamw> #info 6 Accepted Blockers
16:06:00 <adamw> #info 9 Proposed Freeze Exceptions
16:06:01 <adamw> #info 1 Accepted Freeze Exceptions
16:06:10 <kparal> coremodule: if you need some refresher how to update a particular bug, just PM me
16:09:03 * pwhalen just ninja'd another blocker in
16:09:12 <adamw> starting with the proposed blockers...
16:09:13 * sumantro is here
16:09:17 <adamw> pwhalen: ok, remind me at the end if i don't do it
16:09:18 <adamw> #topic (1553488) 'KickstartSpecificationHandler' object has no attribute 'UserData'
16:09:19 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1553488
16:09:19 <adamw> #info Proposed Blocker, anaconda, POST
16:09:24 * adamw will brb, call of nature
16:09:28 <pwhalen> adamw, will do
16:09:40 <pwhalen> +1
16:09:49 <coremodule> kparal, will do!
16:10:48 <kparal> +1 per criterion in comment 8
16:11:03 <kalev> +1
16:11:04 <sumantro> +1
16:11:18 <frantisekz> +1
16:11:20 <lbrabec> +1
16:12:02 <lruzicka> Isn't the bug resolved already as per comment 10?
16:12:07 <lruzicka> otherwise +1
16:12:30 <puiterwijk> Well, without an accepted blocker, it won't go into the compose
16:12:32 <puiterwijk> So +1
16:12:35 <satellit> +1
16:13:08 <kparal> lruzicka: a new build is not created yet, it seems. and it needs a to be pushed into the compose, which needs either a blocker or a freeze exception, as puiterwijk says
16:13:42 <kparal> fixing this just in source code is of course not enough
16:13:47 <lruzicka> kparal: Thanks, kparal, in that case a blocker of course.
16:14:12 <lruzicka> kparal: Now, I start to understand a bit :D
16:14:58 * mboddu is here now
16:15:39 <adamw> proposed #agreed 1553488 - AcceptedBlocker (Beta) - clearly violates "The scripted installation mechanism must provide a working function for creating local user accounts, including the ability to specify a hashed password, and for specifying a hashed password for the root account."
16:15:49 <kparal> ack
16:15:52 <sumantro> ack
16:15:53 <lbrabec> ack
16:15:56 <frantisekz> ack
16:15:57 <satellit> ack
16:16:27 <adamw> lruzicka: once the fix is committed to upstream anaconda git, we still need a release from upstream, then a package build, then - when bodhi is enabled for the affected branch - an update submitted. when freeze is in effect, the update can only be pushed stable if there is an accepted FE or blocker bug.
16:16:31 <adamw> #agreed 1553488 - AcceptedBlocker (Beta) - clearly violates "The scripted installation mechanism must provide a working function for creating local user accounts, including the ability to specify a hashed password, and for specifying a hashed password for the root account."
16:16:48 <adamw> #topic (1553792) Gnome Software doesn't offer upgrade from F26 to F28
16:16:48 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1553792
16:16:48 <adamw> #info Proposed Blocker, gnome-software, NEW
16:17:11 <adamw> has anyone else confirmed this? does sound like a blocker as described.
16:17:34 * kalev hasn't checked it.
16:17:42 <kparal> adamw: why not?
16:18:10 <kparal> I haven't checked it either
16:18:13 <adamw> i said 'does'
16:18:25 * lruzicka has not either.
16:18:29 * satellit related: gnome-software was not in branched workstation as  of Fedora-Workstation-Live-x86_64-28-20180309.n.0.iso
16:18:34 <kparal> adamw: my eyes betrayed me
16:18:43 <adamw> .fire kparal's eyes
16:18:43 <zodbot> adamw fires kparal's eyes
16:18:53 <lruzicka> satellit: Now, it is in 20180310.n.0
16:18:58 * kparal imagines what everybody else says
16:19:02 <satellit> +1
16:19:10 <kparal> +1 per criterion
16:19:12 <sumantro> +1
16:19:15 <lruzicka> +1
16:19:15 <frantisekz> +1
16:19:16 * satellit not tested
16:19:18 <lbrabec> +1
16:19:23 <kalev> +1
16:19:27 <pwhalen> +1
16:19:46 <lruzicka> I can test it tomorrow
16:20:18 <adamw> satellit: that was another bug (one we're coming to in a minute, in fact)
16:20:30 <satellit> k
16:21:21 <adamw> proposed #agreed 1553792 - AcceptedBlocker (Beta) - seems like a clear violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed" for Workstation (where Software is the recommended upgrade mechanism), would be good if others could confirm
16:21:26 <frantisekz> ack
16:21:27 <mboddu> ack
16:21:30 <lbrabec> ack
16:21:36 <pwhalen> ack
16:21:42 <coremodule> ack
16:21:47 <satellit> ack
16:22:04 <kparal> ack
16:22:06 <lruzicka> ack
16:22:10 <adamw> #agreed 1553792 - AcceptedBlocker (Beta) - seems like a clear violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed" for Workstation (where Software is the recommended upgrade mechanism), would be good if others could confirm
16:22:22 <adamw> #topic (1553646) Upgrading F27 > F28 is not possible because of nss-pem
16:22:23 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1553646
16:22:23 <adamw> #info Proposed Blocker, nss-pem, MODIFIED
16:23:54 <frantisekz> this doesn't happen with default package set I think
16:24:18 <kparal> nss-pem.i686 is most probably not installed by default
16:24:26 <frantisekz> so, +1 FE?
16:24:31 <kparal> so while this probably affects many people, not a default install
16:24:38 <adamw> yeah, -1 blocker +1 FE then.
16:24:43 <puiterwijk> Well...
16:24:48 <puiterwijk> It's even installed in the docker minimal root
16:24:55 <adamw> is it? hum.
16:25:03 <adamw> um
16:25:07 <adamw> the *i686* one is?
16:25:08 <puiterwijk> ^[[A[puiterwijk@workstation ~]$ docker run --rm -it fedora:27 /bin/rpm -q nss-pem
16:25:10 <puiterwijk> nss-pem-1.0.3-5.fc27.x86_64
16:25:12 <puiterwijk> OH, no.
16:25:15 <adamw> this only affects x86_64 installs with i686 installed, i think.
16:25:15 <puiterwijk> the x86_64 one is
16:25:16 <frantisekz> the issue is with i686 on x86_64
16:25:25 <puiterwijk> Right, sorry
16:25:31 <adamw> also, wouldn't --allowerasing work here, and just remove it?
16:25:45 <frantisekz> it'll also remove affected packages
16:25:49 <frantisekz> so, wine for example
16:25:52 <adamw> are you sure?
16:26:02 <adamw> i thought the whole reason this was a problem was that wine didn't require it any more
16:26:02 <frantisekz> 99.99% sure :D
16:26:12 <adamw> if it did, wouldn't it be multilib automatically?
16:26:17 <kalev> iirc gnome-software upgrade passes --allowerasing to the depsolver by default
16:26:32 <kparal> I'm also confused by wine being uninstalled
16:26:32 <adamw> yeah, which i'm not a huge fan of, because it could result in a drastically broken system in some cases, but hey
16:27:00 <kalev> it reports the packages it's going to remove, at least
16:27:14 <adamw> (when you tell dnf 'allow erasing', it really takes it seriously, and will happily perform any 'upgrade' which does not involve erasing a protected package...not many packages are protected...)
16:27:15 <lruzicka> Well, I have just checked and I have wine NOT installed.
16:27:18 <adamw> anyhoo
16:27:29 <adamw> that's kind of a sideline, I'm -1 blocker / +1 fe regardless
16:27:34 <kparal> -1/+1
16:27:41 <frantisekz> -1 blocker, +1 FE
16:27:46 <lruzicka> Although I did have it, and used --allowerasing to be able to upgrade
16:27:56 <puiterwijk> So, I just checked. And the nss that's now in f27 does not require nss-pem
16:28:00 <mboddu> -1 Blocker/+1 FE
16:28:02 <lruzicka> -1/+1
16:28:06 <pwhalen> -1 blocker / +1 fe
16:28:09 <lbrabec> -1 blocker, +1 FE
16:28:16 <puiterwijk> So I think --allowerasing should be able to correctly remove nss-pem without erasing nss.i686 (and thus wine)
16:28:19 <sumantro> -1 blocker/+1 FE
16:28:22 <kalev> -1 blocker, +1 FE
16:28:55 <adamw> proposed #agreed 1553646 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not affect any default package sets so far as we know, so not a blocker, but is likely to affect many folks with wine installed, so we think it's worth a freeze exception
16:29:01 <frantisekz> ack
16:29:03 <kalev> ack
16:29:10 <lruzicka> ack
16:29:13 <kparal> frantisekz: please verify wine during upgrade, thanks
16:29:30 <adamw> puiterwijk: the important thing would actually be whether the nss in *f28 stable* requires it, i think.
16:29:51 <frantisekz> kparal: ack
16:30:03 <adamw> #agreed 1553646 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not affect any default package sets so far as we know, so not a blocker, but is likely to affect many folks with wine installed, so we think it's worth a freeze exception
16:30:03 <puiterwijk> adamw: right. And that, they said, is no longer the case
16:30:13 <adamw> #topic (1552910) Upgrading F27 > F28 is not possible because of shim
16:30:13 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552910
16:30:13 <adamw> #info Proposed Blocker, shim, MODIFIED
16:30:23 <adamw> so...this is interesting. this is the bug i thought was stopping gnome-software from being in composes
16:30:52 <kalev> me too
16:30:56 <coremodule> ahhh... that bug.
16:31:10 <kparal> +1
16:31:18 <lruzicka> Gnome software is in the last compose, though.
16:31:22 <lruzicka> I can confirm.
16:31:36 <adamw> it's in the last two composes
16:31:39 <kalev> huh, weird
16:31:42 <adamw> right?
16:32:11 <lruzicka> adamw: I only tested the last one :) but, as you are saying :)
16:32:17 <adamw> seems we have shim-ia32, shim-unsigned (a really old version of that), shim-unsigned-ia32 and shim-unsigned-x64 in the composes also
16:32:25 <pwhalen> last week we had a tagging issue, an older build got tagged in f28
16:32:29 <adamw> shim-ia32-13-1.x86_64.rpm
16:32:33 <adamw> ah, that could explain it
16:32:38 <adamw> shim-unsigned-0.8-1.fc22.x86_64.rpm
16:32:42 <adamw> (that really shouldn't be there, i don't think)
16:32:46 <adamw> shim-unsigned-ia32-13-0.2.fc28.x86_64.rpm
16:32:50 <adamw> shim-unsigned-x64-13-0.2.fc28.x86_64.rpm
16:33:15 <frantisekz> just checked the upgrade
16:33:20 <frantisekz> and it looks like it's fixed
16:33:26 <adamw> shim-ia32 would be from https://koji.fedoraproject.org/koji/buildinfo?buildID=1051707
16:33:35 <adamw> the others are from https://koji.fedoraproject.org/koji/buildinfo?buildID=1041248
16:33:58 <frantisekz> running "sudo dnf system-upgrade download --refresh --releasever=28 --disablerepo=updates-testing" doesn't want to remove gnome-software anymore
16:34:12 <adamw> per openqa, uefi installs work
16:34:14 <adamw> (not sure about secure boot)
16:34:42 <adamw> let me see if there's a pjones around
16:35:23 <adamw> see if there are any potential blocker/fe consequences of having those builds of shim bits
16:36:31 <adamw> if he's not around, i suggest we leave this proposed for now, post an update, i'll follow up with pjones and we can come back to it next time
16:37:25 <kparal> sounds good
16:38:35 <adamw> welp, not getting a response from planet pjones, so...
16:39:01 <puiterwijk> adamw: random idea: would you be interested in working together on testing secureboot in openqa? I've recently written some utilities to be able to do that quite easily
16:39:31 <puiterwijk> (I'll actually bring that up in #-qa after the meeting)
16:39:48 <adamw> proposed #agreed 1552910 - punt (delay decision) - seems a tagging error has been fixed and current composes get a random selection of shim packages that at least doesn't block gnome-software; we will follow up with pjones to see if there are any other problems here and then make a decision
16:39:53 <mboddu> ack
16:39:58 <frantisekz> ack
16:40:00 <puiterwijk> ack
16:40:02 <kparal> ack
16:40:03 <satellit> ack
16:40:03 <pwhalen> ack
16:40:18 <lruzicka> ack
16:40:18 <sumantro> ack
16:40:22 <coremodule> ack
16:40:38 <lbrabec> ack
16:40:43 <adamw> #agreed 1552910 - punt (delay decision) - seems a tagging error has been fixed and current composes get a random selection of shim packages that at least doesn't block gnome-software; we will follow up with pjones to see if there are any other problems here and then make a decision
16:41:08 <adamw> #topic (1552130) Intermittent boot issues on the rpi3 with uboot-tools-2018.03-0.8.rc3
16:41:09 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552130
16:41:09 <adamw> #info Proposed Blocker, uboot-tools, ON_QA
16:41:16 <adamw> this is the one you ninja-ed, right pwhalen?
16:42:15 <pwhalen> yes
16:42:42 <pwhalen> it should be fixed with the latest uboot, but I havent confirmed it yet
16:43:03 <mboddu> adamw: Is this a release blocking criteria?
16:44:09 <puiterwijk> mboddu: per https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi#Supported_Hardware, RPi3 is a supported ARM board
16:44:49 <lruzicka> Would that block x86_64 architecture, too?
16:45:01 <puiterwijk> No, but armhfp is a primary architecture.
16:45:09 <adamw> right.
16:45:10 <kparal> seems to violate criteria requiring the system to boot without intervention
16:45:25 <adamw> 'intermittent' makes it a bit of a judgment call
16:45:27 <puiterwijk> Yeah, what kparal said. I was just looking through the criteria
16:45:36 <kparal> pwhalen: how often does it happen?
16:46:29 <pwhalen> kparal, pretty regular
16:46:48 <pwhalen> we have a tester for the latest nightly, who hit it (and has hit it before)
16:46:50 <mboddu> puiterwijk: Okay, I didn't know we have to support each and every board as part of armhfp being primary arch
16:47:12 <puiterwijk> mboddu: we don't support every board. We support the ones the ARM WG(?) deems supported
16:47:27 <puiterwijk> https://fedoraproject.org/wiki/Architectures/ARM#Supported_Hardware_and_Devices
16:47:32 <kparal> https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms
16:47:37 <kparal> damn
16:47:52 <puiterwijk> Oh, or the one from kparal. That looks more concrete
16:48:11 <pwhalen> looks like I need to update that for f28
16:48:11 <mboddu> puiterwijk: Yes, by each and every board I meant the supported boards listed on the wiki
16:48:30 <pwhalen> rpi3 is pretty popular, and also used for aarch64.
16:48:31 <puiterwijk> mboddu: if it's listed under "Supported platforms", then yes, that's supported
16:48:41 <adamw> kparal's is the correct link.
16:48:46 <puiterwijk> Yeah
16:48:56 <mboddu> Anyway, we got an updated uboot that needs to be tested
16:49:05 <adamw> i think that list is supposed to be signed off on by fesco per cycle, or something. Some kinda bureaucracy, anyway!
16:49:16 <pwhalen> and reported to fix this as well, just not confirmed myself
16:49:20 <adamw> so, assuming we're going with the f27 list for now, +1 blocker.
16:49:33 <puiterwijk> Yeah, +1 blocker if it happens often
16:49:36 <frantisekz> +1
16:49:46 <mboddu> Yeah, +1 blocker
16:50:24 <sumantro> +1 blocker
16:50:32 <lruzicka> +1
16:51:33 <kalev> +1
16:51:44 <roca> +1
16:52:39 <adamw> just writing a justification here
16:52:45 <kparal> +1
16:56:17 <adamw> proposed #agreed 1552130 - AcceptedBlocker (Beta) - this is accepted as a violation of "All release-blocking images must boot in their supported configurations" for the release-blocking ARM minimal and Xfce disk images, on Raspberry Pi 3, which is a supported ARM platform per https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms
16:56:20 <adamw> sorry
16:56:30 <coremodule> ack
16:56:30 <frantisekz> ack
16:57:02 <kalev> ack
16:57:03 <kparal> ack
16:57:07 <lbrabec> ack
16:57:20 <lruzicka> ack
16:57:24 <pwhalen> ack
16:57:26 <satellit> ack
16:57:43 <sumantro> ack
16:58:57 <roca> ack
17:00:12 <adamw> #agreed 1552130 - AcceptedBlocker (Beta) - this is accepted as a violation of "All release-blocking images must boot in their supported configurations" for the release-blocking ARM minimal and Xfce disk images, on Raspberry Pi 3, which is a supported ARM platform per https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms
17:00:28 <adamw> pjones: thanks, sorry i gave you the wrong channel name earlier - i'll follow up with you in a bit
17:00:46 <adamw> #info moving onto the proposed freeze exceptions
17:02:25 * satellit afk
17:02:29 <adamw> #topic (1418336) Anaconda won't accept /boot on btrfs subvol, installation is impossible on my machine
17:02:29 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1418336
17:02:29 <adamw> #info Proposed Freeze Exceptions, anaconda, NEW
17:02:52 <adamw> so, basically, npmccallum wrote some patches to let /boot on btrfs-subvolume actually work, and would like us to put it into beta
17:03:05 <adamw> he claims it's all tested and won't break anything else
17:03:53 <frantisekz> what could it break.... :D
17:04:07 <kparal> "I have tested this configuration manually, but for broader testing it is crucial we land in beta."
17:04:21 <kparal> I see his point
17:05:04 <kparal> I guess I'm more in favor
17:06:19 <adamw> i'm kinda split, bootloader stuff is *weird* and i wish we'd got this in earlier. but it is something people have been asking for forever.
17:06:37 <adamw> i guess i'm reluctantly willing to give it a +1.
17:06:41 <Kellin> note - the change to grubby is not yet merged either, so thisis double blocked
17:06:45 <Kellin> https://github.com/rhboot/grubby/pull/32
17:07:25 <Kellin> that needs review/testing as well because kernel updates use grubby invoked from the post-install scriplets to update for the new kernel versions
17:07:59 <lruzicka> what is the procedure? will the freeze be lifted after beta and this could sneak in, or will it have to wait until post Final Release update?
17:08:12 <Kellin> imho it should be in rawhide and scheduled for F29
17:08:48 <lruzicka> Or ... it can be the very first update of F28 final release?
17:09:17 <pjones> that patch is in https://bodhi.fedoraproject.org/updates/FEDORA-2018-c0e98e4635
17:09:17 <adamw> Kellin: i'm treating the bug as covering all related packages.
17:09:34 <adamw> lruzicka: we are debating right now whether to put it in beta.
17:09:41 <Kellin> adamw: my vote is the same, it should be placed in rawhide and scheduled to F29; not beta
17:09:49 <adamw> if we don't put it in beta, it's up to the maintainers of the relevant packages whether they land it between beta release and the final freeze.
17:10:15 <lruzicka> adamw: I understand. I am asking if, when it does not make it to beta, there is an option to have in Fedora 28. I guess not?
17:10:18 <adamw> lruzicka: shipping it as an update for f28 would not make an awful lot of sense as it's partly an *installer* change
17:10:31 <adamw> the installer is basically frozen when we release (ignoring the semi-official post-release live image respins)
17:10:45 <adamw> lruzicka: it could theoretically be put in between beta and final.
17:10:47 <lruzicka> adamw: Yeah, of course :)
17:10:59 <lruzicka> adamw: Thats what I meant, too.
17:11:00 <adamw> that'd arguably be against some update policies, but it's not like people haven't done that sort of thing before. :P
17:11:09 <roca> Why has this not been addressed in previous releases? Is there something missing that''s creating a conflict?
17:11:10 <adamw> nat would prefer it go into beta if we want it to be in f28, though, as it will get more testing that way.
17:11:25 <adamw> roca: grubby didn't know how to work with btrfs subvolumes.
17:11:39 <adamw> the thing that changed is someone taught grubby to do that.
17:11:40 * pjones has no opinion on the anaconda bit, but the grubby bit is separable from that and already requested for stable.
17:12:01 <adamw> requested, sure, but it won't be pushed unless we accept this as FE
17:12:04 <roca> understood
17:12:08 <adamw> pjones: do you think the grubby changes are fairly safe?
17:12:10 <lruzicka> I am in, because it is always nice to have better functionality.
17:12:44 <lruzicka> if it works, of course
17:12:44 <pjones> adamw: I do; there's not many cases they actually effect, and npmccallum wrote a pile of test cases for it
17:12:51 <adamw> awww, they're so innocent when they're new
17:12:57 <adamw> i like that.
17:13:01 <lruzicka> adamw: :)
17:13:13 <adamw> lruzicka: give it six months and you too will own a t-shirt with "NO" written on it. :P
17:13:28 <roca> :)
17:13:40 <lruzicka> adamw: :) Therefore I do not push for anything :)
17:13:45 <Kellin> lruzicka: and after 2 years, you get it tattoo'd :op
17:13:53 <lruzicka> :D
17:14:12 <pjones> adamw: you know you're just going to find something else you want in grubby and we'll get it anyway ;)
17:14:12 * nirik has a related question.. does this stuff have anything to do with moving to the BLS in systemd? or thats completely seperate?
17:14:13 * mkolman still remembers the uefi32 fallout in F27
17:14:18 <mboddu> adamw: quick question, the patch is not merged upstream, so what happens if we ship in beta and the patch gets rejected upstream?
17:14:32 <adamw> nirik: i believe it's separate, but imbw.
17:14:49 <adamw> pjones: are you grubby upstream?
17:14:50 <pjones> nirik: that's completely separate
17:14:55 <pjones> adamw: sadly yes
17:15:01 <adamw> pjones: are you going to reject the patch?
17:15:07 <pjones> no.
17:15:11 <adamw> mboddu: ^^ solved. :P
17:15:25 <pjones> (the patch is merged upstream.)
17:15:35 * mboddu didn't know pjones is the maintainer until now :D
17:15:38 <adamw> so, votes?
17:15:41 <Kellin> where is grubby upstream today if not https://github.com/rhboot/grubby ?
17:15:51 <pjones> That's where it is.
17:16:09 <Kellin> https://github.com/rhboot/grubby/pull/32 needs marked as merged then - that's the source of mboddu's confusion
17:16:17 <pjones> ... it is.
17:16:29 <mboddu> Kellin: pjones just merged it
17:16:37 <adamw> sneaky.
17:16:58 <pjones> I mean, I told you.
17:16:59 <frantisekz> I see pushed to master, so +1 :)
17:17:36 <sumantro> +1
17:17:41 <lruzicka> frantisekz: Are we going the risky side then?
17:17:44 <lruzicka> +1
17:17:46 <roca> +1
17:18:09 <frantisekz> lruzicka: looks like so
17:18:15 <kparal> +1 fe
17:19:07 <pwhalen> +1 fe
17:19:09 <adamw> proposed #agreed 1418336 - AcceptedFreezeException (Beta) - we're a bit unhappy about touching bootloader stuff during a chaotic freeze, but this is a feature people have been asking for for a long time that'd add significant value to F28, and if we want it in, we'd better test it in Beta
17:19:25 <frantisekz> ack
17:19:27 <lbrabec> ack
17:19:29 <roca> ack
17:19:32 <sumantro> ack
17:20:13 <coremodule> ack
17:20:14 <adamw> #agreed 1418336 - AcceptedFreezeException (Beta) - we're a bit unhappy about touching bootloader stuff during a chaotic freeze, but this is a feature people have been asking for for a long time that'd add significant value to F28, and if we want it in, we'd better test it in Beta
17:20:30 * mboddu is a bit worried about non x86 arches, but ehhh
17:21:28 <lruzicka> ack
17:21:36 <lruzicka> sorry about the delay
17:21:48 <adamw> #topic (1553935) Installer auto-quits after Workstation live install (as no spokes are on the install hub)
17:21:49 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1553935
17:21:49 <adamw> #info Proposed Freeze Exceptions, anaconda, NEW
17:23:37 <adamw> so yeah, if you haven't done a Workstation live install lately, try one, it's fun. :P
17:24:06 <kparal> we tried today twice on two different bare metals, crashed every time on startup
17:24:17 <kparal> so, not that much fun
17:24:26 <adamw> with which compose?
17:24:33 <lruzicka> the latest one
17:24:37 <adamw> huh.
17:24:39 <adamw> what crash?
17:24:50 <lruzicka> frantisekz: ^
17:24:51 <coremodule> hmmm
17:24:55 <kparal> adamw: bug 1524700
17:25:00 <adamw> oh, usb, right.
17:25:02 <adamw> use a shiny disc!
17:25:07 <adamw> (or use the updates image)
17:25:07 <kparal> haha
17:25:15 <kparal> anyway, +1 FE here
17:25:20 <mboddu> .bug 1524700
17:25:23 <zodbot> mboddu: Bug 1524700 – AttributeError: 'NoneType' object has no attribute 'name' - https://bugzilla.redhat.com/1524700
17:25:26 <kparal> I'd even vote +1 Final
17:25:27 <lruzicka> kparal: Do we have a burner? Maybe we should try the disk.
17:25:44 <lruzicka> +1
17:26:36 <adamw> should be an anaconda that fixes 1524700 today, btw.
17:26:42 <coremodule> whoa! +1 FE
17:27:04 <mkolman> adamw: https://koji.fedoraproject.org/koji/taskinfo?taskID=25662380
17:27:21 <adamw> mkolman: yay
17:28:04 <adamw> proposed #agreed 1553935 - AcceptedFreezeException (Beta) - this could clearly confuse/concern users installing Workstation live in the Beta, and cannot be fixed with an update
17:28:16 <frantisekz> ack
17:28:20 <coremodule> ack
17:28:21 <lruzicka> ack
17:28:30 <kparal> ack
17:28:48 <roca> ack
17:29:44 <sumantro> ack
17:29:50 <coremodule> ack
17:29:57 <lbrabec> ack
17:30:32 <adamw> #agreed 1553935 - AcceptedFreezeException (Beta) - this could clearly confuse/concern users installing Workstation live in the Beta, and cannot be fixed with an update
17:30:44 <adamw> #topic (1552045) Include bolt 0.2 release
17:30:44 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552045
17:30:44 <adamw> #info Proposed Freeze Exceptions, bolt, MODIFIED
17:31:40 <pwhalen> +1 FE
17:31:41 <frantisekz> +1 FE
17:31:42 <kparal> +1 fe
17:32:00 <lbrabec> +1 fe
17:32:17 <mboddu> +1 FE
17:32:19 <roca> +1 fe
17:32:28 <sumantro> +1fe
17:32:33 <lruzicka> +1 fe
17:33:40 <adamw> proposed #agreed 1552045 - AcceptedFreezeException (Beta) - this is part of an accepted Change for F28, it'd be good to have it in Beta for testing, and it should not endanger any release-blocking path
17:33:43 <adamw> (the 's' word, i know)
17:34:22 <coremodule> *should* ---> there's always hope!
17:34:32 <pjones> (yeah, you're really not using that in an rfc2119-compatible way.
17:34:32 <pjones> )
17:34:35 <kparal> ack
17:34:37 <coremodule> ack
17:34:38 <lruzicka> hope dies last
17:34:40 <lruzicka> ack
17:34:46 <roca> ack
17:34:48 <lbrabec> ack
17:35:01 <pwhalen> ack
17:35:23 <adamw> #agreed 1552045 - AcceptedFreezeException (Beta) - this is part of an accepted Change for F28, it'd be good to have it in Beta for testing, and it should not endanger any release-blocking path
17:35:25 <mboddu> akc
17:35:35 <mboddu> Late and miss typed :D
17:35:40 <adamw> #topic (1552814) Need builds for F28 and F29 that reflect the Modularity changes
17:35:41 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552814
17:35:41 <adamw> #info Proposed Freeze Exceptions, fedora-repos, ASSIGNED
17:36:23 <adamw> so far as actually enabling modularity goes this is a blocker, but so far as the criteria go i don't think it is.
17:36:26 <mboddu> adamw: We did build them, but sgallagh is planning on changing them and once he sends out the PR, I will review - merge- build them
17:36:31 <adamw> yep.
17:36:53 <puiterwijk> +1 FE
17:37:01 <mboddu> +1 FE
17:37:17 <pwhalen> +1 FE
17:37:20 <frantisekz> +1 FE
17:37:21 <lruzicka> +1
17:37:23 <roca> +1 FE
17:37:45 <sumantro> +1 FE
17:38:31 <sgallagh> mboddu: The PR was sent an hour ago. A review would be awesome :)
17:42:00 <mboddu> sgallagh: Ahh, sorry, I will take a look at it now
17:43:00 <adamw> proposed #agreed 1552814 - AcceptedFreezeException (Beta) - the new files are necessary for Modularity enablement, which is a major Change for Fedora 28 and definitely needs to land in Beta
17:43:07 <sgallagh> mboddu: Looks like Dennis did while I was at lunch; I'm updating my patch with his comment.
17:43:35 <frantisekz> ack
17:44:03 <mboddu> ac
17:44:05 <sumantro> ack
17:44:06 <mboddu> ack
17:44:06 <roca> ack
17:44:07 <lruzicka> ack
17:44:09 <lbrabec> ack
17:44:15 <mboddu> sgallagh: Okay
17:44:24 <sgallagh> mboddu: Updated :)
17:44:28 <adamw> #agreed 1552814 - AcceptedFreezeException (Beta) - the new files are necessary for Modularity enablement, which is a major Change for Fedora 28 and definitely needs to land in Beta
17:44:39 <adamw> #topic (1552923) Revert inadvertently bumped soname
17:44:39 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552923
17:44:39 <adamw> #info Proposed Freeze Exceptions, ghc-conduit-extra, ON_QA
17:46:46 <lruzicka> +1 FE
17:47:14 <sumantro> +1 FE
17:47:19 <frantisekz> +1 FE
17:47:30 <roca> +1 FE
17:47:30 <pwhalen> +1 FE
17:48:27 <adamw> proposed #agreed 1552923 - AcceptedFreezeException (Beta) - it would be good to get these dependencies in line for the Beta, it may affect the compose of some images
17:48:47 <roca> ack
17:49:07 <pwhalen> ack
17:49:11 <frantisekz> ack
17:49:15 <lruzicka> ack
17:49:15 <sumantro> ack
17:52:15 <adamw> #agreed 1552923 - AcceptedFreezeException (Beta) - it would be good to get these dependencies in line for the Beta, it may affect the compose of some images
17:52:23 <adamw> #topic (1094489) add support for btrfs in grub2 on /boot
17:52:23 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1094489
17:52:23 <adamw> #info Proposed Freeze Exceptions, grubby, ON_QA
17:52:36 <adamw> oh, so we do have a grubby bug for the same thing
17:52:42 <adamw> so, i say +1 on the same basis as the earlier bug.
17:52:47 <frantisekz> +1
17:52:56 <roca> +1
17:52:58 <lruzicka> +1
17:53:09 <lruzicka> we cannot act differently
17:53:10 <Kellin> -1
17:53:12 <kparal> +1
17:53:20 <Kellin> (mostly because I didn't respond fast enough on last one)
17:53:32 <sumantro> +1
17:54:16 <adamw> proposed #agreed 1094489 - AcceptedFreezeException (Beta) - this part of the same feature enablement as 1418336, so our decision is the same
17:54:46 <frantisekz> ack
17:54:47 <kparal> ack
17:54:53 <sumantro> ack
17:55:31 <lruzicka> ack
17:55:41 <adamw> #agreed 1094489 - AcceptedFreezeException (Beta) - this part of the same feature enablement as 1418336, so our decision is the same
17:55:54 <adamw> #topic (1552913) Several packages still need rebuilds against OpenCV 3.4
17:55:55 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552913
17:55:55 <adamw> #info Proposed Freeze Exceptions, opencv, ON_QA
17:57:15 <kparal> +1 fe
17:57:22 <adamw> lots o' rebuilds
17:57:26 <adamw> rebuilds are my life
17:57:29 <adamw> (there's another one coming up later)
17:57:53 <frantisekz> +1
17:58:15 <roca> +1 fe
17:58:15 <lruzicka> +1 without it, the thing stays incomplete
17:58:43 <sumantro> +1 fe
17:58:58 <pwhalen> +1 fe
18:00:15 <adamw> proposed #agreed 1552913 - AcceptedFreezeException (Beta) - again, fixing up dependencies is a good thing to do for the compose, can avoid packages missing from composes and fix upgrade issues
18:00:36 <lruzicka> ack
18:00:37 <sumantro> ack
18:00:43 <frantisekz> ack
18:00:48 <pwhalen> ack
18:01:08 <lbrabec> ack
18:01:46 <roca> ack
18:02:22 <adamw> #agreed 1552913 - AcceptedFreezeException (Beta) - again, fixing up dependencies is a good thing to do for the compose, can avoid packages missing from composes and fix upgrade issues
18:02:32 <adamw> #topic (1549686) Review Request: f28-backgrounds - Fedora 28 default desktop background
18:02:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1549686
18:02:32 <adamw> #info Proposed Freeze Exceptions, Package Review, ON_QA
18:02:46 <adamw> this one's actually a blocker if the current background is the same as f27's...
18:02:47 <kparal> adamw: btw, bug 1554453 is now proposed as well
18:03:00 <adamw> thanks
18:03:35 <kparal> "In this case, F28 backgrounds differ from the previous release so assigning to FE."
18:03:38 * pwhalen hasnt checked the background in a while
18:03:46 <adamw> uh
18:03:46 <kparal> +1 FE
18:03:48 <frantisekz> +1 FE
18:03:50 <adamw> no
18:03:53 <adamw> that sounds like the person didn't understand me
18:03:58 <adamw> of course the *new* backgrounds are different
18:04:06 <adamw> the question is what the background *before* the update looks like
18:04:13 <adamw> openQA says it looks like this:
18:04:13 <adamw> https://openqa.fedoraproject.org/tests/200929#step/_do_install_and_reboot/31
18:04:21 <adamw> which is indeed the f27 background, isn't it?
18:04:26 <pwhalen> yea
18:04:31 <adamw> so, this is a blocker.
18:04:32 <pwhalen> +1 blocker
18:04:33 <kparal> ok
18:04:36 <kparal> +1 blocker
18:04:45 <lruzicka> adamw: My virtual machine had a different background
18:05:24 <lruzicka> the last compose Workstation had some funny spheres ...it looked like pencilart
18:05:36 <adamw> lruzicka: did you do a network install?
18:05:39 <adamw> and/or update after install?
18:05:40 <roca> yes (RE: the 27 background) +1 blocker
18:06:11 <lruzicka> fresh install Fedora Workstation from Everything-netinst
18:06:58 <adamw> ok, yeah, if you use a netinst, it's going to pull in updates-testing, i believe.
18:07:00 <adamw> lruzicka: https://openqa.fedoraproject.org/tests/201905#step/_do_install_and_reboot/57
18:07:03 <adamw> is that what you saw?
18:07:03 <mkolman> BTW: http://blog.linuxgrrl.com/2018/03/06/fedora-28s-desktop-background-design/
18:07:34 <lruzicka> adamw: This exactly :)
18:07:44 <adamw> lruzicka: that's the new background, yes. but it's only in updates-testing atm.
18:07:45 <kparal> I can confirm the wallpaper is F27 one, when installed from Live
18:07:51 <adamw> so live images don't have it, for e.g.
18:08:49 <adamw> proposed #agreed 1549686 - AcceptedBlocker (Beta) - we are accepting this as a blocker (not just FE) as the background in current F28 composes is the same as the F27 background, which violates "The default desktop background must be different from that of the last two stable releases"
18:08:56 <kparal> ack
18:09:04 <pwhalen> ack
18:09:06 <lruzicka> if so, then ack
18:09:10 <lbrabec> ack
18:09:53 <adamw> #agreed 1549686 - AcceptedBlocker (Beta) - we are accepting this as a blocker (not just FE) as the background in current F28 composes is the same as the F27 background, which violates "The default desktop background must be different from that of the last two stable releases"
18:09:56 <roca> ack
18:10:04 <adamw> coremodule: so, remember to change that from blocking the FE bug to blocking the blocker bug
18:10:35 <adamw> #topic (1552318) Re-base Dogtag 10.5 to Dogtag 10.6
18:10:35 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1552318
18:10:35 <adamw> #info Proposed Freeze Exceptions, pki-core, NEW
18:10:36 <roca> mkolman: thanks for that link
18:10:53 <mkolman> np - saw it on planet Fedora a few days ago :)
18:10:58 <adamw> so, aiui, this is basically freeipa folks asking for permission to bump the release of something as this is part of how they want to go about fixing freeipa to actually work.
18:11:17 <coremodule> adamw, roger, will do!
18:12:10 <adamw> i am an unhappy +1 on it.
18:12:24 <adamw> because it sounds like we're basically not going to get a working freeipa any other way.
18:12:49 <adamw> we could try digging in our heels and saying "you've got to make whatever major versions are in beta right now work with each other", but practically speaking i doubt we'd get very far with that.
18:13:13 <kparal> +1
18:13:19 <sumantro> +1
18:13:42 <roca> +1
18:13:58 <pwhalen> +1 :/
18:14:00 <frantisekz> +1
18:14:01 <lruzicka> +1 but maybe we should tell them to be more exact on dates?
18:14:29 <roca> agreed. they didn't seem to provide an estimate on the requested extension
18:15:08 <adamw> lruzicka: yeah, i'm trying to kick up a bit off fuss about this for future releases too
18:15:43 <lruzicka> adamw: thanks, that's a good thing to do :)
18:16:13 <adamw> proposed #agreed 1552318 - AcceptedFreezeException (Beta) - we're not super happy about major version bumps this late, but it seems this is the only way we are likely to get a working FreeIPA. we would like to ask the FreeIPA-related teams to co-ordinate to get appropriate, interoperable versions landed *before* Beta freeze in future cycles.
18:16:31 <lruzicka> good so, ack
18:16:35 <sumantro> ack
18:16:40 <roca> ack
18:16:47 <kparal> ack
18:16:56 <adamw> #agreed 1552318 - AcceptedFreezeException (Beta) - we're not super happy about major version bumps this late, but it seems this is the only way we are likely to get a working FreeIPA. we would like to ask the FreeIPA-related teams to co-ordinate to get appropriate, interoperable versions landed *before* Beta freeze in future cycles.
18:18:14 <adamw> #topic (1554453) "exported surface had an invalid role" protocol errors from xdg_exporter when opening files
18:18:14 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1554453
18:18:15 <adamw> #info Proposed Freeze Exceptions, mutter, NEW
18:18:51 <adamw> so, this one boils down to 'nautilus crashes a lot'
18:19:07 <adamw> since it's a core Workstation app, definitely seems +1 blocker to me. will affect use of Workstation lives, for e.g.
18:19:23 <kparal> not a lot, always when you try to open a file
18:19:47 <frantisekz> +1 , clear blocker then
18:19:53 <roca> +1 blocker
18:20:00 <kparal> it's proposed against Final, to be clear
18:20:03 <kparal> and Beta FE
18:20:25 <kparal> our Beta criteria don't talk about nautilus
18:20:38 <adamw> +1 beta FE, +1 Final blocker
18:20:50 <lruzicka> kparal: But we test for core apps and Nautilus is one of them
18:21:09 <kparal> do we have a Beta criterion for core apps?
18:21:13 <lruzicka> I have no problem to go as adamw ... just saying
18:21:27 <adamw> kparal: don't think so
18:21:44 <kparal> I'm not happy with this not blocking Beta
18:21:52 <kparal> but I don't see anything matching
18:22:02 <adamw> we could tweak the criteria, i guess. it's always a balance.
18:22:23 <kparal> what do others think? it's non-functional file manager good enough for Beta?
18:22:38 <frantisekz> I'd tweak the criteria, so this counts as a beta blocker
18:22:56 <adamw> where do you draw the line?
18:23:08 <kparal> I'm not convinced myself, it's still Beta. I'm just asking
18:23:12 <adamw> do we move the whole 'core apps' criterion (whatever it says exactly) from final to beta?
18:23:52 <lruzicka> adamw: I would say yes, because core apps should be working in Beta
18:24:09 <adamw> well, so, we can discuss it outside the meeting, if we just want to discuss the principle
18:24:19 <adamw> we only have to discuss here if we think it's important enough to make *this specific* bug a blocker
18:24:30 <kparal> adamw: the funny thing is, we block on all core apps except gedit and nautilus in Beta already :)
18:24:32 <adamw> bearing in mind that we have a fix for it, so making it an FE means it's going to get fixed anyway...
18:24:43 <adamw> kparal: heh, i guess we do...
18:24:44 <kparal> firefox, gnome-software, terminal, boxes
18:25:07 <lruzicka> adamw: that would still go fixed if that was a blocker, right?
18:25:09 <kparal> aaanyway. if the fix is ready, let's move on
18:25:20 <adamw> kparal: do go ahead and draft a criteria proposal...
18:25:23 <pwhalen> +1 FE (it does seem like a blocker-ish imo)
18:25:26 <frantisekz> so, +1 FE then for now
18:25:37 <kparal> +1 final blocker,  +1 beta FE at the moment
18:25:41 <sumantro> +1 FE for now
18:25:42 <lruzicka> adamw: kparal: I can try to think about some
18:26:01 <lruzicka> +1 FE now, +1 final blocker
18:26:26 <adamw> proposed #agreed 1552318 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - we accept this as an FE (it's an obvious major bug in a core Workstation component that will affect live experience) and a Final blocker (as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic
18:26:26 <adamw> functionality test")
18:26:27 <roca> +1 final blocker, +1 beta FE
18:26:32 <adamw> grr
18:26:37 <roca> sorry
18:26:39 <adamw> proposed #agreed 1552318 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - we accept this as an FE (it's an obvious major bug in a core Workstation component that will affect live experience) and a Final blocker (as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test")
18:26:48 <adamw> roca: no, i was 'grr'ing that my proposal was too long :)
18:27:02 <roca> :D
18:27:12 <lruzicka> adamw: But it exactly names the problem.
18:27:14 <lruzicka> ack
18:28:01 <frantisekz> ack
18:28:13 <roca> ack
18:29:08 <adamw> #agreed 1552318 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - we accept this as an FE (it's an obvious major bug in a core Workstation component that will affect live experience) and a Final blocker (as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test")
18:29:11 <adamw> ok, one more...
18:29:30 <adamw> #topic (1554464) Rebuilds for GCC 8 ABI change miscompilation issue
18:29:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1554464
18:29:31 <adamw> #info Proposed Freeze Exceptions, distribution, MODIFIED
18:29:36 <adamw> yet another set of rebuilds.
18:29:51 <adamw> i am still not sure exactly what this 'miscompilation' entails, but getting the rebuilds in seems like a solid idea.
18:29:55 <pwhalen> +1
18:30:17 <kparal> +1
18:30:31 <lruzicka> +1
18:31:02 <roca> +1 FE
18:32:17 <sumantro> +1 FE
18:32:51 <adamw> proposed #agreed 1554464 - AcceptedFreezeException (Beta) - when the gcc maintainers tell us their compiler miscompiled some stuff and it should be recompiled, recompiling it seems like a good plan.
18:33:00 <lruzicka> ack
18:33:05 <sumantro> ack
18:33:05 <pwhalen> ack
18:33:21 <frantisekz> ack
18:33:22 <roca> ack
18:33:55 <adamw> #agreed 1554464 - AcceptedFreezeException (Beta) - when the gcc maintainers tell us their compiler miscompiled some stuff and it should be recompiled, recompiling it seems like a good plan.
18:34:03 <adamw> ok, that's all the proposals
18:34:20 <adamw> #info that's all the proposals
18:34:35 <adamw> looking at existing accepted blockers, most are clearly being addressed...
18:34:42 <adamw> let's just quickly check in on two that aren't
18:34:47 <adamw> #info quick check-in on accepted blockers
18:34:53 <adamw> #topic (1496562) freeipa tests in Fedora28+ shouldn't test for specific NSS database filenames, but should be flexible
18:34:53 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1496562
18:34:53 <adamw> #info Accepted Blocker, pki-core, ASSIGNED
18:35:00 <adamw> so, this one is basically a proxy for 'freeipa don't work;
18:35:02 <adamw> so, this one is basically a proxy for 'freeipa don't work'
18:35:27 <adamw> as mentioned in earlier discussion, my broad understanding of the state here is 'we're waiting for freeipa devs to submit a bunch of new versions of things that should magically make everything work'
18:35:32 <adamw> i will be following up with them this week
18:35:59 <adamw> #info freeipa is still broken and has been for months, freeipa folks intend to fix it by landing new versions of several things; adamw will check in with them on precise plan
18:36:13 <adamw> #action adamw to check with freeipa folks on plan and schedule for landing working freeipa bits
18:36:19 <adamw> any other notes on this?
18:38:42 <sumantro> nothing from my end
18:39:16 <adamw> ok
18:39:25 <adamw> #topic (1520580) Unable to log in on arm disk images
18:39:25 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1520580
18:39:25 <adamw> #info Accepted Blocker, selinux-policy, NEW
18:39:44 * pwhalen hasnt seen any movement or change on this
18:39:50 <adamw> hmm, okay
18:39:54 <adamw> i'd better poke the selinux folks
18:40:04 <adamw> #info this has been unaddressed for a long time, we need to ping selinux folks about it
18:40:13 <adamw> #action adamw to ping selinux maintainers re 1520580
18:40:51 <adamw> #topic Open floor
18:40:57 <adamw> alrighty, any other issues to bring up, folks? any missed bugs?
18:41:27 <kparal> nothing here
18:41:49 * pwhalen has nothing
18:42:22 <sumantro> nothing here
18:43:35 * lruzicka nothing
18:43:44 <adamw> alrighty, thanks for coming, folks
18:43:48 <adamw> now go forth and...fix all the bugs :P
18:43:59 <roca> \o/
18:44:00 <pwhalen> :)
18:44:03 <frantisekz> thanks for leading the meeting adam
18:44:26 <sumantro> thanks for hosting the meeting adamw :)
18:44:33 <adamw> #endmeeting