16:01:27 <adamw> #startmeeting F28-blocker-review
16:01:27 <zodbot> Meeting started Mon Apr  9 16:01:27 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:27 <zodbot> The meeting name has been set to 'f28-blocker-review'
16:01:27 <adamw> #meetingname F28-blocker-review
16:01:27 <adamw> #topic Roll Call
16:01:27 <zodbot> The meeting name has been set to 'f28-blocker-review'
16:01:33 <adamw> morning folks, who's around for blocker review fun?
16:01:46 * lruzicka is here
16:01:49 * satellit listening
16:01:51 * sumantro is here
16:02:30 * coremodule is here, willing to secretarialize!
16:02:46 <kalev> morning
16:03:09 <sgallagh> .hello2
16:03:10 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:04:42 * kparal is here
16:04:47 <adamw> #chair sgallagh kalev
16:04:47 <zodbot> Current chairs: adamw kalev sgallagh
16:06:41 <adamw> #topic Introduction
16:06:41 <adamw> Why are we here?
16:06:41 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:41 <adamw> #info We'll be following the process outlined at:
16:06:41 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:42 <adamw> #info The bugs up for review today are available at:
16:06:44 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:06:46 <adamw> #info The criteria for release blocking bugs can be found at:
16:06:48 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:06:50 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria
16:06:52 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria
16:06:55 <adamw> we have:
16:06:56 <adamw> #info 6 Proposed Blockers
16:06:58 <adamw> #info 4 Accepted Blockers
16:07:02 <adamw> #info 1 Proposed Freeze Exceptions
16:07:04 <adamw> #info 2 Accepted Freeze Exceptions
16:07:06 <adamw> #info coremodule will secretarialize
16:07:16 <adamw> alrighty, let's get started with proposed blockers
16:07:25 <adamw> #topic (1560481) Some core applications in Gnome 3.28 are unresponsive and not working on AMD graphics cards
16:07:25 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1560481
16:07:25 <adamw> #info Proposed Blocker, gnome-shell, NEW
16:08:11 <lruzicka> Seems like a blocker to me
16:09:19 * sumantro seconds lruzicka
16:09:26 <kparal> +1
16:09:30 <lruzicka> +1
16:09:37 <sumantro> +1
16:09:44 <sgallagh> Yeah, I'm +1 here as well
16:09:48 <adamw> yup, me too
16:10:18 <adamw> kalev: do you see any problems with taking this as a blocker?
16:10:55 <sgallagh> If it doesn't get fixed in mutter, the upstream bug has a simple workaround to disable 10-bit support
16:11:09 <adamw> that helps
16:11:34 <kparal> workaround: https://gitlab.gnome.org/GNOME/mutter/issues/2#note_48418
16:12:02 <kparal> it would be nice if somebody tested it
16:12:11 <adamw> proposed #agreed 1560481 - AcceptedBlocker (Final) - accepted as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" on all or many AMD graphics cards
16:12:26 <kparal> ack
16:12:28 <lruzicka> ack
16:13:00 <sumantro> ack
16:13:01 <sgallagh> ack
16:13:21 <adamw> #agreed 1560481 - AcceptedBlocker (Final) - accepted as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" on all or many AMD graphics cards
16:13:31 <adamw> #topic (1555292) Fedora Workstation Live can't resume after suspend when booted from DVD connected via an external drive
16:13:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1555292
16:13:32 <adamw> #info Proposed Blocker, kernel, NEW
16:13:34 <adamw> ah, this ol' chestnut
16:13:55 <adamw> we still haven't restarted the desktop@ discussion on this, but we *do* have some more test results
16:14:11 <adamw> well...we have one.
16:14:16 <adamw> one is some!
16:14:21 <kparal> adamw: autosuspend has been disabled for F28
16:14:50 <kparal> https://pagure.io/fedora-workstation/issue/42#comment-504425
16:14:54 <kparal> #link https://pagure.io/fedora-workstation/issue/42#comment-504425
16:15:07 <adamw> oh, well, that solves things.
16:15:11 <sgallagh> And will also be disabled in F29 except when the system is on battery mode
16:15:13 <adamw> oh right, there was a ticket. i forgot.
16:15:18 <sgallagh> So I'm -1 to blocking on that
16:15:33 <kparal> -1
16:15:37 <sgallagh> (honestly, who has a CD drive anymore?)
16:16:14 <kalev> sorry, I got distracted, back now
16:16:16 <lruzicka> sgallagh: I do :) but if it is going to be disabled, -1
16:16:23 <sumantro> -1
16:16:46 <kalev> -1, yes, we're change the default to not suspend as per today's workstation wg decision
16:17:30 <kparal> kalev: also, you might want to consider this, when implementing it again: https://pagure.io/fedora-workstation/issue/42#comment-504272
16:17:42 <kparal> so that you don't push it for the wrong reasons
16:18:01 <kparal> damn, wrong link
16:18:09 <kparal> this is the right one: https://pagure.io/fesco/issue/1873#comment-504339
16:18:10 <adamw> proposed #agreed 1555292 - RejectedBlocker (Final) - Workstation WG voted today to disable auto-suspend for F28 Final: https://pagure.io/fedora-workstation/issue/42 . As this was proposed as a blocker due to the auto-suspend behaviour and that will be taken out, we no longer have any grounds to accept it
16:18:40 <sgallagh> ack
16:18:44 <kparal> ack
16:18:46 <kalev> ack
16:18:49 <sumantro> ack
16:18:50 <lruzicka> ack
16:19:08 <kalev> kparal: thanks, I'll try to keep it in mind, but I'm not really working on suspend stuff
16:19:12 <adamw> #agreed 1555292 - RejectedBlocker (Final) - Workstation WG voted today to disable auto-suspend for F28 Final: https://pagure.io/fedora-workstation/issue/42 . As this was proposed as a blocker due to the auto-suspend behaviour and that will be taken out, we no longer have any grounds to accept it
16:19:37 <adamw> #topic (1562743) F27 to F28 upgrade fails due to libkolab
16:19:37 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1562743
16:19:37 <adamw> #info Proposed Blocker, libkolab, ON_QA
16:20:02 <adamw> i think we should probably write down somewhere whether we accept or reject things that prevent upgrade working, but can be worked around with --allowerasing ...
16:20:46 <adamw> i can't remember which way we've gone before, or if we've even been consistent.
16:21:08 <kparal> well is it a part of some default installation?
16:21:27 <lruzicka> kparal: I think it says KDE desktop will have it
16:21:53 <sgallagh> It says "many KDE users will have it". I think it's a dep of a groupware app
16:22:50 <kparal> the criteria say it's a blocker if it's in a default install
16:23:01 <adamw> yeah...let me see if the test is running into this
16:23:11 <kparal> unless the package is obsolete or something
16:23:16 <kparal> then --allowerasing is of course fine
16:23:45 <adamw> https://openqa.fedoraproject.org/tests/217798 didn't hit it
16:24:01 <adamw> kparal: well, all obsolete packages should be *properly obsoleted*
16:24:19 <kparal> unless the package is dropped from fedora
16:24:22 <kparal> how is that called?
16:24:22 <adamw> my problem with --allowerasing is it's universal, it can be kinda dangerous
16:24:24 <kalev> we have fedora-obsoletes-package these days for obsoleting random leaf things
16:24:26 <adamw> kparal: no, even then.
16:24:35 <kparal> ah, ok, cool
16:24:48 <adamw> dnf doesn't know about retired packages; we have to teach it with obsoletes.
16:24:56 <adamw> it is hard to get all packagers to understand this, though. :P
16:25:04 <kparal> retired is the word, thanks
16:25:06 <adamw> so, anyway
16:25:25 <kalev> I think in general it makes sense to make sure that we correctly obsolete any low level components (libraries etc)
16:25:55 <kalev> not so sure about leaf desktop apps -- maybe it's nice to flag them up during the upgrade so that users see that something is getting removed
16:26:10 <adamw> proposed #agreed 1562743 - RejectedBlocker AcceptedFreezeException (Final) - this is rejected as a blocker as the affected package is not in any default release-blocking package set install. However it's accepted as an FE as it is fairly commonly installed and we would like to avoid use of --allowerasing as much as possible.
16:26:17 <kalev> ack
16:26:38 <lruzicka> ack
16:26:41 <adamw> kalev: i think they all should be obsoleted, a) because of problems like this, b) because security
16:26:55 <kalev> fair enough
16:26:56 <adamw> (giving it an FE just in case the update doesn't go stable before freeze)
16:27:08 * adamw should check what the package retirement docs say...
16:27:40 <sgallagh> ack
16:28:01 <kalev> when doing distro upgrades through gnome-software, it shows a popup saying that a package is going to be removed -- but that's only when nothing obsoletes it and it has broken deps
16:28:08 <kalev> if it's obsoleted, then it just gets silently removed
16:28:40 <sumantro> ack
16:28:41 <adamw> kalev: well, it's basically using --allowerasing
16:28:48 <adamw> the problem with *that* is it can also do really destructive stuff
16:28:57 <kalev> so in a way, not obsoleting important apps makes for a nicer user experience: they get forcibly removed, but the user learns about that
16:28:59 <adamw> i kinda don't like that workstation defaults to using it, though i do understand why
16:29:06 * kalev nods. yes
16:29:30 <adamw> greed 1562743 - RejectedBlocker AcceptedFreezeException (Final) - this is rejected as a blocker as the affected package is not in any default release-blocking package set install. However it's accepted as an FE as it is fairly commonly installed and we would like to avoid use of --allowerasing as much as possible.
16:29:32 <kalev> I think we need to add some extra protection there to not remove really important stuff, like gnome-shell for example
16:29:32 <adamw> grr
16:29:38 <adamw> #agreed 1562743 - RejectedBlocker AcceptedFreezeException (Final) - this is rejected as a blocker as the affected package is not in any default release-blocking package set install. However it's accepted as an FE as it is fairly commonly installed and we would like to avoid use of --allowerasing as much as possible.
16:29:51 <adamw> kalev: there are some protected packages, but it's a really small list (and the dnf devs hate that it exists)
16:30:02 * kalev nods.
16:30:29 <adamw> anyway, back to the blockers...
16:30:30 <adamw> #topic (1561763) KDE live image for Fedora 28 is oversize
16:30:30 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1561763
16:30:30 <adamw> #info Proposed Blocker, LiveCD - KDE, NEW
16:30:51 * pwhalen joins
16:30:57 <adamw> so, given that this would still be a blocker under kparal's proposed revised criterion, i'm gonna say +1
16:31:04 <adamw> give KDE team a chance to bump the target size or whatever
16:31:13 <kalev> we discussed this during the workstation wg meeting and agreed with a plan to fix it for f28
16:31:21 <kalev> let me find the link
16:31:26 <sumantro> +1
16:31:48 <kparal> +1
16:31:57 <kalev> https://pagure.io/fedora-workstation/issue/46
16:32:00 <kalev> * AGREED: juhp_ to investigate if we can improve the situation for F28
16:32:03 <kalev> by subpackaging, and if it doesn't work out, revert to F27 fonts
16:32:03 <pwhalen> +1
16:32:06 <kalev> (+1:6, 0:0, -1:0)  (kalev, 13:46:53)
16:32:20 <adamw> ah, the i18n font side of things?
16:32:26 <kalev> yup
16:32:41 <lruzicka> +1
16:32:54 <kalev> anyway, +1 :)
16:34:14 <adamw> proposed #agreed 1561763 - AcceptedBlocker (Final) - accepted as a violation of current Beta criterion "The release-blocking images must meet current size requirements", with a note that this would still be a blocker under the current proposed revision to that criterion
16:34:30 <pwhalen> ack
16:34:33 <kalev> ack
16:35:24 <lruzicka> ack
16:35:27 <sumantro> ack
16:36:03 <adamw> #agreed 1561763 - AcceptedBlocker (Final) - accepted as a violation of current Beta criterion "The release-blocking images must meet current size requirements", with a note that this would still be a blocker under the current proposed revision to that criterion
16:36:07 <adamw> #topic (1564210) 18.0.0-3.fc28 build causes llvmpipe fallback on GNOME (Wayland)
16:36:07 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1564210
16:36:07 <adamw> #info Proposed Blocker, mesa, MODIFIED
16:37:15 * adamw goes criteria fishing
16:37:41 <adamw> hmm, "totem fails with Clutter error including "Missing Cogl context"" sounds blockery.
16:37:47 <adamw> and cheese.
16:37:55 <adamw> so, I'm +1 for those.
16:38:00 <lruzicka> +1
16:38:05 <sumantro> +1
16:38:13 <sgallagh> +1, I guess
16:38:18 <pwhalen> +1
16:38:31 <kalev> 1
16:38:33 <kalev> +1
16:39:28 <kparal> +1
16:39:58 <adamw> proposed #agreed 1564210 - AcceptedBlocker (Final) - accepted as a Final blocker as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test", as this is reported to break Totem and Cheese
16:40:08 <sumantro> ack
16:40:08 <pwhalen> ack
16:40:23 <kparal> ack
16:40:34 <kparal> also, games don't run, blocker!
16:41:03 <lruzicka> ack
16:41:25 <adamw> hehe
16:41:29 <adamw> #agreed 1564210 - AcceptedBlocker (Final) - accepted as a Final blocker as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test", as this is reported to break Totem and Cheese
16:41:37 <adamw> kparal: right, we need those games to distract you from filing blockers...
16:41:49 <adamw> #topic (1563674) Nautilus silently fails to delete non-empty directories on Samba share
16:41:49 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1563674
16:41:50 <adamw> #info Proposed Blocker, samba, NEW
16:41:55 <adamw> this doesn't smell very blocker-y to me...
16:42:45 <sgallagh> Not all bugs are blockers
16:42:45 <kparal> -1, corner case, no harm done
16:42:47 <sgallagh> -1
16:43:01 <sumantro> -1
16:43:02 <sgallagh> If it was arbitrarily deleting OTHER directories... maybe
16:43:03 <pwhalen> -1
16:43:07 <kalev> -1
16:43:10 <lruzicka> -1. I agree that it is a corner case
16:43:20 <adamw> for the record the proposal justification was "I would argue that deleting directories correctly on Samba shares is basic functionality of the default file manager (Nautilus)."
16:43:24 <adamw> i think i disagree :)
16:43:30 <kparal> oh, non-empty, not empty
16:43:35 <kparal> that's a bit more problematic
16:43:37 <adamw> eh
16:43:46 <adamw> either way, doesn't seem worth blocking on.
16:43:57 <adamw> probably worth a commonbugs note.
16:44:01 * sgallagh nods
16:44:12 <kparal> I added it to commonbugs
16:44:12 * sumantro seconds
16:44:23 * lruzicka thirds
16:44:43 <sgallagh> I remember a bug from years past where a kernel update would sometimes lose the windows boot entry. I was always tempted to call that one a feature...
16:44:44 <kparal> still not a blocker, most probably. but it's uglier than I thought
16:46:12 <adamw> =)
16:47:02 <adamw> proposed #agreed 1563674 - RejectedBlocker (Final) - while this is unfortunate, we agree that it's too much of a stretch to define it as "basic functionality" of nautilus, there are obvious workarounds, and it can be substantially addressed with an update
16:47:14 <lruzicka> ack
16:47:15 <adamw> i'd consider it for an FE, but i think maybe closer to the time, if it comes up.
16:47:41 <lruzicka> +1 FE, that could help also
16:49:52 <kalev> ack
16:50:01 <sumantro> ack
16:50:03 <sgallagh> adamw: I'd actually put changes to libsmbclient and nautilus on the list of things not to touch unless they are blockers during freeze
16:50:13 <sgallagh> But then, I'm more paranoid than you.
16:50:18 <adamw> as i said, i'd *consider* it. :)
16:50:23 <adamw> for now we're just rejectingblocker.
16:50:35 <adamw> to be clear, fe is not part of the proposal.
16:50:38 <kalev> agreed, I don't think it helps to randomly mark things as FE. I'll come and ask for a FE if we actually have a nautilus update ready to go that needs FE :)
16:50:51 <pwhalen> ack
16:51:03 <adamw> #agreed 1563674 - RejectedBlocker (Final) - while this is unfortunate, we agree that it's too much of a stretch to define it as "basic functionality" of nautilus, there are obvious workarounds, and it can be substantially addressed with an update
16:51:31 <lruzicka> kalev: And when you have it, I will not object :) That is what I meant
16:51:33 <adamw> #info moving onto proposed freeze exceptions
16:51:44 <adamw> #undo
16:51:44 <zodbot> Removing item from minutes: INFO by adamw at 16:51:33 : moving onto proposed freeze exceptions
16:51:51 <adamw> actually, belay that. we only have one and we accepted it as a blocker.
16:52:09 <adamw> #info moving onto accepted blockers (there are no proposed FEs outstanding now)
16:52:18 <adamw> #topic (1561768) Requires python-smbios, which doesn't exist
16:52:18 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1561768
16:52:18 <adamw> #info Accepted Blocker, firmware-addon-dell, NEW
16:52:37 <adamw> since pjones seems to be fairly absent atm, i think i'm just going to send a PR to drop the package from the server DVD
16:52:43 <adamw> that'd make this not a blocker
16:53:07 <sgallagh> adamw: I can get behind that
16:53:10 <kalev> this is deja vu, I think we had the exact same bug (that got fixed) for F27
16:53:16 <adamw> kalev: not quite the same, no.
16:53:46 <adamw> you're thinking of https://bugzilla.redhat.com/show_bug.cgi?id=1522905 , i think.
16:54:07 <kalev> yep, that's the one
16:54:20 <adamw> that problem was that python-smbios had a broken dep, this problem is it just doesn't exist any more (only python3-smbios)
16:54:34 <adamw> i actually suspect firmware-addon-dell is no use any more, it hasn't been touched upstream for seven years.
16:54:42 <kalev> ah, libsmbios vs firmware-addon-dell, different packages
16:54:48 <adamw> https://github.com/dell/firmware-addon-dell
16:55:07 <adamw> kalev: firmware-addon-dell is the ultimate issue in both cases - it depends on python-smbios .
16:55:22 <adamw> "Latest commit 453dc75 on Apr 29, 2011"
16:55:23 <sgallagh> I'll ask around and see if we can just retire it
16:55:32 <kalev> that would be best
16:55:35 <adamw> sgallagh: i've already asked that in the FTBFS bug, but no-one replied yet.
16:55:37 <sgallagh> It could just be super-stable!
16:55:47 <sgallagh> ok
16:55:53 <adamw> that's https://bugzilla.redhat.com/show_bug.cgi?id=1555752 .
16:56:24 <adamw> sgallagh: if you can get a reply, that'd be awesome. :P
16:56:45 <kalev> I can ask hughsie tomorrow, he might know
16:56:46 <adamw> #info as no-one seems keen to work on resolving this ATM, adamw will send a PR to drop it from comps, which will make it no longer a blocking issue
16:56:49 <adamw> kalev: thanks
16:57:38 <adamw> #topic (1557655) FCoE install fails to boot, stops at "Failed to start udev Wait for Complete Device Initialization"
16:57:38 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1557655
16:57:38 <adamw> #info Accepted Blocker, kernel, NEW
16:58:25 <adamw> so, zbigniew kicked this to the kernel maintainers today...
16:58:47 <adamw> #info this has just been kicked to the kernel team
17:00:21 <adamw> #action adamw to check in with kernel team
17:00:28 <adamw> anything else on this one?
17:01:15 <lruzicka> dont think so
17:02:35 <adamw> ok
17:03:11 <adamw> #info the other accepted blockers seem to be moving along acceptably
17:03:17 <adamw> #topic Open floor
17:03:29 <adamw> OK! anything else related before we close out
17:03:30 <adamw> ?
17:03:43 <kparal> nope
17:04:23 <sumantro> nothing from my side
17:04:34 <lruzicka> no :)
17:04:56 <kalev> nothing from me!
17:06:05 <adamw> yay, short blocker meetings++
17:06:09 <adamw> thanks for coming, everyone
17:06:27 <adamw> #endmeeting