#fedora-blocker-review: F30-blocker-review

Meeting started by adamw at 17:03:30 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:03:30)
    1. coremodule will secret terrialize (adamw, 17:06:06)

  2. Introduction (adamw, 17:07:42)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:07:43)
    2. We'll be following the process outlined at: (adamw, 17:07:44)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:07:44)
    4. The bugs up for review today are available at: (adamw, 17:07:46)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:07:48)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:07:50)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 17:07:52)
    8. https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria (adamw, 17:07:54)
    9. https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria (adamw, 17:07:56)
    10. 3 Proposed Blockers (adamw, 17:09:49)
    11. 2 Accepted Blockers (adamw, 17:09:50)
    12. 2 Proposed Freeze Exceptions (adamw, 17:09:54)
    13. above was for Beta (adamw, 17:10:01)
    14. for Final, we have: (adamw, 17:10:10)
    15. 1 Proposed Blockers (adamw, 17:10:13)
    16. we will start with proposed Beta blockers (adamw, 17:10:24)

  3. (1683197) gdm Fails to load with "nomodeset" (adamw, 17:10:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1683197 (adamw, 17:10:32)
    2. Proposed Blocker, gdm, NEW (adamw, 17:10:32)
    3. AGREED: 1683197 - AcceptedBlocker (Beta) - for now we accept this as a violation of the cited criterion, note further testing on bare metal systems may cause a re-evaluation if the bug turns out not to happen in some cases (adamw, 17:17:32)

  4. (1673710) [abrt] virt-manager: gst_caps_set_simple_valist(): python3.7 killed by SIGSEGV (adamw, 17:17:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1673710 (adamw, 17:17:42)
    2. Proposed Blocker, gstreamer1, NEW (adamw, 17:17:42)
    3. AGREED: 1673710 - AcceptedBlocker (Beta) - accepted as a violation of "The release must be able host virtual guest instances of the same release". We note that using VNC can be considered a 'workaround', but still think the bug is a blocker, and note that it is not straightforward to do this in Boxes and it is not equal in quality to the default config (adamw, 17:25:29)

  5. (1684612) Review Request: f30-backgrounds - Fedora 30 default desktop background (adamw, 17:25:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1684612 (adamw, 17:25:38)
    2. Proposed Blocker, Package Review, NEW (adamw, 17:25:38)
    3. AGREED: 1684612 - AcceptedBlocker (Beta) - accepted as a violation of "The default desktop background must be different from that of the last two stable releases" (the new package needs to be approved, built and pushed in order to meet that criterion) (adamw, 17:30:03)

  6. Proposed Beta freeze exceptions (adamw, 17:30:25)
    1. as we'll be in Beta freeze very shortly, let's review these next (adamw, 17:30:40)

  7. (1684808) dark theme in Mate leads to unreadable text (adamw, 17:30:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1684808 (adamw, 17:30:58)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 17:30:58)
    3. AGREED: 1684808 - AcceptedFreezeException (Beta) - this bug makes it hard to read the installer in MATE and obviously cannot be fixed with an update (adamw, 17:36:56)

  8. (1600444) Wrong conflicts between dnf and yum prevents upgrade (adamw, 17:37:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1600444 (adamw, 17:37:03)
    2. Proposed Freeze Exceptions, dnf, ASSIGNED (adamw, 17:37:03)
    3. AGREED: 1600444 - AcceptedFreezeException (Beta) - accepted as this interferes with upgrades in a common case. Granting an FE allows a fix to go to F30 stable during freeze, so upgrades run without updates-testing enabled (the usual case) during freeze period will not hit the bug (adamw, 17:49:18)

  9. (1677732) "Advanced Network Configuration" appears in "X-GNOME-Sundry" folder (adamw, 17:49:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1677732 (adamw, 17:49:27)
    2. Proposed Freeze Exceptions, gsettings-desktop-schemas, NEW (adamw, 17:49:27)
    3. AGREED: 1677732 - AcceptedFreezeException (Beta) - this will be visible and confusing in the Workstation live, so it's worth fixing and cannot be fixed with an update (adamw, 17:55:37)

  10. Proposed Final blocker (adamw, 17:55:43)
    1. finally, we'll do the proposed Final blocker (adamw, 17:55:49)

  11. (1683189) [abrt] gnome-remote-desktop: handle_socket_data(): gnome-remote-desktop-daemon killed by SIGABRT (adamw, 17:55:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1683189 (adamw, 17:55:53)
    2. Proposed Blocker, gnome-remote-desktop, MODIFIED (adamw, 17:55:53)
    3. the fix for this is built and tagged f30 so will be in any future composes, thus no practical need to consider this bug, we will close it (adamw, 18:01:27)

  12. Open floor (adamw, 18:02:17)


Meeting ended at 18:11:18 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (136)
  2. lruzicka (44)
  3. bcotton (19)
  4. jlanda (13)
  5. zodbot (13)
  6. sumantro (13)
  7. frantisekz (12)
  8. coremodule (10)
  9. pwhalen (7)
  10. satellit (6)
  11. sgallagh (5)
  12. lbrabec (1)


Generated by MeetBot 0.1.4.