16:00:29 <adamw> #startmeeting F30-blocker-review
16:00:29 <zodbot> Meeting started Mon Apr 22 16:00:29 2019 UTC.
16:00:29 <zodbot> This meeting is logged and archived in a public location.
16:00:29 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <zodbot> The meeting name has been set to 'f30-blocker-review'
16:00:29 <adamw> #meetingname F30-blocker-review
16:00:29 <adamw> #topic Roll Call
16:00:29 <zodbot> The meeting name has been set to 'f30-blocker-review'
16:00:38 <adamw> morning folks, who's around for blocker fun?
16:00:42 <frantisekz> .hello2
16:00:43 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:00:45 <bcotton> .hello2
16:00:46 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:03 <frantisekz> I don't expect too many people from Brno since we have a public holiday today
16:01:58 <bcotton> frantisekz: that's okay, we don't have too many blockers :p
16:02:48 <frantisekz> yeah... at this point, more than one is too many :D
16:02:50 <adamw> hope we have at least enough people to vote
16:02:52 <cmurf> .hello2
16:02:53 <zodbot> cmurf: Sorry, but you don't exist
16:02:55 <adamw> hi cmurf
16:02:56 <cmurf> never gets old
16:02:58 <adamw> tflink said he might be along too
16:03:03 <adamw> mboddu: ping?
16:03:03 <zodbot> adamw: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:03:05 <cmurf> hi adamw
16:03:14 <adamw> nirik: ping
16:03:14 <zodbot> adamw: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:03:18 <adamw> assuming sgallagh is still on holiday
16:03:25 <adamw> coremodule: ping
16:03:25 <zodbot> adamw: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:03:33 <nirik> icmp packet unreachable
16:03:38 <nirik> whats up?
16:03:39 <cmurf> haha
16:03:46 <sgallagh> I’m here-ish
16:03:56 * mboddu is kinda here
16:03:57 <sgallagh> I need to leave in 30 to take my kid to a check-up though.
16:04:00 <coremodule> ugh, I'm here, i always get logged out and cant send messages
16:04:01 <adamw> nirik: it's blocker review t-t-t-time
16:04:09 <adamw> alrighty, looks like we have enough folks
16:04:10 * coremodule is here, ready to secretarialize.
16:04:16 <adamw> #chair coremodule cmurf
16:04:16 <zodbot> Current chairs: adamw cmurf coremodule
16:04:24 <adamw> boilerplate alert!
16:04:30 <adamw> #topic Introduction
16:04:31 <adamw> Why are we here?
16:04:31 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:04:31 <adamw> #info We'll be following the process outlined at:
16:04:31 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:04:32 <adamw> #info The bugs up for review today are available at:
16:04:34 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:04:36 <adamw> #info The criteria for release blocking bugs can be found at:
16:04:37 * nirik is trying to catch up on email and such, but can try and pay some attention
16:04:38 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:04:40 <adamw> #link https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria
16:04:42 <adamw> #link https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria
16:04:44 <adamw> #info we have, all for Final:
16:04:54 <adamw> #info 2 Proposed Blockers
16:04:54 <adamw> #info 2 Accepted Blockers
16:04:57 <adamw> #info 4 Proposed Freeze Exceptions
16:04:58 <adamw> #info 6 Accepted Freeze Exceptions
16:05:06 <adamw> so without further ado...
16:05:10 <adamw> #info let's start with proposed blockers
16:05:21 <adamw> #topic (1700856) data abort in U-Boot when attempting to boot Allwinner A20 SBC's from SATA
16:05:21 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1700856
16:05:21 <adamw> #info Proposed Blocker, uboot-tools, ON_QA
16:05:50 * mboddu bbiab
16:06:11 <coremodule> seems straightforward enough
16:06:13 <coremodule> +1 blocker
16:06:16 <nirik> +1 blocker, those are pretty common I think?
16:06:22 <adamw> if pbrobinson says it's supported platforms, +1
16:06:24 <frantisekz> I don't know on what all arm boards/cpus are we blocking right now, but seems like a small change
16:06:28 <frantisekz> yeah, +1
16:06:31 <sgallagh> +1
16:06:38 <bcotton> +1
16:06:57 <adamw> proposed #agreed 1700856 - AcceptedBlocker (Final) - accepted as a violation of "All release-blocking images must boot in their supported configurations.  ...
16:06:57 <adamw> Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms."
16:07:01 <adamw> d'oh
16:07:15 <adamw> proposed #agreed 1700856 - AcceptedBlocker (Final) - accepted as a violation of "All release-blocking images must boot in their supported configurations.  ... Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms.
16:07:18 <bcotton> acl
16:07:21 <cmurf> ack
16:07:22 <bcotton> ack, too
16:07:23 <frantisekz> ack
16:07:24 <coremodule> mcl
16:07:27 <coremodule> ack
16:07:28 <adamw> with a closing quote mark
16:07:33 <adamw> and then i will go die in shame
16:07:38 <adamw> #agreed 1700856 - AcceptedBlocker (Final) - accepted as a violation of "All release-blocking images must boot in their supported configurations.  ... Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms."
16:07:39 <bcotton> RIP adamw
16:08:01 <frantisekz> adamw, the wiki page seems outdated, but A20 is there, thanks
16:08:05 <adamw> adamw (corpse version) will take over the meeting
16:08:20 <adamw> #topic (1697591) modesetting driver on some Intel hardware fails to start after kernel 4.20.13 update
16:08:21 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1697591
16:08:21 <adamw> #info Proposed Blocker, xorg-x11-server, ASSIGNED
16:08:38 <adamw> so...we punted this to ask for info from graphics folks, and...didn't get any
16:09:02 <adamw> which is a bit of a problem.
16:09:04 <cmurf> there's an open WG ticket about this that I got an update on this morning
16:09:13 <frantisekz> so, do we have any idea how many Intel iGPU generations are affected?
16:09:18 <cmurf> https://pagure.io/fedora-workstation/issue/89
16:09:19 <adamw> cmurf: linky?
16:09:20 <adamw> thanks'
16:09:21 <frantisekz> don't remember if we talked about that last mtg
16:09:33 <cmurf> has it been resolved satisfactorily? nope
16:09:40 <sgallagh> I'm disinclined to vote until ajax chimes in
16:09:48 <adamw> how does this relaet?
16:09:51 <adamw> to the ticket you linked
16:09:55 <adamw> this isn't to do with nomodeset
16:09:59 * nirik nods. try and get answer more...urgently
16:10:16 <cmurf> OOPS
16:10:21 <cmurf> sorry
16:10:46 <adamw> yeah, me too
16:10:53 <adamw> i will try pinging airlied as well
16:10:58 <adamw> and maybe get mattdm to shake some trees
16:10:59 <sgallagh> I just pinged cschalle as well
16:11:50 * satellit_ listening but afk
16:12:01 <cmurf> ok so punt?
16:12:29 <sgallagh> As near as I can tell, things work fine on Wayland, yes?
16:12:50 <coremodule> sgallagh, wayland has worked for me on two machines
16:12:52 <sgallagh> So barring a strong statement in favor of blocking from the graphics folks, I'd make it an FE
16:13:17 <sgallagh> Same here; I've got five or six systems with intel and wayland that haven't had this problem
16:13:20 <nirik> well, for the people that things work fine for, they don't need this. ;) It's everyone else
16:13:39 <adamw> the problem is that KDE is X by default
16:13:41 <adamw> and so is Xfce
16:13:45 <adamw> and those are both release-blocking desktops
16:13:51 <frantisekz> Xfce is not on intel
16:14:05 * nirik cannot parse that
16:14:07 <frantisekz> (if I remember correctly)
16:14:14 <adamw> oh, iswym
16:14:28 <adamw> it's release blocking on ARM which is never intel graphics, yes
16:14:30 <adamw> still, KDE.
16:14:35 <adamw> anyway, yeah, is anyone not punt on this?
16:14:50 <frantisekz> reading through the bug, it depends in Display used
16:14:59 <sgallagh> go/no-go is not this week, right?
16:15:09 * mboddu is back
16:15:14 <nirik> ah yes, the arm ons is the only one blocking for xfce, so I see what you are saying...
16:15:20 <mboddu> sgallagh: It is this Thu
16:15:27 <sgallagh> Ah, right
16:15:44 <sgallagh> Then I think we kind of need to decide today, because punting it to Go/No-Go... sucks
16:15:47 <adamw> we have a 'preferred target' of 04-30...
16:15:55 <sgallagh> Can we defer it to the end of the meeting and try to track down some SMEs?
16:16:00 <adamw> sure
16:16:12 <adamw> though i pinged ajax and airlied on #fedora-devel earlier, no reply
16:16:29 <frantisekz> if this happens only on X server only on some displays, I'd say +1 FE, but we can discuss later
16:16:32 <adamw> #info we will circle back to this later, in case we can track down relevant folks for input during the meeting
16:16:49 <sgallagh> Yeah, let's at least get FE in place
16:16:54 <adamw> #topic Proposed freeze exceptions
16:17:05 <adamw> #topic #topic (1689409) Let desktop-backgrounds-compat provide a symlink to the 16:9 image in ../f30/default/tv-wide/f30.png
16:17:05 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1689409
16:17:05 <adamw> #info Proposed Freeze Exceptions, desktop-backgrounds, ON_QA
16:17:39 <coremodule> +1 fe
16:17:49 <adamw> sure, +1
16:17:53 <frantisekz> +1
16:17:53 <sgallagh> Low risk and high value to installs. +1
16:17:53 <cmurf> +1
16:17:54 <bcotton> +1 fe
16:18:11 <tflink> +1 fe
16:18:22 <adamw> proposed #agreed 1689409 - AcceptedFreezeException (Final) - this affects live environments and so cannot be fully fixed with an update, and is a very safe change
16:18:30 <bcotton> ack
16:18:34 <frantisekz> ack
16:18:36 <coremodule> ack
16:18:53 <adamw> #agreed 1689409 - AcceptedFreezeException (Final) - this affects live environments and so cannot be fully fixed with an update, and is a very safe change
16:19:04 <adamw> #topic (1701012) Many packages require rebuild for Meson 0.50.0 execstack bug
16:19:05 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1701012
16:19:05 <adamw> #info Proposed Freeze Exceptions, distribution, MODIFIED
16:19:22 * mboddu caught up
16:19:46 <nirik> +1 FE.
16:19:55 <cmurf> +1
16:19:56 <bcotton> +1 fe
16:20:00 <coremodule> +1 fe
16:20:01 <frantisekz> +1
16:20:07 <tflink> +1
16:20:15 <mboddu> +1 FE
16:20:45 <sgallagh> how lovely
16:20:57 <frantisekz> :D
16:21:58 <adamw> yeah, this was a fun week for me!
16:22:47 <adamw> proposed #agreed 1701012 - AcceptedFreezeException (Final) - it is desirable from a security standpoint to avoid having packages built with 0.50.0 in the frozen release repos, so this is accepted as an FE. Only cases where the current stable package was built with 0.50.0 will be pushed
16:22:55 <bcotton> ack
16:22:56 <frantisekz> ack
16:22:59 <tflink> ack
16:23:03 <coremodule> ack
16:23:38 <sgallagh> ack
16:23:43 <sgallagh> (and +1)
16:24:18 <mboddu> ack
16:25:58 <adamw> #agreed 1701012 - AcceptedFreezeException (Final) - it is desirable from a security standpoint to avoid having packages built with 0.50.0 in the frozen release repos, so this is accepted as an FE. Only cases where the current stable package was built with 0.50.0 will be pushed
16:26:06 <adamw> #topic (1699432) appliance-creator crash in setting up grub-legacy
16:26:06 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1699432
16:26:07 <adamw> #info Proposed Freeze Exceptions, livecd-tools, MODIFIED
16:26:16 <frantisekz> +1
16:26:20 <cmurf> +1
16:26:33 <coremodule> +1
16:27:04 <sgallagh> Hmm
16:27:12 <sgallagh> What's the reason for needing it in the GA?
16:27:21 <sgallagh> It's not part of blocking media, is it?
16:27:46 <adamw> yeah
16:27:53 <adamw> i don't immediately see a rationale for this
16:28:00 <adamw> and it's obviously theoretically a change that can endanger composes
16:28:15 <sgallagh> Yeah, I'm -1 on this
16:28:28 <cmurf> livecd-tools isn't used for composes anymore though is it?
16:28:52 <bcotton> -1 because there's no compelling reason given
16:28:59 * Son_Goku waves
16:29:22 <Son_Goku> hello all
16:29:25 <frantisekz> Hi
16:29:28 <cmurf> i thought it's all done by livemedia-creator now
16:29:31 <tflink> yeah, -1 as well. It isn't blocking and touches the compose process
16:29:36 <frantisekz> I see you proposed that as a FE Son_Goku
16:29:46 <cmurf> *shrug* tested fix in Rawhide
16:29:56 <Son_Goku> it is how our ARM images are made
16:29:57 <coremodule> while true, I don't particularly see it as a risk as it's been tested by ngompa and kfenzi
16:29:57 <Southern_Gentlem> cmurf,  some people still use livecd-tools when the lmc stuff crashes
16:30:12 <Son_Goku> it also was validated by pgreco in CentOS
16:30:15 <adamw> what's the benefit of having it in the frozen package set, though?
16:30:22 <cmurf> it's a valid question
16:30:23 <adamw> why is that necessary vs. shipping it as an update?
16:30:36 <coremodule> that... is a good point
16:30:37 <cmurf> why is it best fixed on release rather than as an update?
16:30:47 <sgallagh> Right, the FE process isn't meant to be a "this would be nice to have" process
16:30:50 <Son_Goku> adamw, the 27.0 release that made it into the core basically either crashes or just silently produces empty grub configs
16:31:07 <sgallagh> It's "we wouldn't block on this, but shipping it as an update wouldn't be sufficient"
16:31:31 <coremodule> we should really change this...
16:31:32 <coremodule> "Our purpose in this meeting is to review proposed blocker and nice-to-have bugs"
16:31:33 <cmurf> ok so affected systems won't boot, if there's empty grub.cfg
16:31:35 <sgallagh> In this case, an update sound sufficient.
16:31:37 <coremodule> in the boilerplate
16:31:41 <coremodule> :P
16:31:44 <Son_Goku> I proposed it as an FE because I have no idea whether we'd been shipping borked ARM images
16:31:50 <tflink> coremodule: yeah, FE used to be nice-to-have
16:32:03 <sgallagh> Son_Goku: If we had been, those would have been blockers
16:32:05 <Son_Goku> because the original fix accidentally meant there'd be empty syslinux configs
16:32:14 <adamw> pwhalen: are we shipping broken ARM images?
16:32:26 <adamw> i would expect pbrobinson and pwhalen to yell very loudly if that was happening.
16:32:33 <sgallagh> I need to run for now. I'll be on my phone. Ping if needed.
16:32:34 <coremodule> *very*
16:32:48 <adamw> Son_Goku: okay, slow down. what is "the original fix"?
16:32:59 <nirik> this was deployed on builders...
16:33:09 <Son_Goku> it was https://github.com/livecd-tools/livecd-tools/commit/ef98227a1fa76427538026449e9711d03145ba44
16:33:48 <Son_Goku> err, and this: https://src.fedoraproject.org/rpms/livecd-tools/blob/7f741c1b212f6aa2ae667358cd8c15f655cc32e7/f/0101-creator-Change-to-text-strings-for-reading-file-list.patch
16:34:25 <Son_Goku> adamw, basically the "first fix" as a hasty patch on dist-git borked creation on < F31, and the second fix silently broke image boot configs
16:34:35 <Son_Goku> which led to me creating 27.1 to fix both
16:34:45 <mboddu> adamw: We ship all the images that comes out of the compose (that includes broken images) but we can use the excuse of "non-blocking artifacts with known bugs"
16:35:12 * mboddu is not a fan of it though, since now we have a fix for this
16:35:29 <adamw> Son_Goku: that 'first fix' wouldn't have made it to f30 during a freeze, though.
16:36:14 <Son_Goku> no, the second fix was in f30 with 27.0, iirc
16:36:48 <adamw> okay, this all seems very confused.
16:37:04 <adamw> my position on this is: if we're producing broken ARM images with whatever is in F30 stable, that is clearly a blocker
16:37:16 <adamw> if we are producing working ARM images with whatever is in F30 stable, we should not change anything
16:37:28 <adamw> i don't see any situation where this is plausibly an FE
16:37:34 * Son_Goku shrugs
16:37:53 <Son_Goku> I just don't want stuff to be broken if I can help it
16:38:10 <nirik> the rpm change didn't happen in f30 right? only rawhide? (I sure hope)
16:38:15 <Son_Goku> I have no idea
16:38:33 <Son_Goku> I keep getting bugs filed against my projects because of that change
16:38:47 <nirik> I can't imagine it did. We are using livecd-tools-26.1-3.fc30 for f30
16:39:33 <Son_Goku> okay, so then I guess this is just a nice to have to fix misc issues with creating live media on fedora 30
16:39:45 <adamw> okay.
16:39:47 <adamw> so i am still -1 FE.
16:39:49 <Son_Goku> with the dracut changes and removal of initscripts in the base
16:40:19 <mboddu> nirik is right, we are using livecd-tools-26.1-3.fc30 for f30
16:40:19 <Son_Goku> which exist currently as patches on top of 26.1 with 26.1-3.fc30
16:40:36 <Son_Goku> well, not the dracut change, just the initscripts one
16:41:41 <Son_Goku> if anyone cares, it just makes it so that the dracut config actually always takes effect when written into the filesystem
16:41:51 <Son_Goku> previously, it could be accidentally ignored or overwritten by other things
16:42:03 <Son_Goku> https://github.com/livecd-tools/livecd-tools/commit/1764b8034c816672d142e17b2f18904bf649f9a0
16:42:04 <adamw> proposed #agreed 1699432 - RejectedFreezeException (Final) - at this point we don't want to touch the compose creation tools unless absolutely necessary. What is in F30 currently is working for producing F30, we don't want to change it. This can be shipped fine as an update
16:42:12 <mboddu> ack
16:42:13 <bcotton> ack
16:42:23 <Son_Goku> welp
16:42:25 <tflink> ack
16:42:29 <frantisekz> ack
16:42:32 <Son_Goku> sorry guys, just being cautious
16:42:37 <coremodule> ack
16:42:50 <Son_Goku> it's hard for me to figure out what's being used, so I just went with it :(
16:43:09 <cmurf> Son_Goku: so it could be a transient failure? some users reboot after install and might get a grub prompt?
16:43:24 <frantisekz> the question is though, if 26.1 is currently used, but 27.0 is in stable, is it not going to be updated at some point?
16:43:32 <frantisekz> or 26.1 is in stable?
16:43:44 <adamw> Son_Goku: it's fine to propose it, don't worry
16:43:45 <cmurf> frantisekz: as soon as freeze is lifted, users will get the update
16:43:54 <adamw> would be best to provide details on what builds are broken and in what ways, though, for the future :)
16:44:07 <Son_Goku> adamw, well I dunno, I just know what stuff people ask me to fix :)
16:44:19 <Son_Goku> I have no easy way to figure out from Fedora things how to check
16:44:22 <frantisekz> cmurf, yeah, I know, but I am talking about what is used to build the images
16:44:25 <adamw> frantisekz: you can check this via koji and bodhi
16:44:30 <cmurf> frantisekz: ahhh gotcha
16:44:34 <adamw> frantisekz: look up current livecd-tools builds in koji:
16:44:37 <adamw> https://koji.fedoraproject.org/koji/packageinfo?packageID=2463
16:44:40 <adamw> look at the 27.0 package:
16:44:45 <adamw> https://koji.fedoraproject.org/koji/buildinfo?buildID=1249323
16:44:57 <adamw> it is tagged only 'f30-updates-candidate'
16:45:06 <adamw> that means it's not stable and there is in fact no active update for it
16:45:13 <adamw> 27.1 build:
16:45:14 <adamw> https://koji.fedoraproject.org/koji/buildinfo?buildID=1252678
16:45:33 <adamw> is tagged 'f30-updates-pending' and 'f30-updates-testing', which indicates it's in a pending update but is not stable
16:45:46 <adamw> 26.1-3:
16:45:46 <adamw> https://koji.fedoraproject.org/koji/buildinfo?buildID=1243478
16:45:48 <frantisekz> yeah, RejectedFE seems fine, thanks
16:45:53 <adamw> is tagged 'f30', meaning it is stable
16:46:00 <adamw> the most recently-tagged 'f30' build is what will be in composes
16:46:11 <adamw> since we're frozen, anything not currently tagged 'f30' is not going to *be* tagged f30 unless it gets an FE or blocker
16:46:20 <adamw> you can also just go look at what's actually in a current compose
16:46:30 <Son_Goku> anyway guys, i g2g
16:46:32 <Son_Goku> need to eat
16:46:34 <adamw> thanks son_goku
16:46:35 <Son_Goku> sorry for wasting your time :(
16:46:36 <adamw> cya later
16:46:40 <adamw> not at all
16:46:45 <frantisekz> no worries
16:46:45 <adamw> it's always better to propose things
16:46:58 <adamw> #agreed 1699432 - RejectedFreezeException (Final) - at this point we don't want to touch the compose creation tools unless absolutely necessary. What is in F30 currently is working for producing F30, we don't want to change it. This can be shipped fine as an update
16:47:08 <adamw> #topic (1700737) CVE-2018-16877 CVE-2018-16878 CVE-2019-3885 pacemaker: various flaws [fedora-all]
16:47:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1700737
16:47:08 <adamw> #info Proposed Freeze Exceptions, pacemaker, ON_QA
16:47:23 <cmurf> does "high" = "important" ?
16:47:39 <cmurf> if so then this is actually a blocker but anyway I'm +1 FE
16:48:30 <cmurf> wait, I don't even have pacemaker on any of my systems so is it on any release blocking images?
16:48:42 <cmurf> or used for build or composes?
16:48:57 <adamw> not sure
16:49:02 <mboddu> On the above thing, what is being used in the compose, you can just use - "$koji list-tagged fxx pkg --latest"
16:49:19 <adamw> it's in the high availability group
16:49:20 <adamw> mboddu: right
16:49:25 <Lailah> Hi
16:49:30 <Lailah> Sorry for my lateness
16:49:35 <Lailah> .fas lailah
16:49:36 <zodbot> Lailah: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:49:40 <adamw> but i don't think that group is in anything we ship...
16:49:50 <bcotton> i would suspect pacemaker isn't on any shipped media (and if it is....why?)
16:50:18 * mboddu checking
16:50:45 <adamw> https://access.redhat.com/security/cve/cve-2018-16877
16:50:47 <adamw> "important"
16:50:58 <adamw> and that criterion doesn't limit itself to the release media, so...by the book, this is a blocker
16:51:02 <adamw> +1 blocker
16:51:07 <bcotton> okay, well that makes it easy :-)
16:51:10 <bcotton> +1 blocker
16:51:37 <cmurf> +1 blocker
16:51:39 <frantisekz> +1
16:51:45 <Lailah> I have no opinion because I don't know what y'all talking about
16:51:48 <mboddu> Yeah, +1 blocker, made it easier
16:51:49 <tflink> +1 blocker
16:52:12 <tflink> Lailah: https://bugzilla.redhat.com/show_bug.cgi?id=1700737
16:53:02 <adamw> Lailah: the current bug is always in the topic :)
16:53:32 <Lailah> adamw: yes, I know, but I don't know what pacemaker is for.
16:53:42 <Lailah> I'm as in the darkness as before.
16:53:46 <Southern_Gentlem> +1 blocker
16:53:48 <Lailah> But it doesn't matter
16:53:56 <adamw> proposed #agreed 1700737 - AcceptedBlocker (Final) - accepted as a blocker (despite proposal as an FE) as a violation of Final criterion "The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation)." - CVE-2018-16877 is rated 'important'
16:54:00 <cmurf> ack
16:54:01 <mboddu> ack
16:54:03 <Lailah> ack
16:54:06 <frantisekz> ack
16:54:06 <tflink> ack
16:54:08 <adamw> Lailah: for this decision you don't even need to know what the package does :)
16:54:15 <coremodule> ack
16:54:15 <Southern_Gentlem> ack
16:54:24 <adamw> the criteria say "any known 'important' CVE is a blocker", we have a known 'important' CVE, that's all we need to know
16:54:26 <Lailah> adamw: ah, okay, goo
16:54:29 <Lailah> good *
16:54:32 <bcotton> ack
16:54:47 <Lailah> adamw: fair enough
16:54:48 <adamw> #agreed 1700737 - AcceptedBlocker (Final) - accepted as a blocker (despite proposal as an FE) as a violation of Final criterion "The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation)." - CVE-2018-16877 is rated 'important'
16:54:55 <adamw> okay
16:54:57 <adamw> so
16:55:02 <adamw> #topic Proposed blockers redux
16:55:07 <adamw> let's circle back to that proposed blocker from earlier
16:55:12 <adamw> #topic (1697591) modesetting driver on some Intel hardware fails to start after kernel 4.20.13 update
16:55:13 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1697591
16:55:13 <adamw> #info Proposed Blocker, xorg-x11-server, ASSIGNED
16:55:21 <cmurf> right
16:55:22 <adamw> unfortunately i don't think we succeeded in getting a hold of anyone...
16:55:27 <adamw> sgallagh tried, but i don't think he got anywhere
16:56:02 <adamw> so...let's say, i'm at least +1 FE on this
16:56:13 <adamw> if we have enough votes for FE status we can at least give it that
16:56:16 <cmurf> is it fair to say it negatively impacts a significant minority of KDE users with intel graphics?
16:56:18 <cmurf> +1 FE
16:56:18 <Southern_Gentlem> does that issue still exist with the 5.X kernels
16:56:25 <bcotton> +1 FE
16:56:33 <Southern_Gentlem> +1 FE
16:56:48 <frantisekz> +1 FE
16:56:52 <Lailah> Oh, I've heard complaints about it
16:56:55 <Lailah> +1 FE
16:57:05 <adamw> cmurf: i think that's probably a reasonable characterization
16:57:13 <tflink> +1 FE
16:57:18 <adamw> Southern_Gentlem: yes, because the bug is in X
16:57:28 <adamw> Southern_Gentlem: the kernel was previously kinda bodging over it, but stopped doing that
16:57:35 <mboddu> adamw: Its only affecting KDE on wayland, right?
16:57:40 <cmurf> well I'm more inclinded to +1 blocker this if at least a significant minority are affected
16:57:41 <frantisekz> KDE on X
16:57:42 <frantisekz> mboddu
16:57:43 <adamw> mboddu: it affects only X, it is an X bug
16:57:46 <adamw> it affects anything on X
16:57:49 <Lailah> I hadn't this issue myself and I'm using KDE with Intel Graphics, but I did hear other people complaining. I don't know if it's still an issue though
16:57:52 <mboddu> Sorry, KDE on XOrg
16:57:59 <adamw> the point about KDE is, in Fedora, our default for GNOME is Wayland (at least *most* of the time)
16:58:02 <adamw> but our default for KDE is X
16:58:11 <adamw> Lailah: it definitely is
16:58:13 <cmurf> but then that gets into the pragmatic aspect of resources, we can't indefinitely block if a fix isn't due anytime soon
16:58:31 <frantisekz> I didn't see that in the wild just yet (on three different displays on Intel GPUs)... and I am running on X
16:58:36 <mboddu> Has anyone tried KDE on Wayland and see if they replicate this?
16:58:38 <adamw> so...it's really hard to vote on blocker status for this without more info, i think
16:58:47 <adamw> mboddu: it cannot happen on wayland beacuse the bug is *in X*
16:58:49 <Lailah> mboddu: I can do that
16:58:52 <adamw> but KDE on Wayland is pretty niche
16:59:02 <mboddu> If it works on KDE on wayland, then we can add it to known issues and I am +1 FE
16:59:08 <adamw> i don't think we even have an option for on login screen or anything
16:59:09 <cmurf> Huh, I can back out of GNOME on Wayland and run GNOME on X with i915 graphics on two systems...
16:59:16 <cmurf> ancient i915 and skylake i915
16:59:18 <adamw> cmurf: sure, it doesn't affect everyhing.
16:59:23 <cmurf> ok...
16:59:32 <adamw> we know that, at least
16:59:34 <Southern_Gentlem> common bug as well
16:59:39 <adamw> that's kinda why it's hard to vote...
16:59:41 <Lailah> adamw: there is, I installed Wayland on my previous KDE and while it looked horrible, the option was there
16:59:50 <adamw> Lailah: ah OK. but only if you install the packages manually?
16:59:59 <frantisekz> so, cmruf, everything before and including Skylake?
17:00:05 <Lailah> adamw: yes, because it's not KDE default
17:00:28 <frantisekz> or something more ancient and Skylake with some gens before SKylake working?
17:00:35 <cmurf> frantisekz: I don't know I'm just saying I've got two systems with i915 graphics that aren't affected, and their generations are far apart
17:00:41 <cmurf> so i'm just not sure what generation is affected
17:00:49 <adamw> i don't think we know with confidence exactly what hardware is affected
17:00:49 <frantisekz> oh, thanks
17:00:56 <adamw> that's one of the things i'd really like the experts to tell us
17:01:23 <Lailah> adamw: I can install Wayland in my laptop and test it
17:01:44 <Lailah> At least, I can tell if in my machine there's any bug or not
17:01:47 <adamw> it might be useful to know how good/bad KDE on Wayland is as a 'workaround' to this, sure
17:01:52 <adamw> thanks
17:02:13 <mboddu> thanks Lailah
17:02:20 <Lailah> My pleasure :-)
17:03:33 <adamw> so, i think i'm still punt on this for blocker status
17:03:44 <cmurf> sounds good
17:03:44 <adamw> but we should try *really* hard to get info asap so we can vote ahead of go/no-go
17:04:21 <cmurf> 9 days and counting!
17:04:23 <Southern_Gentlem> +fe
17:05:39 <adamw> proposed #agreed 1697591 - AcceptedFreezeException (Final), punt (blocker status) - we still cannot make a solid blocker decision here as we are still missing input from the graphics team. However, we think this is at minimum serious enough to rate a freeze exception. We will try to get info from graphics team ASAP and make a blocker decision
17:05:51 <frantisekz> ack
17:05:53 <coremodule> ack
17:05:54 <bcotton> ack
17:05:58 <Southern_Gentlem> cmurf 2 days til go/no-go
17:05:59 <Lailah> ack
17:06:01 <Southern_Gentlem> ack
17:06:22 <mboddu> ack
17:06:37 <adamw> #agreed 1697591 - AcceptedFreezeException (Final), punt (blocker status) - we still cannot make a solid blocker decision here as we are still missing input from the graphics team. However, we think this is at minimum serious enough to rate a freeze exception. We will try to get info from graphics team ASAP and make a blocker decision
17:06:45 <adamw> #topic Open floor
17:06:47 <cmurf> oh my got it's this week?
17:06:55 <Southern_Gentlem> yep
17:06:56 <adamw> oh, wait
17:06:57 <cmurf> the time, it flies
17:07:02 <adamw> #topic Accepted blockers
17:07:12 <adamw> #info 1693409 - we are waiting on the graphics team for this one
17:07:28 <adamw> #info 1688462 - we are waiting for clarification from the dnf team on what exactly needs to be pushed where to get this fully 'fixed'
17:07:53 <adamw> any notes/questions on those?
17:08:42 <cmurf> nope
17:08:47 <cmurf> likely arrival?
17:08:50 <cmurf> like tomorrow?
17:09:11 <adamw> likely arrival of what?
17:09:13 <cmurf> that's a nope followed by two questions
17:09:17 <cmurf> fixes
17:09:51 <cmurf> we need fixes for those two bugs to get RC composes, right?
17:10:21 <Southern_Gentlem> .bug 1693409
17:10:22 <zodbot> Southern_Gentlem: 1693409 – gdm/X start fails on 'nomodeset' UEFI boot on multiple bare metal systems: "Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices" - https://bugzilla.redhat.com/1693409
17:11:08 <frantisekz> adamw (and others), what do you think about this? It's Gnome Control Center crashing on display tab while booted with nomodeset, https://bugzilla.redhat.com/show_bug.cgi?id=1699975
17:11:30 <adamw> cmurf: i can't really predict the arrival of *fixes* before we at least get *information* :)
17:11:32 <frantisekz> I don't think it should be blocker, but you might have a different opinion
17:11:40 <adamw> i'm gonna try as hard as possible to at least get hte info by tomorrow
17:11:53 <adamw> frantisekz: mm, seems a bit unfortunate...
17:12:09 <adamw> frantisekz: worth an FE probably, i'd think
17:12:10 <bcotton> think if i never hear the term "modeset" again, it will be too soon :-)
17:12:15 <Lailah> I doesn't seem to show any progress...
17:12:48 <cmurf> it's when there's multiple modesetting related bugs that I get confused
17:12:52 <frantisekz> okay, I'll propose that adamw, but fix is likely not coming (or at least, I didn't see reply from devs, I'll try to ping them tomorrow)
17:12:59 <frantisekz> *not coming soon
17:13:01 <adamw> bcotton: =)
17:13:42 <cmurf> seems like there is a 100% chance the only thing in common they'll have is the word modeset
17:14:36 <cmurf> get out your tortoise shells!
17:15:01 <Lailah> cmurf: I'm comfy inside my tortoise shell, thanks
17:15:15 <cmurf> (oracle bones) :D
17:15:21 <Southern_Gentlem> is kparal locked in his closet?
17:15:44 <cmurf> yeah what is the deal with kparal adamw? I was just joking when I said lock him away.
17:16:04 <mboddu> Southern_Gentlem: I think its holiday for kparal (also for adamw)
17:16:24 <adamw> yeah, today is a public holiday in canada and most of the eu
17:16:35 <Lailah> It's holidays here too
17:16:41 <adamw> (well, it's a sort of odd one in canada, it's not officially a public holiday nationwide but lots of companies give it, including rh)
17:16:41 <Lailah> But I'm here.
17:16:54 <adamw> but since we're this late in cycle we needed to run a meeting anyway
17:17:03 <adamw> looks like we're about done here, thanks a lot for coming out, folks
17:17:13 <adamw> #topic Open floor
17:17:13 <frantisekz> thanks adamw
17:17:16 <adamw> ooh, sorry, forgot to open floo
17:17:17 <adamw> r
17:17:27 <mboddu> Yeah, thanks a lot everyone esp for those who has a holiday today
17:17:35 <adamw> one note I guess: we rejected https://bugzilla.redhat.com/show_bug.cgi?id=89216 on votes in-bug
17:17:48 <adamw> if anyone feels strongly that was the wrong deicsion we can discuss it here
17:17:59 <cmurf> nope the logic denying it is sound
17:18:25 <Lailah> Nope. I'm fine with the rejection.
17:18:30 <adamw> okely dokely
17:18:32 <Lailah> I don't think it's a blocker
17:18:51 <frantisekz> yeah, blocker process is not here for this, F31 change proposal sounds better
17:19:32 <adamw> alrighty then
17:19:38 <adamw> thanks again everyone!
17:19:40 <adamw> #endmeeting