#fedora-blocker-review: F31-blocker-review
Meeting started by adamw at 16:00:53 UTC
(full logs).
Meeting summary
- Roll Call (adamw, 16:00:54)
 
- Introduction (adamw, 16:07:49)
  - Our purpose in this meeting is to review
    proposed blocker and nice-to-have bugs and decide whether to accept
    them, and to monitor the progress of fixing existing accepted
    blocker and nice-to-have bugs. (adamw,
    16:07:49)
- We'll be following the process outlined
    at: (adamw,
    16:07:49)
- https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
    (adamw,
    16:07:51)
- The bugs up for review today are available
    at: (adamw,
    16:07:52)
- http://qa.fedoraproject.org/blockerbugs/current
    (adamw,
    16:07:54)
- The criteria for release blocking bugs can be
    found at: (adamw,
    16:07:56)
- https://fedoraproject.org/wiki/Basic_Release_Criteria
    (adamw,
    16:07:58)
- https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria
    (adamw,
    16:08:00)
- https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria
    (adamw,
    16:08:02)
- 6 Proposed Blockers (adamw,
    16:08:09)
- 4 Accepted Blockers (adamw,
    16:08:09)
- 4 Proposed Freeze Exceptions (adamw,
    16:08:12)
- 5 Accepted Freeze Exceptions (adamw,
    16:08:13)
- for F31 Final, we have: (adamw,
    16:08:16)
- 4 Proposed Blockers (adamw,
    16:08:24)
- starting with proposed Beta blockers
    (adamw,
    16:08:59)
 
 
- (1749107) firefox does run with old profile after upgrade to F31 (adamw, 16:09:01)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1749107
    (adamw,
    16:09:02)
- Proposed Blocker, firefox, MODIFIED
    (adamw,
    16:09:02)
- AGREED: 1749107 -
    AcceptedBlocker (Beta) - this is accepted as a violation of the
    "upgraded systems must meet release criteria" criterion combined
    with the "desktop browser must work" criterion (adamw,
    16:12:35)
 
 
- (1750394) Gnome Control Center crashes upon a typo in Printers settings (adamw, 16:12:47)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1750394
    (adamw,
    16:12:47)
- Proposed Blocker, gnome-control-center,
    NEW (adamw,
    16:12:47)
- AGREED: 1750394 -
    AcceptedFreezeException (Beta), AcceptedBlocker (Final) - this is
    rejected as a Beta blocker as it doesn't really violate the Beta
    criteria, but is accepted as a Final blocker as a violation of "All
    elements of the default panel (or equivalent) configuration in all
    release-blocking desktops must function correctly in typical use"
    and as a Beta FE so long as the fix is clean (adamw,
    16:18:17)
 
 
- (1749086) Needs updating for Fedora 31 background etc. (adamw, 16:18:30)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1749086
    (adamw,
    16:18:30)
- Proposed Blocker, kde-settings, NEW
    (adamw,
    16:18:30)
- AGREED: 1749086 -
    AcceptedBlocker (Beta) - accepted as a violation of Basic criterion
    "The default desktop background must be different from that of the
    last two stable releases" (for the release-blocking KDE
    desktop) (adamw,
    16:23:37)
 
 
- (1743585) NetworkManager-wifi should prefer wpa_supplicant over iwd (currently iwd is chosen by dnf to resolve ambiguous dependency) (adamw, 16:24:01)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1743585
    (adamw,
    16:24:01)
- Proposed Blocker, NetworkManager,
    MODIFIED (adamw,
    16:24:01)
- AGREED: 1743585 -
    AcceptedBlocker (Beta) - this is accepted as a violation of all
    criteria that rely on a remote network connection (e.g. package
    updates) for a system dependent on a wifi connection (adamw,
    16:26:08)
 
 
- (1734184) python3-jmespath conflicts with but does not obsolete python2-jmespath (adamw, 16:26:14)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1734184
    (adamw,
    16:26:14)
- Proposed Blocker, python-jmespath, ON_QA
    (adamw,
    16:26:14)
- AGREED: 1734184 -
    RejectedBlocker (Beta) AcceptedFreezeException (Beta) - we don't
    believe this is in any release-blocking default install package set,
    so it is rejected as a blocker. However it's accepted as an FE as it
    will affect quite a lot of upgrades, since it's in ansible dep
    chain (adamw,
    16:32:20)
 
 
- (1728240) Cannot start Fedora-KDE-Live (F31) in basic graphics mode on BIOS machine (adamw, 16:32:28)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1728240
    (adamw,
    16:32:28)
- Proposed Blocker, sddm, NEW (adamw,
    16:32:28)
- https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria#.27Basic_graphics_mode.27_boot_mode_behavior
    (adamw,
    16:34:02)
- AGREED: 1728240 -
    AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is
    rejected as a blocker for Beta but accepted for Final under
    criterion "The generic video driver option ('basic graphics mode' -
    as described in the Basic criteria) on all release-blocking
    installer and live images must function as intended...". Also
    accepted as Beta FE as a significant issue that can't be fixed with
    an upgrade (adamw,
    16:38:12)
 
 
- Proposed Beta freeze exceptions (adamw, 16:38:26)
  - as we're in Beta freeze, let's do the Beta FEs
    next (adamw,
    16:38:31)
 
 
- (1750414) inaccessible workstation repos make gnome-software and dnf unusable (adamw, 16:38:38)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1750414
    (adamw,
    16:38:39)
- Proposed Freeze Exceptions,
    fedora-workstation-repositories, MODIFIED (adamw,
    16:38:39)
- AGREED: 1750414 -
    AcceptedFreezeException (Beta), punt (delay decision) for Final
    blocker - this is clearly bad enough (and the fix simple enough)
    that we should take it for Beta. Whether to accept it as a Final
    blocker is a slightly tricky call so we're just going to duck it,
    because fixing it as a Beta FE will mean we don't have to make up
    our minds! (adamw,
    16:48:32)
 
 
- (1750237) g-i-s window overlapped with gdm login screen (adamw, 16:48:42)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1750237
    (adamw,
    16:48:42)
- Proposed Freeze Exceptions,
    gnome-initial-setup, NEW (adamw,
    16:48:42)
- AGREED: 1750237 -
    AcceptedFreezeException (Beta) - the contexts in which this might
    happen are a bit unclear, but we think it can happen on upgrade and
    on first boot after install, so on that basis a freeze exception is
    justified as those cannot be fully addressed with a 0-day
    update (adamw,
    16:54:24)
 
 
- (1749133) Updates to fix robotics spin compose (adamw, 16:54:46)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1749133
    (adamw,
    16:54:46)
- Proposed Freeze Exceptions, player, NEW
    (adamw,
    16:54:46)
- AGREED: 1749133 -
    AcceptedFreezeException (Beta) - fixing a non-blocking image compose
    is a good reason for a freeze exception, and the required changes
    here look focused and safe (adamw,
    16:57:56)
 
 
- (1746538) Rootless podman won't start containers (adamw, 16:58:02)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1746538
    (adamw,
    16:58:03)
- Proposed Freeze Exceptions, podman, POST
    (adamw,
    16:58:03)
- AGREED: 1746538 -
    RejectedFreezeException (Beta) - while this is obviously a
    significant bug worth fixing, we can't see any justification for why
    it needs to be a freeze exception rather than a normal update
    (adamw,
    17:07:17)
 
 
- proposed Final blockers (adamw, 17:09:20)
  - let's move onto proposed Final blockers!
    (adamw,
    17:09:25)
 
 
- (1749433) can't turn zoom off once enabled (adamw, 17:09:52)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1749433
    (adamw,
    17:09:52)
- Proposed Blocker, gnome-control-center,
    NEW (adamw,
    17:09:52)
- AGREED: 1749433 -
    AcceptedBlocker (Final) - this is accepted as a violation of "All
    elements of the default panel (or equivalent) configuration in all
    release-blocking desktops must function correctly in typical
    use." (adamw,
    17:15:29)
 
 
- (1643446) download progress is often invisible (adamw, 17:15:36)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1643446
    (adamw,
    17:15:37)
- Proposed Blocker, gnome-software, NEW
    (adamw,
    17:15:37)
- AGREED: 1643446 -
    RejectedBlocker (Final), AcceptedFreezeException (Beta) - there is
    not enough support to consider this a clear violation of the release
    criteria, but it's certainly a bad enough experience to want it
    fixed for first-time F31 updaters (adamw,
    17:23:36)
 
 
- (1749868) GNOME Software doesn't prepare offline updates (adamw, 17:23:47)
  - https://bugzilla.redhat.com/show_bug.cgi?id=1749868
    (adamw,
    17:23:47)
- Proposed Blocker, gnome-software, NEW
    (adamw,
    17:23:47)
- https://bugzilla.redhat.com/show_bug.cgi?id=1750414
    (adamw,
    17:25:01)
- https://bugzilla.redhat.com/show_bug.cgi?id=1749868#c9
    (kparal,
    17:25:24)
- AGREED: 1749868 -
    punt (delay decision) - with the DNF default flipped, this looks
    like a serious issue, but there are a few uncertainties and we're
    also waiting on the outcome of the FESCo ticket before making a
    decision here (adamw,
    17:34:47)
 
 
- Open floor (adamw, 17:35:01)
  - for the record, coremodule will secretarialize,
    apologies for not noting earlier (adamw,
    17:35:55)
- Beta Go/No-Go meeting is Thursday (bcotton,
    17:37:45)
- https://apps.fedoraproject.org/calendar/meeting/9613/
    (bcotton,
    17:37:54)
 
Meeting ended at 17:43:26 UTC
(full logs).
Action items
  - (none)
People present (lines said)
  - adamw (203)
- kparal (62)
- frantisekz (58)
- Lailah (58)
- bcotton (54)
- cmurf (28)
- pwhalen (26)
- zodbot (15)
- tablepc (6)
- frantisekz_ (3)
- coremodule (2)
- mclasen (2)
- satellit_ (1)
Generated by MeetBot 0.1.4.