#fedora-blocker-review: F31-blocker-review

Meeting started by adamw at 16:02:22 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:23)
  2. Introduction (adamw, 16:04:55)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:04:56)
    2. We'll be following the process outlined at: (adamw, 16:04:56)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:04:56)
    4. The bugs up for review today are available at: (adamw, 16:04:57)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:04:59)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:05:01)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:05:03)
    8. https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria (adamw, 16:05:05)
    9. https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria (adamw, 16:05:07)
    10. coremodule will secretarialize (adamw, 16:05:09)
    11. for Final, we have: (adamw, 16:05:20)
    12. 7 Proposed Blockers (adamw, 16:05:25)
    13. 6 Accepted Blockers (adamw, 16:05:25)
    14. 1 Proposed Freeze Exceptions (adamw, 16:05:28)
    15. let's get started with proposed blockers (adamw, 16:08:51)

  3. (1751673) Second user gets locked out of his session every ~10 seconds (adamw, 16:08:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1751673 (adamw, 16:08:58)
    2. Proposed Blocker, gdm, NEW (adamw, 16:08:58)
    3. AGREED: 1751673 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" (adamw, 16:16:15)

  4. (1750805) Apply button stays gray on Network configuration (adamw, 16:16:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1750805 (adamw, 16:16:24)
    2. Proposed Blocker, gnome-control-center, NEW (adamw, 16:16:24)
    3. AGREED: 1750805 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use." (adamw, 16:19:00)

  5. (1749868) GNOME Software doesn't prepare offline updates (adamw, 16:19:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1749868 (adamw, 16:19:10)
    2. Proposed Blocker, gnome-software, NEW (adamw, 16:19:10)
    3. fesco has asked dnf to revert the change that appears to be causing it (bcotton, 16:20:26)
    4. AGREED: 1749868 - punt (delay decision) - we believe the reversion of the DNF skip_if_unavailable default to True should mean this is no longer a big enough problem to be a blocker, we will confirm this once the reversion is done (adamw, 16:25:59)

  6. (1747408) Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed (adamw, 16:33:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1747408 (adamw, 16:33:50)
    2. Proposed Blocker, libgit2, NEW (adamw, 16:33:50)
    3. AGREED: 1747408 - RejectedBlocker (Final) AcceptedFreezeException (Final) - we reject this as a Final blocker for the same reason we rejected it for Beta: it does not affect any release-blocking default package set, so does not break the criteria. But it's definitely a bad bug and we'd like it resolved if at all possible, and documented if it is not resolved (adamw, 16:48:48)

  7. (1750036) Problem with time syncronization (adamw, 16:50:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1750036 (adamw, 16:50:02)
    2. Proposed Blocker, selinux-policy, ASSIGNED (adamw, 16:50:02)
    3. AGREED: 1750036 - AcceptedBlocker (Final) - this is accepted as a blocker with reference to multiple criteria: default panel functionality (as this affects time configuration), system services (as the service does not really start 'properly'), and domain-related criteria (as lack of time synchronization will often break domain authentication) (adamw, 16:55:01)
    4. adamw is a legend (kparal, 16:55:22)

  8. (1750345) [abrt] gnome-initial-setup: webkitWebViewBaseMakeGLContextCurrent(): gnome-initial-setup killed by SIGSEGV (adamw, 16:55:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1750345 (adamw, 16:55:29)
    2. Proposed Blocker, webkit2gtk3, NEW (adamw, 16:55:29)
    3. AGREED: 1750345 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" (adamw, 17:00:30)

  9. (1751852) Xfce is using upstream desktop background (adamw, 17:00:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1751852 (adamw, 17:00:37)
    2. Proposed Blocker, xfdesktop, ON_QA (adamw, 17:00:37)
    3. AGREED: 1751852 - AcceptedBlocker (Final) - this is accepted as a violation of "The proposed final Fedora artwork must be included and used as the background on release-blocking desktops..." (adamw, 17:04:41)

  10. Proposed Final freeze exception (adamw, 17:05:18)
  11. (1751936) Google account shows just empty window (adamw, 17:05:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1751936 (adamw, 17:05:27)
    2. Proposed Freeze Exceptions, gnome-online-accounts, NEW (adamw, 17:05:28)
    3. AGREED: 1751936 - AcceptedBlocker (Final) - we accept this as a *blocker*, not just an FE, as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" (adamw, 17:11:52)

  12. Accepted blockers (adamw, 17:12:43)
    1. most of these are in a fairly straightforward state and don't need particular followup (adamw, 17:12:54)

  13. (1728240) Cannot start Fedora-KDE-Live (F31) in basic graphics mode on BIOS machine (adamw, 17:13:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1728240 (adamw, 17:13:33)
    2. Accepted Blocker, sddm, NEW (adamw, 17:13:33)
    3. ACTION: frantisekz and lruzicka to further investigate on this bug (sddm (and possibly gdm?) issues with basic graphics mode) (adamw, 17:17:22)

  14. Open floor (adamw, 17:18:25)


Meeting ended at 17:25:02 UTC (full logs).

Action items

  1. frantisekz and lruzicka to further investigate on this bug (sddm (and possibly gdm?) issues with basic graphics mode)


Action items, by person

  1. frantisekz
    1. frantisekz and lruzicka to further investigate on this bug (sddm (and possibly gdm?) issues with basic graphics mode)
  2. lruzicka
    1. frantisekz and lruzicka to further investigate on this bug (sddm (and possibly gdm?) issues with basic graphics mode)


People present (lines said)

  1. adamw (132)
  2. kparal (74)
  3. frantisekz (74)
  4. lruzicka (46)
  5. sgallagh (35)
  6. bcotton (26)
  7. coremodule (21)
  8. zodbot (14)
  9. pwhalen (12)
  10. Southern_Gentlem (5)
  11. satellit_ (2)


Generated by MeetBot 0.1.4.