#fedora-blocker-review: F31-blocker-review

Meeting started by adamw at 16:00:04 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:04)
  2. Introduction (adamw, 16:06:37)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:06:37)
    2. We'll be following the process outlined at: (adamw, 16:06:37)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:40)
    4. The bugs up for review today are available at: (adamw, 16:06:40)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:06:42)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:06:44)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:06:46)
    8. https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria (adamw, 16:06:49)
    9. https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria (adamw, 16:06:50)
    10. for F31 Final, we have: (adamw, 16:06:57)
    11. 12 Proposed Blockers (adamw, 16:06:57)
    12. 7 Accepted Blockers (adamw, 16:06:57)
    13. 3 Proposed Freeze Exceptions (adamw, 16:07:01)
    14. coremodule will secretarialize (adamw, 16:09:26)
    15. we'll start with proposed Final blockers (adamw, 16:09:45)

  3. (1755813) bios boot partition can't be created at the disk beginning, if a partition already exists in the middle of the disk (adamw, 16:09:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1755813 (adamw, 16:09:54)
    2. Proposed Blocker, blivet-gui, ASSIGNED (adamw, 16:09:54)
    3. AGREED: 1755813 - AcceptedBlocker (Final) - this is accepted as a violation of "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration" for installs done via 'advanced custom' partitioning (adamw, 16:17:40)

  4. (1751103) [abrt] dnf: configure_upgrade(): system_upgrade.py:410:configure_upgrade:TypeError: argument of type 'NoneType' is not iterable (adamw, 16:17:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1751103 (adamw, 16:17:49)
    2. Proposed Blocker, dnf, ON_QA (adamw, 16:17:49)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1756105 has more on the gnome-software interaction (adamw, 16:26:27)
    4. AGREED: 1751103 - AcceptedBlocker (Final) - as reported in dupe 1756105 it seems this can be triggered simply by running a normal GNOME update, causing the update to fail silently, so this is accepted as a violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)..." (adamw, 16:34:01)

  5. (1757089) /usr/lib64/samba/pdb/ipasam.so: undefined symbol: unixid_from_gid, version SAMBA_PASSDB_0.2.0 (adamw, 16:34:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1757089 (adamw, 16:34:12)
    2. Proposed Blocker, freeipa, ASSIGNED (adamw, 16:34:12)
    3. AGREED: 1757089 - RejectedBlocker (Final), AcceptedFreezeException (Final) - this is rejected as a blocker as it breaks only if a non-default feature not in the criteria (AD trust) is enabled, but accepted as a freeze exception to help minimize the number of affected upgrades (adamw, 16:39:30)

  6. (1754630) Automatic workspaces are seriously broken (adamw, 16:39:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1754630 (adamw, 16:39:40)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:39:40)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1754630#c12 (frantisekz, 16:43:02)
    4. AGREED: 1754630 - AcceptedBlocker (Final) - this is accepted with reference to both "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" and "All known bugs that can cause corruption of user data must be fixed or documented at Common F31 bugs" (as any Shell crash on Wayland can cause data loss/corruption) (adamw, 16:46:41)

  7. (1755898) numlock handling is seriously broken (adamw, 16:46:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1755898 (adamw, 16:46:48)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:46:48)
    3. ACTION: bcotton and/or kparal and/or anyone else who feels strongly to propose a criterion for this (adamw, 16:53:40)
    4. AGREED: 1755898 - punt (delay decision) for blocker status, AcceptedFreezeException (Final) - there's some support for blocking on this but it really doesn't seem to violate any current criterion; we agreed to allow time to propose and discuss a new criterion. In the mean time it's accepted as an FE issue as a prominent bug that can't be fixed fully with an update (adamw, 16:55:45)

  8. (1749868) GNOME Software doesn't prepare offline updates (adamw, 16:56:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1749868 (adamw, 16:56:02)
    2. Proposed Blocker, gnome-software, NEW (adamw, 16:56:02)
    3. AGREED: 1749868 - RejectedBlocker (Final) - we are still waiting to check the status of this with the dnf default changed back, but to avoid it clogging up the list we're going to assume for now that it'll be fine once that change happens; if it turns out still to be a problem it can be re-proposed (adamw, 17:01:19)

  9. (1703700) Newer kernels do not boot and have invalid grub.cfg entries (adamw, 17:01:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1703700 (adamw, 17:01:37)
    2. Proposed Blocker, grub2, NEW (adamw, 17:01:37)
    3. AGREED: 1703700 - punt (delay decision) - the details of the issue here are not yet entirely clear so it's hard to decide if it's a blocker, also we're not sure yet if we intend to complete the criterion change to block only on ec2 rather than all xen guest functionality (adamw, 17:14:17)

  10. (1752961) After upgrading to Fedora 31 got a kernel panic loading 5.3.0 kernel (adamw, 17:14:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1752961 (adamw, 17:14:22)
    2. Proposed Blocker, kernel, NEW (adamw, 17:14:22)
    3. AGREED: 1752961 - punt (delay decision) on blocker, AcceptedFreezeException (Final) - this is clearly worthy of an FE, we're not sure if it will affect enough systems to qualify as a blocker yet (adamw, 17:23:14)

  11. (1751646) Images to clipboard don't work, clipboard doesn't contain any data (adamw, 17:23:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1751646 (adamw, 17:23:20)
    2. Proposed Blocker, mutter, NEW (adamw, 17:23:20)
    3. https://gitlab.gnome.org/GNOME/mutter/issues/789 has more detailed reproduction steps (adamw, 17:28:07)
    4. AGREED: 1751646 - RejectedBlocker (Final) AcceptedFreezeException (Final) - we agreed this is an unfortunate bug but it doesn't clearly violate an existing criterion and we don't think it's serious enough to consider writing a new one. Accepted as an FE as it will affect lives and so cannot be fully fixed with an update (adamw, 17:35:27)

  12. (1750123) blivet unable to use all the usable freespace regions (adamw, 17:35:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1750123 (adamw, 17:35:38)
    2. Proposed Blocker, python-blivet, NEW (adamw, 17:35:38)
    3. AGREED: 1750123 - RejectedBlocker (Final) - this seems to be more a design limitation in the custom partitioning UI than a clear bug, and is not a regression; it's not really suitable for treatment as a blocker bug. We'll hold that it doesn't violate the criterion as the installer is not "offering" to create the layout in question (adamw, 17:41:16)

  13. (1755038) VM clipboard integration wipes clipboard contents randomly and frequently (X11 host) (adamw, 17:41:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1755038 (adamw, 17:41:22)
    2. Proposed Blocker, spice-vdagent, NEW (adamw, 17:41:22)
    3. AGREED: 1755038 - RejectedBlocker (Final) AcceptedFreezeException (Final) - we think a bug of this nature could conceivably be a blocker under various criteria, but as this one only manifests when using an X11 session (not default in most cases) *and* running a virtual machine, we agreed it's slightly too limited in impact. Accepted as an FE as it can't be fixed for lives with an update (adamw, 17:55:30)

  14. (1755733) Gnome Xorg session stuck immediately after login (adamw, 17:55:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1755733 (adamw, 17:55:41)
    2. Proposed Blocker, xorg-x11-server, NEW (adamw, 17:55:41)
    3. ACTION: adamw to send out call for testing on 1755733 (adamw, 18:02:23)
    4. AGREED: 1755733 - punt (delay decision) - so far we can only be sure one system has a problem here; we need to test more systems to assess blocker and FE status (adamw, 18:03:52)

  15. Proposed freeze exceptions (adamw, 18:04:13)
    1. moving onto Proposed freeze exception issues (adamw, 18:04:20)
    2. we already accepted 1757089 earlier (adamw, 18:04:44)

  16. (1754875) nm-connection-editor not available in overview (adamw, 18:04:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1754875 (adamw, 18:04:50)
    2. Proposed Freeze Exceptions, network-manager-applet, NEW (adamw, 18:04:50)
    3. AGREED: 1754875 - RejectedFreezeException (Final) - we're generally agreed that the risk/reward for changing this during a freeze period would not be worthwhile (adamw, 18:11:47)

  17. (1756024) Qt applications cannot be maximized with double click in title bar (adamw, 18:11:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1756024 (adamw, 18:11:57)
    2. Proposed Freeze Exceptions, qgnomeplatform, NEW (adamw, 18:11:57)
    3. AGREED: 1756024 - RejectedFreezeException (Final) - we're not aware of any prominent Qt apps on the Workstation live image, so we think this can be fixed just as well with an update as a freeze exception (adamw, 18:21:07)

  18. (1756771) f31 sugar fails to install (adamw, 18:21:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1756771 (adamw, 18:21:43)
    2. Proposed Freeze Exceptions, sugar, NEW (adamw, 18:21:43)
    3. AGREED: 1756771 - punt (delay decision) - we believe this should be fixed 'magically' with the next compose as the package was unretired. if not, we will re-evaluate next week (adamw, 18:27:42)
    4. that's all proposed blockers and FEs (adamw, 18:27:54)

  19. Accepted blockers (adamw, 18:27:58)
    1. most accepted blockers are in a straightforward state - mainly waiting on developers (adamw, 18:28:14)

  20. (1747408) Cannot upgrade to Fedora 31: package exa-0.9.0-2.module_f31+5365+04413d87.x86_64 requires libgit2.so.28()(64bit), but none of the providers can be installed (adamw, 18:28:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1747408 (adamw, 18:28:26)
    2. Accepted Blocker, distribution, NEW (adamw, 18:28:26)
    3. ACTION: bcotton to follow up on 1747408 and try to get some movement (adamw, 18:31:43)

  21. (1752249) Revert skip_if_unavailable default back to true (adamw, 18:31:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1752249 (adamw, 18:31:52)
    2. Accepted Blocker, dnf, ASSIGNED (adamw, 18:31:52)
    3. this seems fairly straightforward but has been hanging for weeks (adamw, 18:32:14)
    4. ACTION: adamw and bcotton to prod dnf team into taking care of 1752249 (adamw, 18:32:35)

  22. (1728240) Cannot start Fedora-KDE-Live (F31) in basic graphics mode on BIOS machine (adamw, 18:34:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1728240 (adamw, 18:34:04)
    2. Accepted Blocker, sddm, NEW (adamw, 18:34:04)
    3. there is one pretty clear-cut issue here, that sddm simply fails to start when doing a BIOS nomodeset boot, but there doesn't seem to be clear progress towards a resolution (adamw, 18:34:45)
    4. ACTION: frantisekz to file an upstream report for #1728240 (adamw, 18:36:40)

  23. Open floor (adamw, 18:37:47)


Meeting ended at 18:45:35 UTC (full logs).

Action items

  1. bcotton and/or kparal and/or anyone else who feels strongly to propose a criterion for this
  2. adamw to send out call for testing on 1755733
  3. bcotton to follow up on 1747408 and try to get some movement
  4. adamw and bcotton to prod dnf team into taking care of 1752249
  5. frantisekz to file an upstream report for #1728240


Action items, by person

  1. adamw
    1. adamw to send out call for testing on 1755733
    2. adamw and bcotton to prod dnf team into taking care of 1752249
  2. bcotton
    1. bcotton and/or kparal and/or anyone else who feels strongly to propose a criterion for this
    2. bcotton to follow up on 1747408 and try to get some movement
    3. adamw and bcotton to prod dnf team into taking care of 1752249
  3. frantisekz
    1. frantisekz to file an upstream report for #1728240
  4. kparal
    1. bcotton and/or kparal and/or anyone else who feels strongly to propose a criterion for this


People present (lines said)

  1. adamw (337)
  2. frantisekz (106)
  3. kparal (102)
  4. bcotton (56)
  5. pwhalen (32)
  6. lruzicka (32)
  7. zodbot (23)
  8. coremodule (18)
  9. cmurf (10)
  10. tablepc (9)
  11. Southern_Gentlem (5)
  12. satellit_ (3)
  13. Son_Goku (3)


Generated by MeetBot 0.1.4.