#fedora-blocker-review: F31-blocker-review

Meeting started by adamw at 16:02:59 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:59)
  2. Introduction (adamw, 16:07:38)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:39)
    2. We'll be following the process outlined at: (adamw, 16:07:39)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:39)
    4. The bugs up for review today are available at: (adamw, 16:07:40)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:42)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:46)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:48)
    8. https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria (adamw, 16:07:50)
    9. https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria (adamw, 16:07:52)
    10. For F31 Final, we have: (adamw, 16:07:54)
    11. 5 Proposed Blockers (adamw, 16:07:56)
    12. 7 Accepted Blockers (adamw, 16:07:58)
    13. 2 Proposed Freeze Exceptions (adamw, 16:08:00)
    14. 4 Accepted Freeze Exceptions (adamw, 16:08:02)
    15. coremodule will secretarialize (adamw, 16:08:04)
    16. without further ado, let's start in with proposed Final blockers (adamw, 16:08:12)

  3. (1757948) fwupd.service fails to start if /var/cache/fwupd doesn't exist (e.g. clean install) (adamw, 16:08:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1757948 (adamw, 16:08:20)
    2. Proposed Blocker, fwupd, ASSIGNED (adamw, 16:08:20)
    3. https://openqa.fedoraproject.org/tests/464372#step/desktop_update_graphical/30 (adamw, 16:10:21)
    4. AGREED: 1757948 - AcceptedBlocker (Final) - this is a clear violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)." (adamw, 16:13:59)

  4. (1755898) numlock handling is seriously broken (adamw, 16:14:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1755898 (adamw, 16:14:06)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:14:06)
    3. AGREED: 1755898 - AcceptedBlocker (Final) - per list and meeting discussion of bcotton's proposed criterion, we agree in principle to block on modifier key toggling working well and consistently throughout the system, but not on the light state being correct (as that is difficult to guarantee). consequently the 'shell and apps behave differently' portion of this is accepted (adamw, 16:28:24)

  5. (1758873) Regression: X selection buffers are not available to Qt applications (adamw, 16:28:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1758873 (adamw, 16:28:48)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:28:48)
    3. AGREED: 1758873 - punt (delay decision) - this does not clearly come under any existing criteria, but we may be open to considering a new one; however, we want to do more testing to identify the exact extent of the problem first (adamw, 16:39:45)

  6. (1759215) Alt-tab for siwtching-windows does not work (adamw, 16:39:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1759215 (adamw, 16:39:54)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:39:54)
    3. AGREED: 1759215 - RejectedBlocker (Final) - so far, the bug as we understand it does not really violate the criteria or appear serious enough to block the release, and may not even be reproducible. It can be re-proposed if more information emerges that makes it seem more serious (adamw, 16:52:20)

  7. (1703700) Newer kernels do not boot and have invalid grub.cfg entries (on Xen DomU guests) (adamw, 16:52:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1703700 (adamw, 16:52:26)
    2. Proposed Blocker, grub2, NEW (adamw, 16:52:26)
    3. AGREED: 1703700 - punt (delay decision) again - we meant to re-test this from scratch last week, but didn't manage to. we will pull the xen folks in on the bug this week and see if any progress can be made before finally deciding what to do next week (adamw, 17:09:22)

  8. Proposed freeze exceptions (adamw, 17:10:03)
    1. let's move onto the proposed FEs (adamw, 17:10:07)

  9. (1759186) Include GNOME 3.34.1 in Fedora 31 Final (adamw, 17:10:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1759186 (adamw, 17:10:14)
    2. Proposed Freeze Exceptions, distribution, NEW (adamw, 17:10:14)
    3. AGREED: 1759186 - AcceptedFreezeException (Final) - we agree it makes sense to pull this in early in freeze as it is a bug fix release and addresses many bugs that were encountered and reported in Fedora 31 Beta testing (adamw, 17:16:12)

  10. (1746413) selinux blocks dbus-broker from starting (adamw, 17:16:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1746413 (adamw, 17:16:18)
    2. Proposed Freeze Exceptions, selinux-policy-targeted, POST (adamw, 17:16:19)
    3. AGREED: 1746413 - AcceptedFreezeException (Final) - this is accepted as an FE as a showstopping issue on a non-blocking arch that cannot be fixed with an update alone (adamw, 17:20:00)

  11. Proposed Final blockers, redux (adamw, 17:20:24)
    1. we have a new proposed Final blocker, so let's cover that now (adamw, 17:20:31)

  12. (1759221) after changing Formats to Germany then back to English, localectl shows Germany even after a reboot (adamw, 17:20:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1759221 (adamw, 17:20:32)
    2. Proposed Blocker, gnome-control-center, NEW (adamw, 17:20:32)
    3. AGREED: 1759221 - AcceptedBlocker (Final) - this is accepted as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" (this counts as 'basic functionality' of the Language and Formats applet) (adamw, 17:31:18)

  13. Accepted Final blockers (adamw, 17:33:11)
    1. there has been some movement on 1747408 at least, which is good (adamw, 17:33:40)
    2. and also a bit on 1728240 (adamw, 17:34:22)
    3. aside from that, we're mostly waiting on devs to fix each bug (adamw, 17:35:15)
    4. progress is happening upstream on all the GNOME blockers (adamw, 17:40:22)

  14. Open floor (adamw, 17:41:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1759193 (gnome-software regression after appstream-glib update) looks blockerish (kalev, 17:43:28)

  15. proposed Final blocker redux redux (adamw, 17:44:20)
    1. there is one more bug supposed to be proposed as a blocker which was not showing up (adamw, 17:44:30)

  16. (1750575) dnfdragora complains that dnf is locked by another process after updates (adamw, 17:45:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1750575 (adamw, 17:45:29)
    2. Proposed Blockers, libdnf, NEW (adamw, 17:45:42)

  17. (1750575) dnfdragora complains that dnf is locked by another process after updates (adamw, 18:05:36)
    1. AGREED: 1750575 - punt (delay decision) - we did not have enough votes for a clear decision on this in meeting; we will ask for votes in-bug to get a clearer decision (adamw, 18:05:41)

  18. Open floor (adamw, 18:05:45)


Meeting ended at 18:07:46 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (222)
  2. cmurf (78)
  3. kparal (53)
  4. kalev (41)
  5. coremodule (35)
  6. frantisekz (28)
  7. pwhalen (17)
  8. zodbot (15)
  9. tablepc (6)
  10. mclasen (4)
  11. mkolman (3)
  12. satellit_ (1)


Generated by MeetBot 0.1.4.