#fedora-blocker-review: F32-blocker-review

Meeting started by adamw at 16:01:02 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:02)
  2. Introduction (adamw, 16:07:16)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:16)
    2. We'll be following the process outlined at: (adamw, 16:07:16)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:18)
    4. The bugs up for review today are available at: (adamw, 16:07:18)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:20)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:22)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:24)
    8. https://fedoraproject.org/wiki/Fedora_32_Beta_Release_Criteria (adamw, 16:07:26)
    9. https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria (adamw, 16:07:28)
    10. for Beta, we have: (adamw, 16:07:47)
    11. 5 Proposed Blockers (adamw, 16:07:48)
    12. 4 Accepted Blockers (adamw, 16:07:48)
    13. 1 Accepted Previous Release Blockers (adamw, 16:07:53)
    14. 12 Proposed Freeze Exceptions (adamw, 16:07:53)
    15. 1 Accepted Freeze Exceptions (adamw, 16:07:53)
    16. for Final, we have: (adamw, 16:07:56)
    17. 3 Proposed Blockers (adamw, 16:08:07)
    18. 3 Accepted Blockers (adamw, 16:08:07)
    19. coremodule will secretarialize, with adamw as emergency cover (adamw, 16:08:43)

  3. Proposed Beta blockers (adamw, 16:09:00)
  4. (1807252) bootloader entry missing after installation on armhfp (adamw, 16:09:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1807252 (adamw, 16:09:06)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 16:09:06)
    3. AGREED: 1807252 - punt (delay decision) - we still don't have definitive word on whether we should block on 32-bit ARM installer issues currently, but this is accepted FE and a fix will be included in the next build (adamw, 16:17:02)

  5. (1810963) Support OpenDNSSEC 2.1 in FreeIPA (adamw, 16:17:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1810963 (adamw, 16:17:11)
    2. Proposed Blocker, freeipa, ASSIGNED (adamw, 16:17:11)
    3. AGREED: 1807252 - RejectedBlocker (Beta), RejectedFreezeException (Beta) - as we understand it this bug is a request to pull a new opendnssec and a FreeIPA build updated to work with it into Beta. This is clearly not release-blocking as it doesn't fix some criteria-breaking bug we have in current Beta packages. We also reject it as for FE status as we think it's not 'baked' enough yet given where we are in the Beta cycle (adamw, 16:27:07)

  6. (1807661) Display corruption on aarch64 virtual machines (adamw, 16:27:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1807661 (adamw, 16:27:14)
    2. Proposed Blocker, kernel, NEW (adamw, 16:27:14)
    3. AGREED: 1807661 - AcceptedBlocker (Beta) - accepted as a violation of "The release must be able host virtual guest instances of the same release" and for its impact on aarch64 testing coverage (adamw, 16:39:26)

  7. (1809117) mdadm udev rules are installed in a wrong folder (adamw, 16:40:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1809117 (adamw, 16:40:02)
    2. Proposed Blocker, mdadm, ON_QA (adamw, 16:40:02)
    3. AGREED: 1809117 - punt (delay decision) on blocker status, AcceptedFreezeException (Beta) - this is clearly a bad bug and we'd like it fixed for Beta. there are a couple of outstanding questions that prevent us deciding blocker status yet. There is a possibility the bug is the same as 1804080, which is already a blocker: we will test to confirm this, and close the bug as a dupe if they turn out to be the same (adamw, 16:49:24)

  8. (1810070) LUKS password prompt is not shown with more displays connected (adamw, 16:49:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1810070 (adamw, 16:49:38)
    2. Proposed Blocker, plymouth, ON_QA (adamw, 16:49:38)
    3. AGREED: 1810070 - RejectedBlocker (Beta), AcceptedFreezeException (Beta), AcceptedBlocker (Final) - rejected as Beta blocker but accepted Final blocker under "A system installed with a release-blocking desktop must boot to a log in screen..." for encrypted installs with affected display configurations. Accepted as a Beta FE as we obviously would like affected systems to work in Beta as well (adamw, 16:58:40)
    4. since Beta is close, and we have a lot of them, let's move onto... (adamw, 16:58:58)

  9. Proposed Beta freeze exceptions (adamw, 16:59:06)
  10. (1811708) Include GNOME 3.36.0 in F32 Beta (adamw, 16:59:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1811708 (adamw, 16:59:20)
    2. Proposed Freeze Exceptions, distribution, NEW (adamw, 16:59:20)
    3. AGREED: 1811708 - AcceptedFreezeException (Beta) - this is accepted, but provisionally: we do not intend to actually pull 3.36.0 in if we stay on schedule to sign off Beta this week, but will consider pulling it in if it becomes clear we will not be signing off on Thursday (adamw, 17:09:35)

  11. (1809831) Firefox outdated (72.0.2) on Fedora 32 due to multiple build failures (adamw, 17:09:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1809831 (adamw, 17:09:47)
    2. Proposed Freeze Exceptions, firefox, MODIFIED (adamw, 17:09:47)
    3. AGREED: 1809831 - AcceptedFreezeException (Beta) - this is accepted as there are clear obvious benefits to ensuring latest Firefox is in Beta release images (security, avoiding negative first impressions) (adamw, 17:13:20)

  12. (1774746) iscsi login fails during install with "buf[20] !sufficient to decode string[66]" since Fedora-Rawhide-20191119.n.2 (adamw, 17:13:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1774746 (adamw, 17:13:42)
    2. Proposed Freeze Exceptions, iscsi-initiator-utils, ON_QA (adamw, 17:13:42)
    3. AGREED: 1774746 - AcceptedFreezeException (Beta) - accepted as a clear installation bug that can't be fixed with an update or worked around (adamw, 17:19:15)

  13. (1809681) kernel-5.6-rc#: Only 1 of 2 monitors lights up on DP-MST docks (adamw, 17:19:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1809681 (adamw, 17:19:26)
    2. Proposed Freeze Exceptions, kernel, VERIFIED (adamw, 17:19:26)
    3. AGREED: 1809681 - AcceptedFreezeException (Beta) - this is accepted as it's a significant fix that can't be fully deployed via update for affected systems, but note we may exercise restraint and not pull an available fix if it comes with much other kernel change, depending on timing (adamw, 17:24:40)

  14. (1807737) lzo 2.10-1 violates ISO C alias rules (adamw, 17:24:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1807737 (adamw, 17:24:57)
    2. Proposed Freeze Exceptions, lzo, NEW (adamw, 17:24:57)
    3. AGREED: 1807737 - AcceptedFreezeException (Beta) - accepted as a freeze exception as it breaks openvpn using lzo compression on live images (adamw, 17:36:54)

  15. (1811178) Include llvm 10 instead of llvm 9 on F32 Beta media (adamw, 17:37:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1811178 (adamw, 17:37:19)
    2. Proposed Freeze Exceptions, mesa, MODIFIED (adamw, 17:37:19)
    3. AGREED: 1811178 - RejectedFreezeException (Beta) - we don't think there's a strong enough justification to include this and think it'd make more sense for it just to go out as a regular update (adamw, 17:39:54)

  16. (1810907) upgrade to F32 changes the default image viewer from eog to gimp (adamw, 17:40:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1810907 (adamw, 17:40:02)
    2. Proposed Freeze Exceptions, shared-mime-info, VERIFIED (adamw, 17:40:02)
    3. AGREED: 1810907 - AcceptedFreezeException (Beta) - this is accepted as a visible and annoying upgrade issue: we tend to grant FEs to upgrade issues as upgrades usually run with updates-testing disabled, so it is good to push fixes for annoying upgrade issues stable (adamw, 17:45:17)

  17. (1810705) PipeWire has been requested for inclusion in Fedora Jam (adamw, 17:45:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1810705 (adamw, 17:45:25)
    2. Proposed Freeze Exceptions, spin-kickstarts, NEW (adamw, 17:45:25)
    3. AGREED: 1810705 - AcceptedFreezeException (Beta) - this looks like a reasonable change which can't have an effect outside the spin it's intended for (adamw, 17:50:11)

  18. (1808564) Wi-fi networks not displayed in F32 SoaS (works in F31 SoaS) spin (adamw, 17:50:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1808564 (adamw, 17:50:52)
    2. Proposed Freeze Exceptions, sugar, ON_QA (adamw, 17:50:52)
    3. AGREED: 1808564 - AcceptedFreezeException (Beta) - this is a significant issue in Sugar, which is mainly used live and so obviously cannot be fixed with an update (adamw, 17:53:44)

  19. (1738982) sugar-pippy depends on Python 2 (adamw, 17:53:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1738982 (adamw, 17:53:48)
    2. Proposed Freeze Exceptions, sugar-pippy, ON_QA (adamw, 17:53:49)
    3. AGREED: 1738982 - AcceptedFreezeException (Beta) - accepted as it's clearly good to try and get Python 2 out of the Sugar image compose, and we can't do it for Beta with an update (adamw, 17:56:39)

  20. (1811740) Move back grubby to @core group (adamw, 17:57:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1811740 (adamw, 17:57:00)
    2. Proposed Freeze Exceptions, comps, NEW (adamw, 17:57:00)
    3. AGREED: 1811740 - AcceptedFreezeException (Beta) - it's not entirely clear whether this change should happen as requested, but *if* we're going to change it, it would make sense for the change to be in Beta to help discover any issues it causes. (adamw, 18:12:58)

  21. proposed Final blockers (adamw, 18:16:34)
  22. (1811382) anaconda failed to login to the iscsi target (adamw, 18:16:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1811382 (adamw, 18:16:54)
    2. Proposed Blocker, anaconda, ASSIGNED (adamw, 18:16:54)
    3. AGREED: 1811382 - punt (delay decision) - we believe this is very likely to be a duplicate of 1774746, so we will delay the decision while we confirm that (adamw, 18:21:34)

  23. (1803996) systemd-ask-password-console.service: Unit configuration has fatal error (adamw, 18:21:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1803996 (adamw, 18:21:35)
    2. Proposed Blocker, dracut, ON_QA (adamw, 18:21:35)
    3. AGREED: 1803996 - punt (delay decision) - it's not clear whether/when this actually manifests as a failed service in systemctl --failed, and it's also not clear what its practical effect is. also, anaconda team has alerted us that dracut 050 breaks kickstart installs, so we cannot simply pull in dracut 050 to fix this. with all of those considerations, we will punt on this for now to try and investigate the bug further and come up with a plan (adamw, 18:34:34)

  24. (1795524) SELinux denials for 'setsched' force glib down a fallback path with performance implications (adamw, 18:35:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1795524 (adamw, 18:35:10)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 18:35:10)
    3. AGREED: 1795524 - RejectedBlocker (Final) - this is a bit messy, but it seems there is no criteria violation. We do not install the component that shows AVCs as desktop notifications any more, so that criterion is not violated even though AVCs are occurring (adamw, 18:53:02)

  25. Open floor (adamw, 18:56:00)
    1. https://pagure.io/fedora-qa/issue/623 and https://pagure.io/fedora-qa/issue/618 are still open (adamw, 18:57:00)
    2. IoT status still unclear for Beta, I will try and follow up with appropriate authorities (adamw, 19:01:33)


Meeting ended at 19:03:16 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (342)
  2. cmurf (90)
  3. Southern_Gentlem (66)
  4. pwhalen (52)
  5. kalev (44)
  6. kparal (43)
  7. lruzicka2 (41)
  8. frantisekz (16)
  9. sgallagh (14)
  10. zodbot (13)
  11. jkonecny (9)
  12. jsmith (9)
  13. coremodule (7)
  14. nirik (2)


Generated by MeetBot 0.1.4.