#fedora-blocker-review: F32-blocker-review

Meeting started by adamw at 16:00:40 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:41)
  2. Introduction (adamw, 16:07:59)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:59)
    2. We'll be following the process outlined at: (adamw, 16:07:59)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:59)
    4. The bugs up for review today are available at: (adamw, 16:08:01)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:03)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:05)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:08:07)
    8. https://fedoraproject.org/wiki/Fedora_32_Beta_Release_Criteria (adamw, 16:08:11)
    9. https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria (adamw, 16:08:13)
    10. for Final, we have: (adamw, 16:08:42)
    11. 8 Proposed Blockers (adamw, 16:08:43)
    12. 1 Accepted Blockers (adamw, 16:08:43)
    13. 2 Proposed Freeze Exceptions (adamw, 16:09:08)
    14. 1 Accepted Freeze Exceptions (adamw, 16:09:08)
    15. coremodule will secretarialize (adamw, 16:10:09)

  3. Proposed Final blockers (adamw, 16:10:17)
  4. (1768206) DNF prompts for GPG key import for "repo_gpgcheck=1"-repositories despite "rpm --import"-ing the keys first (adamw, 16:11:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1768206 (adamw, 16:11:08)
    2. Proposed Blocker, dnf, NEW (adamw, 16:11:08)
    3. AGREED: 1768206 - AcceptedBlocker (Final) - accepted as a clear violation of "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present" for the Cloud default install. note blocker aspect can be resolved by adjusting the service, without fixing the underlying dnf issue (adamw, 16:19:06)

  5. (1803996) systemd-ask-password-console.service: Unit configuration has fatal error (adamw, 16:19:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1803996 (adamw, 16:19:15)
    2. Proposed Blocker, dracut, ON_QA (adamw, 16:19:15)
    3. AGREED: 1803996 - punt (delay decision) again - we still don't have follow up on this. this time we'll needinfo cmurf expressly to check it out further and also see if the update fixes it (adamw, 16:26:05)

  6. (1814370) gnome-clocks won't add a new world clock (adamw, 16:26:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1814370 (adamw, 16:26:13)
    2. Proposed Blocker, gnome-clocks, NEW (adamw, 16:26:13)
    3. AGREED: 1814370 - RejectedBlocker (Final) - so far we only have one system that hits this out of 5 or 6 that have tried, so it doesn't seem widespread enough to justify blocker status. we are open to reconsider if more information emerges (adamw, 16:32:04)

  7. (1815487) X11 session is broken ('Something has gone wrong') in VMs (adamw, 16:32:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815487 (adamw, 16:32:14)
    2. Proposed Blocker, gnome-session, NEW (adamw, 16:32:14)
    3. https://www.virtualbox.org/ticket/13471 (frantisekz, 16:40:39)
    4. AGREED: 1815487 - RejectedBlocker (Final) - as so far this is believed to affect virtual environments only, it is rejected on the basis that there is no situation in which the criteria require GNOME-on-X11 to work on our supported virtualization stack (Wayland is the default and should always work) (adamw, 17:12:16)

  8. (1809717) Update gnome-shell to version 3.35.92-1 brings a lot of problems (adamw, 17:12:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1809717 (adamw, 17:12:31)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 17:12:31)
    3. ACTION: adamw to send out request for testing (adamw, 17:22:45)
    4. AGREED: 1809717 - punt (delay decision) - as we understand it, the remaining issue here is 4K display on X11 not working properly. This would be a significant issue if it affects a reasonable range of hardware. We will send out a call for people to test 4K-on-X11 on various graphics hardware and see how widespread the issue is (adamw, 17:25:31)

  9. (1815544) libreport crashes when trying to report a crash on X11 (BadAlloc) (adamw, 17:25:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815544 (adamw, 17:25:43)
    2. Proposed Blocker, libreport, ON_QA (adamw, 17:25:43)
    3. AGREED: 1815544 - AcceptedBlocker (Final) - this is accepted as a conditional violation of the app "basic functionality" criterion, when abrt gui runs on X11, since it is part of default KDE install and KDE uses X11 by default, and even some GNOME installs fall back on X11 (adamw, 17:36:00)

  10. (1815463) It's impossible to create another user account through KDE System Settings (adamw, 17:36:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815463 (adamw, 17:36:54)
    2. Proposed Blocker, plasma-systemsettings, NEW (adamw, 17:36:54)
    3. AGREED: 1815463 - AcceptedBlocker (Final) - this is accepted as a violation of the "Default application functionality" Final criterion. System Settings is not currently among the specified apps for KDE but we agreed in the meeting that this was an oversight and it will be added, thus this bug can be accepted (adamw, 17:48:11)

  11. (1797531) Confusing error when running container with parameter --rm (adamw, 17:48:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1797531 (adamw, 17:48:35)
    2. Proposed Blocker, podman, VERIFIED (adamw, 17:48:35)
    3. AGREED: 1797531 - RejectedBlocker (Final) AcceptedFreezeException (Final) - there are (still) no criteria at all requiring podman/container functionality to work at all so we really cannot block on this. However, it's obviously important functionality these days that we would want to work at release, so accepted as an FE issue (adamw, 17:56:27)

  12. Proposed Final freeze exceptions (adamw, 17:56:44)
    1. that's all the proposed blockers, moving onto proposed FEs (adamw, 17:56:50)

  13. (1809096) Progressbar during offline upgrade phase gets reset after entering "Verifying phase" (adamw, 17:56:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1809096 (adamw, 17:56:51)
    2. Proposed Freeze Exceptions, dnf-plugins-extras, POST (adamw, 17:56:51)
    3. AGREED: 1809096 - RejectedFreezeException (Final) - as this needs to be fixed in F30 and F31 for upgrades to F32, there is no justification for an F32 freeze exception, it would not achieve anything (adamw, 18:07:02)

  14. (1812449) The cursor position isn't correct during pre-editing (adamw, 18:07:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1812449 (adamw, 18:07:12)
    2. Proposed Freeze Exceptions, mutter, NEW (adamw, 18:07:12)
    3. AGREED: 1812449 - AcceptedFreezeException (Final) - this is very inconvenient for the default Japanese input method and various other similar ones, and cannot be fixed for live environments with an update (adamw, 18:20:15)

  15. Open floor (adamw, 18:20:24)


Meeting ended at 18:27:07 UTC (full logs).

Action items

  1. adamw to send out request for testing


Action items, by person

  1. adamw
    1. adamw to send out request for testing


People present (lines said)

  1. adamw (259)
  2. kparal (132)
  3. frantisekz (79)
  4. lruzicka (65)
  5. coremodule (28)
  6. sgallagh (21)
  7. zodbot (14)
  8. pwhalen (10)
  9. King_InuYasha (4)
  10. tflink (1)


Generated by MeetBot 0.1.4.