#fedora-blocker-review: F32-blocker-review

Meeting started by adamw at 16:00:12 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:12)
  2. Introduction (adamw, 16:09:48)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:48)
    2. We'll be following the process outlined at: (adamw, 16:09:48)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:50)
    4. The bugs up for review today are available at: (adamw, 16:09:50)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:09:52)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:09:56)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:09:58)
    8. https://fedoraproject.org/wiki/Fedora_32_Beta_Release_Criteria (adamw, 16:10:00)
    9. https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria (adamw, 16:10:02)
    10. for Final, we have: (adamw, 16:10:17)
    11. 4 Proposed Blockers (adamw, 16:10:17)
    12. 4 Accepted Blockers (adamw, 16:10:18)
    13. 2 Proposed Freeze Exceptions (adamw, 16:10:21)
    14. coremodule will secretarialize, thanks (adamw, 16:10:39)

  3. Proposed Final blockers (adamw, 16:10:59)
  4. (1816621) Second suspend does not work (adamw, 16:11:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1816621 (adamw, 16:11:08)
    2. Proposed Blocker, kernel, ON_QA (adamw, 16:11:08)
    3. AGREED: 1816621 - punt (delay decision) on blocker, AcceptedFreezeException (Final) - there is some support for blocking on suspend issues on widely-used laptop models, but we do not currently have this in the criteria, so we will delay blocker decision to allow proposals. Accepted as an FE issue as a very visible bug on widely-used hardware (adamw, 16:24:25)

  5. (1814015) System freeze.locksup when using wayland on P53 (adamw, 16:25:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1814015 (adamw, 16:25:16)
    2. Proposed Blocker, mutter, NEW (adamw, 16:25:16)
    3. AGREED: 1814015 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this seems to affect only one laptop model and there is a known workaround, so it is not considered broad enough in impact to be a release blocker, but is accepted as an FE as a significant and highly visible bug on a relatively popular piece of hardware (adamw, 16:32:07)

  6. (1817708) The desktop session will not start. (adamw, 16:32:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1817708 (adamw, 16:32:15)
    2. Proposed Blocker, plasma-desktop, NEW (adamw, 16:32:15)
    3. AGREED: 1817708 - punt (delay decision) - this could be a serious problem, but so far it only seems to reliably affect an openQA environment. We will send out a call for testing to see if many people hit this bug in 'real world' environments (adamw, 16:40:01)
    4. ACTION: adamw to send out call for testing for 1817708 (adamw, 16:40:08)

  7. (1819749) KDE login screen cannot handle expired passwords. (adamw, 16:41:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1819749 (adamw, 16:41:34)
    2. Proposed Blocker, sddm, NEW (adamw, 16:41:34)
    3. AGREED: 1819749 - RejectedBlocker (Final) - this is not a clear criteria violation. at best it's a conditional violation of the 'log in/out' criterion, it is not a regression but an unimplemented feature upstream, so we don't think it is significant enough to constitute a blocker (adamw, 16:47:37)
    4. that's all the proposed blockers (adamw, 16:47:50)

  8. Proposed Final freeze exception issues (adamw, 16:47:56)
  9. (1819296) [abrt] geoclue2: g_type_check_instance(): geoclue killed by SIGSEGV (adamw, 16:48:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1819296 (adamw, 16:48:03)
    2. Proposed Freeze Exceptions, geoclue2, NEW (adamw, 16:48:03)
    3. Geoclue is a D-Bus service that provides location information. The goal of the Geoclue project is to make creating location-aware applications as simple as possible. (bcotton, 16:51:44)
    4. AGREED: 1819296 - punt (delay decision) - this one isn't definitely serious enough to take as an FE (or blocker) on current information, we would like more info on the details of the bug and fix before making a decision (adamw, 16:59:58)

  10. (1819749) KDE login screen cannot handle expired passwords. (adamw, 17:00:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1819749 (adamw, 17:00:20)
    2. Proposed Freeze Exceptions, sddm, NEW (adamw, 17:00:20)
    3. AGREED: 1819749 - RejectedFreezeException (Final) - fixing this seems to require implementing a missing feature in SDDM, which would be a very significant change and too disruptive to risk during a freeze (adamw, 17:06:29)
    4. that's all proposed FEs, moving onto accepted blockers (adamw, 17:06:59)

  11. Accepted Final Blocker review (adamw, 17:07:04)
  12. (1768206) DNF prompts for GPG key import for "repo_gpgcheck=1"-repositories despite "rpm --import"-ing the keys first (adamw, 17:07:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1768206 (adamw, 17:07:07)
    2. Accepted Blocker, dnf, NEW (adamw, 17:07:07)
    3. we are worried at the apparent lack of an agreed plan here (adamw, 17:10:43)
    4. ACTION: bcotton to bring 1768206 up during the DNF meeting on Wednesday (adamw, 17:11:02)
    5. ACTION: nirik to investigate viability / silliness of https://bugzilla.redhat.com/show_bug.cgi?id=1768206#c21 option d) (adamw, 17:18:41)

  13. (1816547) Firefox not using langpacks for localization (adamw, 17:21:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1816547 (adamw, 17:21:34)
    2. Accepted Blocker, firefox, NEW (adamw, 17:21:34)
    3. ACTION: adamw to poke mstransky directly to get this one moving (adamw, 17:25:58)

  14. (1813515) [abrt] gnome-shell: cogl_matrix_stack_pop(): gnome-shell killed by SIGSEGV (adamw, 17:26:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1813515 (adamw, 17:26:04)
    2. Accepted Blocker, gnome-shell, ON_QA (adamw, 17:26:04)
    3. feedback indicates the mega-update did indeed fix this bug, so we will close it. (adamw, 17:30:33)

  15. (1815463) Cannot create another user account through KDE System Settings if 'Real Name' field is not filled in (adamw, 17:31:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815463 (adamw, 17:31:17)
    2. Accepted Blocker, plasma-user-manager, NEW (adamw, 17:31:17)
    3. this bug is now known to be somewhat narrower than when we accepted it as a blocker (it only happens if the 'real name' field is not filled in) (adamw, 17:37:53)
    4. ACTION: rdieter to investigate possibility of patching 'real name' field to be mandatory as a workaround for this (adamw, 17:38:13)
    5. there is some support to change this to rejectedblocker based on the 'real name' wrinkle, but not enough to change status at this point. we will revisit next week, hopefully with more info from rdieter (adamw, 17:42:08)

  16. Open floor (adamw, 17:42:15)
    1. Fedora 32 Final freeze is delayed by 2 days (to 2020-04-09). other milestones are unaffected (bcotton, 17:43:35)
    2. Fedora 32 Final freeze is delayed by 2 days (to 2020-04-09). other milestones are unaffected (bcotton, 17:44:03)
    3. https://fedorapeople.org/groups/schedule/f-32/f-32-quality-tasks.html (bcotton, 17:44:18)


Meeting ended at 17:49:36 UTC (full logs).

Action items

  1. adamw to send out call for testing for 1817708
  2. bcotton to bring 1768206 up during the DNF meeting on Wednesday
  3. nirik to investigate viability / silliness of https://bugzilla.redhat.com/show_bug.cgi?id=1768206#c21 option d)
  4. adamw to poke mstransky directly to get this one moving
  5. rdieter to investigate possibility of patching 'real name' field to be mandatory as a workaround for this


Action items, by person

  1. adamw
    1. adamw to send out call for testing for 1817708
    2. adamw to poke mstransky directly to get this one moving
  2. bcotton
    1. bcotton to bring 1768206 up during the DNF meeting on Wednesday
  3. nirik
    1. nirik to investigate viability / silliness of https://bugzilla.redhat.com/show_bug.cgi?id=1768206#c21 option d)
  4. rdieter
    1. rdieter to investigate possibility of patching 'real name' field to be mandatory as a workaround for this


People present (lines said)

  1. adamw (203)
  2. Lailah (67)
  3. cmurf (49)
  4. bcotton (49)
  5. lruzicka (46)
  6. frantisekz (24)
  7. Southern_Gentlem (23)
  8. zodbot (20)
  9. jforbes (17)
  10. pwhalen (14)
  11. kparal (13)
  12. sgallagh (10)
  13. nirik (8)
  14. rdieter (8)
  15. coremodule (8)
  16. mboddu (1)


Generated by MeetBot 0.1.4.