#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:01:48 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:48)
  2. Introduction (adamw, 16:03:51)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:03:51)
    2. We'll be following the process outlined at: (adamw, 16:03:52)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:03:52)
    4. The bugs up for review today are available at: (adamw, 16:03:54)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:03:55)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:03:57)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:03:59)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:04:01)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:04:03)
    10. for Beta, we have: (adamw, 16:04:07)
    11. 1 Proposed Blockers (adamw, 16:04:09)
    12. 7 Accepted Blockers (adamw, 16:04:11)
    13. 3 Proposed Freeze Exceptions (adamw, 16:04:13)
    14. 13 Accepted Freeze Exceptions (adamw, 16:04:15)
    15. for Final, we have: (adamw, 16:04:19)
    16. 2 Proposed Blockers (adamw, 16:04:24)
    17. 1 Accepted Blockers (adamw, 16:04:24)
    18. coremodule will secretarialize (adamw, 16:04:36)

  3. Proposed Beta blockers (adamw, 16:04:46)
  4. (1878317) doesn't offer option to process stack traces locally (adamw, 16:04:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1878317 (adamw, 16:04:57)
    2. https://pagure.io/fedora-qa/blocker-review/issue/86 (adamw, 16:04:57)
    3. Proposed Blocker, abrt, NEW (adamw, 16:04:57)
    4. AGREED: 1878317 - AcceptedBlocker (Beta) - accepted on the grounds that it "hinders execution of required Beta test plans or dramatically reduces test coverage", like the other similar bugs. we will sort out which bugs do and don't exist with which updates after the meeting (adamw, 16:12:42)

  5. Proposed Beta freeze exceptions (adamw, 16:13:03)
  6. (1878828) Include GNOME 3.38.0 in F33 Beta (adamw, 16:13:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1878828 (adamw, 16:13:10)
    2. https://pagure.io/fedora-qa/blocker-review/issue/89 (adamw, 16:13:10)
    3. Proposed Freeze Exceptions, distribution, NEW (adamw, 16:13:10)
    4. AGREED: 1878828 - AcceptedFreezeException (Beta) - this is accepted as a major useful change that affects live images, but we will only pull it in if we slip this week and it tests out well in the meantime (adamw, 16:15:33)

  7. (1878526) fedora-repos-modular-33-0.12 requires fedora-repos-rawhide (adamw, 16:15:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1878526 (adamw, 16:15:50)
    2. https://pagure.io/fedora-qa/blocker-review/issue/88 (adamw, 16:15:50)
    3. Proposed Freeze Exceptions, fedora-repos, ON_QA (adamw, 16:15:50)
    4. AGREED: 1878526 - AcceptedFreezeException (Beta) - accepted as it'll affect live image and install time package sets and can't be fully fixed with an update, we don't want to pull rawhide repos into f33 installs (adamw, 16:18:34)

  8. (1876162) anaconda storage configuration is extremely slow with an existing btrfs filesystem containing hundreds of snapshots (adamw, 16:18:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1876162 (adamw, 16:18:49)
    2. https://pagure.io/fedora-qa/blocker-review/issue/64 (adamw, 16:18:49)
    3. Proposed Freeze Exceptions, python-blivet, NEW (adamw, 16:18:49)
    4. AGREED: 1876162 - AcceptedFreezeException (Beta) - this is accepted on the basis that it's a significant installer issue that can't be fixed with an update, but we may still decide the change is too dangerous or not worthwhile after more consideration/testing (adamw, 16:29:12)

  9. (1878836) anaconda won't set hostname in KDE live (adamw, 16:32:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1878836 (adamw, 16:32:21)
    2. https://pagure.io/fedora-qa/blocker-review/issue/90 (adamw, 16:32:21)
    3. Proposed Freeze Exceptions, anaconda, NEW (adamw, 16:32:21)
    4. AGREED: 1878836 - punt (delay decision) - this looks like a good candidate but we could do with a bit more testing and info. once more info is available we will vote in the async voting system (adamw, 16:38:09)

  10. Proposed Beta blockers (adamw, 16:38:15)
    1. a new proposal came in (adamw, 16:38:19)

  11. (1815392) avc: denied { write } for pid=507 comm="systemd-journal" name="/" dev="dm-0" (adamw, 16:38:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815392 (adamw, 16:38:25)
    2. https://pagure.io/fedora-qa/blocker-review/issue/25 (adamw, 16:38:25)
    3. Proposed Blocker, systemd, NEW (adamw, 16:38:25)
    4. this is some kind of blockerbugs error, this bug is not proposed as an F33 blocker at all (adamw, 16:41:03)

  12. Proposed Final blockers (adamw, 16:41:38)
  13. (1816547) Firefox not using langpacks for localization (adamw, 16:41:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1816547 (adamw, 16:41:52)
    2. https://pagure.io/fedora-qa/blocker-review/issue/69 (adamw, 16:41:52)
    3. Proposed Blocker, firefox, ASSIGNED (adamw, 16:41:52)
    4. +3 votes in https://pagure.io/fedora-qa/blocker-review/issue/69 from bcotton, kparal, sumantro (adamw, 16:42:42)
    5. AGREED: 1816547 - AcceptedBlocker (Final) - accepted as a violation of "All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use" (with precedent from a similar bug in F32) (adamw, 16:43:48)

  14. (1876162) anaconda storage configuration is extremely slow with an existing btrfs filesystem containing hundreds of snapshots (adamw, 16:43:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1876162 (adamw, 16:43:56)
    2. https://pagure.io/fedora-qa/blocker-review/issue/64 (adamw, 16:43:56)
    3. Proposed Blocker, python-blivet, NEW (adamw, 16:43:56)
    4. AGREED: 1876162 - punt (delay decision) - we would like more evaluation from anaconda team and also testing with a real-world case (not identical snapshots) to figure out what's really plausible in an f33 timeframe before voting on this (adamw, 16:47:22)

  15. Fedora 33 Beta accepted blockers (bcotton, 16:49:05)
    1. Go/No-Go is Thursday (bcotton, 16:50:36)

  16. (1861700) login stuck when changing users repeatedly (log out, log in a different one) (bcotton, 16:50:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861700 (bcotton, 16:50:51)
    2. https://pagure.io/fedora-qa/blocker-review/issue/16 (bcotton, 16:50:59)
    3. Accepted Blocker, dbus-broker, NEW (bcotton, 16:51:06)
    4. https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Exceptional_cases (cmurf, 16:54:23)

  17. (1849430) Fedora 33: Everything boot x86_64 image exceeds maximum size (bcotton, 16:57:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1849430 (bcotton, 16:57:25)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=1849431 (bcotton, 16:57:36)
    3. Main cause appears to be growth in linux-firmware (bcotton, 17:00:20)
    4. tdawson is looking into places we can trim (bcotton, 17:00:28)

  18. libreport bugs (1860616 and 1873029) (bcotton, 17:05:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1860616 (bcotton, 17:05:18)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=1873029 (bcotton, 17:05:24)

  19. (1863041) systemd-resolved.service not work with DNS server placed behind VPN (openconnect) (bcotton, 17:10:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1863041 (bcotton, 17:10:30)
    2. Accepted Blocker, NetworkManager, NEW (bcotton, 17:10:37)
    3. ACTION: bcotton to ask for updated summary in the bug (bcotton, 17:15:41)

  20. (1873856) resolv.conf misconfigured on fresh install (bcotton, 17:17:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1873856 (bcotton, 17:17:48)
    2. https://pagure.io/fedora-qa/blocker-review/issue/53 (bcotton, 17:17:54)
    3. Accepted Blocker, systemd, ASSIGNED (bcotton, 17:18:00)
    4. There's a proposed fix (to remove /etc/resolv.conf and replace it with a symlink on install) (bcotton, 17:18:39)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=1873856#c14 (bcotton, 17:18:53)
    6. ACTION: bcotton to nudge the maintainers to see what they think of the proposed fix (bcotton, 17:21:51)

  21. Open floor (bcotton, 17:22:03)
  22. Image size blockers (1849430 and 1849431) (bcotton, 17:23:56)
    1. adamw has made a bunch of changes in Rawhide that have shrunk the ISO quite a lot, but still over size (bcotton, 17:24:28)

  23. Open floor (bcotton, 17:37:09)


Meeting ended at 17:39:08 UTC (full logs).

Action items

  1. bcotton to ask for updated summary in the bug
  2. bcotton to nudge the maintainers to see what they think of the proposed fix


Action items, by person

  1. bcotton
    1. bcotton to ask for updated summary in the bug
    2. bcotton to nudge the maintainers to see what they think of the proposed fix


People present (lines said)

  1. adamw (164)
  2. cmurf (104)
  3. bcotton (87)
  4. Lailah (45)
  5. sgallagh (28)
  6. coremodule (22)
  7. lruzicka (20)
  8. kalev (16)
  9. zodbot (15)
  10. kparal (15)
  11. michel_slm (11)
  12. jlanda (11)
  13. pwhalen (6)
  14. nirik (5)
  15. nb (1)
  16. mclasen (1)
  17. robatino (1)


Generated by MeetBot 0.1.4.