#fedora-blocker-review: F34-blocker-review

Meeting started by adamw at 16:02:15 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:26)
  2. Introduction (adamw, 16:10:50)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:11:02)
    2. We'll be following the process outlined at: (adamw, 16:11:06)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:11:10)
    4. The bugs up for review today are available at: (adamw, 16:11:15)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:11:20)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:11:25)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:11:30)
    8. https://fedoraproject.org/wiki/Fedora_34_Beta_Release_Criteria (adamw, 16:11:34)
    9. https://fedoraproject.org/wiki/Fedora_34_Final_Release_Criteria (adamw, 16:11:40)
    10. for Final, we have: (adamw, 16:11:52)
    11. 5 Proposed Blockers (adamw, 16:12:04)
    12. 6 Accepted Blockers (adamw, 16:12:04)
    13. 7 Proposed Freeze Exceptions (adamw, 16:12:08)
    14. 8 Accepted Freeze Exceptions (adamw, 16:12:08)
    15. frantisekz will secretarialize (adamw, 16:12:30)

  3. Proposed Final blockers (adamw, 16:12:38)
  4. (1947446) F34 plasma theming should use new BreezeTwilight (adamw, 16:15:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1947446 (adamw, 16:15:28)
    2. https://pagure.io/fedora-qa/blocker-review/issue/341 (adamw, 16:15:33)
    3. Proposed Blocker, kde-settings, ON_QA (adamw, 16:15:38)
    4. Ticket vote: FinalBlocker (+1,0,-2) (+bcotton, -adamwill, -frantisekz) (adamw, 16:15:49)
    5. Ticket vote: FinalFreezeException (+3,0,-0) (+bcotton, +adamwill, +frantisekz) (adamw, 16:15:53)
    6. AGREED: 1947446 - RejectedBlocker - this does not violate any of the criteria as currently formulated. Note: already accepted as a freeze exception issue (adamw, 16:25:33)

  5. (1948092) dasbus.error.DBusError: 'NoneType' object has no attribute 'upper' (adamw, 16:25:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1948092 (adamw, 16:25:42)
    2. https://pagure.io/fedora-qa/blocker-review/issue/350 (adamw, 16:25:47)
    3. Proposed Blocker, python-blivet, ASSIGNED (adamw, 16:25:52)
    4. AGREED: 1948092 - punt (delay decision) - we agreed to delay this while we get more detail on exactly what the failure case is, and if it's a dupe of 1945914 (or at least fixed by the same change) (adamw, 16:41:58)

  6. Proposed Final freeze exception issues (adamw, 16:42:19)
  7. (1941982) [abrt] gjs: ObjectInstance::~ObjectInstance()(): gjs-console killed by SIGTRAP (adamw, 16:42:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1941982 (adamw, 16:42:29)
    2. https://pagure.io/fedora-qa/blocker-review/issue/343 (adamw, 16:42:33)
    3. Proposed Freeze Exceptions, gjs, POST (adamw, 16:42:38)
    4. Ticket vote: FinalFreezeException (+1,1,-0) (+adamwill, kalev) (adamw, 16:42:43)
    5. AGREED: 1941982 - punt (delay decision) - we are punting with intent: this means we won't pull in a big hairy potential fix this week, but if we wind up slipping this week, it gives us the option to possibly pull it in for the next go-round (adamw, 16:56:49)

  8. (1948576) update to 5.11.12 for 64k page size fixes on ppc64le (adamw, 16:56:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1948576 (adamw, 16:57:09)
    2. https://pagure.io/fedora-qa/blocker-review/issue/351 (adamw, 16:57:09)
    3. Proposed Freeze Exceptions, kernel, ON_QA (adamw, 16:57:13)
    4. https://lore.kernel.org/linux-wireless/b606a193-3e4d-cdd7-a2e4-c5b801e2f8fc@gmail.com/T/#t (cmurf, 17:00:31)
    5. AGREED: 1948576 - AcceptedFreezeException (Final) - we are a bit worried about a potential intel wifi issue, but there seems to be only one outlying upstream report and no Fedora reports. 5.11.12 is going stable for F32 and F33. so pulling it into F34 for this and other fixes seems reasonable (adamw, 17:21:13)

  9. (1946950) Samba RPC daemons leak memory (adamw, 17:21:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1946950 (adamw, 17:21:30)
    2. https://pagure.io/fedora-qa/blocker-review/issue/334 (adamw, 17:21:35)
    3. Proposed Freeze Exceptions, samba, ON_QA (adamw, 17:21:40)
    4. Ticket vote: FinalFreezeException (+0,2,-1) (bcotton, kparal, -adamwill) (adamw, 17:21:44)
    5. AGREED: 1946950 - RejectedFreezeException (Final) - no justification has been provided for why this needs a freeze exception and cannot just be a 0-day update (adamw, 17:26:45)

  10. (1947664) Re-enable systemd-resolved caching (adamw, 17:26:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1947664 (adamw, 17:27:02)
    2. https://pagure.io/fedora-qa/blocker-review/issue/344 (adamw, 17:27:07)
    3. Proposed Freeze Exceptions, systemd, MODIFIED (adamw, 17:27:18)
    4. AGREED: 1947664 - AcceptedFreezeException (Final) - so far there's no indication that anyone's had name resolution issues with this, so we're hopeful it finally solves all the major problems. we do want the feature enabled for release as it's a major part of the change. (adamw, 17:40:24)

  11. (1948003) Backport support for hardware acceleration with proprietary NVIDIA driver (adamw, 17:40:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1948003 (adamw, 17:40:40)
    2. https://pagure.io/fedora-qa/blocker-review/issue/347 (adamw, 17:40:45)
    3. Proposed Freeze Exceptions, xorg-x11-server-Xwayland, NEW (adamw, 17:40:50)
    4. AGREED: 1948003 - RejectedFreezeException (Final) - this is a lot of change for the benefit solely of a proprietary driver. The cost/benefit doesn't seem worth it at this point (adamw, 17:46:16)

  12. (1946950) Samba RPC daemons leak memory (adamw, 17:52:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1946950 (adamw, 17:52:19)
    2. https://pagure.io/fedora-qa/blocker-review/issue/334 (adamw, 17:52:21)
    3. Proposed Freeze Exceptions, samba, ON_QA (adamw, 17:52:21)
    4. we are re-voting this at ab's request (adamw, 17:52:31)
    5. AGREED: 1946950 - AcceptedFreezeException (Final) - this is now accepted as an FE due to its impact on FreeIPA deployments, which are part of the Server DVD package set (adamw, 17:56:27)

  13. Open floor (adamw, 17:56:32)
  14. Accepted blocker status (adamw, 18:00:38)
  15. (1947704) Do final F34 fedora-release and fedora-repos builds (adamw, 18:01:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1947704 (adamw, 18:01:40)
    2. https://pagure.io/fedora-qa/blocker-review/issue/346 (adamw, 18:01:47)
    3. Accepted Blocker, fedora-release, NEW (adamw, 18:01:55)
    4. mboddu is working on this today (adamw, 18:04:48)
    5. ACTION: mboddu to submit final fedora-release and fedora-repos builds (adamw, 18:04:57)

  16. (1948034) Server deployment fails on current F34 and Rawhide ("All nameservers failed to answer the query...") (adamw, 18:06:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1948034 (adamw, 18:06:43)
    2. https://pagure.io/fedora-qa/blocker-review/issue/349 (adamw, 18:06:48)
    3. Accepted Blocker, freeipa, ASSIGNED (adamw, 18:06:53)
    4. a fix for this has been tested as a scratch build, an update will be coming today we hope (adamw, 18:07:26)

  17. (1943943) Hitting "Update All" in Plasma Discover sometimes does nothing, just cycles back (adamw, 18:08:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1943943 (adamw, 18:08:19)
    2. https://pagure.io/fedora-qa/blocker-review/issue/320 (adamw, 18:08:22)
    3. Accepted Blocker, plasma-discover, NEW (adamw, 18:08:27)
    4. AGREED: 1943943 - RejectedBlocker (Final) - this is revoted to rejected because it doesn't happen all the time, we're not sure if it will actually happen at all often in regular use or if it's just a quirk of openQA's test setup, and the workaround is one folks will probably 'naturally' stumble across (adamw, 18:28:18)

  18. (1929643) logout after switch returns the user to console instead of sddm (adamw, 18:28:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1929643 (adamw, 18:28:53)
    2. https://pagure.io/fedora-qa/blocker-review/issue/235 (adamw, 18:28:56)
    3. Accepted Blocker, sddm, NEW (adamw, 18:29:02)
    4. upstream is working on this bug, but no fix appears to be ready yet (adamw, 18:43:55)

  19. (1938630) include new bootloaders on Fedora 34 install media so UEFI Secure Boot enabled systems can boot from them (adamw, 18:44:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1938630 (adamw, 18:44:58)
    2. https://pagure.io/fedora-qa/blocker-review/issue/310 (adamw, 18:45:03)
    3. Accepted Blocker, shim, POST (adamw, 18:45:08)
    4. a resigned shim is built and in updates-testing, but two significant bugs have been discovered in it (adamw, 18:46:21)
    5. https://koji.fedoraproject.org/koji/buildinfo?buildID=1734914 does include both fixes (adamw, 18:49:28)
    6. https://bugzilla.redhat.com/show_bug.cgi?id=1948432 (cmurf, 18:50:58)
    7. ACTION: adamw to try and get clarity on where we stand with getting a new signed shim build, and what's in it (adamw, 18:54:36)

  20. (1946278) latest uboot fails to load the dtb (adamw, 18:55:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1946278 (adamw, 18:55:06)
    2. https://pagure.io/fedora-qa/blocker-review/issue/322 (adamw, 18:55:11)
    3. Accepted Blocker, uboot-tools, ASSIGNED (adamw, 18:55:14)
    4. pbrobinson is working on this and made some progress (adamw, 18:57:51)
    5. ACTION: pbrobinson to finish fixing this (adamw, 18:58:57)

  21. Open floor (adamw, 18:59:00)
    1. https://testdays.fedoraproject.org/events/111 (cmurf, 19:01:01)


Meeting ended at 19:05:02 UTC (full logs).

Action items

  1. mboddu to submit final fedora-release and fedora-repos builds
  2. adamw to try and get clarity on where we stand with getting a new signed shim build, and what's in it
  3. pbrobinson to finish fixing this


Action items, by person

  1. adamw
    1. adamw to try and get clarity on where we stand with getting a new signed shim build, and what's in it
  2. mboddu
    1. mboddu to submit final fedora-release and fedora-repos builds


People present (lines said)

  1. adamw (245)
  2. cmurf (79)
  3. bcotton (40)
  4. frantisekz (38)
  5. Southern_Gentlem (25)
  6. pwhalen (24)
  7. lruzicka[m] (23)
  8. zodbot (16)
  9. Eighth_Doctor (8)
  10. coremodule (5)
  11. ab (5)
  12. marcdeop (3)
  13. mboddu (2)
  14. NateGraham[m] (1)
  15. spongebob (0)


Generated by MeetBot 0.1.4.