16:00:10 <adamw> #startmeeting F35-blocker-review
16:00:10 <zodbot> Meeting started Mon Sep  6 16:00:10 2021 UTC.
16:00:10 <zodbot> This meeting is logged and archived in a public location.
16:00:10 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:10 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:00:20 <adamw> #meetingname F35-blocker-review
16:00:20 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:00:24 <adamw> #topic Roll Call
16:00:34 <adamw> ahoyhoy folks, who's around for blocker review?
16:00:58 * bittin is
16:01:39 <adamw> aaaaanybody else
16:03:54 <bcotton> .hello2
16:03:55 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:04:02 <adamw> hi ben
16:04:10 <bcotton> hi adam, hi luna!
16:04:11 <adamw> we're a bit short
16:04:20 <bittin> hey Adam and Ben
16:04:32 <adamw> most of the bugs got cleared up with offline voting, there are only a couple of 'stragglers'
16:04:35 <adamw> so if we don't have enough people we can can it
16:04:54 <adamw> oh, and someone just proposed a new one...
16:05:02 * bcotton does the can-can
16:05:30 * kparal has some limited time to join, maybe
16:05:37 <geraldosimiao> .hello geraldosimiao
16:05:38 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. SimiĆ£o Kutz' <geraldo.simiao.kutz@gmail.com>
16:05:39 <adamw> ok, let's see if we can knock a few out
16:06:06 <adamw> boilerplate alert
16:06:08 <adamw> #topic Introduction
16:06:14 <adamw> Why are we here?
16:06:15 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:19 <adamw> #info We'll be following the process outlined at:
16:06:29 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:29 <adamw> #info The bugs up for review today are available at:
16:06:30 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:06:33 <adamw> #info The criteria for release blocking bugs can be found at:
16:06:38 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:06:43 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria
16:06:46 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria
16:06:51 <adamw> #info for Beta, we have:
16:06:58 <adamw> #info 2 Proposed Blockers
16:07:02 <adamw> #info 5 Accepted Blockers
16:07:07 <adamw> #info 12 Accepted Freeze Exceptions
16:07:10 <adamw> #info for Final, we have:
16:07:24 <adamw> #info 3 Proposed Blockers
16:07:34 <adamw> #info I will secretarialize since we're a bit short today
16:07:35 <adamw> let's start with...
16:07:38 <adamw> #topic Proposed Beta blockers
16:07:49 <adamw> #topic (2001591) IndexError: list index out of range
16:07:49 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2001591
16:07:49 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/437
16:07:49 <adamw> #info Proposed Blocker, anaconda, NEW
16:08:05 <bittin> https://bugzilla.redhat.com/show_bug.cgi?id=2001591
16:08:07 <adamw> this is a brand new proposal, in anaconda, if you fiddle with the NTP server list. seems a bit too niche to be a blocker for me
16:08:09 <adamw> i don't think we have a criterion
16:08:16 <adamw> oh dang
16:08:26 <adamw> did that paste ok to IRC?
16:08:45 <bittin> yeah
16:09:56 <adamw> ok, let's hope we're right then :D
16:09:59 <adamw> so, I think i'm -1 on this
16:10:05 <bcotton> -1 beta blocker
16:10:23 <bittin> -1 for beta but would be great to have it fixed for the release atleast
16:10:30 <bcotton> I could easily be convinced it's a final blocker
16:10:40 <adamw> it looks like a very simple fix (just need the code to be slightly more paranoid about the list it's checking) so I'd be +1 FE
16:10:51 * kparal reproduced the issue
16:11:01 <bittin> -1 beta +1 final
16:11:01 <adamw> it's literally just adding "self._servers and" to the line
16:11:13 <adamw> or, well, not quite that. but something like that. :D
16:11:14 <kparal> -1 beta, +1 final, +1 betafe
16:11:39 * adamw didn't have his codeflakes yet this morning
16:11:40 <geraldosimiao> -1 beta blocker +1 final
16:11:52 <adamw> any other beta FE votes?
16:12:06 <bcotton> i'll say beta fe +1 in case we dont' make a final blocker decision
16:12:58 <adamw> proposed #agreed 2001591 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not really count as a significant violation of the criterion cited, and we see no other criteria. But it's a relatively easily encounterable crash and the fix should be easy and safe, so we accept it as a Beta FE
16:13:15 <adamw> not sure it's worth voting on final blocker this early when it will be a simple fix, also nobody cited a criterion. :D
16:13:20 <bcotton> ack
16:13:34 <bcotton> yeah, let's see if it still exists post-beta and decide then :-)
16:13:39 * kparal adding blocks:finalblocker to the bug, so that it doesn't get lost
16:13:47 <kparal> ack
16:13:47 <adamw> sure, we can propose it for safety
16:13:52 <adamw> i will do that when secretarializing
16:14:14 <adamw> any more acks?
16:15:20 <geraldosimiao> ack
16:15:35 <adamw> #agreed 2001591 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not really count as a significant violation of the criterion cited, and we see no other criteria. But it's a relatively easily encounterable crash and the fix should be easy and safe, so we accept it as a Beta FE
16:15:42 <adamw> #topic (2001261) qt5-qtwebengine rendering broken in F35
16:15:46 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2001261
16:15:51 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/433
16:15:56 <adamw> #info Proposed Blocker, qt5-qtwebengine, MODIFIED
16:16:02 <adamw> #info Ticket vote: BetaBlocker (+0,0,-2) (-kparal, -lruzicka)
16:16:07 <adamw> #info Ticket vote: BetaFreezeException (+4,0,-0) (+churchyard, +kparal, +lruzicka, +adamwill)
16:16:23 <adamw> so this has -2 in the app, but i wanted to bring it up at the meeting because the bug does mention it affects kmail
16:16:45 <kparal> kmail is not required to work, though
16:17:01 <adamw> yeah...looking at the criteria we don't have anything that'd require that
16:17:05 <adamw> so i guess i can agree with -1
16:17:07 <bittin> throw it on the Fedora KDE people ?
16:17:17 <adamw> which puts us at -3. does anyone want to argue +1 ?
16:17:28 <adamw> bittin: it's their job to fix it for sure :D but it's our job to decide if it's a blocker
16:17:46 <bcotton> -1 blocker. idk that web rendering is a critical function of a mail client. particularly in a beta release
16:17:54 <geraldosimiao> FE +1
16:18:13 * kparal often afk from now on
16:18:14 <bittin> seems its fixed in bodhi: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2b436cae88
16:18:19 <adamw> it's already accepted as FE
16:18:27 <bittin> so +-0
16:18:39 <geraldosimiao> ok, so -1 BetaBlocker
16:18:44 <adamw> ok
16:19:26 <adamw> proposed #agreed 2001261 - RejectedBlocker (Beta) - this is an unfortunate bug and would be visible on KDE, but it does not affect any app that is required to work at Beta (as the default browser for KDE is Firefox). Note it has already been accepted as an FE so the fix will be pulled in as long as it causes no problems
16:19:45 <bcotton> ack
16:19:48 <bittin> ack
16:19:49 <geraldosimiao> ack
16:20:04 <adamw> #agreed 2001261 - RejectedBlocker (Beta) - this is an unfortunate bug and would be visible on KDE, but it does not affect any app that is required to work at Beta (as the default browser for KDE is Firefox). Note it has already been accepted as an FE so the fix will be pulled in as long as it causes no problems
16:20:12 <adamw> ok, moving on to:
16:20:15 <adamw> #topic Proposed Final blockers
16:20:36 <adamw> #topic (1997315) abrt-dbus segmentation faulted in abrt_p2_service_dbus when shutting down, rebooting, or logging out of Plasma
16:20:38 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1997315
16:20:48 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/431
16:20:49 <adamw> #info Proposed Blocker, abrt, NEW
16:22:10 <bcotton> if the crash reporter crashes, you can't have any crash reports. very clever :-)
16:22:15 <adamw> if this actually stops the 'problem reporter' working correctly, i'm +1
16:22:30 <adamw> i don't know if chris actually quite said that's the consequence, though it seems likely
16:22:32 <bcotton> i find the arguments cmurf made compelling https://bugzilla.redhat.com/show_bug.cgi?id=1997315#c3
16:22:36 <adamw> so i'm either +1 or punt for that
16:22:36 <bcotton> +1 final blocker
16:23:22 <bittin> +1
16:23:39 <geraldosimiao> yeah, I think abrt must work on the beta too...
16:23:52 <adamw> this is for final, it's not required for beta
16:24:14 <geraldosimiao> but thats not the purpose for the beta too?
16:24:41 <adamw> right. all relevant criteria here are final
16:24:54 <adamw> the "required applications" criterion and anything related to crash reports, they're all final
16:24:55 <geraldosimiao> the public to test, and send abrts reports?
16:25:10 <adamw> i mean, it's bad if it doesn't work at beta
16:25:17 <adamw> so i guess we could also vote this as a beta FE
16:25:21 <bittin> +1
16:25:35 <adamw> though it's a bit late and we don't know how safe a fix for this would be
16:25:40 <geraldosimiao> ok, +1 Final and +1 FE
16:26:04 <adamw> anyone else wanna vote on beta FE?
16:26:52 <bcotton> +1 beta fe
16:26:53 <bittin> +1 FE
16:26:55 * bcotton looks at the number of accepted blockers in the NEW state and wonders if it's actually late :-)
16:26:56 <geraldosimiao> yeah, I mean beta FE (+1)
16:30:06 <adamw> proposed #agreed 1997315 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - assuming a consequence of this bug is that the problem reporting tool does not work correctly, we agree it violates the "default application functionality" criterion. We also accept it as a Beta freeze exception as it is definitely desirable for crash reporting to work at Beta; of course, we'll only pull a fix that's sufficiently safe and tested
16:30:19 <geraldosimiao> ack
16:30:32 <bcotton> ack
16:30:34 <bittin> ack
16:30:54 <adamw> #agreed 1997315 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - assuming a consequence of this bug is that the problem reporting tool does not work correctly, we agree it violates the "default application functionality" criterion. We also accept it as a Beta freeze exception as it is definitely desirable for crash reporting to work at Beta; of course, we'll only pull a fix that's sufficiently safe and tested
16:31:14 <adamw> #topic (1991075) time is transiently incorrect when Automatic Time Zone is enabled
16:31:20 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1991075
16:31:22 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/389
16:31:26 <adamw> #info Proposed Blocker, gnome-settings-daemon, NEW
16:31:33 <adamw> #info Ticket vote: FinalBlocker (+3,0,-0) (+bcotton, +chrismurphy, +tablepc)
16:31:51 <adamw> so we punted on this last time for more info, and we haven't really had any more info
16:31:59 <adamw> there are +3 votes in the ticket, though not really with any justifications
16:32:26 <adamw> i still kinda feel punty, but we could take it with the ticket votes, I guess...
16:32:53 <bcotton> i'm still weakly +1 based on https://bugzilla.redhat.com/show_bug.cgi?id=1991075#c3
16:33:05 <bcotton> but i wouldn't oppose another punt
16:34:06 <adamw> anyone else got an opinion? accepting opinions!
16:35:56 <bittin> don't really have any opinion, nice to have but always something that can be fixed with ntpd on login or such
16:36:26 <adamw> proposed #agreed 1991075 - punt (delay decision) - nothing has really changed since we punted last time, so let's punt again. it's not urgent to make a call here
16:36:37 <bcotton> ack
16:36:40 <bittin> ack
16:36:58 <geraldosimiao> ack
16:37:06 <adamw> ok, and finally:
16:37:07 <adamw> #agreed 1991075 - punt (delay decision) - nothing has really changed since we punted last time, so let's punt again. it's not urgent to make a call here
16:37:14 <adamw> #topic (2000300) gsd-usb-protect dumps core on first boot
16:37:15 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2000300
16:37:17 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/434
16:37:25 <adamw> #info Proposed Blocker, gnome-settings-daemon, NEW
16:38:05 <adamw> so i think this is based partly on a misunderstanding
16:38:22 <adamw> it cites the extended time for g-i-s to start, which we don't believe has anything to do with the gsd-usb-protect crash, which has been around for a while
16:38:41 <bittin> +1 for fixing the crash
16:39:02 <adamw> i guess technically in some configurations the sadface might still be visible briefly on boot if we fix the g-i-s delay...not sure if that would pass the last blocker test, though
16:39:06 <adamw> i believe f34 shipped with this crash
16:39:35 <geraldosimiao> I remember something similar with this on F34 too...
16:39:57 <bittin> yeah me too
16:40:02 <geraldosimiao> the "sad face" problem
16:40:08 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1937073 is the F34 bug
16:40:29 <adamw> i guess my vote might be 'punt till we have the selinux stuff for g-i-s sorted out and see how it looks them"
16:40:48 <bittin> +1 for fixing it as good as we can
16:40:52 <geraldosimiao> ack
16:41:11 <adamw> bittin: we always want to fix things. the question at this meeting is whether they block releases :)
16:41:27 <geraldosimiao> thats a problem all people ho download the beta iso will shout about...
16:41:37 <bittin> +1
16:42:26 <adamw> geraldosimiao: the "g-i-s takes a long time" bug is already accepted as a blocker
16:42:43 <geraldosimiao> adamw: allright then
16:42:47 <adamw> this bug is specifically for the crash. we don't really know how things will look yet if we fix g-i-s starting up slowly, but don't fix gsd-usb-protection crashing
16:43:02 <adamw> so that's why i'd vote to see how things look after we fix the g-i-s delay
16:43:16 <bcotton> +1 punt
16:43:28 <geraldosimiao> +1 punt
16:44:51 <adamw> proposed #agreed 1937073 - punt (delay decision) - this bug was proposed under the belief that the gsb-usb-protect crash causes the g-i-s startup delay and visible sadface screen, but in fact, we believe the g-i-s delay is caused by SELinux issues (that's 1997310). so we vote to punt on this to see how bad the consequences of the crash are after the g-i-s delay is fixed in SELinux policy.
16:46:15 <bcotton> ack
16:46:32 <bittin> ack
16:46:57 <adamw> #agreed 1937073 - punt (delay decision) - this bug was proposed under the belief that the gsb-usb-protect crash causes the g-i-s startup delay and visible sadface screen, but in fact, we believe the g-i-s delay is caused by SELinux issues (that's 1997310). so we vote to punt on this to see how bad the consequences of the crash are after the g-i-s delay is fixed in SELinux policy.
16:47:20 <adamw> ok, and i need to go get dim sum, so i am gonna punt on the accepted blockers section. we're generally on top of...most of them.'
16:47:21 <adamw> #topic Open floor
16:47:29 <adamw> any other business? any worrying blockers anyone particularly wants to talk about?
16:47:57 <bittin> don't have anything right now think bcotton proposed a 35 Beta Go/No Go meeting on Thursday this week? if i don't remember wrong
16:48:07 <geraldosimiao> theres something Im testing now: F34 upgrade to F35...
16:48:36 <adamw> bittin: yep, that's the meeting for the early target release date
16:48:36 <geraldosimiao> and the pipewire-session/wireplumber are bottering me
16:48:42 <adamw> geraldosimiao: oh? that's not working right?
16:48:49 <bittin> adamw, ah, also a lot of test weeks/test days
16:48:57 <bittin> https://fedoramagazine.org/contribute-at-fedora-linux-35-audio-i18n-gnome-41-and-kernel-test-days/
16:48:59 <geraldosimiao> not right from the start no
16:49:01 <bittin> #info https://fedoramagazine.org/contribute-at-fedora-linux-35-audio-i18n-gnome-41-and-kernel-test-days/
16:49:16 <adamw> geraldosimiao: can you post your findings on the bug about the issue? let me dig it out, it may be closed, so we may have to reopen it
16:49:36 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1997992
16:49:50 <adamw> oh no sorry
16:49:50 <geraldosimiao> ok, I already did some on that
16:49:51 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1983861
16:49:54 <geraldosimiao> but wil research further
16:49:54 <adamw> ah yes i see your comments
16:50:06 <geraldosimiao> and let you know :)
16:50:06 <adamw> i will take a look into it later, thanks a lot for reporting
16:50:55 <geraldosimiao> :D
16:51:22 <bcotton> adamw: what's your take on the freeipa bug? is it progressing or are we stuck?
16:51:31 <bittin> #info Fedora 35 Beta Go/No Go Meeting on Thursday
16:51:49 <adamw> Ben Cotton (he/him/his): it's progressing, sort of slowly
16:52:01 <adamw> i'll work on it some more with ab tomorrow
16:52:56 <bcotton> ok
16:53:19 <adamw> ok, is that everything?
16:53:48 <geraldosimiao> bittin: theres gonna be a RC iso until then?
16:53:59 <adamw> if we get all the blockers fixed, yeah.
16:54:04 <adamw> if not, it'll be a short meeting. :D
16:54:04 <bcotton> we'll find out!
16:54:12 <geraldosimiao> ok
16:54:32 <adamw> by policy we don't build RCs when there are known blockers.
16:55:04 <geraldosimiao> allright, now I understand :)
16:55:15 <adamw> thanks a lot, everyone!
16:55:19 <bittin> thats good to know :) thx
16:55:44 <adamw> #endmeeting