23:34:19 <rrix> #startmeeting
23:34:20 <zodbot> Meeting started Wed Apr 7 23:34:19 2010 UTC. The chair is rrix. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:34:21 <rrix> btw
23:34:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:34:26 * rrix summarizes
23:34:30 <mchua> (thanks rrix)
23:34:42 <rrix> mchua asks what we have for campus amb
23:34:55 <rrix> people who want to do tihngs, but no real idea what to do
23:35:00 <rrix> no clear goals yet
23:35:19 <rrix> and we don't want them decided by one single person or a small group; but the whole group should be involved
23:35:41 <rrix> mchua asks me to think about my case, and what *i* want to do at uni next year
23:35:52 <rrix> multi-distro installfest seems like a good idea
23:35:57 <rrix> for a first goal
23:36:18 <rrix> Software Freedom Day is Sept18, and my classes start Aug23, so it seems like a good target day
23:36:25 <rrix> kk, mchua all up to speed :D
23:37:33 <mchua> Yup!
23:37:33 <rrix> #link http://asulug.org/ <-- ASU LUG's website
23:38:08 <rrix> #link http://asulug.org/?page=installfest
23:38:09 <mchua> Ok. So, multi-distro installfest - probably for a mostly-student audience, and folks who may be new to Linux, I'm assuming?
23:38:12 <mchua> Nice :)
23:38:16 <rrix> Yes, indeed
23:38:31 <rrix> They have one twice a year, but the last time I talked to someone in ASULUG, it was pretty Ubuntu-centric
23:39:02 <mchua> Great. So, what's the minimum number of distros you'd like to see repesented?
23:39:05 <mchua> er, represented?
23:39:52 <mchua> Will you be coordinating the overall event, or the Fedora portion of it (and then tag-teaming with others working on other distros)?
23:40:24 <rrix> Ugh; their mailing list etiquette says top posting only? :(
23:40:46 <rrix> mchua: I haven't the slightest, I'd have to get involved with ASULUG first, probably
23:41:01 <rrix> i just sub'd to their mailing list. I guess the first step would be to say hi :)
23:45:00 * mchua grins
23:45:26 <mchua> I might be poking too much on organizational details... but milestones (or ideas for them, anyway) are a good place to start.
23:45:41 <mchua> #idea multi-distro installfest on campus on software freedom day (September 18, 2010)
23:45:46 <mchua> rrix: What else do you want to do at ASU?
23:46:08 <rrix> mchua: 1) attract users, 2) attract contributors
23:47:01 <rrix> 1) primarily through asulug involvement and activism at first, then when I have relationships with professors, getting them involved, having their students use FOSS tools, and encourage their students to release software they create as foss, etc
23:47:21 <rrix> 2) once those people are creating foss themselves, it can be much easier
23:47:26 <rrix> to get them to do 2), rather
23:49:48 <mchua> Ok, so maybe another target is, for each class you take, try to use all-FOSS tools for it
23:50:02 <mchua> and work with the prof (if needed) to publish notes for other students on how they can do the same
23:50:29 <mchua> like, "oh, I can use gnuplot to make this chart for math... want pretty graphs too? here's how!" <link to existing gnuplot tutorial>
23:50:39 <rrix> oooh
23:50:42 * rrix nod
23:50:44 <mchua> "the <course number> guide to using free software"
23:51:00 <mchua> we had a really informal version of that at my school... the linux geeks would pass around tips on what programs to use and such.
23:51:04 <rrix> #idea Try to use all FOSS tools for a course, and publish notes on how to do that
23:51:28 <mchua> #idea Target audience - all the other students in that class (and with the blessing of the prof when possible)
23:51:42 <mchua> the thing we missed was getting the folks who weren't already linux geeks into it. ;)
23:52:23 <rrix> definitely
23:52:43 <rrix> "hey you don't have to buy (or illegally download) matlab, use octave!"
23:53:13 * mchua nods
23:53:28 <mchua> "here's a screencast of how to install it"
23:55:29 <rrix> definitely
23:55:56 <mchua> So... that's two targets.
23:56:03 <mchua> Both towards "attract users."
23:56:09 <mchua> rrix: how about contributors? ;) What do you want to do with that?
23:56:26 <rrix> annnnd down the rabbit hole we go :)
23:56:32 * mchua grins
23:57:15 <rrix> 1) "hey I can't get such and such working" "hey is such and such packaged in fedora" "hey I have this issue; where can I file a bug?"
23:57:36 <rrix> answer those questions with a call for action
23:57:58 <rrix> "we do'nt have that packaged, but you and I could meet up later, and I can show you how to make an rpm"
23:58:16 <mchua> momentum-building ftw!
23:58:28 <mchua> will there be a way for people to see what other people are doing for FOSS on ASU's campus?
23:58:49 <rrix> Hmmm
23:58:54 <rrix> in what way?
23:58:58 <mchua> by that I mean... if I were a student there, is there a way for me to get pinged whenever someone else contributes someting cool to any sort of free softwaer project?
23:59:02 <mchua> er, software.
23:59:11 <rrix> hmmm
23:59:23 <rrix> That is a good question; one I don't have an answer for :)
23:59:36 <rrix> what about a monthly or so report to the LUG mailing list
23:59:48 <rrix> "Hey this is all the Wicked Awesome Stuff that happened this month:
23:59:58 <rrix> Joe pushed three patches to OOo...
00:00:07 <mchua> Can it be even more realtime?
00:00:12 <rrix> hmmm
00:00:19 <mchua> a ASULUG identi.ca account that acts as a brag wall?
00:00:24 <rrix> ohh
00:00:25 * mchua throwing out random ideas
00:00:38 <rrix> #idea Campus LUG identi.ca account/groups
00:00:41 <mchua> I mean, a lot of cool stuff happens in-channel when you go "oh dude you just did THAT and I could do THIS to follow up on it and YAY"
00:01:10 * rrix nod
00:02:34 <mchua> And ways to get it out beyond the people who Already Care About Free Software
00:02:43 <mchua> like, "I'm an art student, what's FOSS?"
00:02:53 <mchua> "Oh, I could *not* pay $500 for software this semester? Dude."
00:02:58 <rrix> "Here's inkscape, really awesome tool!"
00:03:14 <rrix> "Oh, here's the gimp, go MAKE SOMETHING :D"
00:03:29 * mchua looking forward to what you're going to be doing with your *non* CS clases next year ;)
00:03:36 <rrix> :-)
00:03:44 <mchua> if students go "um, what is the gimp? how do I..."
00:03:49 <mchua> that's a nice opportunity for a fedora classroom session
00:03:50 <rrix> US History since 1865 should be an interesting one to integrate foss into :)
00:03:54 * mchua laughs
00:03:55 <mchua> oh yes.
00:04:03 <rrix> yeah, fedora classroom sessions FTW
00:04:19 <rrix> also: multi-perosn project managing using Gobby and wiki
00:04:22 <mchua> "hey, $person, we've got a room of ASU students who want to know about $this_foss_related_thing, can haz?"
00:04:25 <mchua> YES
00:04:26 <mchua> project management tools fw.
00:04:28 <mchua> er, ftw.
00:04:50 <rrix> I also want a groupware server setup so that people can publish meetings, whatnot, and send invitiations, etc.
00:04:57 <rrix> but that's more a personal thing ;)
00:05:06 * mchua grins
00:05:20 <mchua> Ok... how many ideas did we just have up there to #idea?
00:05:37 <rrix> #idea fedora classroom sessions for GIMP, other tools that students would use
00:06:59 <rrix> #idea integrate more than CS classes, (Inkscape/GIMP for arties, gnuplot/octave for math whizzes, KDevelop/Eclipse for CS, lilypad for musicians, ETC)
00:07:11 <mchua> #idea realtime feed of "cool contributions ASU students have made to FOSS" (identi.ca brag wall, etc)
00:07:19 <mchua> ooh! yes!
00:07:31 <mchua> Start with your own classes... maybe get other students in the LUG to do it for their classes
00:07:46 <mchua> you could keep notes on the wiki so that it became the place to go to for "what software do I use for $this_ASU_class?
00:07:49 <mchua> "
00:08:10 <rrix> definitely
00:09:23 <rrix> mchua: brb, phone
00:10:16 * mchua nods
00:18:19 <rrix> ooooookay
00:18:22 <rrix> Sorry about that mchua
00:19:31 <rrix> Sooooo... I think there's plenty in that department; let's change gears, if that's okay with you
00:21:44 <mchua> rrix: go for it.
00:21:46 <mchua> np!
00:22:09 <rrix> Okay; we have all this awesome stuff for campus ambassadors to do... What _is_ a campus ambassador is the next question I should ask
00:22:23 <rrix> We already have the ambassadors program...
00:23:38 <rrix> Are campus ambassadors a member of the ambassador group? do they have to be mentored by an ambassador?
00:24:04 <mchua> Start with the cases you have right now... there's you, there's a few other people.
00:24:14 <rrix> I am tempted to say yes, and that is what most others think, but I worry that is setting the bar too high for someone who just wants to go and evangalize at their school
00:24:14 <mchua> Are you a member of the Ambassadors group? do you have to be mentored by an ambassador? ;)
00:24:20 <rrix> Yes, I am :)
00:24:37 <mchua> Okay, then take a new person like Colin Zwiebel... he's new to contributing to Fedora and FOSS.
00:24:45 <mchua> (I know Colin - he's a student at my alma mater.)
00:24:53 <mchua> He's not an Ambassador. Yet, anyway.
00:25:02 <mchua> What should he have to do in order to participate in campusamb?
00:25:06 <mchua> What's the bar you want to set for him?
00:25:25 * mchua finds it easier to talk about specific cases, but if this doesn't work for you we can switch.
00:25:51 <mchua> rrix: Or you can take me as a case study, though I think that might be less useful. :) I won't be a student for another... 8 months - and that's only if things go well and I get accepted.
00:25:58 <mchua> and grad school != undergrad.
00:26:05 <rrix> definitely
00:26:44 <mchua> rrix: so, either me or Colin... what's the req to set for us?
00:27:00 <mchua> You can do things on a case-by-case basis and adjust as needed until you have enough cases to go "oh yeah, that's what we've been doing."
00:27:03 <rrix> mchua: hmm, thinking
00:27:06 * mchua nods
00:27:37 <rrix> let's take you, when you take off the red hat
00:28:07 <rrix> You're going into grad school, you're heavily involved in Fedora and you know what you need to do to put Fedora in your school
00:28:39 <rrix> You know enough that you shouldn't have to be mentorred
00:28:56 <rrix> in fact, you'd be the prime example to become a mentor :)
00:29:26 * mchua may still have the red hat on. not sure yet... these are things I'm trying to work out.
00:29:30 <rrix> but you're not currently an ambassador; should you have to become one to become a campus ambassador
00:29:30 <mchua> but anyhoo.
00:29:36 <mchua> Should I?
00:29:38 <rrix> mchua: hypothetically taking it off :)
00:29:43 <mchua> rrix: aye. :)
00:29:45 <rrix> mchua: that's where I'm stuck
00:29:59 <mchua> rrix: what do I get by being an ambassador?
00:30:05 <rrix> do we want to be a sub-group of ambassadors, and only a subgroup?
00:30:11 <mchua> I'm unlikely to have time to fly out to linux conferences in the region, I'm going to be hosed with school and such
00:30:29 <mchua> (...well, in reality, I'll try anyway, but... it helps a lot if it can tie back into something school-related)
00:30:46 <rrix> mchua: you get access to FAmNA's deep pockets, for one. But you also have the responsibility of being in charge of _all_ foss stuff in the area
00:30:48 <mchua> heck, I'm unlikely to have *cash* to fly to conferences. starving student mode!
00:31:00 <rrix> exactly, linux confs, community lugs, etc.
00:31:12 <mchua> all FOSS stuff? not just my campus?
00:31:27 <rrix> as a "normal" ambassador that would probably be the expectation
00:31:36 <mchua> I can use my campus as an outreach hub, I suppose... but to be responsible for things happening beyond my campus walls is really hard.
00:31:45 <rrix> which is why I'm worried about someone going having to go through the rigor of becoming a "normal" ambassador
00:31:47 <mchua> can your "area" be limited to your campus?
00:31:57 <mchua> just specify that as a special type of region?
00:32:00 <mchua> i mean, colleges can be pretty big
00:32:04 * rrix nods
00:32:08 <rrix> They should be
00:32:10 <rrix> mo
00:32:11 <rrix> imo**
00:32:24 <mchua> and as a student I'm going to be *way* better positioned to tap campus resources than any other place - and better positioned to tap them than someone who is not a student/staff/faculty member.
00:32:33 <rrix> definitely
00:32:53 <mchua> rrix: well, then. what does that mean wrt "things Mel needs to do to be a campusamb?"
00:32:59 <mchua> do I have to become an ambassador?
00:33:18 <mchua> do we want to ask famna if we can be a subgroup, with a special kind of geo/region?
00:33:22 <mchua> (or whatever the right words here are)
00:34:08 <rrix> I think that would be more famsco than famna now that I think about it; we have a _lot_ of campusamb applicants in APAC, for example
00:34:19 <mchua> s/famna/famsco
00:34:24 <mchua> same question :)
00:34:29 <rrix> yes
00:34:35 <rrix> I think that would be possible
00:34:55 <rrix> at that point, if we exist seperately from famna, emea, etc, I worry about funds, etc, for ambassadors
00:35:11 <rrix> they don't need money to fly to conferences or anything, but swag and media are region-specific, aren't they?
00:35:24 <rrix> if we identify as a different "region", where does that leave us?
00:36:00 <mchua> Do we have to identify as a region?
00:36:15 <mchua> or just make it so that... so, here is where I show my ignorance about the workings of ambassadors
00:36:23 <rrix> at a famsco level that's what we would be called
00:36:27 <mchua> normally when you become an ambassador you become responsible for local presence in your area, right?
00:36:39 <mchua> is that called "responsible for your region?" where your region might be, say, the greater boston area?
00:36:43 <mchua> (for me right now)
00:36:57 <rrix> basically
00:37:59 <mchua> ok. so can we say "I want my region to *just* be this school?"
00:38:06 <mchua> not the town around it, not the city near it... just my school?
00:38:42 <rrix> I think so, that would be something to ask famsco to be sure of though
00:39:57 <rrix> at that point, though campusambassadors are regular ambassadors. What are the points of the FAS group, the mailing list, the irc channel, etc, as opposed to just popping them into the ambassadors mailing list and irc channel?
00:40:29 <mchua> Well, I am willing to bet that there will be similarities across campus activities no matter what geo you're in.
00:40:35 <mchua> as in, we know APAC and NA are different
00:40:49 <mchua> but a school in APAC and a school in NA may be more similar than a school in NA and a city in NA
00:41:02 <mchua> in terms of "what info is useful for ambassadors with this sort of territory to share?"
00:41:06 <mchua> if that makes sense
00:41:15 <rrix> I think s
00:41:17 <rrix> o
00:41:18 <mchua> y'all have classes, grades, profs, finals...
00:42:47 <rrix> I just realize we've not been #idea'ing
00:42:48 <rrix> oh well
00:43:28 <mchua> #idea make campusamb requirements on a case-by-case basis as needed, in the beginning
00:43:35 <mchua> no sense in having more structure than you need ;)
00:43:39 <rrix> :)
00:43:50 <mchua> not sure how you phrase the question to famsco
00:43:58 <mchua> can you try wording that one? I don't know the terminology.
00:44:16 <mchua> "can we be ambassadors with our schools only as the territory?"
00:44:21 * mchua waves hands around and babbles
00:45:06 <rrix> #ida "how can students who only want to be an ambassador for their school, due to either time or interests, indicate that? Students' workload is often too high to represent Fedora for an entire city, but they should be able to represent their school as an ambassador" or so
00:45:16 <rrix> #idea "how can students who only want to be an ambassador for their school, due to either time or interests, indicate that? Students' workload is often too high to represent Fedora for an entire city, but they should be able to represent their school as an ambassador" or so
00:45:50 <mchua> I think that works.
00:46:19 * rrix nods
00:46:33 <rrix> at least as a jumping point for one of my classicly long winded emails to the famsco list :)
00:47:16 * mchua grins
00:47:17 <mchua> good stuff, those.
00:47:44 <rrix> :P
00:51:31 <mchua> rrix: ok - what else do we need to do to start as campusambs?
00:51:57 <rrix> From whose point of view? Students or us trying to start the project?
00:54:58 <mchua> rrix: at this point, is there any difference? ;)
00:55:03 <mchua> who you've got is who you've got.
00:55:08 <rrix> true
00:55:30 <mchua> start with the few you've got, do something that works for them - for us - and then figure out how to help others once you've taken care of people who are here already and eager to do stuff.
00:55:33 <rrix> I mean, are we talking about "what do i have to do to join campus amb" or "what do i have to do to start campus amb"?
00:55:50 <mchua> well, in order to start campusamb, you need to have people joining it, so...
00:56:04 <mchua> so, let me back up a bit
00:56:05 * rrix nods
00:56:29 <mchua> one of my profs once told me "what is law? law is what laywers do." (I was confused by this for days.)
00:56:44 <mchua> Campus ambassadoring is whatever campus ambassadors do; we'll define the group by the actions that we take.
00:56:52 <mchua> We don't necessarily need to premeditate them all right now. ;)
00:57:10 <mchua> Right now, there is one member of the campusamb group that has a bunch of targets to hit next semester
00:57:21 <mchua> that he can figure out how to work towards and plan for, over the summer/fall.
00:57:24 <mchua> that's you.
00:57:31 <mchua> you have some ideas of what you're going to do at ASU.
00:57:36 * rrix nods
00:57:57 <mchua> you can tell us that you have these plans, that for you, being a campusamb means you're going to be doing this $stuff that seems to fit within campusamb's purview
00:58:05 <mchua> "and what are other people doing?"
00:58:22 * rrix nodnod
00:58:23 <mchua> and then you can walk people through the same questions I asked you today, to help them figure out their own campus plan.
00:58:40 * mchua would be happy to be a case study but won't get to school until the spring semester and doesn't know what that's going to look like yet.
00:58:55 <mchua> but if you'd like the practice, I could probably begin thinking ahead to what Purdue could use. :)
00:59:57 <mchua> I am assuming that I'll get accepted into their engineering education PhD program in order to learn how to figure out how learning happens in open source communities, and what good things about the culture of a FOSS environment can be translated into undergraduate engineering classrooms.
01:00:12 <rrix> awesome!!
01:00:22 <mchua> That's a large assumption. I need to get in first. :)
01:00:43 <mchua> But assuming that I do... and that I'll be rather hosed with coursework and whatnot... how might I think about being a campusamb?
01:00:47 <mchua> o fearless leader, guide me. :)
01:02:03 <rrix> OHSHI- :)
01:02:55 <rrix> well, start by gettng in contact with a mentor in the ambassadors program, and seeing what you can do to become an ambassador; campus ambassadors have to go through the same rigor that "regular" ambassadors do to join the program
01:03:03 <rrix> oh
01:03:09 <rrix> #idea Campus Ambassador mentors for each region?
01:03:45 <mchua> should campus ambassadors mentor campus ambassadors? Ooh, that's not a bad idea.
01:03:50 <mchua> When it's possible, that would probably be good.
01:04:10 * mchua wonders if Arizona and Indiana are sufficiently close that she can ask rrix to be her mentor when the time comes.
01:04:38 <rrix> mchua: the only thing is getting famsco to agree with having three/four college kids become mentors :)
01:05:09 <rrix> mchua: I was mentored by a guy from utah, I think that geographical differences are mostly non-issues if they are in the same region at least
01:05:31 * mchua nods
01:05:45 <rrix> and even then, there are exceptions (nelson marques from Portugal was being mentored by Rodrigo from LATAM for example)
01:05:53 <mchua> rrix: I don't see why that should be a problem (having college students as mentors) but I also don't know the requirements to become a mentor
01:06:04 <mchua> and whether college students are likely to be able to meet them
01:06:09 <mchua> I mean, the age shouldn't matter.
01:06:12 <rrix> yeah, me neither
01:06:25 <rrix> I do know that mentors have to be voted on by famsco
01:06:39 <rrix> #action rrix to see when famsco meets and bring this up to them
01:08:16 <mchua> #action rrix to find out what requirements for becoming a mentor are, and whether it's realistic to aim for having campus ambassadors be mentored by other campus ambassadors eventually (for some value of $eventually)
01:08:29 <mchua> rrix: in the meantime, what can I do to think about Purude / get started / etc?
01:09:18 <rrix> Purude?
01:12:29 <mchua> er, Purdue.
01:12:30 <mchua> Yes.
01:12:31 <mchua> I can type.
01:12:41 <rrix> ahhh
01:12:53 <rrix> is that where you're hopefully off to? nice :)
01:12:58 <rrix> hmmmm
01:13:03 <rrix> probably ask yourself the same questions you asked me :)
01:13:14 <mchua> You ask me, I've forgotten. :)
01:13:19 <mchua> It's good practice.
01:13:28 <mchua> well... s/I've forgotten/I'm too lazy to scroll all the way back up
01:13:36 <rrix> [16:30] <mchua> rrix: what do *you* want to do at ASU in the fall? :)
01:13:42 <mchua> s/fall/spring
01:13:48 <mchua> but yes.
01:13:49 <mchua> Um...
01:13:51 <mchua> pass classes.
01:14:04 <rrix> er, yess :)
01:14:07 <mchua> Find if we have a campus LUG, I suppose.
01:14:13 <mchua> what already exists there.
01:14:24 <mchua> #action mchua find out if Purdue has a campus LUG, what already happens on campus
01:14:33 <mchua> And then figure out what load I'll be carrying, what classes I'll be taking.
01:14:37 <rrix> I can't imagine there wouldn't be a LUG
01:14:48 <mchua> I... don't know how much bandwidth I'll have to do outreach *into* Purdue
01:14:56 <mchua> but what I could do is blog about my experiences to Fedora
01:15:10 <mchua> in terms of "these are interesting things happening on campus, any applications of FOSS/TOSW you folks can think of?"
01:15:13 <mchua> and then relay those in
01:15:18 <rrix> oooh
01:15:34 <mchua> I think there are some people who would like more context as to what is going on at schools so we can go in and tap them better and whatnot
01:16:02 <rrix> definitely
01:16:05 <rrix> I know that i do :)
01:16:08 <mchua> so I can at least write about my experiences. "gaaaah this computer lab is totally locked up" or "this teacher was very responsive when i asked if I could use FEL for classwork if I converted the files to her preferred hand-in format at the end"
01:16:40 <rrix> #idea window into school from Fedora Planet et al
01:16:44 <rrix> er
01:16:47 <rrix> #undo
01:16:47 <zodbot> Removing item from minutes: <MeetBot.items.Idea object at 0x2b03b0fe46d0>
01:16:52 <rrix> that was horribly worded
01:17:04 <rrix> #idea window into school's FOSS activities to Fedora Planet et al
01:21:28 <mchua> rrix: think we've got enough? :)
01:21:35 * mchua has to hop out soon
01:21:41 <rrix> I daresay we do, was about to ask the same :)
01:21:44 <mchua> rrix: does this help in terms of "what do I do to start campusamb?"
01:21:49 <rrix> definitely
01:21:51 <mchua> rrix: do you know what you're going to do next?
01:22:05 <rrix> I'm going to throw this at biertie and lcafiero with some distillation
01:22:14 <rrix> and see what they think, and if they agree, roll with it
01:23:10 <mchua> rrix: well, you can also throw your ASU plans for next year to the list right now
01:23:20 <mchua> since you can do that no matter what ;)
01:23:22 <rrix> definitely
01:24:19 <mchua> I'm on the list, so when I see that email from you, it'll remind me to do the same.
01:26:25 <rrix> kk :)
01:26:32 <rrix> shall we endmeeting?
01:27:17 <mchua> rrix: worksforme
01:27:21 <rrix> kk
01:27:21 <mchua> thanks, rrix!
01:27:28 <rrix> thank *you* mchua!
01:27:31 <rrix> #endmeeting