17:31:36 <decause> #startmeeting
17:31:36 <zodbot> Meeting started Wed Aug 12 17:31:36 2015 UTC.  The chair is decause. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:31:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:31:53 <decause> #info Zoltan HOppar is the session lead
17:32:08 <decause> #topic Ambassador Mentoring Upgrade
17:32:28 <decause> I'd like to talk abou the process we used to generate ambassadors, and get new mentees
17:32:39 <decause> I think it would be good to further this process
17:32:43 <decause> we have lots of things:
17:32:50 <decause> 1) Short Introduction
17:32:59 <decause> I've mentord since 2010, approved by cwickert
17:33:23 <decause> because of lack of mentors who care about people. Community member since 09. Tranlsation, localization, marketing
17:33:35 <decause> as a people person, I think I'm one of the guys who is right for this task
17:33:44 <decause> #topic what is mentoring?
17:33:57 <decause> process to teach and approve the right candidates as ambassadors
17:34:10 <decause> they don't just look at people, but are involved in coding an dother tasks.
17:34:16 <decause> they are the backbone of the community that matters
17:34:31 <decause> sometimes, the local members of ambassadors are the first in a region
17:34:42 <decause> this can blossom into a community locally, and internationally
17:34:54 <decause> ambassadors are the face of the community, then the mentors are the soul of ambassadors
17:35:03 <decause> #topic current process
17:35:13 <decause> when someone asks, we get introductions via email
17:35:19 <decause> "hey, I'd like to be ambassador"
17:35:34 <decause> the mentors look over it, and the ambassador chooses a mentor
17:35:45 <decause> the candidate gets entered into the trac
17:35:54 <decause> they get a welcoming message, and first tasks they have to do
17:35:58 <decause> within Fedora
17:36:13 <decause> mentors take care and work together with candidates, or new mentees, that brings us further
17:36:43 <decause> in the end, if the mentor finds taht candidate ready, they will add them to the FAS mentor and/or ambassadors list
17:37:11 <decause> Q: IS this the trac, or FAS amabassadors group?
17:37:16 <decause> A: FAS group.
17:37:29 <decause> before you apply, you must understand the info in the welcome message
17:37:44 <decause> it is a good thing to maintain a checklist to make sure the candidates make it through the process
17:37:59 <decause> sometimes, candidates don't get the mail, or they don't read it, and we have to pay attention to this
17:38:14 <decause> we must support the new candidate with a task, and we have to inspire it, instead of the candidate
17:38:24 <decause> when possible, we have to be open that we are always available
17:38:33 <decause> it is a good idea to run on the IRC office hours
17:38:42 <decause> it is good that people have a fixed point to come back to
17:38:49 <decause> a mail list is useful to come back to
17:38:58 <decause> Q: Email list?
17:39:18 <decause> A: There is a mentors mailing list, and an ambassadors list. It doesn' thave as much traffic (mentors) and is useful for this purpose
17:39:30 <decause> when you are talking personally with your candidate, logged sessions must be an option
17:39:51 <decause> you must represent to them what you have given and teached, and the availability for them to follow what they learned earlier
17:40:02 <decause> not everyone has the same free-time in their sched, so this helps to syncronize
17:40:11 <decause> as a mentor, you must balance time and resources
17:40:26 <decause> a candidate must know the process is based on trust
17:40:32 <decause> both people must have known avaliability
17:40:34 <decause> we are humans
17:40:52 <decause> the mentor is helping you, but, it won't work if they can't do their job
17:41:00 <decause> pointing to what is necessary to do or learn is important
17:41:17 <decause> keeping those sessions, and times, and follow-ups, and tickets in trac, helps a lot
17:41:21 <decause> this can mean problems
17:41:30 <decause> #topic Mentoring Problems
17:41:42 <decause> 1) Candidate can't see the process
17:42:01 <decause> there is no website where candidate can follow along, and see if it is possible to check into the next mentoring time
17:42:11 <decause> the wiki is updated, but it isn't clear about where in the process things are
17:42:24 <decause> if someone wants to step to the next level of ambassador, and we need to upgrade our site
17:42:37 <decause> we need detailed guidelines on what to teach AND how to teach it
17:42:46 <decause> we need a procedure for everyone
17:42:56 <decause> trac is useful, but it is not the perfect tool
17:43:07 <decause> if we want to use it more, we need more fine-grained milestones fitted to candidates
17:43:27 <decause> we always connect with talented folks who don't need to be shown
17:43:38 <decause> but we need to connect with newer folks too
17:43:50 <decause> 2) Mentors doesn't have a website where you can find mentors
17:44:33 <decause> New ambassadors need some kind of starter kit, or page, perhaps a hub page
17:44:48 <decause> #info go to the Fedora Hubs talk with mizmo/mrichards
17:44:52 <decause> :)
17:45:19 <decause> Q: I have this problem now, where a candidate cannot check his status.
17:45:47 <decause> Q: The mentor is very busy, and does teaching, and community things, and the candidate doesn't know their status in over a year
17:46:40 <decause> Q: yeah, we don't have many active ambassadors in Australia
17:47:38 <decause> Q: is there a requirement that mentor/mentee must be from same region?
17:47:50 <decause> A: No, but there is a possible language barrier than can be difficult
17:48:25 <decause> Q: If I didnt' meet a person at a conference, I wouldn't have gotten involved in the ambassador program
17:48:58 <decause> Q: The apac region is very very big. We need more resources there for sure.
17:49:12 <decause> Q: last year, for the first time, we drew up a budget for APAC
17:49:51 <decause> I had a similar experience with an ambassador in Egypt
17:50:09 <decause> in the last few months, he's been represeting Fedora both inside and outside of classroom as a teacher
17:50:16 <decause> he should come next year, and get his visa
17:50:25 <decause> I'd like to approve him as a mentor, and another from Turkey
17:50:49 <decause> Q: one of the problems in the past, may be solved now, is that local communities must approve a mentor
17:51:14 <decause> Q: No, that doesn't work. FamSco wanted each ambassador to be part of another part of Fedora, to not just be an outside rep
17:53:38 <decause> #topic Possible Solution
17:53:48 <decause> would be a great option to:
17:54:06 <decause> - make a new code of conduct for mentors, and teaching guidelines for new ambassadors
17:54:23 <decause> - work on the created content manager plugin and static website (Fedora Hubs)
17:54:37 <decause> - make a digital starter pack for ambassadors (website content)
17:55:05 <decause> - make a Fedora press center and contacts website (similar to the Firefox one - to see who will lead)
17:55:13 <decause> - fix and update the current wiki how-to's and such
17:55:58 <decause> Q: I've done lots of kids mentoring in US/UK/AUS
17:56:27 <decause> Q: They didn't have a starterpack, and I didn't know why. The problems were phenomenal. YOu don't bring someone into mentoring and say "you're here. do it"
17:56:40 <decause> Q: There is a difference between ignorance and arrogance
17:57:32 <decause> one of my friends in the Hungary community created this
17:57:56 <decause> #link http://fedorapack-zoltanh721.rhcloud.com
17:58:44 <decause> this is a php wordpress template
17:58:54 <decause> it is a fully customizable task management system
18:00:13 <decause> Q: It sounds like you want a process above just tickets in trac, to manage process?
18:00:16 <decause> A: Yes.
18:00:54 <decause> Q: Coming into Mozilla, bugzilla is a huge barrier to entry. In 2015, teenagers don't want to understand it, or jump into heavy end of trac. An abstracted level above that would help.
18:03:12 <decause> Q: it sounds like the design team has a nice process!
18:03:48 <decause> Q: There are some barriers to language, but the biggest thing is time zones. I struggled with that bigtime.
18:03:57 <decause> Q: When I'm on IRC, there are not many others
18:05:20 <decause> Q: in some regions, asking for financial assistance is considered "begging" so understanding cultural differences is important too
18:07:56 <decause> #topic questions/openfloor
18:09:12 <decause> Q: one of hte things I want to do, and have been talking about, is doing some tutorials, and focusing on end-users
18:09:42 <decause> Q: we talk about IRC meetings, but I spend about 5% of my time on there
18:10:15 <decause> Q: there are barriers to using IRC itself
18:10:33 <decause> Q: maybe this is a wiki thing, or a hub thing, is that starter pack
18:10:46 <decause> Q: if there was a place you could go to to see an easy walk-through.
18:11:51 <decause> #action decause aggregate a list of all the #fedora-* IRC channels
18:14:19 <decause> #link http://blog.mozilla.org/press/kits
18:14:34 <decause> #endmeeting