14:03:59 <pingou> #startmeeting fedora-hubs
14:03:59 <zodbot> Meeting started Tue Jun 14 14:03:59 2016 UTC.  The chair is pingou. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:59 <zodbot> The meeting name has been set to 'fedora-hubs'
14:04:05 <pingou> #topic rollcall
14:04:11 * skrzepto is here
14:04:18 <radhikak> .hello radhikamani88
14:04:19 <zodbot> radhikak: radhikamani88 'Radhika Kolathumani' <radhikak@umich.edu>
14:04:30 <atelic> .hello atelic
14:04:31 <zodbot> atelic: atelic 'Eric Barbour' <ebarbour@redhat.com>
14:04:58 <stickster> .hello pfrields
14:04:59 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:05:12 <decause> .hello decause
14:05:13 <zodbot> decause: decause 'Remy DeCausemaker' <decause@redhat.com>
14:05:23 <sayan> .hello sayanchowdhury
14:05:24 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:05:34 <pingou> mizmo: around?
14:05:51 <radhikak> Yes
14:06:06 <radhikak> She must be logging in now
14:06:37 <pingou> ok let's give her a minute then :)
14:08:06 <jflory7> .hello jflory7
14:08:07 <zodbot> jflory7: jflory7 'Justin W. Flory' <me@justinwflory.com>
14:08:17 <pingou> hi jflory7 :)
14:08:21 <jflory7> Hiya :)
14:09:02 <pingou> ok so let's get started mizmo will join if/when she arrives :)
14:09:14 <pingou> #topic status update
14:09:22 <pingou> radhikak: would you like to start?
14:09:37 <radhikak> Sure
14:09:57 <radhikak> I finished the mockups for issues 91, 57
14:10:07 <pingou> which are? :)
14:10:35 <radhikak> https://pagure.io/fedora-hubs/issue/57
14:10:59 <radhikak> https://pagure.io/fedora-hubs/issue/91
14:11:11 <radhikak> personal calendar and plus plus widget
14:11:30 <pingou> cool :)
14:11:41 <radhikak> Completed the second week blog post, but having trouble uploading the mockups in jekyll.
14:11:42 <pingou> we'll need to write that small API for ++
14:11:51 <radhikak> Yes
14:12:40 <radhikak> Further , finished the paper prototypes for the issue 63 https://pagure.io/fedora-hubs/issue/63
14:12:59 <pingou> cool :)
14:13:03 <sayan> radhikak++ :)
14:13:03 <zodbot> sayan: Karma for radhikamani88 changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:13:06 * pingou look forward seeing them :)
14:13:12 <jflory7> radhikak++
14:13:27 <radhikak> I am using breadcrumbs navigation for this particular issue, haven't yet figured out what to do with the freeze updates
14:13:46 <radhikak> thanks :)
14:14:47 <radhikak> So I am kind of stuck wit this issue 63 https://pagure.io/fedora-hubs/issue/63
14:15:50 <pingou> stuck as in?
14:16:49 <sayan> can we have something like a timeline? https://timeline.knightlab.com/
14:17:02 <sayan> not exactly this but something on these lines
14:17:08 <radhikak> Thinking in terms of the ui, how should I show the freeze updates ? I remember you had mentioned that it is easy to show the alpha release
14:17:38 <pingou> radhikak: what do you mean with 'freeze updates'?
14:18:41 <pingou> (to be sure we speak about the same thing)
14:19:02 <radhikak> branching/ alpha freeze starts/ alpha release/ alpha freeze ends/ beta freeze starts / beta release/ beta freeze ends/ release freeze starts/ release
14:19:03 <sayan> I guess when the freeze starts and ends
14:19:27 <radhikak> This is cycle that you explained to me previously
14:19:35 <pingou> so you want to show the fact that it changed? or the freeze period?
14:19:59 <radhikak> The freeze period
14:20:58 <pingou> so that would be a small period surrounding the release
14:21:08 <stickster> Oh interesting. We don't really have a queryable API for that do we?
14:21:26 <stickster> just e.g. https://fedoraproject.org/wiki/Releases/24/Schedule
14:21:27 <pingou> using some sort of timeline we could show them and highlight them w/ a background color
14:21:42 <pingou> stickster: the schedule used to be put on fedocal as well, not sure it still is
14:21:47 <stickster> keeping in mind they can change during the actual schedule itself
14:22:33 <stickster> https://apps.fedoraproject.org/calendar/Fedora%20release/
14:22:36 <radhikak> I figured out how to show the pattern and the colors as well. The trouble is will the fedocal have the email updates ( about the freeze period)
14:22:43 <stickster> Although it looks like it wasn't updated since the last go/no-go meeting
14:23:40 <pingou> radhikak: if the person in charge of the program does, it should
14:23:50 <decause> love this concept
14:23:58 <stickster> pingou: are you talking about jkurik?
14:24:15 <pingou> stickster: could be, I keep forgetting their name :)
14:24:37 <pingou> stickster: yes him
14:24:39 <stickster> yes... it looks like jkurik has been keeping up with schedule changes on the fedocal calendar, although the very latest hasn't made it there yet
14:25:33 <jkurik> hi, even the last schedule update is imported to the Fedocal
14:25:34 <stickster> Wait, I'm wrong pingou  -- it is indeed correct! Thanks jkurik  :-)
14:25:40 <stickster> jkurik++
14:25:57 <pingou> jkurik: awesome, thanks for keeping it up to date :)
14:26:01 <pingou> jkurik++
14:26:01 <zodbot> pingou: Karma for jkurik changed to 10 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:26:07 <jkurik> #link https://apps.fedoraproject.org/calendar/Fedora%20release/
14:26:14 <pingou> so that solves the "source of info" question :)
14:26:34 <radhikak> Hmm, then I guess I got it, just wanting to know how it would work under the hood.
14:27:07 <radhikak> thanks jkurik
14:27:54 <pingou> cool :)
14:28:10 <pingou> anything else radhikak ?
14:28:23 <radhikak> Nope
14:29:40 <pingou> thanks for the update radhikak :)
14:29:47 <pingou> atelic: do you want to continue?
14:29:58 <atelic> sure thing
14:30:31 <atelic> So the majority of work this past week has been on getting the feed widget to live update from server sent events
14:30:55 <pingou> sweet
14:30:57 <atelic> aside from a few more tests and a little speed improvement, that is almost ready for functional/code review
14:31:09 <pingou> atelic++
14:31:15 <atelic> It's working really nicely locally
14:31:16 * decause is interested in this, after disabling feed widget at pycon sprints
14:31:23 <atelic> h/t skrzepto for the streaming server
14:31:25 <decause> locally
14:31:51 <pingou> atelic: so PR expected this week?
14:32:08 <atelic> pingou: yes within the next day or two
14:32:15 <pingou> great! :)
14:33:06 <sayan> atelic: great :)
14:33:06 <atelic> also this week I did some research on possible JS frameworks for hubs and fedora-apps in general to use and spoke to sayan and some people on fedora-infrastructure
14:33:26 <atelic> I wrote up a blog post here: https://barbour-em.github.io/javascript-frameworks.html if anyone missed it
14:33:46 <atelic> I think this is something that should be decided on earlier rather than later and might be a topic for later this meeting
14:33:50 <pingou> your take away was: angular right?
14:34:00 <atelic> pingou: no React
14:34:05 <pingou> ^^
14:34:15 <pingou> starts well ^^
14:34:15 <sayan> I also feel React is better
14:34:42 <sayan> but going ahead with React we need to rewrite the templates
14:34:59 <atelic> I think there aren't a whole lot of uses for managing state or user interaction yet with most apps yet and can implement View first
14:35:12 <mizmo> omg atelic this blog post is awesome
14:35:22 <atelic> we can also start rewriting templates modularly. I'm actually more than happy to do that work
14:35:25 <atelic> mizmo: thanks! :)
14:36:27 <atelic> Lastly, I started thinking about and organizing how api tests would look for hubs. I know skrzepto has thoughts on this and we will probably work together on increasing that converage
14:36:33 <atelic> </update>
14:37:00 <pingou> nice, ++ on the tests side
14:37:26 <pingou> skrzepto: want to continue?
14:37:30 <skrzepto> sure :)
14:37:58 <stickster> atelic++
14:37:58 <zodbot> stickster: Karma for atelic changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:38:13 <pingou> atelic++
14:38:16 <pingou> few :)
14:38:20 <pingou> phew*
14:39:06 <skrzepto> I just have a quick update. Just regarding Hubs, I fixed the models so when you delete users/hubs they cascade and now like atelic mentioned im working on increasing test coverage and noticed that the authenitcation layer is missing and reported it. Started with about 47% coverage and now up to 51% main blocker was getting user injected into the unittests
14:39:27 <skrzepto> ^user login
14:39:37 <pingou> which is solved as of yesterday if I read the logs correctly, no?
14:39:53 <skrzepto> pingou, yes i think so :)
14:40:04 <skrzepto> pingou, at least i see the user data in the tests :)
14:40:06 <pingou> cool :)
14:40:29 <skrzepto> </update>
14:40:58 <pingou> nice nice :)
14:41:07 <pingou> sayan: want to follow up?
14:41:09 <decause> skrzepto++
14:41:10 <zodbot> decause: Karma for skrzepto changed to 9 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:41:17 <sayan> Sure
14:41:20 <stickster> skrzepto++
14:42:10 <sayan> Last week I integrated redux-oidc
14:43:10 <sayan> and did a setup of different actions related to a login
14:43:58 <sayan> rtnpro: and I also discussed the intialstate for the application
14:44:19 <sayan> something which is very much needed for a React app
14:45:13 <sayan> we got a contributor who has been working on React and helped us refactoring the code - https://github.com/waartaa/waartaa/pull/207
14:45:52 <sayan> puiterwijk helped me setting up the tokens for oidc
14:46:23 <sayan> I will start working on adding those tokens with waartaa and see how things work out
14:46:38 <sayan> <eom>
14:47:05 <pingou> sayan: so you got login working or is it still wip?
14:47:43 <sayan> pingou: still in progress, I got the code ready but was able to generate the tokens yesterday
14:48:01 <pingou> cool
14:48:03 <sayan> I have not tested yet after generating the tokens
14:48:19 <pingou> ok, I gave it a try on fedocal yesterday, got the basic login to work
14:48:32 <pingou> but not in js and not using redux-oidc :)
14:49:14 <pingou> ok, on my side
14:49:24 <pingou> basically the FMN rewrite is ready
14:49:37 <pingou> the part that's missing is the IRC backend that needs to be fixed
14:49:48 <pingou> after that we can test/break it some more
14:50:04 <pingou> fingers crossed that this will work
14:50:17 <decause> pingou++
14:50:43 <pingou> I did some stats of the number of messages processed by seconds over a period of time: http://ambre.pingoured.fr/public/msg_per_sec_workers2.png
14:51:01 <pingou> we can nicely see when a worker goes down or when it/they come back up
14:51:31 <pingou> and practically we should be 2 to 5 times faster iirc
14:52:09 <pingou> </eof> for me
14:52:20 <pingou> devyani7: said she couldn't make the meeting today due to coming exams
14:52:30 <pingou> mizmo: do you have an update?
14:52:57 <mizmo> pingou, trying to get my workstation booted so i can tell you what i did lol
14:53:15 <pingou> ^^
14:53:21 <mizmo> i reviewed radhikak's mockups for the personal calendar widget and updated the ticket with some notes / suggestions
14:53:24 <mizmo> dont remember the ticket number offhand
14:53:37 <radhikak> 91
14:53:39 <pingou> https://pagure.io/fedora-hubs/issue/57
14:53:51 <pingou> indeed 57 is the ++
14:54:03 <radhikak> nope https://pagure.io/fedora-hubs/issue/91
14:54:14 <mizmo> oh i made more progress researching the translation hub stuff - i came up with a list of questions for noriko and her team and got back the answers just this morning, will spend some time this week reviewing and probably meeting with noriko and the zanata UX lead
14:54:30 <mizmo> i made some widget suggestions and ran them by the team to see if they'd be helpful, there was a list of like 8
14:54:39 <mizmo> so ill start mocking up the ones they noted would be useful and make a ticket for each
14:55:14 <mizmo> that's about what i have for this week
14:55:17 <pingou> mizmo: oh could you pass on skrzepto 's ticket as well?
14:55:36 <mizmo> pingou, number?
14:55:45 <mizmo> (sorry i just switched from laptop to workstation)
14:55:51 <pingou> would be great if they could tell us what they think of the request and ideally if they have timeline to implement it
14:56:01 <skrzepto> https://zanata.atlassian.net/browse/ZNTA-1166
14:56:08 <skrzepto> pingou, mizmo ^^
14:56:10 <pingou> thanks skrzepto :)
14:56:30 <mizmo> cool i can do that, i believe they offered help from the zanata development team so i will be sure to pass this on as something we need help with
14:56:44 <mizmo> #action mizmo to pass this on to zanata + noriko: https://zanata.atlassian.net/browse/ZNTA-1166
14:56:49 <skrzepto> np :) totalyy forgot to mention that in my update i was working on zanata
14:57:16 <pingou> skrzepto-- :D
14:57:29 <pingou> nah, thanks for the ticket skrzepto
14:57:34 <skrzepto> lol :P
14:57:39 <mizmo> yeh this ticket is great skrzepto
14:57:46 <pingou> it's nice and clear and nicely explains what we need and why
14:58:25 <pingou> hm, did I miss anyone for the status updates?
14:59:39 <pingou> ok so
14:59:43 <pingou> #topic open-floor
14:59:52 <sayan> An update - I would be starting to work on Fedora Badges widget issue
15:00:06 <pingou> sayan: server side or widget side?
15:00:55 <sayan> pingou: widget side, don't knwo if the server side needs changes
15:01:10 <pingou> sayan: there was the idea of: your next badge
15:01:32 <pingou> and that requires changes to the way badges are stored/modeled
15:01:35 <mizmo> yeh sort of a first start at implementing badge tracks
15:01:39 <sayan> https://pagure.io/fedora-hubs/issue/85
15:02:22 <pingou> yeah ok, for this mock-up we should be good w/ the current data
15:02:36 <mizmo> yeh that's the "personal" version
15:02:44 <mizmo> the one that needs the path/track support is the team version
15:02:59 <sayan> yes, this would help me get idea of badges codebase that will help me with the track functionality
15:03:42 <pingou> cool :)
15:04:16 <radhikak> I am thinking of something in lines of pattern-fly ...having a style guide for the fedora project. I believe this would be very useful. What do you think of it mizmo?
15:04:42 <pingou> radhikak: isn't that the idea of fedora-bootstrap?
15:04:52 <mizmo> radhikak, fedora-bootstrap is the equivalent of patternfly for fedora
15:05:24 <radhikak> Yup I know, I thinking more on the terms having it defined
15:05:53 <mizmo> radhikak, i think having documentation for fedora-bootstrap would be great
15:05:59 <radhikak> Currently, I have to check multiple sources for the style guide
15:06:38 <mizmo> i think continuing to mock up new widgets for hubs will help with that cuz fedora-bootstrap doesn't necessarily have everything we need yet
15:06:48 <mizmo> maybe documenting what is there will help us identify what we need to add too
15:07:17 <radhikak> Yup, that would be great too
15:14:53 <pingou> ok, should we close?
15:15:04 <pingou> 7 minutes of silence makes me think we're good to close :)
15:15:12 <pingou> #endmeeting