14:05:45 <pingou> #startmeeting fedora-hubs
14:05:45 <zodbot> Meeting started Tue Jul 12 14:05:45 2016 UTC.  The chair is pingou. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:05:45 <zodbot> The meeting name has been set to 'fedora-hubs'
14:05:48 <sayan> pingou: puiterwijk: seen this error: http://paste.fedoraproject.org/390233/32286146
14:05:58 <pingou> #topic rollcall
14:06:09 <skrzepto> .hello skrzepto
14:06:10 <zodbot> skrzepto: skrzepto 'Szymon Mucha' <skrzepto@gmail.com>
14:06:11 <sayan> .hello sayanchowdhury
14:06:13 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:06:13 <radhikak> .hello radhikamani88
14:06:14 <atelic> .hello atelic
14:06:14 <pingou> sayan: new one to me
14:06:16 <zodbot> radhikak: radhikamani88 'Radhika Kolathumani' <radhikak@umich.edu>
14:06:17 * pingou here
14:06:19 <zodbot> atelic: atelic 'Eric Barbour' <ebarbour@redhat.com>
14:06:26 <sayan> pingou: comes with gunicorn
14:08:59 <pingou> mizmo, stickster, devyani7 around?
14:09:18 <puiterwijk> sayan: yes, I have
14:10:15 <pingou> ok let's continue
14:10:19 <pingou> #topic status update
14:10:31 <pingou> atelic: do you want to start this week?
14:10:58 <atelic> Sure thing
14:11:32 <atelic> So last week I have been working two things. First, I worked to get plus-plus-service pretty much fully functional and that's up for review now. If anyone wants to review it or test it out, let me know.
14:11:57 <atelic> I also worked with skrzepto to get the feed live update pulling in from another server and iterating on the UI. I think I have a video of it in action.
14:12:02 <pingou> atelic: link?
14:12:11 <pingou> sweet :)
14:12:15 <pingou> atelic++ skrzepto++
14:12:25 <pingou> (atelic+skrzepto)++
14:12:25 * atelic digging for it
14:12:47 <stickster> me lurking
14:12:56 <atelic> ok: https://drive.google.com/file/d/0BwhhwdHuATxFNkVhbmFhS19wSGM/view?usp=sharing
14:12:58 <mizmo> pingou, hey im here but not here, in a flock planning meeting
14:13:04 <mizmo> (sorry :( )
14:13:07 <pingou> mizmo: ok, have fun :)
14:13:14 <mizmo> "fun" :)
14:13:23 <atelic> So that is the live feed with a limit of 20 messages before it trims off the older ones in the stack
14:13:24 <pingou> for some definition of it :)
14:13:40 <pingou> atelic: nice
14:13:52 <atelic> What you don't see in there is that the message limit is now configurable just like things are in the bar like other widgets
14:14:09 <pingou> sweet!
14:14:45 <atelic> At some point I'd like to get some people testing it out for some UI/UX feedback but most of the tech is in place
14:15:11 <atelic> Don't think there is anything else. Huge h/t to skrzepto for all his work. </update>
14:15:41 <atelic> ah, one last thing. the time stamp that gets passed in from the back end will get updated in real time as your feed sits on your page
14:16:00 <atelic> so if a message comes in, it will go from -> just now -> 1 minute -> 2 minutes etc
14:16:01 <sayan> atelic: cool
14:16:26 <atelic> sayan: https://github.com/nmn/react-timeago
14:16:51 <pingou> nice :)
14:17:03 <pingou> skrzepto: want to continue?
14:17:08 <sayan> nice
14:17:12 <skrzepto> pingou, yup
14:18:54 <skrzepto> I spent the entire last week squashing bugs that would cause the sse server to hang, also configuring it so it is valid sse. One of my biggest blockers was that I was sending messages as \n\n  but in python you need to send it as \r\n\r\n  super strange.   I then cleaned up the fronted so that the feed should auto authenticate and start consuming messages after you click enable. Before I was manually inserting data into the db to make it work.
14:19:34 <pingou> oh you fixed this? Cool!
14:19:35 <skrzepto> I also converted the fmn.sse project to fmn folder structure, as a result I lost coverage analysis fort some reason?
14:19:57 <skrzepto> pingou, yea but its kind of a monkey patch :P ill need to talk with you about that later
14:20:03 <pingou> ok
14:20:57 <skrzepto> Unfortunately my knowledge with deploying wsgi apps and setting up ssl certs is none, i wasn't able to setup a live demo :(  </update>
14:21:20 <skrzepto> the sse server is up just fedora-hubs is down
14:21:35 <pingou> we will start looking into deploying things in staging
14:21:47 <pingou> I need someone (or more) to review the fmn.consumer re-write
14:21:57 <pingou> from there we can make a first release
14:22:10 <pingou> release fmn.sse, roll that one out as well :)
14:22:20 <sayan> pingou: I will start that once I get the autocloud thing fixed and deploy fedmsg.meta
14:22:30 <pingou> https://github.com/fedora-infra/fmn.consumer/pull/76 for the review
14:22:35 <sayan> pingou: most probably from tomorrow
14:22:39 <pingou> sayan: thanks
14:22:47 <pingou> anyone is welcome to check it out
14:22:49 <skrzepto> pingou, I will need to look into how its deployed because im currous :)     Ill take a look as well
14:23:23 <pingou> thanks
14:23:36 <pingou> radhikak: want to continue?
14:23:42 <radhikak> sure :)
14:23:49 <radhikak> I worked on the prototypes , shared the link in the mail, still figuring few more functionalists , basically few more fixes, hoping to finish up by today or tomorrow. Started the work on calendar widget as well. Worked on other projects assigned. I still have to finish up the fedroa-bootsrap ( I have some ideas , shared with ryan in mail)
14:24:31 <pingou> shared the link in the mail -> which one?
14:25:11 <radhikak> http://radhikakolathumani.github.io/redhat/2016/07/10/design-and-code.html
14:25:22 <radhikak> This post has both the links to the prototypes
14:25:35 <radhikak> http://helphelp.s3-website-us-west-2.amazonaws.com/
14:25:44 <radhikak> http://releasecycle.s3-website-us-west-2.amazonaws.com/
14:26:23 <radhikak> Made some progress yesterday on this, still the images in the release cycle are not responsive :(
14:26:33 <pingou> .fasinfo radhikak
14:26:34 <zodbot> pingou: User "radhikak" doesn't exist
14:27:06 <radhikak> .fasinfo radhikamani88
14:27:07 <zodbot> radhikak: User: radhikamani88, Name: Radhika Kolathumani, email: radhikak@umich.edu, Creation: 2016-04-14, IRC Nick: radhikak, Timezone: UTC, Locale: en, GPG key ID: None, Status: active
14:27:10 <zodbot> radhikak: Approved Groups: designteam cla_done cla_fpca
14:27:26 <pingou> radhikak: thanks, so you're cla+1 which should give you access to fedorapeople if you want
14:27:47 <pingou> (if you don't want to use aws to hosts these files)
14:28:31 <radhikak> Just used the aws for hosting since I havent created a repo yet for committing the code
14:28:38 <radhikak> Will do so today
14:28:41 <pingou> radhikak: one question about the release widget, where did you plan it in a hub?
14:28:49 <pingou> left column? Right column?
14:29:36 <radhikak> I am planning on right column for now, however while protyping this widget yesterday I was thinking maybe a vertical one would do better ? But
14:30:13 <pingou> radhikak: yes, the current layout will make it hard to read for a right column widget
14:30:13 <radhikak> The slider movement wont be that effective as in making it "prominent"
14:30:21 <pingou> radhikak: thought about making this a circle?
14:31:02 <radhikak> That works as well however the widget would take up space , small circle wont be that effective representation
14:32:29 <pingou> it could be seen as the release circle, fn-1 release, alpha, beta, fn release
14:32:36 <pingou> with rawhide going always straight
14:33:30 <pingou> anyway food for thoughts :)
14:33:50 <pingou> it's just that the current widget is really wide for going on the right hand-side column
14:34:01 <radhikak> Yes I thought so too
14:34:10 <radhikak> shrinking the widget wont be effective
14:34:40 <pingou> anything else for you?
14:35:15 <radhikak> I will think more on this, nope thats all for now I was working other assignments last week
14:35:25 <pingou> thanks for the update
14:35:30 <pingou> sayan: want to continue?
14:35:33 <sayan> sure
14:36:05 <sayan> Last week I could not attend as I was running around collecting documents for the Poland visa interview
14:36:21 <fedmsg-hubs> pagure.pull-request.comment.added -- pingou commented on pull-request#210 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/210#comment-7083
14:36:23 <sayan> The interview was last Tuesday
14:37:07 <pingou> how did it go?
14:37:23 <sayan> I guess I mentioned earlier that rtnpro would be handling the backend stuffs and me working on React
14:37:31 <sayan> pingou: good :)
14:38:27 <sayan> pingou: I was almost on the verge of missing the interview as my flight to that city got cancelled due to heavy rains
14:39:05 <sayan> rtnpro has been working on realtime publishers https://github.com/waartaa/ircb/pull/70/
14:39:28 <sayan> and a websodcket server for react client https://github.com/waartaa/waartaa/pull/212
14:39:52 * pingou looks forward testing all this :)
14:40:25 <sayan> After fixing a few bugs: I got the thing working today morning
14:40:34 <pingou> sayan++
14:40:37 <pingou> rtnpro++
14:41:11 <sayan> On the React side: with new React release v15.2.0, a lot of packages broke
14:41:43 <sayan> along with the material-ui package which we were using
14:41:53 <sayan> This is the error https://facebook.github.io/react/warnings/unknown-prop.html
14:42:48 <sayan> the material-ui guys are working on it: https://github.com/callemall/material-ui/pull/4572
14:43:38 <sayan> this is the one I filed https://github.com/callemall/material-ui/issues/4670
14:44:29 <pingou> sounds like "fun" :/
14:44:30 <sayan> So, the react-ui is broken, but I right now the drawers which will be containing the channel list and user list works
14:44:55 <sayan> and I am working with mobile-first in mind, so it's responsive
14:44:57 <pingou> sayan: downgrading in the mean while isn't possible?
14:45:12 <sayan> pingou: I need some features which are in the higher versions
14:45:20 <pingou> arf
14:45:20 <sayan> I mean the latest versions
14:46:02 <sayan> Anyways that does not block my work, since the websocket client is ready I will work with the chatlog container now
14:46:26 <sayan> ChatLog container will contain the channel messages
14:47:19 <sayan> On the badges side, I thought to work over the weekend but could not setup due to the token issues
14:48:20 <sayan> but I did read a lot of react project code that has helped me to frame idea for generic react widget
14:48:30 <sayan> <eof>
14:49:03 <pingou> thanks for all this sayan
14:49:13 <pingou> atelic: is hub impacted by the new react?
14:50:00 <radhikak> pingou : can do a simplified version of this d3.js example , basically a sunburst kind of design (http://bl.ocks.org/kerryrodden/7090426). But it would be super tiny in a mobile version.
14:50:22 <atelic> pingou: no we are fine to stay on 15.1
14:50:27 <sayan> pingou: should not, as the version is not upgraded I guess
14:50:37 <pingou> ok, good for us then :)
14:50:46 <devyani7> .hello devyani7
14:50:47 <sayan> atelic: but we need to follow the right pattern so that it does not break later
14:50:47 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
14:51:01 <sayan> atelic: you can read the link I shared
14:51:20 * devyani7 was stuck in traffic :(
14:51:54 <atelic> sayan: I will go through the link today. I saved it to instapaper for now :)
14:52:21 <sayan> cool :)
14:52:46 <pingou> devyani7: just in time :)
14:52:50 <pingou> devyani7: any updates on your side?
14:53:12 <fedmsg-hubs> pagure.pull-request.comment.added -- atelic commented on pull-request#210 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/210#comment-7083
14:53:13 <fedmsg-hubs> pagure.pull-request.closed -- atelic merged pull-request#210 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/210
14:53:32 <devyani7> pingou: hi :) um, tried to save using forms
14:53:44 <devyani7> but am not sure how behind I am
14:53:58 <devyani7> am getting a oidc error when I try to register
14:54:10 <devyani7> and ofcourse : IOError: [Errno 2] No such file or directory: '/home/devyani/code-junk/fedora-hubs/hubs/../client_secrets.json'
14:54:14 <devyani7> :(
14:54:20 <pingou> we merged a small PR today that should improve getting setup with oidc
14:54:26 <pingou> so check the new README :)
14:54:27 <sayan> devyani7: check the README for the new steps
14:54:39 <sayan> flask-oidc was added recently
14:54:48 * devyani7 nods. will do that :)
14:54:57 <devyani7> thanks pingou sayan
14:55:02 <devyani7> <eom>
14:55:15 <pingou> well, not much on my side
14:55:25 <pingou> just improved the README for these issues with oidc
14:55:36 <pingou> and a small bug fix I ran into last time I ran hubs
14:56:30 <pingou> I spent a little time today going through the errors from fmn.hubs and fedmsg_meta to fix them
14:56:43 <pingou> so far, it looks like my changes are working :)
14:57:02 <stickster> \o/
14:57:58 <pingou> #topic flock-readiness meeting
14:58:25 <pingou> so stickster and I discussed last week that it would be good to start having a clear picture of what we will be able to demo at flock
14:58:42 <pingou> for this, we thought having a dedicated meeting, tomorrow, same time would be good
14:58:49 <pingou> can everyone make it?
14:59:13 <pingou> stickster, sayan, skrzepto, atelic, radhikak, mizmo, devyani7 ?
14:59:18 * stickster can
14:59:23 <sayan> +1 for me
14:59:39 <pingou> (reminder, that is tomorrow Wed July 13th at 14:00 UTC)
14:59:57 * devyani7 can. will start early :)
15:00:03 <stickster> from my POV... a good outcome would be a list of critical tickets (or other tasks/blockers) to focus on, so that we have at best some sort of demo for Flock, and at worst, a basis for a strong hackfest
15:00:11 * skrzepto checking what 14;00utc is locally
15:00:16 <atelic> +1 ill be there
15:00:17 <mizmo> pingou, i can do this time tomm
15:00:21 <pingou> should be 10 am skrzepto
15:00:23 <pingou> stickster: ^
15:00:27 <stickster> 10am Eastern skrzepto
15:00:28 <skrzepto> pingou, then i can :)
15:00:30 <radhikak> Yes , I can as well
15:00:36 <pingou> cool :)
15:00:38 <mizmo> pingou, for skrzepto i think it's 9 am?
15:00:41 <skrzepto> so 9 am here which is til fine
15:00:47 <skrzepto> mizmo, yea :)
15:00:54 <pingou> mizmo: ah, bummer, these people not on the east cost really...
15:00:56 <pingou> :D
15:01:04 <stickster> pingou: Along the same lines -- were you successful at getting a room for workshop/hackfest at Flock on Friday?
15:01:13 <pingou> #agreed flcok readiness meeting: Wed July 13th at 14:00 UTC
15:01:33 <pingou> stickster: not yet, but failed to ask as well
15:01:38 <pingou> #undo
15:01:38 <zodbot> Removing item from minutes: AGREED by pingou at 15:01:13 : flcok readiness meeting: Wed July 13th at 14:00 UTC
15:01:45 <pingou> #agreed flock readiness meeting: Wed July 13th at 14:00 UTC
15:01:47 <stickster> pingou: Please do, but I think there is still space if I read the schedule right
15:01:52 <stickster> https://flock2016.sched.org/
15:01:59 <pingou> stickster: will do that today
15:02:15 <stickster> Friday afternoon == Friday morning in US-EDT, so it should be possible for remote participation too
15:02:27 <stickster> coolio
15:02:31 * pingou blinks at mizmo
15:03:01 <mizmo> i can get a babysitter :)
15:03:20 <pingou> alright, we're at the hour
15:03:29 <pingou> does anyone have something to add?
15:04:12 <sayan> no
15:04:22 <pingou> so let's finish :)
15:04:24 <pingou> #endmeeting