14:05:41 <pingou> #startmeeting fedora-hubs
14:05:41 <zodbot> Meeting started Tue Jul 19 14:05:41 2016 UTC.  The chair is pingou. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:05:41 <zodbot> The meeting name has been set to 'fedora-hubs'
14:05:48 <pingou> #chair mizmo sayan
14:05:48 <zodbot> Current chairs: mizmo pingou sayan
14:05:55 <pingou> #topic rollcall
14:05:58 <radhikak> .hello radhikamani88
14:05:59 <zodbot> radhikak: radhikamani88 'Radhika Kolathumani' <radhikak@umich.edu>
14:06:03 <atelic> .hello atelic
14:06:04 <zodbot> atelic: atelic 'Eric Barbour' <ebarbour@redhat.com>
14:06:04 <sayan> .hello sayanchowdhury
14:06:06 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:06:16 * skrzepto is here
14:06:49 <mizmo> .hello duffy
14:06:50 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
14:07:57 <pingou> alright :)
14:08:02 <pingou> #topic status update
14:08:08 <pingou> who wants to start?
14:08:30 <pingou> not everyone at once :)
14:08:36 <atelic> I ca
14:08:42 <pingou> go for it :)
14:09:03 <atelic> So I've been working on knocking out the tickets I was assigned for flock and I think I've made some pretty good progress
14:09:24 <atelic> Ticket #159 (User Membership Widget): https://pagure.io/fedora-hubs/pull-request/217 is up but like I said on the ticket it doesn't look like we have a way to distinguish if a hub is a group or a project right now so it just gets all non-user hubs
14:09:54 <mizmo> atelic, ++ no worries about group v project for flock
14:09:55 <atelic> Tickets #161 and #173 (Ellipsizing): https://pagure.io/fedora-hubs/pull-request/216 is up and seems to be pretty good to go once I push the changes pingou suggested today.
14:10:07 <atelic> mizmo: cool :)
14:10:32 <atelic> Ticket #158 (My Stream) has been big. First iteration of prototyping: http://i.imgur.com/9TiZM4R.png After the Feed widget was merged yesterday, hooked up a feed component to each tab.
14:10:52 <pingou> yeah there is no concept of team vs project in hubs right now
14:10:58 <atelic> Still a lot of questions left about how this should work though. Where will the data come from? Assuming fedora notifications. Will we create filters for the user for each tab? How do we distinguish an action from a mention? Looks like notifications only has 'message about a particular user'
14:11:01 <pingou> or rather all hubs are either: a person or a team
14:11:47 <pingou> the 'My action' tab should be easy
14:12:01 <pingou> we can just look if the user is in msg2usernames
14:12:33 <pingou> my mentions and saved notifs are harder
14:12:45 <pingou> (not even sure how we would do them at all)
14:13:14 <atelic> pingou: cool on My action. I've started thinking about saved notfications but that involved saving on the hubs db which I don't think meshes with how we think about hubs
14:14:00 <pingou> atelic: well saving this shouldn't be too much of a problem as it's info from elsewhere
14:15:14 <atelic> pingou: so we could probably POST the markup link and icon to save to the db and pull back up for presentation for the Saved Nofifs tab
14:15:40 <pingou> atelic: sounds good
14:15:57 <atelic> Ok, then that's all from me
14:16:03 <pingou> for saved notifs, I don't see another way than saving them in hubs itself
14:16:33 <atelic> I don't either
14:16:47 <pingou> I'd suggest we drop 'My mentions' for flock
14:17:06 <mizmo> for stuff we're dropping - could we keep the tab and just have some static text when you go to the tab explaining what would be there?
14:17:37 <atelic> mizmo: sure, not a problem
14:17:42 <mizmo> thanks :)
14:18:42 <pingou> skrzepto: want to continue?
14:18:54 <skrzepto> sure
14:19:19 <skrzepto> I was working on getting frequency of a hubs visit for each user
14:19:22 <skrzepto> https://pagure.io/fedora-hubs/pull-request/215
14:19:28 <skrzepto> pretty much done
14:19:50 <skrzepto> One problem with integration test is that I'm unable to load ajax in flask unittesting
14:20:01 <skrzepto> but I have tests that check the direct route to increment the counter
14:20:30 <skrzepto> thats about it for me in regards to hubs
14:20:33 <sayan> skrzepto: never done an ajax testing but afaik ajax testing is hard :\
14:20:49 <pingou> one option could be about adding tests with rube
14:21:01 <pingou> but that (imho) should be another set of tests, next to the unit-tests
14:21:09 <skrzepto> rube?
14:21:22 <pingou> https://github.com/fedora-infra/rube
14:21:40 <skrzepto> ahh selenium :)
14:21:44 <sayan> this is good :)
14:21:46 <pingou> yes :)
14:22:04 <skrzepto> I think that would be a great idea.
14:22:21 <pingou> sayan: you're up?
14:22:39 <sayan> sure :)
14:23:32 <sayan> nothing much to update, working on waartaa Chat Log container. no concrete work yet to commit
14:23:57 <sayan> on the badges side I worked on the models and the API - https://github.com/fedora-infra/tahrir-api/compare/badges-path
14:24:55 <sayan> and next work would be add it badges frontend
14:24:58 <pingou> sayan: oh you should really simplify this https://github.com/fedora-infra/tahrir-api/compare/badges-path#diff-32c1e0aac2527c335961e248a41e7c41R64 ping me after the meeting
14:25:32 <sayan> pingou: I was thinking to make it more generic because most of the queries are same
14:26:06 <sayan> but due to time issues, I did not bother much
14:26:19 <sayan> sure, I'll ping you after the meeting
14:26:23 <pingou> sayan: there are more to do :)
14:26:39 <sayan> <eof>
14:26:51 <pingou> radhikak: want to continue?
14:26:54 <radhikak> sure
14:27:01 <radhikak> Apologies for this link again, these are the two working prototypes for help widget and release cycle (done)
14:27:10 <radhikak> https://s3-us-west-2.amazonaws.com/helphelp/v2/index.html
14:27:19 <radhikak> file:///home/rkolathu/Desktop/Design%20Protoypes/release/i.html
14:27:32 <pingou> I fear that one won't work ^ :)
14:27:44 <radhikak> The release one ?
14:27:50 <pingou> check the link :)
14:27:58 <radhikak> OHH WAIT
14:28:02 <pingou> ^^
14:28:07 <radhikak> sorry about that
14:28:10 <mizmo> lol
14:28:26 <radhikak> https://s3-us-west-2.amazonaws.com/releasecycle/v3/i.html
14:28:42 <pingou> nice!
14:28:44 <pingou> and
14:28:47 <pingou> I like the animation :)
14:29:05 <atelic> radhikak++ looks nice!
14:29:06 <zodbot> atelic: Karma for radhikamani88 changed to 5 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:29:11 <pingou> radhikak++
14:29:11 <radhikak> thanks :)
14:29:31 <radhikak> I made it small so that it can adjust well in the right column
14:29:33 <pingou> radhikak: we should try to make it easier to update, so put the different dates in a JSON blob
14:29:33 <mizmo> pingou, i love the helphelp one. i think so far this looks good. a couple of things -
14:29:43 <pingou> and update the html based on it
14:29:49 <mizmo> (1) it seems the pull down / filter box needs a label otherwise ppl won't know to click on it / why they could / should
14:29:59 <mizmo> (2) probably the filters need a 'clear all' button
14:30:17 <pingou> oh that is a filtering box?
14:30:21 <radhikak> Yes , i need to add the event handler to the cross mark
14:30:22 <mizmo> for the release one - i think the key thing is a person can look at it at a glacne and understand where we are in the release cycle
14:30:26 <mizmo> when i look at it, i dont know where we are
14:30:30 <mizmo> am i missing something?
14:30:31 <pingou> (the date and people field will need to be adjusted)
14:30:49 <mizmo> pingou, (yeh its just a mockup)
14:31:00 <radhikak> The slider slides quickly, so probably the backend needs to be done
14:31:08 * stickster catches up and sees the release cycle graphic
14:31:11 <stickster> radhikak++
14:31:11 <zodbot> stickster: Karma for radhikamani88 changed to 6 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:31:47 <mizmo> radhikak, oh i see if i refresh it i see the slider, but it seems that could be missed. also it should fill from bottom up, not top bottom right? (because release is at top, branch at bottom)
14:32:04 <mizmo> maybe some kind of arrow along the left or right side pointing at the current status?
14:32:19 <pingou> cool yes
14:32:20 <mizmo> kind of like on a map "you are here" marker
14:32:24 <radhikak> yes , it fills from the bottom up ....the top is the rocket where the slider is at currently
14:32:38 <pingou> radhikak: then invert the colors
14:32:43 <radhikak> So yes, mizmo I agree
14:33:08 <mizmo> radhikak, so if this release cycle widget prototype is supposed to reflect that we're at release... i would expect the line to fill up from the bottom like a thermometer
14:33:22 <mizmo> radhikak, at least in my browser (firefox) it's light grey with a little nubbin of dark grey by the rocket
14:33:43 <pingou> mizmo: if you invert the grey/dark blue color, you get what you're describing :)
14:33:58 <radhikak> Its greyed out now , I will adjust the speed of the slider , maybe it will be clear then
14:34:15 <mizmo> pingou, yeh i think so
14:34:29 <mizmo> radhikak, i think you can't count on the user being there when this animation runs even if it's slower, you need a static indicator too
14:34:50 <mizmo> radhikak, eg what if (and i hate this term but it applies) this widget is below the fold of the page when the animation runs?
14:34:59 <radhikak> ohh okay , probably to see when where we are at currently
14:35:21 <mizmo> the other thing is animation is one of those things that sets off a bear detector right? they're loud - so it'll overpower anything else on the page eg other widgets if its present
14:35:49 <mizmo> (bear detector - in other words, if a bear is running at you, you don't tend to notice the flowers and the trees, your focus goes completely away from them)
14:36:05 <pingou> grrrrrggrrr
14:36:13 <radhikak> I was hoping maybe by backend we could do the slider according to the dates in the document
14:36:27 <radhikak> currently I wanted to show the how it moves tats all
14:36:59 <mizmo> radhikak, right - ideally this would be programmed to load in the current date / release schedule status, but even if it reflected that data accurately, i think there are some interaction issues to think through with this one
14:37:00 <radhikak> And I see it will hog all of the attention as compared to other widgets in the page
14:37:39 <mizmo> that doesn't mean that animation is bad or can't be used! it does look slick! just think about how to do it in a way that won't disrupt the user -
14:37:59 <mizmo> for example if you could think about somehow doing it on demand, maybe if the user hovers over that widget - but still make sure the info is available at a glance without direct interaction
14:38:34 <mizmo> if you animate on demand when the user is interactingw ith the thing, the bear detector rule doesn't apply since the user is explicitly focused on the thing that's being animated
14:38:57 * pingou likes the on over
14:39:35 <radhikak> ohhh okay, I got ur point. Perhaps we could be indicate the current status and then think about the animation part.
14:40:05 <mizmo> radhikak, ++
14:40:15 <radhikak> Currently, I still have to think about the on demand you suggested
14:41:19 <radhikak> Ohh one more, its just a visual mockup for now (https://pagure.io/fedora-hubs/issue/169)
14:42:00 <mizmo> radhikak, ooh i like it! i think the illustration needs a little bit of work but this is a really nice visual / layout!
14:42:15 <radhikak> Thanks mizmo
14:42:19 <pingou> that one should be easy to implement :)
14:42:23 <mizmo> im really excited you were able to make these interactive prototypes too, very hard work
14:42:30 <radhikak> I was thinking animation in the pandas
14:42:32 <mizmo> radhikak++
14:42:32 <zodbot> mizmo: Karma for radhikamani88 changed to 7 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:42:45 <radhikak> like changing the colors
14:43:32 <radhikak> radhikak thanks mizmo again and again :)
14:44:52 <pingou> mizmo: want to continue?
14:45:15 <mizmo> pingou, sure
14:45:38 <mizmo> sadly again i have not much to report, but now most of the big ticket flock items are at the vendors/printers, so hoping to get back into things this week
14:45:49 <mizmo> i did post a couple of summaries of the 2 meetings we had last week to hubs-devel
14:45:59 <mizmo> i also noticed there were some things we don't have tickets for that need to be done for flock :-/
14:46:00 <pingou> many many thanks for this mizmo !
14:46:03 <mizmo> i dont know that they are major
14:46:05 <mizmo> but -
14:46:22 <mizmo> (1) welcome message - i think we have this? but how do we set the text? and does it dismiss?
14:46:32 <mizmo> (the welcome message at the top of each team hub)
14:46:43 <pingou> should be doable
14:46:50 <mizmo> (2) blog posts in feed widget - i dont think they are they now
14:47:06 <pingou> they are in fedmsg, aren't they?
14:47:13 <mizmo> (3) add community guidelines to admins widget (we have the admins widget but the guidelines line isn't there - i think it should just be a simple link to the team wiki page)
14:47:15 <pingou> isn't that how they show up in #fedora-design?
14:47:44 <mizmo> pingou, ohhhh! you are right! i was thinking planet.fpo/design isn't in fedmsg, but fedmsg does the equivalent by highlighting design team members posts in #fedora-design
14:48:00 <mizmo> pingou, yes! so if we can just show the same posts fedmsg posts to #fedora-design in the design hub feed widget, that would be perfect
14:48:18 <pingou> not sure if we can make this before flock
14:48:21 <mizmo> i think i had more but cant find my notes.... the others i was concerned about was for the user profile
14:48:26 <pingou> but we know we can do this
14:48:50 <mizmo> well, i can make the tickets, and post the list of tickets to hubs-devel, and we can decide on list which ones could be tagged flock and which to leave for ater? would that be helpful?
14:48:58 <pingou> sure
14:49:00 <pingou> thanks
14:49:01 <mizmo> cool
14:49:16 <mizmo> #action mizmo to make missing tickets and post to hubs-devel, start discussion about which should be tagged flock
14:49:31 <mizmo> today im going to try to build the hubs code again on my system
14:49:36 <mizmo> and check things out
14:50:02 <mizmo> < /eom>
14:50:13 <pingou> making them work w/ oidc takes some tricks sometime
14:50:19 <pingou> so let us know if you run into something
14:50:35 <mizmo> ah okay, i probably will :)
14:50:35 <pingou> devyani7: want to update us on your progress?
14:52:04 <devyani7> pingou: hey, hi.
14:52:48 <devyani7> um, no. working on #162. not much updates.
14:52:54 <pingou> ok
14:53:05 * devyani7 lost her way, therfore missed rollcall
14:53:08 <pingou> let us know if you think you cannot make it, so that we can re-assign the ticket
14:53:24 <pingou> devyani7: also let us know if we can help :)
14:53:51 <skrzepto> Im free to help out if needed
14:54:02 <pingou> on my side, good news on the FMN front
14:54:12 <pingou> it's running the new fmn.consumer in stg
14:54:14 <devyani7> pingou: sorry, will work on it :)
14:54:21 <pingou> so far, no problem over the last 24h
14:54:30 <pingou> and it's been spamming me, the only user :D
14:54:40 <pingou> I'm looking forward pushing this to prod
14:54:49 <pingou> then we can merge skrzepto 's PR and push them to stg
14:55:04 <skrzepto> +1
14:55:15 <pingou> in other news: http://hubs-dev.fedorainfracloud.org/pingou/
14:55:21 <pingou> this is running from the top of develop
14:55:27 <pingou> but login is currently not working
14:55:37 <mizmo> pingou, \o/
14:55:40 <pingou> need to setup https for this first
14:55:51 <sayan> pingou++
14:55:53 <zodbot> sayan: Karma for pingou changed to 13 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:56:16 <radhikak> pingou \o/
14:56:55 <pingou> I also made the number of meetings shown in the meetings widget configurable
14:57:17 <pingou> and I have a PR making the meetings widget always show, even if no meeting were found in the specified calendar
14:57:33 <pingou> (which allows editing the widget if the calendar specified didn't exist)
14:58:04 <mizmo> pingou, does the meetings widget show meetings you are subscribed to?
14:58:19 <pingou> mizmo: it shows the meeting in a specified calendar
14:58:45 <mizmo> pingou, ah so your page is connected to the f24 release calendar?
14:58:56 <pingou> the 'infrastructure' calendar yes :)
14:59:19 <mizmo> ah okay
14:59:25 <mizmo> i wonder if that makes sense to do
14:59:40 <pingou> do?
15:00:10 <mizmo> yeh - if i was visiting a user's profile and there was a meeting widget, i'd expect it to have meetings i could meet the person at
15:00:17 <mizmo> but i think the meeting widget makes more sense on a team hub
15:00:32 <pingou> well, these are dates of interest to me
15:00:40 <mizmo> ah yeh
15:00:43 <mizmo> we have this issue - and its my fault -
15:00:48 <mizmo> there's the profile page for other people to read about you
15:00:56 <mizmo> and there's the personal page for you to get stuff you care about
15:00:58 <mizmo> and they aren't the same
15:01:01 <pingou> that's something we don't have for now
15:01:04 <mizmo> yeh
15:01:34 <mizmo> i wonder too if the meeting widget should be accordian style, so there are less details up front and you can open up the details for the meeting you're interested in (to save on vertical space)
15:01:52 <pingou> +1 for me
15:02:02 <mizmo> just some thoughts - sorry - i'm looking at this from the pov of what the demo will look like
15:02:07 <radhikak> The fedmsg events infograhic can be made interactive
15:02:14 <pingou> saving space was also the main idea for allowing to set a number of meetings
15:02:17 <sayan> +1 for me too
15:03:09 <mizmo> i think the subsribers / subscribed to widget should be very top, then next should be the hubs widget (belongs to, subscribed to) - the ordering of the rest maybe not as crtitical as those
15:03:14 <mizmo> i dont know if we can easily control order?
15:03:50 <mizmo> the profile badges widget needs similar accordion-izing i think - we have a ticket for that but it isn't tagged flock i dont think
15:03:51 <pingou> except that these aren't widget that are of much interest to me :)
15:03:54 <pingou> thus lower down
15:04:05 <sayan> btw, one more thing that the fonts are too much variable, if we can fix that
15:04:08 <mizmo> pingou, those should be top for other people visiting your profile (which i think is how people viewing the demo will see)
15:04:22 <mizmo> pingou, for your own view, i think it should be different
15:04:37 <mizmo> the ticket atelic is working on is meant to be for your own view
15:04:56 <mizmo> (158)
15:05:28 <pingou> but the own view just shows different feed
15:05:42 <pingou> s/own view/ticket 158/
15:06:14 <mizmo> "This page should be the first thing you see when you log in. It's different than your profile. There's information on your profile that doesn't necessarily have interest for you personally. See issue #84 for a discussion comparing the two."
15:06:43 <mizmo> so the feed widget in 158 should show notifications / etc that have to do with you
15:06:56 <mizmo> and the right hand sidebar can include any widgets you're interested in - basically the stack you have here
15:07:00 <pingou> ok
15:07:08 <mizmo> (the mockup just has library but others can be there)
15:07:27 <pingou> well the public facing page is still up to the user to organize as they wish since we allow them to edit/order
15:07:30 <mizmo> i was hoping the profile would be for other users... you know, who is person, where are they from, etc
15:07:48 <pingou> http://hubs-dev.fedorainfracloud.org/duffy/
15:07:58 <mizmo> pingou, absolutely, i think some of the widgets (at some point, doesn't have to be for flock) should be static though, like the subscriber count is always at top
15:08:13 * mizmo takes a look
15:09:30 <mizmo> so by default mine is a lot of stuff i dont know / care about :-/
15:09:54 <mizmo> for the demo we'll have to configure specific ones to make sense
15:10:25 <mizmo> it's developer / packager focused now which doesn't make sense for a designer, for example
15:11:18 <mizmo> half my widgets say "Got an error retrieving this widget. Sorry :("  :(
15:11:33 <pingou> yeah, checking the logs
15:11:43 <pingou> I think the DB isn't up to date
15:11:53 <pingou> but I need to fix the login first there
15:12:40 <mizmo> kk
15:12:46 <pingou> alright, anything else or should we close?
15:13:05 <mizmo> is the feed widget on the user profiles going to have anything?
15:13:20 <pingou> yes, once we have the SSE running
15:13:26 <mizmo> ah okay cool
15:13:32 * mizmo all set
15:13:43 <pingou> #topic open-floor
15:13:50 <pingou> we're way past the hour :(
15:14:00 <pingou> but does anyone have something to add?
15:14:03 * mizmo fault :(
15:14:15 <pingou> that's fine :)
15:14:40 <atelic> radhikak: do you have a svg/png for the panda circle?
15:15:02 <radhikak> Yes I do,
15:15:27 <radhikak> If you want the html code too I have that as well :P
15:15:35 <mizmo> atelic, radhikak - i think the illustration needs a bit more iteration tho
15:15:47 <radhikak> Yes , I have to work on the feedback first
15:16:18 <atelic> radhikak: mizmo okay, didn't realize you had an html mockup either. nvm then
15:17:37 <radhikak> I was not able to ale to push my code that y , will resolve that today
15:21:13 <sayan> pingou: shall we end?
15:21:22 <pingou> +1
15:21:25 <pingou> #endmeeting