14:00:38 <sayan> #startmeeting fedora-hubs
14:00:38 <zodbot> Meeting started Tue Aug 30 14:00:38 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:38 <zodbot> The meeting name has been set to 'fedora-hubs'
14:00:44 <sayan> #topic Roll Call
14:00:45 <pingou> o/
14:00:49 <devyani7> .hello devyani7
14:00:50 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
14:00:53 <abompard> .hello abompard
14:00:54 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:00:56 <sayan> o/
14:00:59 <sayan> .hello sayanchowdhury
14:01:02 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:01:30 <mleonova> .hello mleonova
14:01:32 <zodbot> mleonova: mleonova 'Maria Leonova' <mleonova@redhat.com>
14:02:22 <sayan> #chair mizmo mleonova abompard devyani7 pingou stickster
14:02:22 <zodbot> Current chairs: abompard devyani7 mizmo mleonova pingou sayan stickster
14:02:29 <stickster> .hello pfrields
14:02:30 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:02:58 <sayan> #topic Weekly Updates
14:03:06 <sayan> devyani7: want to go first?
14:03:13 <devyani7> sayan, sure
14:03:47 <devyani7> so, while helping a2batic and gunjan
14:04:04 <devyani7> I figured out that there are a few known errors that newcomers
14:04:06 <devyani7> are facing
14:04:19 <devyani7> so I wrote a "getting started with fedora-hubs" blog
14:04:45 <devyani7> Also helping a2batic with PR #236 and #251
14:05:01 <devyani7> to get the karma updates on the contact widget
14:05:17 <sayan> devyani7: is a2batic around? can you tell her to join the meeting
14:05:24 <sayan> devyani7: +1 for the blogpost
14:05:36 <devyani7> she left for home, should be joining soon
14:05:42 <sayan> Okay
14:05:48 <devyani7> sayan, one more thing
14:06:30 <devyani7> The bookmark modal needs a few more points, maybe
14:06:43 <a2batic> .hello a2batic
14:06:44 <zodbot> a2batic: a2batic 'None' <kmurarka@redhat.com>
14:06:49 <devyani7> will be working on it this week
14:06:51 <sayan> #chair a2batic
14:06:51 <zodbot> Current chairs: a2batic abompard devyani7 mizmo mleonova pingou sayan stickster
14:06:57 <devyani7> </update>
14:06:59 <sayan> devyani7: sure, ping for issues
14:07:09 <devyani7> yup, sure
14:07:22 <sayan> devyani7: btw, you need to update the last screenshot in the blog post, is your source updated?
14:07:29 <sayan> mleonova: want to go next?
14:07:38 <devyani7> um, yup it is updated
14:07:50 <devyani7> will update the screenshot. noted !
14:08:05 <mleonova> hey, sure. I don't have much to share yet
14:08:24 <mleonova> I think I need to talk to mizmo, but not right now
14:09:10 <sayan> mleonova: ok
14:09:28 <sayan> abompard: want to go next?
14:09:34 <abompard> sure
14:10:12 <abompard> so, I've pushed a big change in the Mailman/HyperKitty stack recently, that will allow us to survive the shutdown of Mozilla Persona.
14:10:26 <abompard> I'm waiting for the end of the alpha freeze to push it to prod
14:10:39 <abompard> in the meantime, I'm reading up on React.js for hubs
14:11:04 <abompard> I haven't written a lot yet, but I'm starting to understand the framework. It's nice :-)
14:11:09 <sayan> abompard++
14:11:10 <zodbot> sayan: Karma for abompard changed to 5 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:11:34 <abompard> I think atelic wanted to write the UI for the plus-plus widget?
14:11:59 <abompard> if that's the case I'll work on the supybot plugin update
14:12:05 <abompard> but if not, I'll write it
14:12:11 <sayan> abompard: right now a2batic is working on it
14:12:30 <abompard> ah, perfect
14:12:36 <abompard> Alright, that's all for me
14:12:59 <sayan> abompard: skrzepto worked on the frontend and sent us a PR
14:13:18 <abompard> sayan: I'll check it out :-)
14:13:32 <sayan> but then we thought to display the karma in the contact widget
14:13:57 <sayan> so a2batic is working on merging the PRs that are open right now.
14:14:04 <abompard> cool
14:14:27 <a2batic> sayan, yup
14:15:21 <sayan> mizmo: I was looking into this issue https://pagure.io/fedora-hubs/issue/98
14:15:24 <stickster> sayan: It might be helpful to '#action <person> <task>' so the meetinue minutes make it easy to check on what should be done by next time... I'll go back through log and help
14:15:44 <devyani7> stickster++
14:15:45 <zodbot> devyani7: Karma for pfrields changed to 8 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:15:51 <sayan> sure
14:15:52 * mizmo looks
14:16:30 <stickster> #action devyani7 a2batic finish PR #236
14:16:31 <stickster> #action devyani7 a2batic finish PR #251
14:16:54 <sayan> mizmo: is the mockup done then maybe abompard can work on it?
14:17:17 <stickster> #action abompard work on supybot plugin update
14:18:05 <mizmo> sayan, let me do a final pass on the mockup, i'll add it to my todos
14:18:19 <mizmo> #action mizmo to do final review on #98
14:18:27 <sayan> mizmo: thanks
14:18:34 <sayan> a2batic: you want to go next?
14:19:25 <a2batic> yes
14:19:30 <a2batic> my pr is -> https://pagure.io/fork/a2batic/fedora-hubs/diff/develop..plus_branch
14:20:07 <a2batic> I have integrated the karma with contact widget, but the karma is not working
14:20:29 <sayan> a2batic: right, let check it today after the meeting
14:20:49 <a2batic> There is some error in the js while converting html to json
14:21:01 <a2batic> sayan, ok
14:21:20 <sayan> a2batic: hmm, if there a js error that could be a issue
14:21:34 <sayan> mizmo: do you want to go next?
14:22:04 <mizmo> sure
14:22:12 <rahul_bajaj> hey, sorry for being late.
14:22:33 <mizmo> so first, ive been working with an outreachy applicant getting her started with hubs, sayan you helped her get her setup working too (wispfox)
14:22:48 <mizmo> i'm going to meet with her tomorrow to get her started on some ux tickets
14:22:56 <mizmo> in terms of design, i've been working on waartaa
14:23:06 <mizmo> i did a big survey of various IRC clients including web clients
14:23:24 <mizmo> found vector.im (matrix client, which supports irc)
14:23:33 <mizmo> and some others
14:23:48 <sayan> oh! maybe wispfox can start join these meetings too.
14:23:54 <mizmo> sayan and i talked about matrix and whether it might make sense at some future point for waartaa to support matrix
14:24:15 <sayan> mizmo++ on the beautiful waartaa mockups
14:24:17 <zodbot> sayan: Karma for duffy changed to 18 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:24:19 <mizmo> oh yeh, i told her about them last week but she had a conflict, lemme remind her tomm and see if we can get her to come regularly
14:24:21 <mizmo> yay
14:24:30 <mizmo> yeh so first i did a login mockup, very simple
14:24:41 <mizmo> i'm trying to do these in the style of the fedora bootstrap stuff ryan did for pagure, et al
14:24:56 <mizmo> (sec)
14:25:04 <mizmo> https://github.com/waartaa/waartaa/issues/219
14:25:34 <mizmo> and ive been doing a lot of thinking and trying on a main chat ui, here's a rough cut
14:25:44 <mizmo> https://github.com/waartaa/waartaa/issues/220
14:25:44 <stickster> That Matrix thing was pretty cool for a future branch
14:25:47 <mizmo> https://cloud.githubusercontent.com/assets/799683/18091945/7a377e7c-6e98-11e6-8111-836027fadb42.png
14:26:04 <mizmo> so you can see a lot of ideas with this one -
14:26:07 <sayan> yes, we need to do a detail research on the matrix before moving forward. I saw that matrix has python sdk.
14:26:15 <mizmo> - room list on left
14:26:30 <mizmo> (im thinking aobut listing them irregardless of network rather than splitting out by network... but haven't mocked all that up)
14:26:33 <stickster> jeez mizmo, that's awesome!
14:26:41 <mizmo> - tabbed sidebar on the right, where we could do pluggable modules
14:26:51 <mizmo> eg right now as mocked up it shows a potential meetbot integration widget
14:27:15 <mizmo> which would live update the meeting status - and it has a meeting running time clock too, highlights the current topic, and has a running action item list
14:27:19 <mizmo> thanks stickster :) :)
14:27:27 <mizmo> another idea here is inline images, bc i want that bad lol
14:27:48 <sayan> same here :)
14:27:50 <stickster> how would you know the future topics tho?
14:27:51 <mizmo> i played around a lot with the positioning of folks in the channel, after a lot of thought i think maybe having a horizontal bar up top made the most sense
14:27:56 <pingou> mizmo: do note that there could be two rooms w/ the same name on different network
14:27:57 <stickster> meh, minor nit :-D
14:28:02 <mizmo> it'd get ellipiszed after a certain point
14:28:13 <sayan> pingou: right, I was going to say the same thing
14:28:27 <mizmo> but i want visually for people to get the sense that there's a crowd vs a few people without too much effort. had some ideas about how people who are really active show first rather than ops/alpha ordering
14:28:43 <mizmo> and it's a pull down drawer thing (need to work on the controls for that) where you could see the full list of participants
14:29:08 <mizmo> pingou, oh i know, a lot of fedora channels are duplicated on gimpnet for instance... but they can just have a ($NETWORK_NAME) after them
14:29:16 <pingou> ok
14:29:45 <mizmo> the roomlist is the least finished part of this mockup in particular
14:29:46 <mizmo> anyway
14:29:47 <sayan> how about a divder on the top
14:29:58 <sayan> like most client have?
14:30:07 <mizmo> thats what i worked on
14:30:27 <mizmo> sayan, what do you mean by divider? like the line that comes across to mark when the window last had focus?
14:31:18 <sayan> mizmo: divider would be a wrong word here, just below Rooms we can have the name of the network
14:31:38 <sayan> also the use avatars on the top is the list of users in the channel?
14:31:48 <sayan> s/use/user
14:31:50 <mizmo> sayan, oh i didn't want to sort them by network, i wanted them alpha regardless of network so divider wouldn't make sense
14:31:58 <mizmo> sayan, yep that's right, the avatars on top are the users in channel
14:32:12 <sayan> mizmo: hmm
14:32:23 <mizmo> the idea iwth listing them flat without being categorized into networks is that a given channel's network is kind of an implementation detail
14:32:24 <mizmo> eg
14:32:24 <sayan> mizmo: what if there are huge numbers of user in the channel
14:32:35 <mizmo> if i want to watch weeds, i dont really care if it's netflix or hulu, i just want to watch weeds
14:32:57 <mizmo> sayan, it ellipsizes... there's an arrow to drop it down to view all too (haven't designed the full drawer view yet)
14:33:57 <sayan> mizmo: when it expands would it we the user avatar and the name of the user?
14:35:08 <mizmo> sayan, yeh i think so. also their presence / away msgs
14:35:34 <mizmo> there should be a search filter too i think
14:35:39 <mizmo> have to think more on it
14:35:45 <sayan> yes #freenode has 1500 users
14:36:04 <sayan> we always take the use-case of #freenode whenever thinking about users: )
14:36:05 <sayan> :)
14:36:15 <mizmo> sayan, lol thats a great idea
14:36:30 <mizmo> sayan, yeh im thinking up front it just lists users who have said something in the past 60 minutes or so
14:36:36 <mizmo> then there would be a divider kind of thing
14:36:47 <mizmo> and then it becomes more like a searchable phone directory or something
14:37:27 <sayan> yes, that sounds good
14:37:30 <mizmo> so for a 1500 user channel, im guessing only the people talking show up at the top, and maybe a paged searchable list of all 1500 below that
14:38:07 <sayan> The number of people talking would be far less
14:38:21 <mizmo> yeh
14:38:28 <mizmo> i think one of the #1 confusions about IRC for new users
14:38:32 <mizmo> is that "nobody's talking"
14:38:43 <mizmo> they dont understand peoples' presence and the concept of idling
14:38:59 <mizmo> so i want to break the user list down into active vs idle and really deemphasize the idlers
14:39:11 <sayan> yeah
14:39:30 <sayan> pingou: you want to go next?
14:39:40 <pingou> well, it'll be short :)
14:39:45 <pingou> I was afk for the last two weeks
14:39:59 <pingou> and I've been busy w/ pagure :)
14:40:08 <pingou> </eof> pretty much :)
14:40:41 <sayan> :)
14:41:18 <sayan> I have been spending time on the waartaa login frontend. Still in progress
14:41:58 <sayan> mizmo: what would be a good way to use the fedora-bootstrap? Extend the scss or just use the css file and extend it?
14:42:37 <mizmo> sayan, that's a good question for ryan - im guessing extending the scss is probably the preferred way to go
14:43:22 <sayan> mizmo: hmm, I'll ping ryan then on how to extend scss
14:44:07 <sayan> I was planning to add the fedora-bootstrap as a git submodule to waartaa but then I don't know how to change webpack to build that submodule
14:45:01 <sayan> <eom>
14:45:36 <sayan> let's go through the action items from last week once
14:46:08 <sayan> * mizmo to copy latest roadmap into pagure README for hubs
14:46:09 <sayan> (https://lists.fedoraproject.org/archives/list/hubs-devel@lists.fedoraproject.org/thread/KWK7D2HKPSNMIQ43KULIJK4J2ZKDFGEK/)
14:46:11 <sayan> * mizmo to archive old roadmap file into hubs repo
14:46:13 <sayan> * sayan to contact alex for update on zanata / sample output we can use
14:46:15 <sayan> to move forward
14:46:17 <sayan> * mizmo to investigate adding hubs positoins to outreachy (ux/dev / apps
14:46:19 <sayan> open up sep 5)
14:46:21 <sayan> * sayan ping lmacken on the issue #40
14:47:30 <sayan> alex told that they will be having a meeting on Wednesday and will be updating us
14:47:41 <mizmo> so i did add the roadmap to the readme (after a few goofs, sorry about that), i archived the old roadmap into the repo (it's in the docs dir), and i added the ux outreachy position to the fedora outreachy positoin list
14:47:51 <mizmo> (https://fedoraproject.org/wiki/Outreachy/2016)
14:48:06 <sayan> I am yet to ping lmacken so I am going to re-action that
14:48:17 <sayan> #action sayan ping lmacken on the issue #40
14:49:12 <sayan> Shall we go ahead an triage a few issues?
14:49:26 <sayan> we stopped at #57 last time
14:49:46 <mizmo> sure lets do
14:49:48 <mizmo> #topic triage
14:50:12 <sayan> #link https://pagure.io/fedora-hubs/issue/58
14:50:15 <mizmo> Create test suite framework for testing widget json data
14:50:25 <mizmo> We need an automated test suite.
14:50:25 <mizmo> It should have a framework for easily creating a widget configuration and then testing that the json data returned matches the expected output.
14:50:25 <mizmo> All the widgets end up doing network requests on the other side, so, instead of mocking, we should use the python 'vcr' module to freeze this.
14:50:30 <mizmo> priority?
14:50:50 <sayan> Normal for now
14:51:07 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#58 https://pagure.io/fedora-hubs/issue/58
14:51:16 <sayan> same for issue #59
14:51:21 <mizmo> kk
14:51:25 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#59 https://pagure.io/fedora-hubs/issue/59
14:51:26 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#59 https://pagure.io/fedora-hubs/issue/59
14:52:04 <mizmo> next is 63
14:52:05 <mizmo> https://pagure.io/fedora-hubs/issue/63
14:52:12 <mizmo> Current status in release cycle widget
14:52:28 <mizmo> i want to review & update this one
14:52:32 <mizmo> will reassign to myself
14:52:37 <mizmo> in terms of priority, i'd say normal
14:52:39 <mizmo> what do you guys think
14:52:42 <sayan> +!
14:52:44 <sayan> +1
14:52:51 <fedmsg-hubs> pagure.issue.assigned.reset -- duffy reset the assignee of ticket fedora-hubs#63 https://pagure.io/fedora-hubs/issue/63
14:52:52 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#63 https://pagure.io/fedora-hubs/issue/63
14:53:00 <mizmo> #action mizmo to review / update #63
14:53:12 <fedmsg-hubs> pagure.issue.assigned.added -- duffy assigned ticket fedora-hubs#63 to duffy https://pagure.io/fedora-hubs/issue/63
14:53:32 <mizmo> https://pagure.io/fedora-hubs/issue/64
14:53:35 <mizmo> Mail List widget
14:53:47 <mizmo> okay this one im confused about bc the mailing list messages are handled by the feed widget no?
14:54:33 <sayan> afaik, yes
14:54:47 <mizmo> so do we need another widget to display mialing list posts?
14:54:59 <mizmo> devyani7, do you know the status on https://pagure.io/fedora-hubs/issue/64 ?
14:55:20 <devyani7> mizmo: this needs to be integrated with the feed widget
14:55:56 <devyani7> I remember having a discussion with threebean regarding this, not quite sure how much work is left here
14:56:08 <devyani7> similar to blogposts
14:56:13 <mizmo> devyani7, okay. there are mockups for mailing lists posts in the feed widget but they look quite a bit different
14:56:24 <devyani7> mizmo, nod nod
14:56:25 <mizmo> devyani7, oh i see
14:56:42 <mizmo> devyani7, do you think this should stay a separate ticket? maybe rename it to 'integrate mailing list posts with feed widget' ?
14:56:53 <devyani7> post will be the threads, and replies will be the comments
14:56:58 <devyani7> mizmo, sure thing
14:57:00 <devyani7> :)
14:57:07 <sayan> devyani7: we have a seperate ticket for the comments
14:57:08 <mizmo> coolio
14:57:20 <mizmo> as for priority id set it to high since mailing list posts are super important for hubs
14:57:26 <devyani7> sayan, is it? am not aware of that :/
14:57:43 <sayan> abompard told we need to have an API on Hyperkitty for that, right?
14:57:43 <fedmsg-hubs> pagure.issue.edit -- duffy edited the title fields of ticket fedora-hubs#64 https://pagure.io/fedora-hubs/issue/64
14:57:48 <sayan> #link https://pagure.io/fedora-hubs/issue/175
14:57:54 <abompard> sayan: yes
14:58:37 <devyani7> hm
14:58:59 <fedmsg-hubs> pagure.issue.edit -- duffy edited the priority fields of ticket fedora-hubs#64 https://pagure.io/fedora-hubs/issue/64
14:59:26 <mizmo> sayan, do you know the # for the comments ticket?
14:59:50 <sayan> mizmo: https://pagure.io/fedora-hubs/issue/175
14:59:56 <devyani7> 175 mizmo
15:00:11 <mizmo> cool thanks ill note that in 64 as a reference
15:00:34 <fedmsg-hubs> pagure.issue.comment.added -- duffy commented on ticket fedora-hubs#64: "Integrate mailing list posts with feed widget" https://pagure.io/fedora-hubs/issue/64#comment-4676
15:01:32 <sayan> we are over time.
15:02:18 <sayan> btw, pingou closing the next ticket https://pagure.io/fedora-hubs/issue/73 ?
15:02:21 <mizmo> #info left off ticket triage at 64
15:02:39 <pingou> sayan: wfm
15:02:54 <fedmsg-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#73: "make favicon for each hub the user's avatar" https://pagure.io/fedora-hubs/issue/73#comment-4677
15:02:55 <fedmsg-hubs> pagure.issue.edit -- sayanchowdhury set the status of ticket fedora-hubs#73 to: Fixed https://pagure.io/fedora-hubs/issue/73
15:02:56 <pingou> we can also see how we use the notification in the favicon we have now
15:03:03 <pingou> but that's for later I guess
15:03:32 <sayan> pingou: yes
15:03:47 <sayan> ending the meeting...
15:03:51 <sayan> 3.
15:03:53 <sayan> 2.
15:03:55 <sayan> 1.
15:03:58 <pingou> 0.
15:03:59 <sayan> #endmeeting