14:04:37 <stickster> #startmeeting Fedora Hubs
14:04:37 <zodbot> Meeting started Tue Oct  4 14:04:37 2016 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:37 <zodbot> The meeting name has been set to 'fedora_hubs'
14:04:39 * pingou 
14:04:44 <stickster> #mdeetingname fedora-hubs
14:04:47 <stickster> arg
14:04:49 <stickster> #meetingname fedora-hubs
14:04:49 <zodbot> The meeting name has been set to 'fedora-hubs'
14:04:50 <pingou> ^^
14:04:54 <stickster> #topic Roll call
14:05:01 <sayan> .hello sayanchowdhury
14:05:02 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:05:12 <a2batic> .hello a2batic
14:05:13 <zodbot> a2batic: a2batic 'Kanika Murarka' <murarkakanika@gmail.com>
14:05:30 <saptaks> .hello saptaks
14:05:31 <zodbot> saptaks: saptaks 'Saptak Sengupta' <saptak013@gmail.com>
14:05:37 <abompard> .hello abompard
14:05:40 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:05:51 <devyani7_> .hello devyani7
14:05:51 <zodbot> devyani7_: devyani7 'Devyani Kota' <devyanikota@gmail.com>
14:06:41 <vivek_> .hello vivekanand1101
14:06:42 <zodbot> vivek_: vivekanand1101 'Vivek Anand' <vivekanand1101@gmail.com>
14:07:12 <stickster> #chair sayan a2batic saptaks abompard devyani7_ vivek_
14:07:12 <zodbot> Current chairs: a2batic abompard devyani7_ saptaks sayan stickster vivek_
14:07:55 <stickster> If you guys don't mind, I'm going to "seize" a few minutes at the top here to make sure I understand some general status and objectives
14:07:57 <fedmsg-hubs> pagure.pull-request.comment.added -- sayanchowdhury commented on pull-request#265 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/265#comment-10732
14:07:58 <fedmsg-hubs> pagure.pull-request.closed -- sayanchowdhury merged pull-request#265 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/265
14:08:28 <stickster> is mizmo / mizmo[m] around too?
14:08:38 <sayan> stickster: so each week we take an update on who is working on what
14:09:38 <stickster> sayan: Before we do that, can we reiterate what our milestone point is, and what defines being done with that milestone?
14:09:42 <sayan> Things we are working for the milestone are badges, zanata and irc and plus plus widget
14:09:51 <stickster> sayan: What's the milestone date?
14:10:03 <stickster> #topic General info for tho
14:10:05 <stickster> #undo
14:10:05 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1b577750>
14:10:08 <stickster> #topic General info
14:10:30 <sayan> stickster: mizmo told that their is a FUDCon Latam
14:10:37 <sayan> s/their/there
14:10:43 <stickster> Oct 13-16, 2016
14:10:49 <sayan> i.e October 13-16
14:10:52 <sayan> yeah
14:10:56 <pingou> same time as pycon-fr
14:11:39 <jcline> .hello jcline
14:11:40 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
14:11:43 <jcline> Sorry I'm late
14:11:48 <stickster> sayan: Is there a way to see all the issues that are attached to this milestone?
14:12:05 <stickster> no problem jcline... I'm playing catch-up :-)
14:12:45 <sayan> stickster: the issues are not tagged to milestones
14:13:41 <stickster> sayan: Should they be?
14:14:31 <stickster> even something like a "next" tag might be helpful, because then we could see out of the list of critical issues for the milestone, which ones are lagging and need help
14:15:06 <sayan> stickster: and the #help widget too
14:15:20 <stickster> I don't want to take the whole meeting off track. But it does seem to me that knowing what "done" means for the milestone is important if we want to know how we're doing
14:15:21 <sayan> stickster: so the thing is we were mostly tracking by the High Priority tag
14:16:23 <sayan> But since all the issues are not triaged so issues#<123 can be considered for the next milestone
14:16:52 <stickster> sayan: OK
14:17:34 <sayan> stickster: and then we go forward with status
14:17:42 <stickster> sayan: So should we start with looking for status on issues < #123, that are High priority, and assigned?
14:18:45 <sayan> stickster: yes, so the priority is Badges, IRC, Plus-Plus, Zanata and #help
14:18:50 <sayan> #halp
14:19:14 <stickster> sayan: OK, that tells me that other tickets marked High priority (like Search) should *not* be High priority
14:19:29 <stickster> or am I misunderstanding?
14:19:39 <sayan> stickster: yes, it should not be
14:19:49 <sayan> stickster: moving it to Normal Priority
14:19:56 <stickster> OK, so let's stick with the ones you named to start
14:20:13 <sayan> so Normal priority are the ones which moves to next High Priority
14:20:26 <stickster> #topic IRC widget(s)
14:20:29 <stickster> #link https://pagure.io/fedora-hubs/issue/2
14:20:34 <fedmsg-hubs> pagure.issue.edit -- sayanchowdhury edited the priority fields of ticket fedora-hubs#12 https://pagure.io/fedora-hubs/issue/12
14:20:40 <stickster> this ticket is unassigned, no update in 7 months... is that right?
14:20:50 <sayan> stickster: yes
14:21:08 <stickster> is it blocked by some other tickets?
14:21:30 <sayan> stickster: so IRC widget is completly worked on waartaa
14:21:43 <sayan> so I generally give the status on what is happening on waartaa
14:21:48 <stickster> sayan: OK go ahead
14:22:39 <sayan> last week we released ircb 0.3.0
14:22:59 <sayan> not last week actually it would be yesterday :)
14:24:12 <sayan> right now working on connecting waartaa and ircb to create accounts
14:24:47 <sayan> and sudipta is still working on the chat page
14:24:49 <stickster> sayan: Are issues #2, #27, #52 all handled via waartaa?
14:25:17 <sayan> stickster: right
14:26:51 <stickster> sayan: So at what point will someone be able to update these tickets?
14:27:31 <sayan> stickster: once we have waartaa up, we can update the tickets
14:27:35 <stickster> or maybe a better question is: what is the ETA for waartaa work to transition into fedora-hubs work?
14:27:53 <stickster> how close is waartaa to being done/up?
14:28:12 <stickster> and how do we know what "done" means there?
14:28:31 <sayan> stickster: done is when
14:28:42 <sayan> we have 1. Chat Page
14:28:47 <sayan> 2. Login page
14:28:55 <sayan> 3. Private messages
14:29:50 <sayan> so these things completes the minimalistic things needed for the widget
14:30:01 <sayan> and then we would be integrating it as an iframe
14:30:19 <stickster> OK
14:30:28 * stickster apologizes to all for dragging meeting too far down this road
14:30:41 <stickster> Let's move on to Badges :-)
14:30:46 <stickster> #topic Badges
14:31:14 <sayan> Last week, I worked on badges widget for the user profiles
14:31:39 <sayan> from the backend point of view it's done
14:32:00 <sayan> I have written basic structure for the widget
14:32:11 <sayan> But I need help with the classes for mockup
14:33:07 * sayan needs from mizmo here
14:33:16 <sayan> needs help
14:33:38 <stickster> #info help needed from mizmo -- classes for the mockup
14:34:36 <stickster> sayan: is this issue #17 or #85?
14:34:46 <stickster> sayan: neither of those has a current status
14:35:11 <sayan> stickster: #85 is this one
14:35:37 <stickster> sayan: Can you update the issue please with some current status and tag @duffy in the comment?
14:35:59 <sayan> stickster: Okay doing that
14:36:38 <stickster> sayan: apparently mizmo isn't available at the moment -- there was some sort of all hands meeting at RH that she might be attending
14:36:45 <sayan> yes
14:37:06 <stickster> #action sayan get with mizmo here in the channel later for next steps
14:37:24 <stickster> #action sayan update issue #85 with status
14:37:40 <fedmsg-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#85: "Badges Widget for User Profiles" https://pagure.io/fedora-hubs/issue/85#comment-23325
14:37:44 <stickster> anything else we need to cover on badges?
14:37:47 <fedmsg-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#85: "Badges Widget for User Profiles" https://pagure.io/fedora-hubs/issue/85#comment-23326
14:38:12 <stickster> hmm, pagure liked your comment so much it added it twice :-)
14:39:12 <stickster> sayan: if mizmo can give you information for the classes (I assume you mean CSS for the widget template?), is this close to done?"
14:39:20 <sayan> stickster: yes
14:39:41 <stickster> cool! \o/
14:39:53 <sayan> next is the badges path, for which I need to deploy tahrir, tahrir-api
14:40:10 <sayan> but I will start writing the code with the local setup
14:40:23 <stickster> sayan: so badge paths are *not* written yet?
14:40:51 <stickster> just trying to take a proper note for the minutes
14:41:05 <sayan> stickster: the path support is added to tahrir and tahrir-api
14:41:36 <sayan> I need to write Hubs widget that would use the tahrir rest api to get the data and render the widget
14:41:48 <sayan> so the work on Hubs front is left
14:42:11 <stickster> OK, got it
14:42:54 <stickster> #info for badge paths -- support exists in tahrir{,-api} but the front end work is still left to do on Hubs -- writing a widget that grabs data from the tahrir API and renders the path info
14:43:02 <stickster> anything else before we move on?
14:43:15 <sayan> puiterwijk needs to send a FBR to update rbac ruleset and give me authorization to run the badges playbook
14:43:26 <sayan> yes you can move on
14:44:07 <stickster> OK, thanks sayan
14:44:13 <stickster> #topic Plus-Plus
14:44:24 <stickster> #link https://pagure.io/fedora-hubs/issue/57
14:44:47 <puiterwijk> sayan: if you're blocked on a specific upgrade, I can just run that for you...
14:45:26 <sayan> puiterwijk: I can then test the changes on stg and deploy as soon as we are out of freeze
14:45:29 <stickster> abompard: Is Plus-Plus your baby, or someone else's?
14:46:31 <sayan> stickster: so Plus-Plus is merged, thanks to abompard, a2batic, skrzepto and devyani7_
14:46:33 <abompard> stickster: I started the backend
14:46:37 <stickster> woop woop!
14:46:41 <stickster> abompard++
14:46:41 <abompard> \o/
14:46:43 <stickster> a2batic++
14:46:43 <zodbot> stickster: Karma for a2batic changed to 10 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:46:45 <stickster> skrzepto++
14:46:47 <stickster> devyani7_++
14:46:48 <zodbot> stickster: Karma for skrzepto changed to 8 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:46:56 <stickster> COOKIE PARTY
14:46:57 <devyani7_> :(
14:47:02 <stickster> devyani7++
14:47:02 <zodbot> stickster: Karma for devyani7 changed to 9 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:47:04 <stickster> HAHA!
14:47:05 <a2batic> ^_^
14:47:06 <devyani7_> :)
14:47:09 <sayan> :)
14:47:25 <devyani7_> thanks stickster ^_^
14:47:50 <sayan> one thing is that right now we just show the karma in the profile contact information widget
14:47:51 <a2batic> thanks stickster :)
14:47:53 <stickster> sayan: The issue ticket is talking about being blocked on a couple other issues
14:48:49 <sayan> stickster: yes, the user metadata box right now does not have much information
14:49:12 <sayan> stickster: it is blocking on FAS3 deployment
14:50:39 <sayan> #link https://pagure.io/fedora-hubs/pull-request/236
14:50:46 <stickster> sayan: what do you know about FAS3 deployment status?
14:51:28 <sayan> AFAIK I know it was around November
14:51:38 <sayan> pingou can update here ^^
14:51:55 <stickster> Oh, so the PR #236 is to get around this issue for the time being, is that right sayan?
14:52:01 <sayan> stickster: yes
14:52:18 <pingou> the update is that I haven't heard about it in a while
14:52:32 <pingou> I poke Xavier a little while back about a couple of PRs
14:52:42 <pingou> which apparently are still not merged :(
14:53:12 <pingou> then I know puiterwijk had it on his list of 'to review'
14:53:26 <pingou> so basically, it's stale atm
14:53:38 <stickster> hey pingou, if you want we can ping Xavier in #fedora-apps and find out whether he has time to review/merge them
14:54:25 <pingou> stickster: I'll ask him :)
14:54:32 <stickster> OK
14:54:50 <stickster> #action pingou contact Xavier about PRs waiting in FAS3... and check on general deployment status
14:54:51 <pingou> (done)
14:55:06 <pingou> we have an instance running in stg w/o data
14:55:14 <pingou> we need puiterwijk 's green light to put data in it
14:55:17 <stickster> *nod
14:55:35 <pingou> then it's pyhon-fedora migration time, then the other apps, then announce, then cross fingers, then push to prod
14:55:47 <stickster> OK, so it seems like we have some substantial work left before the Plus-Plus widget issue can really be closed
14:56:01 <devyani7_> stickster, giving an overview on the hubs side, on extracting user's info using fas2, there were authentication issues. But,...
14:56:02 <sayan> Yes
14:56:03 <pingou> ++ waits on FAS3?
14:56:18 <devyani7_> in fas3 we will be able to extract info that the user has made public
14:56:28 <stickster> #info Need to finish testing FAS3 in stage w/ data; migrate python-fedora; then move other dep apps as needed; then announce change; then push to production
14:56:41 <stickster> devyani7_: Understood
14:56:56 <devyani7_> :)
14:56:58 <stickster> sayan: I am going to need to go shortly for another call, can you take over?
14:57:04 <pingou> well ++ itself can still go ahead no?
14:57:21 <sayan> stickster: sure
14:57:31 <stickster> pingou: I think you're right, it can go ahead in its "reduced" current form -- right sayan, devyani7_?
14:57:33 <sayan> abompard: can we give ++ via the API?
14:57:45 <devyani7_> karma field needs to be accessed, i guess !
14:57:51 <devyani7_> user's karma*
14:57:54 <abompard> sayan: yeah, the REST server should work
14:58:14 <sayan> stickster: pingou: I will look into it and update it
14:58:21 <pingou> sayan++
14:58:23 <devyani7_> Its not updated in the API, not sure :/
14:58:47 <a2batic> Its 0 for all users
14:58:58 <a2batic> :p
14:59:11 * stickster hands gavel to sayan
14:59:14 <sayan> #topic Zanata
14:59:51 <sayan> pingou: how should we go ahead integrating Zanata?
15:00:17 <a2batic> I have started with Html and css coding, but not sure about integrating
15:00:30 <sayan> since Hubs is read only, from where do we get the data for Zanata?
15:01:09 <pingou> sayan: from fedmsg
15:01:23 <pingou> via zanata2fedmsg
15:01:45 <pingou> and then w/ caching on the hub fronts to compute the numbers (either that or via statscache)
15:02:26 <sayan> pingou: hmm, I need to look into zanata2fedmsg then
15:02:45 <sayan> I did the setup but did not get time to see how things work
15:02:59 <pingou> basically zanata -- webhook --> zanata2fedmsg ----> fedmsg ----> hubs
15:03:23 <sayan> hmm
15:03:25 <sayan> got it
15:03:41 <sayan> #topic Release Cycle Widget
15:03:51 <sayan> vivek_: saptaks: do you have any update?
15:04:02 <sayan> did you get to see how to integrate with PDC?
15:04:11 <vivek_> nope
15:04:32 <sayan> vivek_: your exams got over today, right?
15:04:43 <vivek_> no, yesterday
15:05:04 <vivek_> i wasn't sure if the PDC was ready
15:05:20 <vivek_> i mean, if it can be used for our purpose, so i didn't read into that much
15:05:31 <vivek_> i will check that again
15:05:42 <sayan> vivek_: sure
15:06:21 <vivek_> i opened it once, but couldn't find any end point where there will be any date for fedora release :/
15:06:34 <sayan> vivek_: it does not have that feature yet
15:06:47 <saptaks> sayan_: same status as vivek_
15:06:54 <sayan> the work would be on the PDC front first
15:06:54 <saptaks> had exam but got the project setup
15:06:56 <vivek_> ok, so i should create an endpoint there?
15:07:04 <vivek_> ohk
15:07:11 <vivek_> is that project on pagure?
15:07:15 <vivek_> where is it? name?
15:07:53 <sayan> vivek_: https://github.com/product-definition-center/product-definition-center
15:08:22 <sayan> #topic #halp widget
15:08:32 <sayan> abompard: any update on the halp widget?
15:08:33 <vivek_> who is leading this project? In case, if i have doubt, whom to ask?
15:09:02 <sayan> vivek_: ping threebean or lsedlar
15:09:12 <vivek_> ok, thanks
15:09:32 <saptaks> thanks. I will look PDC as well.
15:10:31 <sayan> since we are over time lets end this meeting
15:10:34 <sayan> #endmeeting