20:00:28 <pwhalen> #startmeeting Fedora ARM status meeting
20:00:28 <zodbot> Meeting started Wed Jul  2 20:00:28 2014 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:28 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin jdisnard msalter
20:00:29 <zodbot> Current chairs: bconoboy ctyler dgilmore dmarlin jdisnard jonmasters msalter pbrobinson pwhalen
20:00:36 <pwhalen> good afternoon folks
20:00:42 <pwhalen> .fas pwhalen
20:00:43 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:50 <pwhalen> who's here?
20:01:42 <dgilmore> hola
20:02:23 <pwhalen> just you and I so far.. lets give it a few minutes to see if anyone else makes it
20:03:57 <dgilmore> okay
20:04:03 <dgilmore> .iam ausil
20:04:18 <dmarlin> .fas dmarlin
20:04:19 <dgilmore> there is some funky command
20:04:19 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:04:57 * nirik is lurking around in the back
20:05:51 <dgilmore> .hellomynameis ausil
20:05:52 <zodbot> dgilmore: ausil 'Dennis Gilmore' <dennis@ausil.us>
20:06:19 <pwhalen> output looks the same as '.fas'?
20:06:45 <dgilmore> .hellomynameis dgilmore
20:06:46 <zodbot> dgilmore: Sorry, but you don't exist
20:06:48 <nirik> but fas is a wildcard search, so it can get lots more.
20:06:53 <dgilmore> pwhalen: i think it is
20:07:07 <nirik> .hellomynameis kevin
20:07:08 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
20:07:10 <nirik> .fas kevin
20:07:11 <zodbot> nirik: pakdog 'kevin reeder' <reederk@comcast.net> - gonebush 'Kevin Gilbert' <kmg952@bigpond.com> - okazaki 'Kevin' <Psycho250250@126.com> - kevinnewman4life 'Kevin Newman' <kevinnewman4life@gmail.com> - kevcube 'Kevin Liam Mahoney' <kevcube@gmail.com> - fedbot 'Fedora Supybot' <kevin-fedbot@scrye.com> - mightydweeb 'Kevin Connor' <kconnor@proofpoint.com> - westford 'KEVIN GAGNON' <kgagnon@ieee.org> - silverback (31 more messages)
20:07:12 <pwhalen> true
20:07:14 <nirik> see. ;)
20:07:19 <pwhalen> right
20:07:24 <pwhalen> ok, lets get started?
20:07:27 <dgilmore> sure
20:07:37 <bconoboy> .fas blc@
20:07:38 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:07:46 <pwhalen> #topic 1) Kernel Status Update
20:07:47 <dgilmore> .hellomynameis blc
20:07:48 <zodbot> dgilmore: blc 'None' <blc@redhat.com>
20:08:05 <pwhalen> unfortunately, pbrobinson couldnt join, but did a great blog post
20:08:11 <dgilmore> indeed
20:08:13 <pwhalen> #info Peter's '3.15 Fedora ARM kernel status'
20:08:13 <pwhalen> #link http://nullr0ute.com/2014/06/3-15-fedora-arm-kernel-status/
20:08:19 <bconoboy> .hellomynameis blc
20:08:20 <zodbot> bconoboy: blc 'None' <blc@redhat.com>
20:08:31 <pwhalen> for those that havent read it, I also understand one is forth coming for 3.16
20:08:38 <dgilmore> on top of that in 3.16 in rawhide currently video works on i.MX6
20:08:49 <dgilmore> and rawhide/f21 is looking to be kinda awesome
20:08:53 <pwhalen> dgilmore, yes it does, and well
20:09:00 <pwhalen> I agree
20:09:13 <bconoboy> dgilmore: including utilite?
20:09:18 <dgilmore> i have X running on wandboard and cubox-i
20:09:27 <dgilmore> bconoboy: not yet tested
20:09:49 <nirik> pwhalen: did you find anything about that highbank crash in rawhide?
20:10:03 <pwhalen> #info kernel testing needed on Utilite
20:10:20 <pwhalen> nirik, not yet. had some pto and a Canadian holiday
20:10:40 <nirik> no worries. I hadn't filed it, but we should make sure it is and get it fixed. ;)
20:11:08 <pwhalen> #action pwhalen to file BZ on highbank crash with latest 3.16 kernels
20:11:49 <pwhalen> agreed, anything else we want to talk about for the kernel ?
20:12:14 <dgilmore> test test test
20:12:48 <dgilmore> if you need changes to the kernel of for that matter anything arm related try and make sure arm lists/folks are cc'd
20:13:08 <dgilmore> help us to help you get your changes accepted
20:13:23 <dgilmore> and make sure we get things done in teh best possible manner for all
20:14:01 <pwhalen> +1 ..  ok, moving on
20:14:07 <pwhalen> #topic 2a) F21 Alpha Status - Deliverables (Installation methods)
20:14:28 <pwhalen> during our last meeting we discussed a boot.iso type option, any progress here?
20:14:41 <bconoboy> for 32 or 64 bit?
20:15:00 <pwhalen> bconoboy, sorry, this is 32. 64 is the next one
20:16:00 <dgilmore> pwhalen: not sure anyone has worked on it
20:16:04 <dgilmore> but we really should
20:16:20 <pwhalen> masta was to look into it, but hes out on pto.
20:16:40 <dgilmore> pwhalen: lets follow up with him outside the meeting
20:17:12 <pwhalen> ks options for boards that support pxe boot work well, it is possible to write uboot in %post , as well as add the needed fdtdir .. allows the system to just reboot in fedora
20:17:33 <dgilmore> pwhalen: we need it to work without hacks
20:18:01 <dgilmore> pwhalen: i think that I will deal with both in extlinux-bootloader
20:18:18 <pwhalen> dgilmore, agreed its ideal.. but also good to test
20:18:35 <pwhalen> dgilmore, sounds good
20:19:32 <pwhalen> #action pwhalen, dgilmore to follow up with jdisnard re: lorax & pungi
20:20:05 <pwhalen> sounds like we'll need to follow up again next time, anything else?
20:20:43 <pwhalen> #topic 2b) F21 Alpha Status - Open ARM bugs
20:20:48 <dgilmore> pwhalen: nah
20:21:16 <dgilmore> pwhalen: any major bugs?
20:21:24 <pwhalen> I have a few open bz's , I'll be adding them to the alphablocker to get more attention on them
20:21:57 <pwhalen> #info dracut unable to boot 3.16 most of the time
20:22:03 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1109603
20:22:41 <pwhalen> dgilmore, this one is still an issue (intermittent)
20:22:51 <dgilmore> pwhalen: yeah
20:23:13 <dgilmore> i dont remeber seeing it pre 3.16
20:23:24 <dgilmore> could be something in the kernel masked it
20:23:35 <dgilmore> or that dracut changed and its a coincidence
20:24:13 <pwhalen> have a couple more on initial-setup-graphical that we need, will add to the alpha blocker
20:24:42 <dgilmore> okay
20:25:01 <dgilmore> i tend to be over zelous in adding to the blocker bug
20:25:19 <dgilmore> rather it be considered than missed and forgotten
20:25:20 <pwhalen> hey it works
20:25:47 * jsmith has no problem with that
20:25:56 <pwhalen> dgilmore, plans for uboot for alpha?
20:26:08 <dgilmore> pwhalen: i need to finish updating to 2014.07
20:26:22 <dgilmore> I was hoping that there would be more supported boards
20:26:25 <dgilmore> but it seems not
20:26:55 <dgilmore> i talked to the cubox guys about getting things upstream and they were kinda rude about not doing it
20:27:03 <dgilmore> they want certain other features up first
20:27:14 <dgilmore> and wont even look at it until that is done
20:27:23 <pwhalen> thats unfortunate
20:27:30 <pwhalen> any other bugs we've missed?
20:27:43 <dgilmore> they also said that the need to have u-boot on a microsd is a design decision in the hardware
20:27:52 <dgilmore> which i kinda think is a bit rude
20:28:06 <dgilmore> pwhalen: grubby
20:28:14 <dgilmore> i updated patches last night
20:28:20 <dgilmore> i need to redo one
20:28:34 <dgilmore> and we need to do some testing to make sure things work everywhere
20:28:36 <pwhalen> dgilmore, is there a bz?
20:28:41 <dgilmore> pwhalen: yeah
20:29:12 <dgilmore> https://bugzilla.redhat.com/show_bug.cgi?id=1088933
20:29:35 <pwhalen> #info Bug 1088933 - update grubby to support device tree options for arm
20:29:41 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1088933
20:30:42 <pwhalen> #topic 2c) F21 Alpha Status - Other Planning ?
20:31:37 <dgilmore> we need to start on aarch64 composes
20:31:38 <pwhalen> I have scheduled a test day, but need to work out the details with pbrobinson. our plan is to have one after alpha, to determine a baseline board support. and another after beta to refine and test everything.
20:31:46 <dgilmore> which would be easier with hardware in phx2
20:31:59 <dgilmore> pwhalen: sounds good
20:32:10 <pwhalen> dgilmore, welcome to use the westford hosts
20:32:25 <dgilmore> pwhalen: ill probably use the one at home
20:32:33 <pwhalen> ok
20:33:16 <pwhalen> should we have a meeting in a couple of weeks? rather than wait a month?
20:33:56 <pwhalen> I'm open, if others are interested.
20:34:11 <pwhalen> ok, any other planning we should discuss?
20:34:43 <pwhalen> #topic 3) Aarch64 Status update
20:35:09 <pwhalen> anyone able to give us a little update? problem packages or?
20:35:09 <dgilmore> pwhalen: maybe fortnightly
20:35:17 <pwhalen> dgilmore, was thinking that as well.
20:35:53 <dgilmore> last i knew we were missing about 450 packages never built on aarch64 and were about 350 packages behind rawhide
20:36:09 <dgilmore> of those never built v8 was a big one causing issues
20:36:13 <dgilmore> as is mono
20:37:04 <bconoboy> This kernel:  http://koji.fedoraproject.org/koji/buildinfo?buildID=541585 should boot on a mustang board with both ethernet and sata available
20:37:31 <bconoboy> dgilmoe: We have a v8 patchset, what's the issue?
20:38:32 <dgilmore> bconoboy: will test
20:38:41 <dgilmore> bconoboy: you sure?
20:38:46 <dgilmore> afaik we didnt
20:38:58 <dgilmore> we were waiting on v8 to be updated
20:39:05 <bconoboy> dgilmore: v8 is fully upstream, but I believe rawhide's v8 isn't quite current.  even so, we have a patchset from 6 months ago with a non-optimized v8 port.
20:39:17 <bconoboy> dgilmore: I'll send you what I sent pbrobinson.
20:39:31 <dgilmore> bconoboy: right
20:39:37 <pwhalen> looks like kyle updated it today
20:40:37 <bconoboy> #info The v8 package isn't built, blocking some packages. A v8 port is available however.
20:40:45 <bconoboy> #undo
20:40:45 <zodbot> Removing item from minutes: INFO by bconoboy at 20:40:37 : The v8 package isn't built, blocking some packages. A v8 port is available however.
20:40:59 <bconoboy> #info The v8 package isn't built, blocking some packages. A v8 port for aarch64 is available however.  Investigation ongoing.
20:41:09 <dgilmore> pwhalen: http://pkgs.fedoraproject.org/cgit/v8.git/log/
20:41:11 <dgilmore> where?
20:41:29 <bconoboy> #info kernel-3.16.0-0.rc3.git1.1.fc21 should have all patches needed to boot on mustang board
20:42:01 <pwhalen> dgilmore, referring to the kernel
20:42:48 <pwhalen> anything else for aarch64?
20:43:06 <pwhalen> #topic 4) Open Floor
20:43:09 <dgilmore> not really
20:43:36 <bconoboy> will we be shipping a setup tool as part of f21?
20:43:40 <dgilmore> only thing i have for open floor is to reiterate what I said during the kernel portion
20:43:50 <dgilmore> bconoboy: setup tool?
20:43:50 <bconoboy> IE, some version of pwhalen or fossjon's script for setting up boot files?
20:43:58 <dgilmore> bconoboy: I hope so
20:44:09 <bconoboy> we can't hope, we must decide how to proceed.
20:44:18 <dgilmore> bconoboy: we really should
20:44:29 <dgilmore> bconoboy: but someone needs to write, test, package it
20:44:36 <dgilmore> it needs an owner
20:44:37 <bconoboy> The options are to add to an existing package or add a new package
20:44:53 <bconoboy> I think it makes sense to add pwhalen's script to the uboot package we have today.
20:45:04 <bconoboy> There's a direct connection between the two
20:45:05 <pwhalen> I have yet to look at fossjons, I really should. things have changed quite a bit since then
20:46:31 <dgilmore> bconoboy: there is a fedora-arm-installer package
20:46:42 <dgilmore> http://koji.fedoraproject.org/koji/packageinfo?packageID=15301
20:46:45 <bconoboy> is that the fossjon package?
20:46:46 <dgilmore> it shoudl go there
20:46:51 <dgilmore> i think so
20:47:07 <bconoboy> Okay
20:47:19 <bconoboy> Adding pwhalen's script to it makes sense to me then
20:47:29 <pwhalen> right, thats his..ok will look at doing that
20:47:30 <dgilmore> yep
20:47:45 <bconoboy> is fossjon still active? maybe pwhalen could comaintain
20:47:54 <pwhalen> bconoboy, dont think so
20:47:59 <dgilmore> pwhalen: do you want to own this?
20:48:04 <pwhalen> havent seen him in a while
20:48:11 <dgilmore> bconoboy: he's not active that i have seen
20:48:24 <pwhalen> dgilmore, sure
20:48:30 <dgilmore> pwhalen: excellent
20:48:39 <bconoboy> dgilmore: what do we need to do to make it so?
20:48:44 <dgilmore> lets get something done that makes setting up cards easy
20:48:55 <dgilmore> bconoboy: ill get it handed over to pwhalen
20:49:02 <bconoboy> dgilmore: awesome, thanks!
20:49:04 <pwhalen> thanks
20:49:33 <bconoboy> that was it for me
20:50:08 <pwhalen> ok, shall we wrap?
20:50:08 <dgilmore> cool
20:50:15 <dgilmore> okay i wanted to reiterate.
20:50:52 <dgilmore> if you want to make changes in packages for arm related things, that's awesome. but please coordinate with the arm team.
20:51:18 <pwhalen> #action pwhalen to take over ownership of fedora-arm-installer
20:51:19 <dgilmore> please do so by cc'ing the arm list on discussions and patches
20:51:26 <dgilmore> block the arm tracker for bugs
20:52:01 <dgilmore> This is to make sure that we all are working towards making things awesome for all
20:52:02 <pwhalen> #info If you want to make changes in packages for arm related things, that's awesome. but please coordinate with the arm team. Please do so by cc'ing the arm list on discussions and patches amd block the arm tracker for bugs.
20:52:27 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=245418
20:52:28 <dgilmore> it makes sure your change doesnt break things for others or we dont go undoing it to make other changes
20:52:51 <dgilmore> if you are trying to do things with fedora on arm, let us know what it is you are doing.
20:53:09 <pwhalen> #info aarch64 tracker
20:53:17 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=922257
20:53:22 <dgilmore> that way we can take your needs into account when working out what things to work on, or designing solutions to issues we hit
20:53:29 <bconoboy> pwhalen: would you send an email to the fedora-arm list that we're moving to an alternating week schedule for this call?
20:53:41 <bconoboy> s/call/meeting/
20:53:42 <pwhalen> sure
20:54:23 <bconoboy> tnx
20:54:31 <pwhalen> #info Next Fedora ARM status meeting - July 16th
20:54:46 <pwhalen> anything else?
20:54:54 <dgilmore> not from me
20:55:11 <pwhalen> #endmeeting