03:44:59 <cmurf> #startmeeting Workstation WG (2021-08-31)
03:44:59 <zodbot> Meeting started Wed Sep  1 03:44:59 2021 UTC.
03:44:59 <zodbot> This meeting is logged and archived in a public location.
03:44:59 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:44:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
03:44:59 <zodbot> The meeting name has been set to 'workstation_wg_(2021-08-31)'
03:45:01 <cmurf> #meetingname workstation
03:45:01 <zodbot> The meeting name has been set to 'workstation'
03:45:03 <cmurf> #chair: Michael Neal
03:45:03 <zodbot> Current chairs: : Michael Neal cmurf
03:45:22 <cmurf> #topic Rollcall
03:45:24 <cmurf> #info present:  mclasen, Chris, Owen, Tomas, Jens, Michael Catanzaro, , Neal
03:45:26 <cmurf> #info present guests: Luna Jernberg (bittin), Zac, James, Davide
03:45:28 <cmurf> #topic Approval of August 24 minutes
03:45:30 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021/fedora-meeting-2.2021-08-24-17.15.html
03:45:32 <cmurf> #agreed Approved
03:45:34 <cmurf> #topic Announcements, follow-ups, status reports
03:45:36 <cmurf> #info Michael: hard code freeze for GNOME 41 starts on saturday (twice as long as usual, as an experiment).
03:45:38 <cmurf> #info GNOME 41 RC Tarballs due on on Saturday
03:45:40 <cmurf> #info Devconf US Online on Thursday-Friday this week
03:45:42 <cmurf> #link https://www.devconf.info/us/
03:45:44 <cmurf> #topic Make use of malcontent in the default install?
03:45:46 <cmurf> #link https://pagure.io/fedora-workstation/issue/186
03:45:48 <cmurf> #agreed include in F35 Beta
03:45:50 <cmurf> #info Status: Adam waits for us to say: "Yes, put it into the beta". We will do so.
03:45:52 <cmurf> #topic Re-revisit Fedora Workstation minimums https://pagure.io/fedora-workstation/issue/241
03:45:54 <cmurf> - Neal tried with 2G of ram (and other settings simulating a 2009 MacBook pro), and things worked fine.
03:45:56 <cmurf> His theory is that the underlying issue is actually hard-drive performance. Things are fine with an ssd.
03:45:58 <cmurf> - Neal points at lack of readahead (since systemd removed it).
03:46:00 <cmurf> - Chris and Neal suggest that we need to confirm that theory before making changes to the minimum
03:46:02 <cmurf> requirements.
03:46:04 <cmurf> - Owen concurs, and points out that readhead should really only affect boot time, and the
03:46:06 <cmurf> IO scheduler can also influence things.
03:46:08 <cmurf> - Matthias says it would be great to know what percentage of the userbase still uses non-ssd drives.
03:46:10 <cmurf> #info Suggestion from Owen: change the requirements to say "SSD suggested".
03:46:12 <cmurf> #action Chris will file a ticket to request "SSD suggested" being added
03:46:14 <cmurf> #action Neal will follow up with Matthew in the ticket
03:46:16 <cmurf> #topic Improve the user feedback for OOM situations
03:46:18 <cmurf> #link https://pagure.io/fedora-workstation/issue/202
03:46:20 <cmurf> Deferred to a later meeting, since it targets F36.
03:46:22 <cmurf> #topic User directories as Btrfs subvolumes by default
03:46:24 <cmurf> #link https://pagure.io/fedora-workstation/issue/232
03:46:26 <cmurf> - Neal suggests this change, since it will make it easier to use btrfs tools to operate on the whole of the
03:46:28 <cmurf> users data (think backup, compression levels, etc). The target for this is F36 (or F37, depending on getting
03:46:30 <cmurf> bugs fixed).
03:46:32 <cmurf> - Tomas asks if there are any downsides. Neal admits that he can't boot with this configuration :)
03:46:34 <cmurf> But that is just a bug, according to Neal. The other downside is that hardlinks don't work, since inode
03:46:36 <cmurf> numbers don't span across subvolumes. Matthias points out that there was a recent lwn article about
03:46:38 <cmurf> problems between btrfs and nfs wrt to inode numbers. Neal notes this is a problem if you export the parent of subvolumes via NFS, not the subvolumes themselves.
03:46:40 <cmurf> Minor benefits: it becomes harder for containers to cause inode exhaustion.
03:46:42 <cmurf> #link https://lwn.net/Articles/866582/
03:46:44 <cmurf> #link https://lwn.net/Articles/866709/
03:46:46 <cmurf> Chris points out that some backup tools don't cross filesystem boundaries by default, and consider subvolumes
03:46:48 <cmurf> as such. An example mentioned by Chris is a tool called Pika Backup. Chris is worried about more knock-on
03:46:50 <cmurf> effects like this, and suggests getting some exposure and file bugs.
03:46:52 <cmurf> The anaconda UI for nested btrfs subvolumes is not great.
03:46:54 <cmurf> #action Neal to file the bugs he found and get them fixed. Then we can revisit this. Chris to help out too
03:46:56 <cmurf> #topic Open Floor
03:46:58 <cmurf> Luna points out that the hard code freeze is Saturday, not Friday as Michael said earlier. and the RC of 41 will be out on Saturday too
03:47:00 <cmurf> #info Jens: devconf.us happens this week
03:47:02 <cmurf> #link https://www.devconf.info/us/
03:47:44 <cmurf> #endmeeting