17:40:26 <rbergeron> #startmeeting
17:40:26 <zodbot> Meeting started Fri Mar 26 17:40:26 2010 UTC. The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:40:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:40:44 <rbergeron> #topic Fedora Insight - unscheduled discussion
17:40:59 <rbergeron> #chair hiemanshu stickster
17:41:00 <zodbot> Current chairs: hiemanshu rbergeron stickster
17:41:24 <rbergeron> #info stickster is gonna resay some stuff real quicklike :)
17:41:44 <stickster> #info The official distroblogs stuff will be driven by FI
17:41:52 <stickster> One of the achievements will be to eliminate the separate need for that fedoraldc.wp.c site
17:41:59 <stickster> When we're ready, the only thing we have to do is get in touch with Brian Proffitt @ LF and ask for a switcheroo of the RSS feeds.
17:42:24 <stickster> #info We do need editors more than writers *for right now* -- We can provide written content for now from FWN + Planet
17:42:30 <rbergeron> (is he still there? i keep seeing him tweet things about going on job interviews and such)
17:42:56 <stickster> #info Later we'll want more + better + bigger + faster, and that will mean recruiting writers too.
17:43:05 <stickster> We can provide *at least* what we have now just by having people who are capable of promoting the appropriate content using a tag for LDC
17:43:11 <stickster> and doing the other things editors need to do
17:43:17 <stickster> rbergeron: And of course LDC is just part of what the editors will worry about, I realize
17:43:19 <rbergeron> hiemanshu / ke4qqq mentioned that FWN already has a set of "editors" vs. just beat writers - has pcalarco talked to them, to your knowledge, about handling the news end of the editorial things?
17:43:24 * nmarques gets another anxiety attack and rushes back to Alprazolam
17:43:35 <rbergeron> lol
17:43:53 <hiemanshu> rbergeron: he seemed to have got the ball rolling
17:43:54 <stickster> rbergeron: Good question -- that would probably be adamw and... Rashadul maybe?
17:44:17 <rbergeron> i just didn't remember him saying anything about it when we were discussing yesterday
17:44:18 <stickster> rbergeron: I'm about to spread out the @fedoraldc group admin rights too
17:44:53 <rbergeron> stickster: i was just looking around the channel, nobody's here to harass atm, although hiemanshu smacked me around a bit for forgetting to ask nmarques :)
17:45:52 <rbergeron> so - how are the rights going to be inherited in FI?
17:45:54 <rbergeron> i should say permissions
17:46:03 <stickster> rbergeron: You're probably asking the wrong person. I have no idea.
17:46:06 <rbergeron> are we going to be able to get ridof fedoraldc group in FAS?
17:46:14 <stickster> Maybe
17:46:15 <rbergeron> i'm guessing?
17:46:16 <rbergeron> okay
17:46:22 <hiemanshu> rbergeron: we make another LDC group in zikula
17:46:29 <rbergeron> okay
17:46:34 <stickster> So we'd have instead some new "insight-editors-news," "insight-editors-mktg," or so forth
17:46:36 <rbergeron> and they're a subset of editors more or less
17:46:40 <stickster> Ah
17:46:41 <hiemanshu> and add the people from the group
17:46:44 <stickster> hiemanshu: Can we inherit from FAS?
17:46:46 <hiemanshu> to the zikula group
17:46:55 <rbergeron> i mean - we have a cmsadmin group
17:47:00 <hiemanshu> stickster: I havent looked into the FAS plugin, not sure if it can be done
17:47:13 <stickster> hiemanshu: If it can -- might be helpful. That way there's only one place to look for rights
17:47:13 <rbergeron> that seems where the editorial power is coming from currently, is it not? or is that just people who are capable of adding people to certain groups in zikula
17:47:20 <stickster> hiemanshu: And the group in FAS could drive the rights in Zikula.
17:47:32 <ke4qqq> well the fas plugin is essentially the mediawiki plugin tweaked for zikula
17:47:36 <rbergeron> stickster: i think if it's not available, we should put it on the 2.0 list
17:47:37 <hiemanshu> stickster: yup, I am sure it can be done, because we did with blogs.fp.o
17:47:54 <ke4qqq> and we have groups in mediawiki that have special awesomeness
17:48:00 <hiemanshu> so its just a little looking around
17:48:06 <stickster> hiemanshu: I think that would be pretty awesome. If I understand ke4qqq correctly, it should be possible
17:48:09 * stickster is out of his depth here.
17:48:27 <hiemanshu> stickster: its possible, very possible
17:48:37 <stickster> hiemanshu: rbergeron: ke4qqq: Do we agree that using FAS to deal with groups/rights would be the right way to go?
17:48:40 <ke4qqq> stickster: it was possible - we had it going at one point - and have the cmsadmin group in fas already so it's possible - and was working - whether it is now is a diff. story
17:48:55 <rbergeron> i agree that it is the -right- way to do it
17:48:57 * ke4qqq thinks so - no reason to split out authorization from fas IMO
17:49:01 * hiemanshu nods
17:49:02 <rbergeron> i don't know how time effective it will be to implement
17:49:14 <rbergeron> i hate to see us delaying deployment for weeks to figure it out
17:49:17 <stickster> rbergeron: We already have a zikula fas plugin, and hopefully it's even still working.
17:49:23 * rbergeron hopes
17:49:26 <hiemanshu> stickster: it is
17:49:35 <hiemanshu> rbergeron just did a test for us
17:49:40 <rbergeron> okay, well - this seriously affects how editor rights will work
17:49:43 <ke4qqq> so - wait - don't we have a copy of this in staging?
17:49:45 <rbergeron> well - that's for the admin portion
17:49:51 <stickster> #agreed We'll use FAS to assign people to groups, and the CMS will rely on those FAS groups through its FAS plugin.
17:50:00 <rbergeron> if we add, say - cmseditors group - who may not necessarily be admins
17:50:01 <hiemanshu> ke4qqq: not yet in stg
17:50:07 <stickster> ke4qqq: It's on pt6 right now, I believe.
17:50:13 <rbergeron> will that tie somehow into who can publish what right now?
17:50:15 <hiemanshu> ke4qqq: stf = zikula + theme
17:50:17 <stickster> rbergeron: Yes.
17:50:21 <rbergeron> pt6..../zikula
17:50:22 <hiemanshu> stg**
17:50:22 <stickster> That's it exactly.
17:50:37 <rbergeron> stickster: are you saying yes that's the issue or yes we can do that and quickly :)
17:50:47 <stickster> rbergeron: Yes, we can do that, from what hiemanshu just said.
17:51:20 <stickster> rbergeron: hiemanshu: ke4qqq: I think we'd want to do some not-too-granular groups to start with
17:51:24 <rbergeron> so - the part about assigning editors and rights just got a lot less complicated
17:51:53 <rbergeron> it's more of a matter of finding volunteers :)
17:51:54 <stickster> If we get enough people that it becomes an issue, we can go further than just "cmseditors". We could create later "cmseditors-mktg" or "cmseditors-news" or others....
17:51:57 <hiemanshu> rbergeron: in simple words, you dumped your work on someone else :P
17:52:04 <rbergeron> well
17:52:09 <rbergeron> i'm happy to document how to add people in FAS
17:52:44 <stickster> hiemanshu: I think rbergeron is still agreed to write up how editors should do their work :-)
17:52:47 <rbergeron> can we actually try and make a fas group now and tie it into zikula
17:52:52 <stickster> Probably through a learning process.
17:52:57 <hiemanshu> stickster: just j/k :
17:52:59 <hiemanshu> :)
17:53:08 <stickster> rbergeron: Great idea, and there's a page right there.
17:53:26 <hiemanshu> rbergeron: would you like to help out getting the workflow right?
17:53:37 * nmarques prepares another twisted idea!
17:54:16 <rbergeron> hiemanshu: are you interested in helping me invent a time-warping machine? :) i'm not sure how much time i can commit to that - or how long we think it would take
17:54:22 <rbergeron> do you think it's a weekend thing?
17:54:45 * rbergeron looking at upcoming mktg stuff and feature profiles and... yeah
17:54:53 <rbergeron> $reallife
17:55:34 <rbergeron> okay, put me down
17:55:37 <rbergeron> it needs to get down
17:55:39 <rbergeron> for FI to work
17:56:06 <rbergeron> but i can't drive it - i need someone else to be the driver of that boat cracking the whip
17:56:07 <hiemanshu> rbergeron: I can write a py program to make you feel like you are in a time-warping machine, thats the best I can do, simulation :P
17:56:44 <rbergeron> i'm concerned that we have all these editors and that nobody will be taking ownership of actually approving content from planet over to FI
17:56:47 <rbergeron> or anywhere else
17:56:51 <rbergeron> to FI
17:57:12 <rbergeron> stickster: a page right where :)
17:57:20 <hiemanshu> rbergeron: I can do that
17:57:26 <hiemanshu> I can handle approving content
17:57:42 <hiemanshu> because once it is all setup, I wont have much left to do with FI
17:57:45 <stickster> rbergeron: So wait a second, let's back up and talk about editors for a second.
17:57:55 <rbergeron> actually, can i ask hiemanshu a question
17:58:03 <stickster> sure
17:58:07 * stickster gets out of the way!
17:58:08 <rbergeron> hiemanshu: why did i have to log out and back into zikula after you did magic
17:58:12 <rbergeron> if it's tied into FAS?
17:58:23 <rbergeron> or were you adding me to cmsadmin in fas
17:58:25 <hiemanshu> rbergeron: I had to upgrade you to an admin
17:58:31 <hiemanshu> so you could get into the admin panel
17:58:34 <rbergeron> upgrade me in FAS or in zikula
17:58:36 <hiemanshu> and its not yet tied IIRC
17:58:38 <hiemanshu> zikula
17:58:45 <hiemanshu> you can use it for login
17:58:52 <hiemanshu> it make a zikula user via that
17:58:54 <hiemanshu> makes**
17:59:02 <hiemanshu> I need to upgrade the right on the zikula user
17:59:03 <rbergeron> so - nothing we are doing in FAS affects rights in zikula currently?
17:59:08 <hiemanshu> yup
17:59:11 <hiemanshu> WE have to fix that
17:59:56 <rbergeron> so... is this really a short-term thing to have editors appproved through FAS rather than zikula? because it seems like if it was easy - it would already be done
18:00:00 <rbergeron> or am i really missing something here
18:00:16 * rbergeron is clearly not very technical and can just throw around awesome words like "permissions" and "rights"
18:00:19 <rbergeron> :)
18:00:39 <threethirty> rbergeron: you fake it well :)
18:00:46 * rbergeron bows
18:01:01 <rbergeron> no root access for me after 5pm, mmkay?
18:01:04 <hiemanshu> rbergeron: its a long term to have to done with fas
18:01:20 <rbergeron> okay: so short term - i need to document how to add editors in through FI
18:01:22 <hiemanshu> so all we have to do is add people to a fas group
18:01:22 <rbergeron> period
18:01:27 <hiemanshu> rbergeron: yup
18:01:32 <rbergeron> stickster ^^^
18:02:04 <rbergeron> agreed on that? i'm going to document the adding in zikula for editors, not FAS
18:02:17 <rbergeron> so do we need a Fas editors group then right now? or not so much?
18:02:28 <hiemanshu> not right now
18:03:09 <rbergeron> okay
18:03:19 <stickster> rbergeron: OK, I see what you're asking
18:03:19 <hiemanshu> anyways I have to leave now
18:03:33 <stickster> You don't need to document that operation, since we're solving the problem with FAS.
18:03:38 <rbergeron> hiemanshu: thanks for your help :) i think i can figure out the adding people
18:03:41 <rbergeron> .....
18:03:51 <hiemanshu> rbergeron: I will here in ~7 hours
18:03:56 <hiemanshu> if you need me
18:04:03 <stickster> rbergeron: We should just be able to say "Zikula, your editors here will be anyone in the FAS group 'cmseditors'."
18:04:06 <stickster> And be done with it.
18:04:14 <rbergeron> stickster: i agree we should
18:04:24 <ke4qqq> rbergeron: soooo just for giggles
18:04:27 <rbergeron> but hiemanshu just said that even adding people to cmsadmin doesn't make them admins
18:04:33 <ke4qqq> add yourself to the cmsadmin group in ptfas
18:04:33 <stickster> We don't need to document anything further that's FI specific other than, "If you want to make someone an editor, add them to 'cmseditors' in FAS."
18:04:34 <rbergeron> ke4qqq: i love to laugh, please indulge me
18:04:39 <ke4qqq> and see if that works
18:04:58 <hiemanshu> rbergeron: make a new account and do that
18:05:03 <rbergeron> ke4qqq: i'm
18:05:04 <ke4qqq> ohhhhh it doesn't - it used to - I wonder what happened there
18:05:04 <rbergeron> ohhh
18:05:07 <stickster> ke4qqq: I didn't realize there was a ptfas.
18:05:27 <stickster> Oh, maybe I did.
18:05:28 <hiemanshu> stickster: pt3/accounts
18:05:35 <stickster> Of course, because we don't pass real account info on pt* machines.
18:05:38 <rbergeron> stickster: hiemanshu said he still had to go in and manually add me to the admin group in zikula
18:05:40 <stickster> self.slap()
18:05:45 <stickster> I think we're still logging, by the wya.
18:05:46 <stickster> *way.
18:06:05 <rbergeron> stickster: as well we should be, because it's entirely possible my brain may asssplode soon
18:06:34 <rbergeron> ke4qqq: rrix said you were mocking the ASU plug name, btw
18:07:00 <rbergeron> so i should make a new account on pt3?
18:07:28 <rbergeron> pt6?
18:08:10 <ke4qqq> make new account pt3
18:09:11 <stickster> Maybe rbergeron isn't familiar with FAS/ptFAS
18:09:18 <rbergeron> i am
18:09:23 * ke4qqq doesn't recall that conversation with rrix
18:09:34 <rbergeron> lol
18:09:35 <stickster> Ah, OK, I thought I detected confusion, it was the wrong confusion I was thinking of
18:09:41 * rbergeron is just trying to captcha
18:09:43 * stickster is confused about confusion ;-)
18:10:01 * rbergeron is too, and just couldn't remember the full address ... mostly because she didn't read the line of pt3/accounts
18:10:07 <rbergeron> so i was tryign to remember the accounts part
18:10:26 <rrix> moin
18:10:57 <ke4qqq> rbergeron: just tell me the name you added
18:11:10 <rbergeron> dude
18:11:12 <rrix> ke4qqq: weren't you the one who called it ASSPLUG? :)
18:11:17 <rbergeron> captcha
18:11:28 <rbergeron> no, i called it assplug, and rrix, we're recording a meeting atm :)
18:11:35 <rrix> oh. uhm
18:11:36 <rrix> sorry
18:12:04 <ke4qqq> rrix: I don't recall saying that
18:12:14 * rbergeron sends rrix a pizza
18:12:14 * rrix crawls back into his hole
18:12:19 <rbergeron> ke4qqq: i have no idea if it created it
18:12:22 <rbergeron> i can't get past captcha
18:12:50 * ke4qqq has an idea
18:13:05 <rbergeron> oh
18:13:08 <rbergeron> now my email address is taken
18:13:29 <ke4qqq> I'd say it works
18:13:52 <ke4qqq> rbergeron: you can use a fake email address on fakefas
18:14:46 <rbergeron> i just did
18:14:51 <ke4qqq> but I just logged into zikula with fakefas's admin account
18:14:57 <ke4qqq> what user?
18:15:02 <rbergeron> dagny
18:15:39 <ke4qqq> ugghh let me add dagny to cla_done
18:16:11 * stickster lurks
18:16:46 <rbergeron> stickster: so if this doesn't work... ? :)
18:16:48 <ke4qqq> rbergeron: now try and login to zikula with dagny
18:16:51 * rbergeron has all the faith in the universe that it will
18:17:12 <ke4qqq> or as dagny
18:17:52 <mchua> rbergeron: where does the "dagny" come from?
18:18:00 <stickster> Taggart?
18:18:09 * ke4qqq assumes so
18:18:21 <rbergeron> Access denied (error 403)
18:18:21 <rbergeron> Sorry! You don't have authorisation for the page you wanted.
18:18:21 <rbergeron> Additional information
18:18:22 <rbergeron> Sorry! You have not been granted access to this page.
18:18:31 * rbergeron was dagny for liek 10 years on irc
18:18:31 <stickster> Cry, puny human!
18:18:39 <rbergeron> and raisin for 2 years before that
18:18:42 <ke4qqq> well obviously I don't know anything
18:18:45 <stickster> Raisin Taggart?
18:18:58 <rbergeron> precisely, stickster
18:19:27 * rbergeron will have to find the raisin video sometime
18:20:05 <rbergeron> k3rqqq: do you awnt me to add you to the zikula admins page?
18:20:08 <rbergeron> err
18:20:09 <rbergeron> ke4
18:20:14 * rbergeron can't ever type your name, sorry
18:20:24 <ke4qqq> no - I already have admin access to the zikula on pt6
18:20:28 <ke4qqq> wonder if it takes time to sync
18:20:32 <nmarques> take care people, brb
18:20:46 <rbergeron> i don't see you in the list of admins on p6t
18:20:57 <rbergeron> unless you're just awesome by default
18:20:59 <rbergeron> which is possible
18:21:20 <ke4qqq> soooo this is a secret don't tell anyone, but they publish the password to fakefas's admin user, and I have that....lol
18:21:28 <ke4qqq> :)
18:21:38 * rbergeron will note to erase that from this meeting log
18:21:46 * rbergeron grins
18:22:02 * rbergeron wonders if she needs to send mchua a book for her birthday, heh
18:22:08 <ke4qqq> that way you can create fakefas groups, and approve them, etc.
18:22:20 <ke4qqq> mchua has birthdays?? when?
18:23:18 <rbergeron> waiiit a second
18:24:05 <ke4qqq> on?
18:24:15 <rbergeron> ummm
18:24:24 <rbergeron> am i not in cmsadmin or anything on rbergeron anymore?
18:24:33 * rbergeron is really not feeling all that sharp today
18:24:42 <rbergeron> i need cheese i think... i wonder if i have some
18:24:42 <rbergeron> hmm
18:24:43 <ke4qqq> are we talking fakefas or fas
18:25:00 <rbergeron> whatever zikula on pt6 is using
18:25:10 <mchua> Ah! Yeah, I have to read that book.
18:25:15 <mchua> (Atlas Shrugged)
18:25:59 <ke4qqq> ohhhhh you should def. read that book - though others tell me you should start with the fountainhead first (but I didn't do that)
18:26:26 <rbergeron> yes, you should start with fh first
18:27:02 <rbergeron> so
18:27:14 * stickster think of changing '#topic book circle' :-)
18:27:32 * rbergeron still needs to get on the book club train again
18:27:35 <rbergeron> <--- on my list of things to do
18:27:42 <rbergeron> but
18:27:46 <rbergeron> http://publictest6.fedoraproject.org/zikula/
18:27:49 <rbergeron> i totally logged out
18:27:50 <rbergeron> closed my browser
18:27:56 <rbergeron> and now the front page of zikula just says
18:28:01 <rbergeron> ccess denied (error 403)
18:28:02 <rbergeron> Sorry! You don't have authorisation for the page you wanted.
18:28:02 <rbergeron> Additional information
18:28:02 <rbergeron> Sorry! You have not been granted access to this page.
18:28:09 <rbergeron> rather than having a place for me to log in and fakenews to read
18:28:20 * rbergeron looks to ke4qqq and stickster to see who broke it :)
18:28:32 * rbergeron also possibly looks at herself for pebkac issues
18:29:38 <ke4qqq> sorry - phone
18:29:51 <rbergeron> ok, i'm really going to go hope for a large serving of super sharp cheddar in my fridge, brb
18:29:59 <ke4qqq> so I see rbergero as being in cmsadmin
18:30:14 <rbergeron> can you get to the front page of FI?
18:30:19 <rbergeron> where there is a login box and stuff?
18:30:22 <rbergeron> i'm not even seeing that
18:30:42 * ke4qqq goes to look
18:31:05 <rbergeron> http://publictest6.fedoraproject.org/zikula/ .... should be it, right
18:31:45 <ke4qqq> hmmmmmm yeah - not working for me
18:31:56 * rbergeron didn't do it
18:32:06 <ke4qqq> actually it is in ff and not in chromium
18:32:09 <ke4qqq> weird
18:32:20 <rbergeron> did you try reloading :)
18:32:21 <rbergeron> oh, hmmm
18:32:36 * ke4qqq just logged out
18:32:39 <ke4qqq> let me log back in
18:32:50 <rbergeron> i can't get back to the page where i can log in
18:33:35 <ke4qqq> it's up and I can go to places I wasn't able to before
18:33:54 <ke4qqq> or rather that I didn't go to before
18:34:36 <rbergeron> wow
18:35:10 <ke4qqq> ok - must go eat - be back in a bit - sorry to abandon you mid-process - but.....
18:35:21 <rbergeron> ok, so -
18:35:26 <rbergeron> if you type in the wrong password
18:35:56 <rbergeron> it takes you to error 403
18:36:06 <rbergeron> and like.. you can't reload the page
18:38:50 <rbergeron> ke4qqq: so, you basically have to go in and delete your cookie to get in if you fail at typing
18:38:54 <rbergeron> however
18:38:59 <ke4qqq> interesting
18:39:01 <rbergeron> well, not however
18:39:08 <rbergeron> to get back to a login page, it seems
18:39:15 <rbergeron> but
18:39:18 <rbergeron> i deleted my cookie
18:39:21 <rbergeron> and logged in
18:39:28 <rbergeron> and it says i don't have access
18:39:44 <rbergeron> and doesn't show the content in lieu of having access, either, which is silly
18:40:02 <ke4qqq> wonder if, like real fas, fakefas has to sync - let me ask that question
18:47:20 <ke4qqq> apparently not
18:47:33 <ke4qqq> mmcgrath says no anyway
18:50:00 * rbergeron nods
18:52:22 * rbergeron wonders if she can end the meeting or if we have any other important decisions to make
18:52:25 <rbergeron> ;)
18:54:47 * ke4qqq will go look at on pt6 and see if there is something obvious
18:59:05 <rbergeron> i mean - i could be being stupid here
18:59:23 <rbergeron> it's happened :)
19:01:56 <rbergeron> spevack, you should be aware that i adopted a penguin from gdk's farm yesterday
19:02:05 <rbergeron> #endmeeting