14:59:44 <jlaska> #startmeeting Fedora QA Meeting
14:59:44 <zodbot> Meeting started Mon May  3 14:59:44 2010 UTC.  The chair is jlaska. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:49 <jlaska> #meetingname fedora-qa
14:59:49 <zodbot> The meeting name has been set to 'fedora-qa'
14:59:54 <jlaska> #topic Gathering critmass
15:00:07 * adamw gets critically massy
15:00:25 * kparal gets massively critical
15:00:33 <jlaska> adamw: you're moving at a high rate of speed too, and as we all know f=m*a
15:00:38 <jlaska> kparal: hah!
15:00:44 * jeff_hann here
15:01:02 <jlaska> jeff_hann: welcome
15:01:03 <adamw> heh
15:01:20 * adamw send a call out to the critical massive
15:01:30 * jskladan Zug Zug.
15:01:51 <jlaska> jskladan: howdy
15:01:59 <jlaska> wwoods: lurking?
15:02:07 <jlaska> let's get started ... we've all got a lot on our plates
15:02:30 <jlaska> #topic Previous meeting follow-up
15:02:36 <adamw> om nom nom
15:02:48 <jlaska> I only captured 2 items from last week ... and we'll touch on them later in the agenda
15:02:52 <jlaska> so skipping those two items
15:03:03 <jlaska> any other follow-up from last week?
15:03:54 <jlaska> alrighty ... moving along ...
15:04:03 <jlaska> #topic Fedora 13 RC test status
15:04:26 <jlaska> I'm sure folks are already tuned into this topic, but just a reminder on where we are in the F13 schedule
15:04:52 <jlaska> The F-13 Test compose was provided last Thursday, and is in test as we type
15:05:03 <jlaska> #info F-13-Final-TC1 test results available at https://fedoraproject.org/wiki/Category:Fedora_13_Final_TC_Test_Results
15:05:31 <jlaska> many thanks to robatino for handling the announcement and wiki magic while rhe is out
15:05:58 <kparal> the results seem very good so far
15:06:18 <jlaska> kparal: that's great!
15:06:56 <Southern_Gentlem> ?
15:06:57 <jlaska> preupgrade seems to still be sensative to properly recovering from low disk space
15:07:20 <jlaska> According to the blocker bug numbers ...
15:07:40 <jlaska> #info 32 MODIFIED || ON_QA F13Blocker bugs -- http://tinyurl.com/3ae37qy
15:07:57 * maxamillion is here
15:08:00 <maxamillion> sorry I'm late
15:08:02 <jlaska> #info 21 NEW || ASSIGNED F13Blocker bugs -- http://tinyurl.com/3567tqk
15:08:10 <jlaska> maxamillion: no worries, you're double booked too!  Welcome :)
15:08:21 <maxamillion> thankies :)
15:08:27 <jlaska> I know I have a large plate of bugs I need to provide test feedback on this afternoon
15:08:44 <jlaska> and we still have 21 NEW || ASSIGNED bugs preventing the F-13-Final release candidate compose
15:08:47 <adamw> *trumpets*
15:09:01 * wwoods lurking
15:09:03 <jlaska> my "at risk" spidey sense is activating
15:09:11 <jlaska> wwoods: lurk away my good man!
15:10:09 <jlaska> #info there are no more scheduled test days for Fedora 13
15:10:17 * adamw is walking the blocker list atm
15:10:41 <jlaska> so at this point, it's all about verifying your bugs, and carefully reviewing incoming issues
15:10:42 <adamw> obviously the new/assigned bugs are the most worrying  but it helps focus if we can close off as many of the ON_QA / MODIFIED ones as possible
15:11:18 <jlaska> I'd like to do a mass update of the MODIFIED || ON_QA bugs ... just asking for updated test feedback.  Do folks have any concerns about that?
15:12:14 <jlaska> any other thoughts related to F-13-Final testing before we move on?
15:12:39 <jlaska> #info for folks reading the recap, the F-13 QA schedule is available at http://poelstra.fedorapeople.org/schedules/f-13/f-13-quality-tasks.html
15:13:41 <jlaska> okay ... moving on to next topic ...
15:13:53 <jlaska> #topic Proventesters check-in
15:14:04 <jlaska> We discussed this briefly on the list last week
15:14:06 <adamw> jlaska: please don't do a mass update
15:14:13 <adamw> jlaska: i am doing more tailored notes on each bug as I walk
15:14:14 <jlaska> adamw: oh no?
15:14:22 <adamw> so it'd just be a duplication essentially
15:14:30 <jlaska> adamw: ah excellent, I'll refrain from the mass annoy
15:14:35 <jlaska> adamw: thx :)
15:14:56 <jlaska> Okay, with regards to /topic
15:15:03 <maxamillion> yeah ....
15:15:10 <jlaska> I tried to capture what needs to happen in the short-term and then long-term
15:15:29 <jlaska> so short-term, is it correct to say that we need to migrate 'qa' users into 'proventesters
15:15:31 <maxamillion> jlaska: did the proventesters group become authoritative in bodhi?
15:15:36 <jlaska> so that critpath bodhi feedback can continue?
15:15:54 <jlaska> maxamillion: not yet, we need to have testers migrated first I believe
15:16:04 <maxamillion> jlaska: yes, I think we need to move all curent 'qa' members into 'proventesters' so that we don't put any kind of road bumps in the way of forward QA progress in critpath
15:16:11 <maxamillion> jlaska: ah ok
15:16:15 <jlaska> maxamillion: dgilmore also noted that we'll need to migrate users by hand, there isn't a convenient script to mass migrating FAS users
15:16:24 <maxamillion> jlaska: *sweet*
15:16:52 <jlaska> maxamillion: I can take an action item to migrate them over today, and file a ticket against bodhi to request using 'proventesters' for critpath feedback instead
15:16:53 <adamw> remind me to be washing my hair that day
15:17:05 <kparal> how many members are in qa group?
15:17:12 <maxamillion> jlaska: that would be *awesome*
15:17:22 <maxamillion> kparal: quite a bit more than I had originally thought
15:17:37 <maxamillion> kparal: I'm logging in to check now
15:17:54 <kparal> 10 members
15:18:00 <jlaska> 10 approved right?
15:18:02 <jlaska> that's not too bad
15:18:05 <maxamillion> oh
15:18:05 <maxamillion> nvm
15:18:11 <maxamillion> I thought it was a lot more than that
15:18:24 <jlaska> maxamillion: there are a lot of unapproved requests iirc
15:18:31 <maxamillion> ah, ok
15:18:39 <jlaska> #action jlaska to migrate approved FAS 'qa' members into 'proventesters'
15:18:47 <kparal> dozens of unapproved
15:18:57 <jlaska> #action jlaska to request bodhi change to require 'proventesters' feedback for critpath
15:19:00 <adamw> because people kept applying to the group as they thought it was important
15:19:16 <jlaska> okay ... so once those 2 items are complete ... what's next?
15:19:32 <kparal> guidelines for mentors?
15:19:34 <jlaska> basically ... before we can remove https://fedoraproject.org/wiki/QA/JoinProvenTesters:Draft from Draft
15:19:52 <maxamillion> jlaska: that is *the* question ... :/
15:19:55 <jlaska> adamw: maxamillion you both were recommending providing guidance, and being less strict about membership
15:19:57 <kparal> guidelines for proventesters.... )
15:20:06 <jlaska> does that mean we don't have a mentor program?
15:20:14 <jlaska> kparal: yes!
15:20:31 <maxamillion> kparal: +1
15:20:37 <jlaska> #info long-term, need test guidelines for proventesters (something to explain why they are needed)
15:20:50 <adamw> no, having mentors is fine, they do the 'providing guidance' bit. i think.
15:21:16 <jlaska> are mentors also the group that acts on the 'proventesters' group requests?
15:21:17 <maxamillion> jlaska: no, I like the idea of a mentor but I don't want it to be a formal checklist style mentoring, it should be more hands on
15:21:38 <maxamillion> jlaska: yes, I think they would be
15:21:46 <kparal> we need a document specifying how to do proventesters' work properly. because that will also help mentors do their guidance
15:21:54 <maxamillion> kparal: agreed
15:22:15 <jlaska> kparal: what types of things would be in that document?
15:22:25 <jlaska> like your package update acceptance plan?
15:22:38 <maxamillion> I like the package update acceptance plan
15:23:03 <kparal> jlaska: basically it would tell me which package update should be tested with highest priority and what should I look at when testing them
15:23:20 <kparal> to tell the truth, I don't even know how to test package updates myself
15:23:26 <jlaska> ah, so how to prioritize them, and what to do with them
15:23:28 <kparal> so some introduction into it
15:23:57 <jlaska> #info long-term, provide guidance on how to prioritize package update testing
15:24:16 <adamw> jlaska: i think the idea is mentors answer the group requests, yeah
15:24:23 <jlaska> nice, anything else we need to consider?
15:24:45 <jlaska> adamw: maxamillion: so do we need a wiki page about Mentor responsibilities?
15:24:53 <maxamillion> I think so, yes
15:25:09 <jlaska> #info long-term, need to outline mentor responsibilities
15:25:17 <maxamillion> a formal "this is how to test" I think might be hard to capture but I agree with kparal that it should be done
15:25:25 <jlaska> btw ... unless folks are chomping at the bit to take this on right now ... I'm just collecting ideas
15:25:46 <jlaska> once the bulk of testing F-13 is behind us, we can start to divide & conquer
15:26:17 <jlaska> yeah, I have a hard time capturing some of that stuff, but perhaps if we start with what we know and what we do now ... that'll get things moving in the right direction?
15:26:48 <maxamillion> jlaska: agreed, and since we're going to grandfather in the current qa members who weild the critpath karma sword I think we have plenty of time
15:27:24 <jlaska> anything else we need to think about or consider?
15:28:13 <maxamillion> I'm sure there are, but I can't think of any right now
15:28:21 <jlaska> do mentors need a FAS group?
15:28:45 <jlaska> or are they just approved 'proventesters' ?
15:28:59 <kparal> I would go the easy way
15:29:12 <jlaska> yes please!
15:29:15 <jlaska> :)
15:29:33 <maxamillion> jlaska: either one I imagine would work and people who are mentors can just be kept track of in a wiki doc or something
15:29:36 * jlaska has a conflict starting shortly ...
15:29:48 <kparal> proventesters may mentor others. of course supposing people are reasonable and don't start mentoring right after receiving membership
15:29:59 * adamw is on a very laggy line
15:30:08 <adamw> what else is on the agenda?
15:30:27 <kparal> adamw: https://fedoraproject.org/wiki/QA/Meetings/20100503
15:30:36 <jlaska> adamw: an update from kparal on the package update acceptance test plan, AutoQA update, and open-discussion
15:30:42 <jlaska> #chair adamw kparal
15:30:43 <zodbot> Current chairs: adamw jlaska kparal
15:30:51 <maxamillion> kparal: +1
15:31:01 <maxamillion> (about the mentors bit)
15:31:05 <jlaska> maxamillion: kparal: that seems reasonable
15:31:12 <jlaska> okay, I think we've captured enough for now
15:31:25 <maxamillion> +1
15:32:03 <jlaska> #topic AutoQA check-in
15:32:04 <kparal> #info proventesters may mentor others, within some reasonable limits, no need for special FAS group for mentors
15:32:10 <jlaska> doh, wrong topic
15:32:18 <jlaska> #topic Package Acceptance Test Plan check-in
15:33:01 <jlaska> kparal: can you walk us through how things are looking on the PATP?
15:33:02 <kparal> ok, that's gonna be short: Package Update Acceptance Test Plan has been finalized
15:33:10 <kparal> draft status removed
15:33:12 <jlaska> YAY!!!
15:33:17 <kparal> it is now available here: https://fedoraproject.org/wiki/QA:Package_Update_Acceptance_Test_Plan
15:33:19 <kparal> #link https://fedoraproject.org/wiki/QA:Package_Update_Acceptance_Test_Plan
15:33:28 <adamw> yaaaaaay
15:34:02 <kparal> so now we know how to test. the thing missing is the implementation within AutoQA :)
15:34:10 <jlaska> details shetails!
15:34:11 <jlaska> :)
15:34:42 <jlaska> I linked to the 3 different autoqa milestones that implement the proposed plan in a previous meeting
15:34:47 <adamw> yeah, that'll just take a few minutes hehe
15:35:17 <kparal> well most of the tests are already available, we just don't have the infrastructure around
15:36:58 <jlaska> kparal: in keeping with the previous topic, do we want to also document the tests as wiki test cases/
15:37:22 <kparal> yes, we have a ticket for it somewhere
15:37:24 <wwoods> oh man exciting stuff.
15:37:27 <jlaska> okay, cool!
15:37:28 <kparal> I think I mentioned it last meeting
15:39:31 * kparal wonders if he should take the chair?
15:40:22 <kparal> alright, jlaska is probably at the second meeting, let's move to another topic
15:40:29 <jlaska> kparal: can you move us through the AUtoQA update?
15:41:07 <kparal> so, who wants the mic?
15:41:13 <jskladan> OK, probably on me to talk (even thought there is not much to tell)
15:41:26 <kparal> #topic AutoQA check-in
15:41:37 * kparal corrects topic command :)
15:41:53 <jskladan> last week, i've been working on the autotest-id propagation to the autotest-client
15:42:04 <jskladan> (and subsequentely to the autoqa test)
15:42:29 <jskladan> so we can benefit from the direct links to stored results on the Autotest-server
15:42:58 <jskladan> hopefully the patch will be in upstream until the end of the week
15:43:00 <wwoods> so when a test finishes we actually have a link back to all the logs and everything, so we don't need to include so much junk in the email?
15:43:06 <jskladan> yes
15:43:23 <wwoods> just making sure
15:43:24 <wwoods> heh
15:43:34 <kparal> for example we can send just a summary/highlights in the email and link to the full results
15:43:34 <jskladan> hehe
15:44:07 <jskladan> other that that, i'm adding more LSB-compliancy check for initscripts
15:44:18 <wwoods> thanks for taking the lead on that one - I tried and failed to get that to work a while back
15:44:22 * jskladan steals all the stuff from the RHEL guys :)
15:45:09 <jskladan> other than that, jlaska told me, that he'll be packaging autoqa next week
15:45:26 <jskladan> so hopefully the functionality will be on the production server soon :)
15:45:38 <jskladan> any other updates from you guys?
15:45:47 <wwoods> jlaska has been working on visualizing the dependency graph needed for autoqa
15:45:50 <wwoods> it's terrifying
15:46:08 <wwoods> we're probably going to need to have a FAD with some Java packagers if we're expecting to get the entire thing accepted into Fedora
15:46:36 <kparal> well it's java, it is terrifying :)
15:46:39 <wwoods> indeed.
15:46:42 <wwoods> I've got a quick update on autoqa
15:46:42 * kparal takes the mic
15:46:43 <jlaska> we had a FAD in planning, but that's going to be rescheduled and go through planning again after F-13 is out the door
15:46:46 <kparal> oh sorry
15:46:57 <wwoods> but kparal is the chair, so I'll wait for him to hand off the mic
15:46:57 <wwoods> heh
15:47:05 <kparal> alrighty
15:47:17 <maxamillion> there are still java packagers around? .... I thought when dbhole orphaned half the java stack we were in trouble :/
15:47:27 <kparal> so last week I spent a little time on skvidal's patch which he posted into our ML
15:47:34 <wwoods> ah, that's what I was going to talk about too
15:47:54 <jskladan> #info jskladan made progress on the autotest-id to the autoqa test front
15:47:59 <kparal> it should allow us to sent emails directly to package maintainers that are subscribed to receive it
15:48:26 <jskladan> #info jskladan is adding more initscript LSB compliance tests to autoqa
15:48:36 <kparal> there were few bugs and I think we will need some library functions tweaks, but it should be done pretty quickly
15:48:44 <wwoods> it's a per-package thing - maintainers can opt-in to getting email from rpmguard whenever it runs for certain packages
15:48:48 <kparal> I would like to post tested patch this week
15:48:50 <skvidal> kparal: I sent a second patch
15:49:01 <wwoods> we will probably want to document the opt-in procedure for interested maintainers
15:49:06 <kparal> skvidal: I know, I haven't seen it yet unfortunately
15:49:11 <skvidal> kparal: ?
15:49:16 <kparal> skvidal: but many thanks for your work
15:49:16 <skvidal> kparal: you didn't receive it?
15:49:25 <kparal> skvidal: received, but not reviewed :)
15:49:28 <skvidal> oh okay
15:49:29 <wwoods> and note that this is a temporary hack, to be used until resultsdb is able to handle this kind of thing
15:50:20 <kparal> and then we can expect many complaints about the contents :)
15:50:30 <skvidal> which is sorta the point
15:50:40 <skvidal> it'll help field what can be filtered later
15:51:02 <kparal> #info skvidal's patch should allow AutoQA to send direct emails to subscribed package maintainers
15:51:17 <kparal> ok, anything else from AutoQA?
15:51:46 <wwoods> one other thing
15:51:52 <kparal> go ahead
15:52:10 <wwoods> I'm still working on the post-bodhi-update watcher/hook - there are some limitations of the current bodhi design that make it tricky for us to do what we want
15:52:24 <wwoods> but I think I've got the design all worked out now
15:52:39 <adamw> sorry, my connect died
15:52:47 <wwoods> hopefully I will have it testable by the end of this week (so long as administrative things don't get in the way)
15:53:13 <wwoods> I'm also trying to write a big blog post to explain the depcheck test and why it's so hard
15:53:16 <wwoods> heh
15:53:39 * kparal looking forward
15:53:49 <wwoods> I'm trying to keep notes on things that would make the post-bodhi-update watcher/hook easier to implement, so we can make sure that stuff gets put into the design of bodhi2
15:54:00 <wwoods> (without bugging lmacken too much)
15:54:31 <wwoods> but yeah, keep your fingers crossed for some visible progress on that stuff.
15:54:34 <wwoods> that's all from me.
15:55:22 <kparal> ok, thanks wwoods
15:55:40 <kparal> as far as I see, we have open floor now
15:55:50 <kparal> #topic Open discussion - <Your topic here>
15:56:11 <kparal> anything you want to discuss?
15:56:47 <jlaska> kparal: nothing here, thank you for driving while I'm distracted :)
15:56:58 * adamw just focussing on blockers
15:57:14 <adamw> please everyone test some on_qa/modified, there's several anyone could test
15:57:45 <kparal> #info please test on_qa/modified bugs, there's several anyone could test
15:57:50 <adamw> thanks
15:58:21 <wwoods> link to the list?
15:58:32 <wwoods> (for lazyboneses such as myself)
15:58:38 <kparal> is this link correct? https://bugzilla.redhat.com/showdependencytree.cgi?id=507681&hide_resolved=1
15:59:01 <kparal> I know jlaska had two different links while back, but I think it should be the same
15:59:43 <kparal> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=507681&hide_resolved=1
16:00:07 <adamw> that's all blockers
16:00:29 <adamw> i'll try and send out a mail later flagging up bugs that anyone can test
16:00:32 <adamw> i'm making a list
16:00:51 <kparal> #info adamw will send a list of easily testable important bugs
16:01:03 <adamw> hey hey hey, you just VASTLY upgraded my 'try' ;)
16:01:17 <kparal> adamw: now you have an action item :)
16:01:25 <adamw> hehe
16:01:56 <kparal> alright, one hour precisely
16:02:06 <kparal> if you don't have anything else on mind...
16:02:27 <kparal> thanks all for attending!
16:02:31 <kparal> #endmeeting