15:00:26 <adamw> #startmeeting Fedora QA Meeting
15:00:26 <zodbot> Meeting started Mon Oct 17 15:00:26 2011 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <adamw> #meetingname fedora-qa
15:00:30 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:37 <adamw> #topic roll call
15:00:43 * tflink is here
15:00:45 * jskladan is here for all the meeting fun!
15:00:48 * kparal rolls
15:00:56 <adamw> jskladan: i think you're in the wrong place
15:01:25 * j_dulaney is on his phone
15:01:27 <jskladan> adamw: so this ain't the place where you get milk and cookies?
15:02:18 <kparal> that's the #milk-and-cookies channel
15:02:47 <jskladan> kparal: ah, so this must be the Beefy Miracle channel then ;-)
15:02:54 <adamw> only if milk means 'work' and cookies means...'more work'
15:03:10 * pschindl is here
15:03:22 <jskladan> adamw: then I guess it's the right place :)
15:03:24 <tflink> adamw: those sound like crappy milk & cookies to me
15:03:46 <adamw> heya vita
15:04:28 <adamw> #topic previous meeting follow up
15:04:44 <adamw> so, let's see...I wasn't around for last week, but here's the action items...
15:04:59 <adamw> "tflink build python-yourls for F16, F15, EL6 so we can stop dicussing this"
15:05:03 <adamw> tflink, did you stop sucking yet?
15:05:22 <tflink> adamw: packages built, updates submitted
15:05:37 <adamw> #info tflink finally stopped sucking like a dyson, python-yourls is built and submitted
15:05:38 <tflink> ... finally
15:05:47 <tflink> wow, somebody
15:05:55 <tflink> 's grouchy today :)
15:06:04 <adamw> it's 8am on a monday, i'm ALWAYS grouchy ;)
15:06:12 <adamw> 'adamw will draft release criteria change proposals and send out to test@'
15:06:26 <adamw> did that, and we committed most of them already
15:07:00 <adamw> #info adamw submitted the release criteria proposals that came out of recent blocker review meetings
15:07:17 <adamw> on a related note...
15:07:18 <adamw> 'tflink to move Xen release criterion discussion to devel@'
15:07:31 <adamw> i believe we moved it there, moved it back, and accepted a final criterion in the end
15:07:39 <tflink> did that, no objections from devel@
15:07:55 <tflink> AFAIK, you have it correct
15:08:19 <adamw> eggscellent
15:08:33 <adamw> #info Xen criteria discussion went to -devel, came back, and we accepted a criterion for Final
15:09:01 <adamw> 'tflink to continue pestering Cloud SIG people about test cases and coordination'
15:09:27 <tflink> I've been pestering, supposedly it's going to come together today or tomorrow
15:09:31 <adamw> cool.
15:09:37 <adamw> we do obviously need  better xen test cases
15:10:05 <tflink> yeah, I was going to send something to fedora-xen@ asking for help and testers
15:10:13 <adamw> #info 'I've been pestering, supposedly it's going to come together today or tomorrow'
15:10:23 <adamw> excellent...anything I missed from last week?
15:10:30 <tflink> but I don't think that we need the xen cases for the cloud test day
15:11:01 <tflink> oh, I did ask the cloud sig to help formalize the EC2 test cases so they aren't scattered about different wiki pages
15:11:45 <adamw> cool
15:12:07 * tflink wonders where we're going to puth them in the matrix, though
15:12:53 <adamw> the validation matrix? or the cloud test day matrix?
15:13:12 <tflink> the validation matrix, the test day is up to the cloud SIG
15:13:21 <adamw> same place as the other virt tests, i guess.\
15:13:50 <tflink> for the short term, sure but I'm not sure that EC2 tests qualify as installation tests
15:14:02 <tflink> either way, not something to worry about right now
15:15:05 <adamw> sure.
15:15:10 <adamw> #topic Final preparation
15:15:46 <j_dulaney> Yay
15:15:48 <adamw> well, nothing much specific to bring up here, but we're into the Final cycle now...TC1 is out and needs all validation testing run, we've spotted some issues with the metadata but most tests should be possible
15:15:57 * kparal has a related note
15:16:00 <adamw> yup?
15:16:15 <adamw> i'm not aware of any major pending changes which would demand a tc2 unless we re-spin for the metadata issues
15:16:43 <kparal> due to Ben Levenson's incentive, I have talked to a few local team leaders in Brno and they have agreed to lend a few of their interns for the final release validation
15:17:01 <kparal> so I just want to note that you can expect a few more people to be reporting bugs, hopefully
15:17:15 <kparal> (does reporting new bugs in F16 count as "hopefully"?)
15:17:33 <adamw> kparal: that's awesome, nice move
15:17:46 <adamw> thanks for looking after that
15:17:48 <kparal> I will have a meeting with them tomorrow and show them how to do installation and desktop testing
15:18:04 <j_dulaney> Kparal:  indeed
15:18:05 <kparal> end of note
15:18:50 <j_dulaney> What sort of meta data issues are we
15:19:01 <j_dulaney> Talking
15:19:20 <j_dulaney> I haven.t seen any
15:19:38 <j_dulaney> Bloody phone keyboard
15:20:18 <kparal> is it related to missing x64 images?
15:20:53 <adamw> missing .treeinfo and repodata
15:21:01 <j_dulaney> Ah
15:21:03 <adamw> which can affect some install types i think, like preupgrade
15:22:06 <j_dulaney> Yay more pre upgrade issues
15:22:17 <adamw> yup :/
15:22:21 <kparal> so TC2 will be soon?
15:22:35 <adamw> no, the opposite: unless we decide the metadata issues need a respin i think there's no specific need for a tc2
15:22:56 <kparal> and the missing x64 images will be provided?
15:23:04 <adamw> i think they showed up now didn't they?
15:23:11 <robatino> no
15:23:17 <kparal> adamw: http://dl.fedoraproject.org/pub/alt/stage/16.TC1/Fedora/x86_64/
15:23:18 <kparal> no
15:23:28 <adamw> oh, nup, not yet. yeeks.
15:23:44 <adamw> #action adamw to check with dgilmore where we are with x86_64 iso generation
15:24:01 <adamw> okay, other reason to build a tc2 would be if that would get us x86_64 images...i'll co-ordinate with releng on that
15:24:37 <adamw> otherwise i guess we could do one next week to pick up general package set changes, but there's not really a huge amount of reason to re-spin unless certain sensitive packages change (anaconda, kernel, lorax etc)
15:25:08 * j_dulaney thinks a tc2 would not be a bad thing
15:25:27 <kparal> next week is RC1
15:25:35 <j_dulaney> Ah
15:25:42 <kparal> 26th is the plan
15:25:57 <adamw> oh, right. i meant later this week.
15:26:00 <j_dulaney> Maybe that will be sufficient
15:26:01 * adamw still catching up with the universe in general
15:26:06 <kparal> :D
15:26:09 <robatino> the 32-bit half of the install text matrix is almost done and looks good
15:26:14 <adamw> yeah
15:26:34 <adamw> only thorny area i'm really worried about is the grub2/bios raid issues; i'll try and get pjones looking at that
15:27:10 <robatino> people might want to look at bugs 746509 / 746529 having to do with installing TC1 live to hard drive
15:27:19 <adamw> thanks for the flag up
15:27:27 <robatino> black screen in x after installing
15:27:30 <adamw> so, aside from a potential tc1, we have the blocker review on friday, of course
15:28:54 <adamw> anyone else have anything to bring up or concerns about the final process?
15:31:00 <adamw> okay, cool. I had a 'criteria revisions' topic on the list but really we covered it in previous meeting follow-up - we accepted most of the proposed criteria already.
15:31:08 <adamw> so...
15:31:12 <adamw> #topic upcoming QA events
15:32:12 <adamw> well a big vote of thanks to a. s. alam for taking on the role of QA presenter at FUDCon Pune, which for those in Asia is coming up early next month
15:32:32 <adamw> http://fudcon.in/ - 2011-11-04 to 2011-11-06
15:33:32 <adamw> aside from that, we have TC1 testing all week, and the blocker review on Friday 2011-10-21
15:33:39 <adamw> #info we have TC1 testing all week, and the blocker review on Friday 2011-10-21
15:33:59 <adamw> Thursday 2011-10-20 is Cloud Test Day, I believe tflink's been trying to herd that one?
15:34:11 <adamw> #info Thursday 2011-10-20 is Cloud Test Day
15:34:18 <adamw> https://fedoraproject.org/wiki/Test_Day:2011-10-20_Cloud_SIG_Test_Day
15:34:51 <tflink> trying, looks like there are going to be a lot of components
15:35:12 <tflink> I think that some openstack and possibly euca people will be around
15:35:31 <tflink> in addition to EC2, boxgrinder and aeolus
15:35:32 * maxamillion is here ... late but here (which is becoming par for the course)
15:35:51 <tflink> so ... lots of stuff to test :)
15:36:22 <adamw> so it'll be a hot mess, i guess :)
15:36:29 <tflink> yeah, probably
15:38:07 <adamw> but sounds like stuff will get done. hey, at the worst, we can get the cloud teams to test each others' clouds. :)
15:38:39 <tflink> and hopefully, we'll get some good test cases and docs out of it
15:38:42 <adamw> yup.
15:39:21 <adamw> okay, moving swiftly on...
15:39:36 <adamw> oh, tflink / kparal, is it worth doing an autoqa update segment?
15:39:48 <kparal> I don't think so
15:39:56 <tflink> I can't think of anything worth noting
15:42:14 <adamw> okay
15:42:26 <adamw> nirik: anything from proventesters?
15:42:58 <nirik> not off hand, some more ideas...
15:43:25 <adamw> okay
15:43:48 <adamw> #topic open discussion
15:44:04 <adamw> any other business? cookies? milk? plans for world domination?
15:44:19 <brunowolff> I submitted an NTH request for a regression in the rc9 kernel.
15:44:39 <brunowolff> I got Adam's deadwood cleanup patch into spin-kickstarts.
15:44:59 <tflink> brunowolff: what is the bug # on that?
15:45:35 <adamw> note that we're not frozen yet so there can be a kernel update any time the kernel team wants there to be one
15:45:45 <adamw> i should probably poke them and remind them of the schedule so they can plan their builds
15:45:45 <brunowolff> https://bugzilla.redhat.com/show_bug.cgi?id=746485
15:45:59 <tflink> brunowolff: thanks
15:46:02 <adamw> brunowolff: oh, yeah, thanks for that - actually that may be a reason to do a tc2, as well...
15:46:11 <brunowolff> Linus is taking his time getting the 3.1 final out.
15:46:29 <adamw> #info brunowolff committed adamw's systemd conversion for spin-kickstarts, so tc2 and later will have the systemd-based livesys
15:46:49 <brunowolff> I don't think that's the right bug.
15:47:24 <brunowolff> This was the one where some chkconfig's were changed to use native systemd commands.
15:47:29 <adamw> #action adamw to co-ordinate with kernel team for final release build
15:47:37 <brunowolff> The livesys one looked more dangerous.
15:47:45 <adamw> oh right, sorry
15:48:01 <adamw> #undo
15:48:01 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x6404790>
15:48:02 <adamw> #undo
15:48:02 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x5a50290>
15:48:26 <brunowolff> If you think it is safe I could try to test it over the next couple of days. That seems a bit risky, but it would be in before freeze?
15:48:27 <adamw> #info brunowolff committed adamw's patch to clean up service disablement in live images for systemd
15:48:33 <adamw> brunowolff: no, let's leave that for 17
15:48:38 <brunowolff> OK.
15:48:44 <adamw> #action adamw to co-ordinate with kernel team for final release build
15:51:33 <brunowolff> I'll be branching spin-kickstarts soon.
15:52:52 <adamw> cool.
15:52:56 <adamw> welp, sounds like that's everything
15:53:00 * adamw sets fuse for one minute
15:56:48 <kparal> the fuse exploded some time ago?
15:57:40 <tflink> oh no! it got adamw!
15:58:06 <tk009> that 'it' is a killer
15:58:47 <drago01> he might be just moving fast enough that one minute has not passed yet for him ;)
15:58:57 * tflink always wondered what the fuse was attached to
16:01:32 <Cerlyn> You really should be using a fuze and not a fuse
16:05:29 <kparal> maybe the too early getting up killed him
16:05:35 <kparal> I totally understand that
16:05:47 <kparal> anyway, kparal goes off
16:05:52 <kparal> have a nice day everyone
16:15:00 <tflink> adamw: you might want to end the meeting :)
16:15:24 <tk009> no one else has chair?
16:15:49 <tflink> I don't think so
16:17:22 <drago01> adamw: END THE MEETING
16:17:25 <drago01> maybe that works
16:17:31 <Southern_Gentlem> #endmeeting
16:17:51 <Southern_Gentlem> this is why extra chairs are needed
16:18:28 <nirik> .addchair #fedora-meeting nirik
16:18:28 <zodbot> nirik: (addchair <channel> <network> <nick>) -- Add a nick as a chair to the meeting.
16:18:35 <nirik> .addchair #fedora-meeting freenode nirik
16:18:35 <zodbot> nirik: Chair added: nirik on (#fedora-meeting, freenode).
16:18:39 <nirik> #endmeeting