16:00:53 <adamw> #startmeeting Fedora QA meeting
16:00:53 <zodbot> Meeting started Mon Feb  6 16:00:53 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:09 <adamw> #meetingname fedora-qa
16:01:09 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:11 <adamw> #topic roll call
16:01:17 <adamw> happy monday everyone
16:01:25 <adamw> who's here for some awesome qa meeting fun times?
16:01:34 * mkrizek is here
16:01:49 * tflink is present
16:02:17 * kparal appears
16:02:33 <adamw> oh no! a level 65 kparal!
16:03:30 * kparal looks suspiciously for a hidden meaning
16:03:43 <adamw> your join message reminded me of an RPG for some reason
16:03:44 <kparal> or any meaning :)
16:04:29 <adamw> =)
16:04:40 <kparal> I see. let's slain the latecomers!
16:04:42 <adamw> alright then, let's get going - not a lot on the agenda this week, happily
16:04:52 * jskladan is in
16:04:58 <adamw> hi josef
16:05:09 * pschindl is here
16:05:13 <adamw> #topic previous meeting follow-up
16:05:50 <adamw> "kparal to file a bug for the failure of rats #2 DVD image to boot" - that got done, during the meeting in fact
16:06:10 <kparal> yup
16:06:24 <adamw> #info kparal did file a bug for the rats #2 DVD boo fail: https://bugzilla.redhat.com/show_bug.cgi?id=785808
16:06:36 <josef> adamw: hey, just hanging out until the fesco meeting
16:06:42 <josef> dont mind me :)
16:06:44 <adamw> "tflink to test building a boot.iso with usrmove builds "
16:06:48 <adamw> josef: uh, I meant *our* josef :)
16:07:05 <adamw> jskladan = also a josef
16:07:14 <adamw> so this one also got done
16:07:16 <adamw> yay us
16:07:44 <adamw> #info tflink was eventually able to build a functional boot.iso, exposing some required changes in the build process along the way
16:07:54 <josef> ah haha
16:08:17 * tflink is currently working to build another boot.iso, will post that once its done
16:08:18 <adamw> alright. anything else anyone wants to pick up on from last week? I don't see anything else
16:09:27 <adamw> okey dokey
16:09:37 <adamw> #topic upcoming QA events
16:09:49 <adamw> so we're into the f17 alpha cycle now, TC1 is out there and under test
16:10:22 <adamw> feature 'freeze' is tomorrow and RC1 is scheduled for 02-16
16:10:34 <adamw> so we're going to want at least one more TC, probably two
16:11:01 <adamw> i think it's probably a good idea to spin a TC2 ASAP now the /usr move has landed in Rawhide, so we have a post-/usr-move TC to bash on and compare to the pre-/usr-move one
16:11:09 <adamw> anyone any thoughts there?
16:11:39 <tflink> current version of lorax won't work with usrmove
16:11:44 <adamw> ah, okay
16:11:50 <adamw> so we'll need a new one before we can do another compose?
16:11:52 * tflink submitted a patch
16:12:04 <tflink> yeah, the compose will fail silently, otherwise
16:12:21 <tflink> as in it will build but won't actually work
16:12:27 <adamw> #info current lorax does not work correctly with post-/usr-move packages, needs a patch tflink has submitted
16:12:40 <adamw> thanks for looking into that!
16:12:46 <tflink> woah, what happend to koji
16:13:08 <adamw> makeover!
16:13:39 <adamw> #info koji is looking sleek and sophisticated this morning
16:13:51 <tflink> adamw: so the usrmove RPMs hit rawhide?
16:13:56 <adamw> yup
16:14:01 <adamw> hot tagged over on friday
16:14:12 <adamw> s/hot/got/
16:14:12 <tflink> isn't that going to bork any additional testing w/ TC1?
16:14:27 <tflink> nvm, I rethought that one
16:14:30 <adamw> well, depends what you mean by 'testing'
16:14:46 <adamw> you'll have to follow the upgrade procedure to get a TC1 install to update now, that's about all the consequences
16:15:06 <tflink> adamw: only from DVD, netinstall shouldn't require upgrade
16:15:16 <adamw> so, yeah, in case you get stuck upgrading TC1 or need to help someone else, refer to: https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17
16:15:33 <adamw> tflink: yeah, indeed, netinstall should give you a /usr-moved system now. and hopefully should work.
16:15:39 <adamw> #info in case you get stuck upgrading TC1 or need to help someone else, refer to: https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17
16:15:42 <brunowolff> I tried that this weekend and it worked, but there were a couple of oddities.
16:15:52 <adamw> brunowolff: what were the oddities?
16:16:27 <brunowolff> The files get moved over without copying their context type so a relabel is needed, but I didn't see a relabel in the instructions.
16:17:14 <brunowolff> The other was that luks password asking was a bit different. Before switching the root, each needed device got asked about
16:17:14 <adamw> i think one is meant to get triggered somehow as part of the instructions, i forget how precisely
16:17:38 <brunowolff> separately and asterisks weren't echoed like normal.
16:18:10 <brunowolff> This happened both in the initial conversion boot and when rebooting after the update.
16:18:29 <brunowolff> I did a relabel and rebuilt the initramfs again and both issues went away.
16:18:38 <adamw> brunowolff: ah, the 'fixfiles onboot' triggers an selinux relabel next boot.
16:19:03 <brunowolff> The relabel could probably be avoided by copy over the selinix labels when copying the files.
16:19:11 <adamw> probably.
16:19:42 <adamw> maybe file a  bug on dracut suggesting that? as that's where the script lives
16:21:32 <adamw> okay, moving on!
16:21:48 <adamw> oh, i note that the first test day slot is this week but we have no event
16:21:50 <brunowolff> OK, I didn't see the fixfiles part since I was off the script by that point since I was already running rawhide. I would have likely noticed a restorecon.
16:22:01 <adamw> that's fairly usual early in the cycle as people usually want t ogo later
16:22:15 <brunowolff> And with restorecon the relabel could have been limited to a few directories and taken less time.
16:23:50 <adamw> we don't have a j_dulaney to give us a test day update, but he seems to be on top of the tickets.
16:24:08 <adamw> and we have the next blocker review meeting coming up friday, of course.
16:24:16 <tflink> yay!
16:24:20 <adamw> #action adamw to co-ordinate with dgilmore on getting lorax updated and a new compose done
16:24:26 <adamw> fun abounds!
16:24:55 <tflink> sounds like there's going to be a new anaconda build today, too
16:25:00 <adamw> goody.
16:26:41 <adamw> okay, anything else on upcoming events?
16:28:12 <adamw> alrighty then
16:28:15 <adamw> #topic autoqa update
16:28:20 <adamw> #chair tflink kparal
16:28:20 <zodbot> Current chairs: adamw kparal tflink
16:28:32 <adamw> take it away, autoqa wielders
16:28:49 * kparal waiting for zimbra...
16:29:07 <kparal> anyway, the biggest change from last week is that rats_install is finally merged into master
16:29:16 <kparal> so kudos hongqing
16:29:52 <kparal> after that we found out about that root=<foo> anaconda option that is required right now, so it will need one minor patch to get it fully working for the composes
16:30:08 <kparal> and of course we need to have the repository branched, but that should happen tomorrow
16:30:20 <jskladan> and probably the most visible AutoQA update: http://autoqa-stg.fedoraproject.org/resultsdb/frontend we finally have the ResultsDB frontend up'n'running since last friday (even though just collecting data from staging). Looks to be working all right so far ;) (kudos to pschindl!)
16:30:38 <kparal> and yes, resultsdb being the second biggest change :)
16:31:17 <adamw> #info rats_install is merged into autoqa master, needs minor fixes tomorrow
16:31:29 <adamw> #info resultsdb is now up and running at http://autoqa-stg.fedoraproject.org/resultsdb/frontend
16:31:35 <adamw> thanks petr and hongqing!
16:31:52 <kparal> we also learned that we were not sending Bodhi emails for some time due to expired/locked account. that is now also fixed
16:31:58 <adamw> so what's the status of rats_install exactly (assuming the fixes tomorrow)?
16:32:10 <adamw> is it actually at the point now where we can truly have it running entirely automated install tests?
16:32:30 <adamw> #info bodhi mailshots were broken due to expired/locked account, now fixed
16:32:48 <kparal> I need to verify that, because I still don't have the branched repo. I need to check the watchers etc. but basically it should be well prepared
16:33:14 <kparal> I also need to get two bare-metal machines and add them to our staging server so that we can test it our properly
16:33:38 <kparal> I still haven't considered where I will take these machines from
16:33:53 <adamw> whatever you do, just don't get caught
16:33:56 <tflink> kparal: you could take them from production
16:34:16 <kparal> tflink: yes, that is what I will probably try
16:34:32 <tflink> ie lock 2 bare metal hosts in production, add them to staging and hope it doesn't explode
16:34:50 * tflink wonders if autotest will be confused with 2 controllers
16:34:52 <kparal> adamw: does this sentence make you an accomplice?
16:35:10 <adamw> kparal: not as long as irc is an insecure protocol it doesn't
16:35:21 <kparal> :)
16:35:40 <adamw> tflink: you're testing! you're testing!
16:36:08 <adamw> okay, sounds like good stuff, congratulations
16:36:16 <kparal> tflink: I'll ask lmr, as long as they are locked at one controller, it shouldn't be a problem I guess
16:37:03 <tflink> kparal: otherwise, I don't think it's too much of a problem to reinstall those hosts but jlaska would know more
16:37:59 <kparal> I'll work on that
16:38:51 <adamw> cool. anything else for autoqa?
16:39:09 <kparal> that's it
16:40:51 <adamw> okelydokely
16:41:07 <adamw> #topic open floor
16:41:13 <adamw> okay, any other business anyone?
16:42:57 <kparal> I just want to ask what the current status of remote_installation is
16:43:10 * tflink is waiting for management approval of the demo
16:43:21 <tflink> everything is set up and ready to go otherwise
16:43:24 <adamw> on which topic, has anyone heard from benl lately?
16:43:27 <kparal> great
16:43:32 <adamw> i'm waiting for a reply from him too
16:43:47 <tflink> he said something about traveling until tuesday, but I'm not sure
16:44:17 <kparal> I can harass him in person if you want
16:44:39 <kparal> he can't escape, he's at the same building, if not traveling
16:44:48 <tflink> he doesn't seem to be on IRC right now
16:45:45 <adamw> yeah, hasn't been for a while when i've looked
16:45:50 * tflink is wondering if he should re-setup for F17 alpha instead of F16 for remote_install, though
16:46:03 <adamw> tflink: that seems reasonable, given that it's what we want to test :)
16:46:29 <tflink> adamw: my only argument against it is that the demo is for remote_install, not for testing fedora
16:46:38 <tflink> but that isn't a very strong argument
16:46:56 <tflink> either way, I'm waiting for the OK before I do much more
16:47:35 <adamw> okay
16:47:48 <adamw> kparal: if you could look out for ben it'd be appreciated
16:48:03 <adamw> or anyone who might know where he's gotten to
16:48:33 <kparal> adamw: I'll ask around tomorrow
16:48:44 <adamw> oh, hey, he modified my 1x1 slot for tomorrow.
16:48:50 <adamw> so he's aliiiiiive anyway, wherever he is.
16:50:47 <adamw> #info remote_install status: mostly ready to go into public testing, tflink waiting for go-ahead from benl
16:52:14 <adamw> alright, i guess that's about it
16:52:30 <adamw> oh, we also need to fill out tc1 testing, of course
16:52:38 <adamw> looks like robatino and hongqing have knocked out quite a bit of it so far
16:54:34 <adamw> alrighty then, meeting's over, time for heavy drinking everyone! thanks for coming
16:54:42 <adamw> #endmeeting