15:59:58 <adamw> #startmeeting Fedora QA meeting
15:59:58 <zodbot> Meeting started Mon Feb 27 15:59:58 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:02 <adamw> #meetingname fedora-qa
16:00:02 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:06 <adamw> #topic roll call
16:00:14 <adamw> call your rolls, people!
16:00:19 * nirik is lurking.
16:00:20 * kparal rolls
16:00:20 * pschindl is here
16:00:39 * mkrizek here
16:00:44 <tflink> ooh, what rolls can we choose from?
16:01:00 * adamw calls his roll bob
16:01:04 <adamw> before I eat it.
16:01:29 * jskladan wantz a roll with goat cheese and beef ham
16:01:46 <tflink> jskladan: beef ham? Isn't that an oxymoron?
16:01:58 <adamw> unless...it's a beefy miracle
16:02:12 <tflink> it all makes sense now ...
16:02:15 * brunowolff is lurking for the first 1/2 hour, then I have a work meeting.
16:02:18 * Southern_Gentlem sitting in my rocking chair with rollers (so i can rock and roll)
16:02:30 <adamw> hey everyone, let's keep talking nonsense about rolls for the first half hour
16:02:55 <tflink> so we can have an even longer meeting?
16:03:09 <adamw> and so bruno misses it
16:03:11 <jskladan> tflink: http://www.alibaba.com/product-free/215780949/Smoked_Beef_Ham.html
16:03:42 <brunowolff> Thta's better than being fired.
16:03:44 <adamw> with a name like Delicious Food Industries, how can you go wrong.
16:03:56 <jskladan> hehe
16:04:06 <brunowolff> From both work and QA.
16:04:23 <tflink> jskladan: huh, you learn something new every day
16:04:35 <adamw> at last! the meeting is useful!
16:04:45 <adamw> #chair jskladan
16:04:45 <zodbot> Current chairs: adamw jskladan
16:04:49 <adamw> .fire adamw
16:04:49 <zodbot> adamw fires adamw
16:04:53 <adamw> i'm outta here
16:05:09 <jskladan> ok, I call anarchy time!
16:05:37 <adamw> :P
16:05:38 <jskladan> #topic previous meeting follow up
16:05:54 <adamw> aaaaaaand you fell right into the bear trap
16:06:02 <adamw> THERE IS NO PREVIOUS MEETING FOLLOW-UP
16:06:25 <jskladan> #info adamw is in denial about previous meeting!
16:06:38 <jskladan> moving on then :)
16:06:42 <adamw> heheh
16:06:48 <adamw> we had no action items from last week
16:06:53 <adamw> so i just left it out
16:07:00 <jskladan> #topic Fedora 17 Alpha wrap-up and Beta prep
16:07:23 <jskladan> IIRC F17 was declared gold on Feb 22
16:07:29 <adamw> soo, we signed off on alpha. i was probably drunk or something.
16:07:37 <adamw> also, my  birthday
16:08:00 <kparal> that explains being drunk
16:08:01 <tflink> we signed off on your birthday?
16:08:09 <adamw> i think so?
16:08:15 <kparal> you're not sure?
16:08:18 <tflink> someone is spending a bit too much time with processes
16:08:20 <adamw> we definitely need to get common bugs done, cos this thing is riddled with them
16:08:31 <j_dulaney> Sorry I'm late
16:08:34 <j_dulaney> class ran over
16:08:42 <jskladan> #chair j_dulaney
16:08:42 <zodbot> Current chairs: adamw j_dulaney jskladan
16:09:06 <j_dulaney> What did I miss wrap-up wise?
16:09:25 <adamw> nothing
16:09:50 <adamw> so yeah, since we have that kernel slowdown bug, and sound not working, and the installer blowing up if you have any other distro installed...
16:09:51 <tflink> rolls
16:10:06 <adamw> i'll start off the common bugs page today, if anyone else wants to throw in some contributions that'd be great.
16:10:27 <brunowolff> Sound works at least sometimes as I am listening to music on F17 right now.
16:10:51 <j_dulaney> Sound not working = why I have not upgraded bare metal to F17 yet
16:10:58 * j_dulaney needs his Bach
16:11:20 <adamw> j_dulaney: it's incredibly easy to work around, you just cut a bit out of pulseaudio's config or install consolekit.
16:11:27 <adamw> but explaining that is of course why we need the common bugs page...
16:11:44 <adamw> we also need to make sure a livecd-tools update gets karma'ed and pushed for f16 and f15 asap
16:11:47 <adamw> i'll poke bcl about that today
16:12:09 <adamw> #action adamw to start common bugs page
16:12:20 <j_dulaney> adamw:  Why does pulse still want consolekit in it's config?
16:12:23 <adamw> #action adamw to poke bcl about livecd-tools updates for fixing bugs writing f17
16:12:34 <brunowolff> I haven't seen the flood from updates-testing to f17 after goldness. Does releng need to get reminded it's OK for stable updates?
16:12:45 <adamw> j_dulaney: because no-one thought to take it out of there, and then when we did, we found PA doesn't compile any more, so we coldn't fix it quickly.
16:12:53 <adamw> brunowolff: probably, good point
16:12:56 <j_dulaney> Huh
16:13:08 <adamw> #action brunowolff to ping release engineering about post-freeze update re-opening for f17
16:13:09 <nirik> brunowolff: I was waiting until dgilmore finished testing the ec2 image
16:13:15 <j_dulaney> Isn't sound a final criteria?
16:13:16 <nirik> if thats done we can start anytime.
16:13:19 <adamw> fastest. action item. ever.
16:13:23 <adamw> j_dulaney: no, it's a beta one.
16:13:25 <brunowolff> OK.
16:13:32 <adamw> j_dulaney: happily, we just released alpha, so no problem. :P
16:13:43 <j_dulaney> Indeed
16:14:08 <dgilmore> ec2 still doesnt boot
16:14:23 <dgilmore> brunowolff: maybe we will get updates in the next couple of days
16:14:34 <dgilmore> or we will get updates and no ec2 images for alpha
16:15:13 <brunowolff> Do ec2 images need to be part of the goldness process?
16:15:34 <adamw> we didn't write that SOP yet, so we don't have a good answer.
16:15:52 <adamw> there's a 'deliverables' action item zinging around between qa and releng but it hasn't ever got much traction.
16:16:00 <j_dulaney> dgilmore:  Where are ec2 images dumped?
16:16:07 <brunowolff> Otherwise when you push stuff from testing to stable it goes into a black hole.
16:17:53 <adamw> #info updates pushes are still not happening because we don't have an ec2 image yet
16:18:52 <brunowolff> One possible future state would be to use the empty updates repository to hold stuff on its way from testing to stable.
16:19:06 <rbergeron> all updates??
16:19:17 <adamw> f17 updates.
16:19:18 <rbergeron> how do those two depend on each other (sorry, i'm less than brainy here)
16:19:23 <brunowolff> This would also handle dealing with stable not being rebuilt at the same times as the testing repo.
16:19:49 <adamw> rbergeron: if we started updates flowing again, what would dgilmore compose the ec2 images from?
16:19:59 <rbergeron> THIN AIR
16:20:01 <rbergeron> point taken
16:20:07 <tflink> that sounds a little hacky and aren't pre-releases configured to use updates, even though its empty?
16:20:07 <j_dulaney> brunowolff:  How difficult would that be to impliment?
16:20:19 <brunowolff> I am not sure.
16:20:27 <adamw> tflink: that would be my concern - it's something we could change, but it involves several moving parts.
16:20:34 <rbergeron> what's the cutoff point for when we just say "sorry charlie" ?
16:20:36 <adamw> and has consequences up to release time, with the repo configuration question
16:20:45 <adamw> rbergeron: that depends on how you feel about charlie.
16:20:54 <j_dulaney> Poor Charlie
16:21:03 <tflink> he's gone off to the cloud ...
16:21:18 <tflink> on to a "better" place :)
16:21:26 <j_dulaney> We also have to worry about PXE
16:21:37 <j_dulaney> Or is it finally booitng?
16:21:44 <tflink> j_dulaney: for beta, no?
16:22:19 <j_dulaney> tflink:  I think we skipped it for Alpha
16:22:25 <j_dulaney> Well, not skipped, per se
16:22:38 <j_dulaney> But, didn't require it to boot for Alpha
16:22:52 <jskladan> j_dulaney: it is booting, if you provide correct 'extra parameters', which is something i don't really like, but bcl tries to convince me that it's actually OK https://bugzilla.redhat.com/show_bug.cgi?id=787744
16:23:19 <adamw> right, it's not broken. we can document that.
16:23:49 <j_dulaney> Okay
16:24:11 <j_dulaney> Still, a NTH to fix that would be great
16:24:43 <rbergeron> i don't feel that strongly about charlie. charlie would be nice to have though. /me sighs
16:24:43 <adamw> i think it already is fixed, just didn't make alpha.
16:25:22 <j_dulaney> adamw:  PXE?
16:25:26 <adamw> rbergeron: seriously, i dunno the answer to that. isn't it more, er, your department? with either your current hat or your previous one? :)
16:25:36 <adamw> j_dulaney: the need for a kernel= parameter in certain boot types in general
16:25:46 <adamw> i remember seeing some chat in #anaconda to the effect that it's fixed
16:26:49 <j_dulaney> adamw:  Ah
16:27:03 <rbergeron> ec2 shouldn't be a blocker. not when we don't have criteria, or testing beforehand
16:27:18 <j_dulaney> +1
16:27:35 <rbergeron> that said: since we aren't discovering this until the time when we need to post it, we should maybe start considering actually doing a test-compose-to-upload-to-ec2 in the future
16:27:52 <rbergeron> so that if that process is broken we don't find out ... in this meeting the day before release
16:28:06 <adamw> rbergeron: i don't see it as something which should have a criterion - we don't have a 'criterion' that the live image should work, a 'criterion' that the dvd image should work, etc
16:28:07 <brunowolff> Time to get fired from QA so I don't get fired from my paying job. See you next week.
16:28:18 <adamw> the deliverables aren't specified in the criteria, we should have probably a releng sop for them
16:28:44 <adamw> the criteria specify the functions that should work across all supported deliverables. but eh, i'm disappearing up my own process ass here, we can figure it out in post.
16:28:48 <adamw> .fire brunowolff
16:28:48 <zodbot> adamw fires brunowolff
16:29:03 <j_dulaney> .fire brunowolff
16:29:03 <zodbot> adamw fires brunowolff
16:29:09 <aeperezt> sorry late but here john
16:29:12 <rbergeron> there is criteria that things should boot - but do we block if, say, xfce doesn't boot, but gnome does?
16:29:14 <j_dulaney> LOL
16:29:24 <nirik> not currently.
16:29:32 <nirik> gnome and kde are the blocking desktops
16:29:36 <rbergeron> (i think, talking out my ass while i'm on the phone in a meeting)
16:30:16 <j_dulaney> multitasking much?
16:30:29 <adamw> rbergeron: the criteria use the phrase 'supported desktops', and there's a little bit in the preamble which states what those currently are by policy.
16:30:30 <nb> FWIW why should kde get special status over XFCE?
16:30:33 <adamw> (which is KDE and GNOME)
16:30:35 <rbergeron> right. so we could block final if ec2 doesn't boot, but ... not alpha? /me is just brainstorming, but i think we just need a decision here and i i think it's just "sorry charlie, no alpha"
16:30:45 <nb> me can see gnome, since it is default, butn ot kde
16:31:01 <rbergeron> nb: would you like to hold pandora's box so you can peer into it as deeply as possible?
16:31:02 <adamw> nb: it always has and so it continues to. it just is considered to be supported while the others aren't. that can always change, but the decision wouldn't come from us.
16:31:13 <j_dulaney> nb:  Do we block on Fluxbox?
16:31:29 <nirik> nb: historical reasons.
16:31:48 <j_dulaney> nb:  If you want to change that, poke the Board
16:31:55 <nb> ok
16:32:05 <rbergeron> dgilmore: can we not back out changes to last known working appliance-tools, rebuild it, and try that?
16:33:41 <adamw> anyway, it seems like the takeaway here is clearly that we're lacking policy/process for deliverables: what they are, and how hard we try to deliver the ones that aren't required at any point, when we stop trying, etc
16:33:56 <adamw> so we need to renew that ticket, wherever it is, and get that done
16:34:10 <adamw> #action adamw to dig out the 'deliverables' ticket / action item and get it moving again
16:34:21 <j_dulaney> How much of that is FeSCO, how much releng, and how much us?
16:34:30 <adamw> hand wavey!
16:34:47 <adamw> i think it's one of those things where it's better to ask for forgiveness than permission.
16:34:53 <j_dulaney> Does that mean I can wave my hands and make it go awaY?
16:35:33 <adamw> if only.
16:35:48 <adamw> i think we'd best move on and keep discussing this elsewhere, it's getting a bit freeform
16:35:59 <adamw> #topic Upcoming QA events
16:36:41 <adamw> we get back into blocker reviews this week, so everyone set aside your friday...
16:36:52 <j_dulaney> Yay ...
16:37:05 <tflink> wheee!
16:37:09 <j_dulaney> What is todays date?
16:37:10 <adamw> we also have 'Pre-Beta Acceptance Test Plan' on the schedule for two days from now, which seems a) early and b) redundant since rats is now firing daily
16:37:16 <adamw> 02-27
16:37:46 <j_dulaney> First test day is a week from Thursday
16:38:00 <adamw> yup, indeed
16:38:19 <j_dulaney> In fact
16:38:22 <adamw> okay, so it seems like when we got the schedule modified to bump TC1 earlier, 'acceptance test plan' got moved a week earlier instead of being removed
16:38:38 <adamw> rbergeron: the idea was to drop the 'acceptance test plan' points entirely (replace them with TCs), not bump them a week forward
16:38:43 <j_dulaney> #info First test day is a week from Thursday; it is 03/07
16:40:44 <adamw> alrighty, so yeah, blocker review this friday, first TC next week, first test day also next week.
16:41:04 <adamw> i think that's all
16:41:08 <adamw> #topic AutoQA update
16:41:10 <adamw> #chair tflink
16:41:10 <zodbot> Current chairs: adamw j_dulaney jskladan tflink
16:41:19 <adamw> #chair kparal
16:41:19 <zodbot> Current chairs: adamw j_dulaney jskladan kparal tflink
16:41:25 <kparal> I have some small update
16:41:27 <adamw> take it away, folks. just remember to bring it back before the due date
16:41:53 <kparal> first of all I'd like to remind everyone that we're now testing anaconda installation automatically every day
16:42:03 <kparal> link is here: http://autoqa-stg.fedoraproject.org/resultsdb/frontend/search?type=Testcase&terms=rats_install
16:42:23 <kparal> there were some complaints about log messages, so I tried to improve that
16:42:56 <kparal> at the end of the result log you can now see last 10 lines parsed from serial console output: http://autoqa-stg.fedoraproject.org/results/27117-autotest/qa06.qa.fedoraproject.org/rats_install/results/f17-i386.html
16:43:33 <kparal> and someone asked last time whether we can add 'newlines' to the following log: http://autoqa-stg.fedoraproject.org/results/27117-autotest/qa06.qa.fedoraproject.org/rats_install/results/stage2.log
16:43:37 <j_dulaney> Might be a useful feature, that
16:43:44 <adamw> yeah, that'd be good.
16:43:47 <irejaul> hi
16:43:51 <kparal> in short: we can't, because newt is drawing on serial console using escape characters
16:44:06 <kparal> so at least I filtered it using 'strings' command: http://autoqa-stg.fedoraproject.org/results/27117-autotest/qa06.qa.fedoraproject.org/rats_install/results/stage2.log_filtered
16:44:22 <kparal> so now we should be able to debug potential problems quicker
16:45:10 <irejaul> I m Rejaul, Fedora Ambassador Bangldesh
16:45:21 <kparal> #info rats_install output has been improved
16:45:38 <kparal> that's all I have for today
16:45:50 <irejaul> i want to become a mentor of APAC Bangldesh
16:46:01 <j_dulaney> kparal:  BTW, I was the one asking for newlines
16:46:09 <adamw> irejaul: can you please ask in the correct channel? we're in the middle of a QA meeting...sorry
16:46:10 <tflink> irejaul: I think you might have the wrong channel or time
16:46:15 <j_dulaney> kparal:  Much more readable
16:46:19 <j_dulaney> kparal:  Thanks
16:49:33 <adamw> tflink: anything to add for autoqa?
16:49:51 <tflink> adamw: nope
16:50:09 <j_dulaney> kparal:
16:50:18 <kparal> adamw: nope, that's all
16:50:32 <j_dulaney> Instead of replacing the author name in tests, just add a maintainer line
16:50:33 <adamw> okely dokely
16:50:43 <adamw> #topic open floor
16:50:48 <j_dulaney> Have both author and maintainer
16:50:56 <adamw> i hope everyone enjoyed this exciting and enthralling meeting
16:51:06 <adamw> now you can make it even better with your pearls of wisdom!
16:51:26 <j_dulaney> adamw:  We have wisdom?
16:51:32 * j_dulaney did not know of this
16:52:08 <kparal> j_dulaney: the author credits are still available in all the source files
16:52:18 <j_dulaney> kparal:  True
16:52:59 <tflink> kparal: where is the contact info used, anyways?
16:53:44 <kparal> nowhere. it's for our needs only
16:53:57 <kparal> let's discuss in #fedora-qa
16:54:02 <tflink> works for me
16:54:35 <j_dulaney> .fire himself
16:54:35 <zodbot> adamw fires himself
16:55:42 <kparal> :)
16:55:57 <tflink> hrm, he seems to have disappeared
16:55:59 <adamw> holiday!
16:57:20 * j_dulaney wants to go back to the house, stir up the fire place (which has been going for two days now), sit in front of it and watch anime
16:58:17 <j_dulaney> Alas, I've class this afternoon
16:58:21 <jskladan> j_dulaney: come on, you have fireplace, and you're going to watch dragon ball? :)
16:59:12 <jskladan> ok, I'll do what I wanted to do for a long time now :))
16:59:15 <jskladan> #endmeeting