15:01:05 <adamw> #startmeeting fedora-qa
15:01:05 <zodbot> Meeting started Mon Jun 4 15:01:05 2012 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:08 <adamw> #meetingname fedora-qa
15:01:08 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:11 <adamw> #topic roll call
15:01:18 * red_alert :)
15:01:30 <adamw> morning folks
15:01:33 * satellit_ listening
15:01:35 * adamw goes to get breakfast
15:01:50 * tflink is here
15:02:03 * mkrizek is present
15:02:16 * akshayvyas is here
15:02:50 * pschindl is here
15:02:55 * aalam is here
15:04:06 <adamw> alrighty
15:04:10 <adamw> we may have a clumens in a minute
15:04:44 * maxamillion is here
15:04:57 <clumens> already here.
15:05:01 <adamw> aha
15:05:02 <adamw> you lurker
15:05:05 <adamw> awesome
15:05:19 <adamw> so we can actually skip previous meeting follow-up as there's nothing from the last meeting
15:05:19 * kparal is here
15:05:35 <adamw> and zap straight on to...
15:05:39 <adamw> #topic Fedora 18 planning
15:06:11 <adamw> sooo...yeah. everyone stop relaxing about F17 and start panicking about F18.
15:06:18 <maxamillion> lol
15:06:28 <maxamillion> I'm excited about F18
15:07:01 <adamw> we'll have more planning as we go along of course, but i wanted to get one session in early to try and figure out where we're at with the biggest feature we'll have to deal with - the anaconda UI re-design
15:07:33 <adamw> for anyone who's not yet aware: anaconda in f18 will have a completely new UI. see https://fedoraproject.org/wiki/Features/NewInstallerUI for details. obviously, this will be heavy on QA work.
15:07:35 * brunowolff is here for a little bit
15:07:58 <adamw> equally obviously, we're gonna want to start testing it ASAP
15:08:19 <brunowolff> Good luck. There is a problem with build initramfs right now.
15:08:43 <adamw> so...clumens, what's the current status? i think i recall recently seeing someone say they'd just done the first successful install to HD with newui, so it's obviously still somewhat in the works :P
15:09:16 <clumens> well, you can install via at least one method to previously blank disks using autopart
15:09:34 <clumens> and several of your customizations will likely even be reflected in the installed system
15:09:46 <adamw> heh
15:10:25 * j_dulaney waves
15:10:33 <adamw> hi dulaney
15:10:38 <clumens> also, dlehman was talking about having done the first successful hdiso install.
15:10:41 <adamw> ah.
15:11:42 <red_alert> being able to install is nice, but the more important question is probably: at what point does it make sense to track down and report bugs? :)
15:11:44 <adamw> but i guess we're still not to the point where outside testing is going to tell you a lot you don't know? you're still at a point where only a few targeted paths work?
15:11:50 <clumens> there's this, which needs to be updated: http://fedoraproject.org/wiki/Anaconda/TestableUI
15:11:54 <adamw> red_alert: get outta my head
15:12:05 <adamw> right, i figured it needed an update
15:12:23 <red_alert> adamw: but it's comfy! so much space to stretch my legs ;D
15:12:33 <clumens> i am targeting merging for when custom partitioning basically works, regardless of the state of things like your timezone being right.
15:12:42 <clumens> and i'm working on custom partitioning now
15:13:11 <adamw> okay. yeah, i was gonna say, at a broad stroke, most of the testable complexity comes with a) repositories, b) storage, and c) bootloader configuration
15:13:16 <j_dulaney> Does Mo have a UI for that?
15:13:25 <adamw> so it'd be good to know the timeframe on those bits
15:13:25 <clumens> repo stuff is pretty far along.
15:13:59 <clumens> there's no ui for adding additional repos, but i don't consider that an impediment.
15:14:26 <clumens> storage is gonna take more time, but it doesn't have to be feature complete before i want people looking at it.
15:14:31 <clumens> and bootloader... good question.
15:14:37 <adamw> red_alert: why, i oughta...
15:15:03 <tflink> are there any publicly available images for testing?
15:15:15 <clumens> if you're on the RH network, yes
15:15:18 <adamw> so, no
15:15:22 <adamw> :P
15:15:22 <clumens> by which i do not mean RHN
15:15:33 <akshayvyas> tflink i dnt think so
15:16:00 <maxamillion> clumens: dare I ask why its in RHN?
15:16:16 <adamw> maxam: "by which I do not mean RHN"
15:16:21 <maxamillion> oh
15:16:22 <maxamillion> heh
15:16:23 * maxamillion fails
15:16:39 <maxamillion> I read that as "by which I do mean RHN"
15:16:42 <adamw> i'm not hugely concerned about test images until testing can actually contribute something
15:16:47 <clumens> i will never mean RHN.
15:17:00 <adamw> clumens: on bootloader, has that been whiteboarded out and so on, and just waiting to get implemented?
15:17:03 <clumens> yeah i just don't want that point to be too late.
15:17:03 <maxamillion> clumens: yeah, I wouldn't think so :)
15:17:10 <adamw> clumens: except in contexts such as 'i call fire down upon...'
15:17:22 <maxamillion> adamw: +1
15:17:23 <clumens> adamw: there's nothing for bootloader yet.
15:17:41 <adamw> ookay. that gets me a little worried, since we know what a messy little area it can be.
15:17:57 <clumens> well, how much testing does the current bootloader UI get?
15:18:14 <clumens> with all the adding args and passwords and crap?
15:18:16 <j_dulaney> A fair bit
15:18:28 <clumens> we can probably think up something pretty easily to just specify which device gets the bootloader.
15:18:47 <adamw> clumens: it's not so much that added credit stuff i worry about as just the bush of messy problems with bootloader _location_ that we unearthed through f15 and f16 with the grub2 switch
15:18:51 <clumens> a stop-gap, if you will.
15:20:12 <adamw> clumens: that's the most important bit, yeah.
15:20:32 <adamw> we already have a hacky stopgap in f17, i was hoping it would get better with newui, but ah well
15:20:41 <adamw> once it's in there, we can test it and figure out where it causes issues
15:21:15 <clumens> my concern right now is getting something in for F18 that's good enough.
15:21:34 <clumens> if bootloader doesn't suck more than it did in F17, i can live with that.
15:22:14 <adamw> okay. we can talk about the design outside of qa meeting, as long as we know it's a key thing to have in place for testing that's enough
15:22:29 <adamw> can you guess a rough timeframe on when you'll hit the merge point (custom partitioning in place)?
15:22:47 <clumens> a month?
15:23:37 <adamw> so if we double that on general principles, it's right around alpha candidate time, which isn't terrible
15:24:13 <clumens> that would certainly be nice if it worked that way.
15:24:25 <adamw> it might be nice to have one or two publicly available images ahead of that time, just so non-RH testers can get a look at what's coming and maybe spot any huge missing areas
15:24:53 <clumens> i know of a couple already (like, disks without labels get completely ignored)
15:24:57 <clumens> but yeah.
15:25:17 <clumens> maybe i'll try to come up with a solution to that today too.
15:26:08 <clumens> i could try to have something publically available mid-month.
15:26:16 <clumens> i'm out all next week, so...
15:26:39 <adamw> sorry, got lagged out, i just caught up from logs. mid-month sounds great.
15:27:07 <adamw> for qa folks, we'll be wanting to try and get through the whole anaconda test suite as soon as we can, so we'll probably be looking at doing more testing at alpha stage than we usually do
15:27:08 <clumens> i need to deputize someone to deal with patch review and image building in my absence.
15:27:33 <clumens> how much of the test suite has language that's going to need to be changed for this?
15:28:12 <adamw> that's a good question, i don't know the answer offhand, anyone?
15:28:50 <clumens> also: you would probably want a publically available image to not have loader in it, i assume.
15:29:02 <adamw> the intent of tests is usually clear even where they document the current UI, so it shouldn't be a huge hurdle.
15:29:19 <adamw> for the purposes of looking over the new UI, loader presence/absence doesn't matter much
15:29:35 <adamw> once we get to the point of active testing for specific bugs, yeah, we'll want to be using noloader images.
15:29:37 <clumens> good, because i really don't want to spend my time dealing with git merge.
15:30:22 <adamw> we have tests like hardware RAID which read "At type of devices step, choose Specialized Storage Devices and click Next.", "Select hardware RAID device and click next." etc. of course that'll need updating.
15:30:53 <clumens> yes.
15:31:06 <adamw> at a wag, just looking through the list of test cases, i'd say maybe, oh, a half of them will need tweaking. but it's the kind of thing we'll get done in a couple of days once we know what the UI looks like.
15:31:25 <clumens> the UI looks almost exactly like the mockups
15:32:07 <adamw> well, that's good :)
15:32:32 <adamw> okay. i think we're all pretty much on the same page now, right? does anyone have any other questions about newUI as regards qa planning?
15:33:24 <red_alert> could we maybe set up nightly builds for rawhide as long as F18 branching hasn't happened yet?
15:33:57 <red_alert> instead of having clumens create new images manually every other day :)
15:34:09 <tflink> red_alert: wouldn't it be wise to wait until things are testable?
15:34:31 <tflink> unless I'm missing something here (which is very possible)
15:34:43 <clumens> i guess you would have to ask rel-eng for that sort of thing. right now newui code isn't even on the master branch of anaconda, so it's nowhere where real builds get pulled from.
15:34:52 <adamw> once anaconda's merged, then there already _are_ nightly builds, i think.
15:34:56 * kparal is afk for 10 minutes
15:35:12 <red_alert> tflink: sure, but branching happens long after that afaik
15:35:18 <adamw> there's that place in the devel tree where a boot.iso gets built nightly, right?
15:35:45 <tflink> depending on the timing of all of this, the image building project could be an option
15:36:20 <tflink> but that's probably a discussion for another day since it isn't even close to being finished :)
15:36:29 <nirik> adamw: no, only in branched, rawhide produces no images IIRC.
15:36:57 <adamw> oh, yeah. it's just a repository. well, boo.
15:36:58 <red_alert> not anymore ever since nightlies are based on branches
15:37:34 <adamw> so yeah, good call red_alert...if anaconda gets into rawhide significantly before branch, we should ask releng to do nightlies if possible
15:37:52 <adamw> branching is scheduled for 07-31.
15:38:21 <adamw> nirik: how hard would it be to get a nightly boot.iso from rawhide for a few weeks?
15:38:47 <nirik> not too hard I wouldn't think... the branched script already does do them.
15:39:25 <adamw> OK, great.
15:39:47 <adamw> anything else anyone can think of?
15:40:07 <j_dulaney> Wait, what happened to Rawhide nightlies?
15:41:13 <adamw> we stopped getting them when Branched happened, apparently.
15:41:27 <nirik> http://fedoraproject.org/wiki/No_Frozen_Rawhide_Proposal
15:41:37 <adamw> OK, if no-one can think of anything else regarding newUI we can let clumens go, thanks chris!
15:41:47 <clumens> sure
15:41:55 <clumens> i'll go... back to work on new ui.
15:42:08 <j_dulaney> Go forth, my grasshopper
15:42:48 <adamw> OK, so in non-newUI-but-still-F18-planning topics...
15:43:01 <red_alert> do we plan to set up special newui tracker/blocker bugs?
15:43:25 <adamw> if we're going to do most of our testing after merge, which is what it sounds like, i don't really see a need
15:43:29 <adamw> it'll just be 'the anaconda in rawhide'
15:43:38 <j_dulaney> So, no more Rawhide nightlies, ever? I thought they restarted post-release
15:44:14 <red_alert> adamw: right
15:45:01 <adamw> so as long as clumens plans to merge about as early as testing is useful, that simplifies several things.
15:45:06 <nirik> under the current setup, rawhide never makes images.
15:45:16 <nirik> since about 2010
15:45:48 <j_dulaney> nirik: Then what was it that I was pulling that was labelled Rawhide Nightly?
15:45:53 <adamw> so, I have to go through the retrospective feedback and come up with action items, but that's just one for me unless anyone else has a burning desire to help
15:46:11 <nirik> j_dulaney: dunno. or are you talking about the live image nightlies?
15:47:11 <j_dulaney> nirik: +1
15:47:22 <nirik> those do follow rawhide.
15:47:32 <adamw> oh, hey, some #s.
15:47:33 <adamw> #info clumens plans to merge the new anaconda UI into Rawhide as soon as custom partitioning is implemented and broadly works. he estimates one month for that.
15:47:33 <nirik> but it's a seperate process.
15:47:49 <j_dulaney> Ah, Okay
15:48:03 <adamw> #info we don't believe QA can achieve much practical testing until that merge point, but we asked clumens to provide one or two public test images before then so testers can familiarize themselves with the new UI
15:48:05 * j_dulaney understands now
15:48:29 <adamw> #info key areas of installer that provide much of the testable complexity are repository configuration, storage configuration and bootloader configuration
15:49:17 <adamw> #info if newUI lands in anaconda significantly before F18 branch point, we will ask releng to do rawhide nightlies until branching
15:50:58 <adamw> #action adamw to review F17 retrospective and come up with an action plan
15:51:31 <adamw> we also have a bit of a problem lately with Housekeeping stuff; https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora16 for example
15:52:09 <adamw> that stuff sort of falls neatly between QA, bugzappers and the program manager, and consequently we lost track of it when poelcat stopped doing it
15:52:23 <adamw> so we need to co-ordinate with robyn and the new program manager when we have one, to catch up on it for f17 and f18.
15:53:03 <j_dulaney> +1
15:53:06 * j_dulaney can talk to rbergeron about it at SELF
15:53:13 <tflink> has it always been done by hand?
15:54:15 <red_alert> isn't that scripts that are run by rel-eng but no-one opened tickets to get it done
15:54:52 <adamw> it's a messy mish-mash.
15:55:01 <adamw> bits of it are partly automated, bits of it that are just mailshots aren't
15:55:43 <tflink> do the automated parts still work w/ the bz upgrade?
15:55:52 <adamw> one bit of it, for instance, if i remember correctly, the bugzilla EOL stuff requires someone to design a query that lists out all the EOL bugs in bugzilla, and send the query to the RH bugzilla maintainers who run some kind of script that closes them.
15:55:56 <adamw> that's a good question.
15:56:05 <j_dulaney> It does seem like a good candidate for scripting
15:57:50 <j_dulaney> adamw; Is said query done from the web ui?
15:58:24 <nirik> I think it's done by rhit bugzilla folks.
15:58:48 * nirik is tired of it not being done, offers to step up and try and get it done.
15:58:52 <red_alert> the query-url seems documented in the wiki and the process says open a bug against RH eng ops
15:59:17 <red_alert> only updating descriptions is done by hand, really
15:59:26 <nirik> red_alert: url?
15:59:32 <adamw> nirik: the query is supposed to be done by someone our side and sent to engops.
15:59:36 <adamw> anyhow
15:59:55 <adamw> point being, we need someone who wants to take care of this stuff, ideally asap. it's another one i'm happy to do as well, but if anyone else wants it, yell.
15:59:57 <nirik> yeah, ok.
16:00:14 * nirik is also happy to help see it get done, but would be happy for adamw to do it. ;)
16:02:13 <nirik> from my understanding we need: a) f14 notice we are going to close in N days/weeks, b) f15 notice we are going to close in a month, c) f14 close after ndays/weeks, d) f15 close at eol. e) rawhide rebase to f17... prossibly anytime.
16:02:15 <red_alert> nirik: urls are on the wiki page, one for rebase, one for eol
16:02:27 <adamw> nirik: that's the stuff from f16
16:02:46 <adamw> nirik: so actually we need to do the stuff for the f16 cycle, make a page for the f17 cycle and do all that too, and then make a page for the f18 cycle and stay on top of it this time.
16:02:53 <nirik> yep.
16:02:58 <red_alert> F15 was never finished, either
16:03:00 <adamw> fun for all the family!
16:03:06 <adamw> really? excellent.
16:03:13 * nirik was noting the things we are all behind on. Agreed we need to stay on top
16:03:18 <red_alert> wel...maybe it has and the wiki page is not up to date
16:03:29 <nirik> no, f14 bugs were never noticed or closed.
16:04:59 <j_dulaney> Hmm
16:04:59 <j_dulaney> That was weird
16:06:19 <adamw> f14 bugs being noticed and closed is part of f16 cycle, not f15 cycle.
16:06:24 <adamw> remember, EOL date is *two* distros behind.
16:06:35 <adamw> https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora16 talks about 'Fedora 14 EOL Closure'.
16:06:38 * nirik nods. I don't care which cycle, it wasn't done. ;)
16:09:29 <adamw> #action adamw to work with rbergeron to make sure housekeeping gets done for f16/f17/f18
16:09:29 <adamw> okay, we're kinda running over time so let's hold other f18 planning for future meetings, unless anyone has anything super-critical?
16:09:37 <j_dulaney> Huge-o lag
16:09:51 <adamw> yeah, i know, dunno why i'm lagging :/
16:10:32 <akshayvyas> adamw: lagging where??
16:10:45 <adamw> i am. here. occasionally.
16:10:55 <adamw> last call for important f18 planning topics...
16:12:21 <adamw> OK, moving on...
16:12:23 <adamw> #topic AutoQA update
16:12:30 <adamw> do we have any shiny autoqa news, tflink/kparal?
16:13:04 <tflink> nothing worthy of note from me this week
16:13:16 <kparal> no, still recovering from F17
16:13:34 <akshayvyas> kparal: :)
16:14:39 <adamw> okey dokey
16:14:46 <adamw> #info no AutoQA news, team still in F17 recovery
16:14:51 <adamw> #topic open floor
16:14:57 <adamw> alright, anything important missing?
16:15:07 <adamw> speak now or forever hold your peace.
16:15:12 <adamw> or, uh, until next week any how,.
16:18:17 <adamw> okay...
16:18:21 * adamw sets meeting fuse for 2 mins
16:18:24 <adamw> ssssssss
16:18:26 <adamw> #chair tflink kparal
16:18:26 <zodbot> Current chairs: adamw kparal tflink
16:18:39 <tflink> interesting timing on that
16:18:51 <adamw> ?
16:20:36 <tflink> chairing kparal and I after the fuse is set
16:20:36 <tflink> or is that the lag you were talking about earlier
16:20:42 <red_alert> tflink: just so you can never complain not having been chair ;)
16:21:44 <adamw> i chaired you just in case i forget to end the meeting again =)
16:21:48 <adamw> speaking of which...
16:21:50 <adamw> #endmeeting