16:00:32 <kparal> #startmeeting Fedora QA meeting
16:00:32 <zodbot> Meeting started Mon Nov 12 16:00:32 2012 UTC.  The chair is kparal. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:37 <kparal> #meetingname fedora-qa
16:00:40 <kparal> #meetingname fedora-qa
16:00:40 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:49 <kparal> #chair tflink
16:00:49 <zodbot> Current chairs: kparal tflink
16:00:54 <kparal> #topic roll call
16:00:59 * tflink is here
16:01:02 <kparal> hands up!
16:01:07 * mkrizek is here
16:01:41 <kparal> adamw has a vacation day, he's excused
16:01:43 * jskladan lurks
16:01:45 * akshayvyas is here
16:02:07 <Viking-Ice> here
16:02:16 * jreznik_n9 is semi ready
16:02:49 * nirik is lurking
16:02:51 <kparal> pschindl: don't quit on us!
16:03:00 * pschindl1 is here
16:03:15 * satellit listening
16:03:27 * tflink wonders if pschindl was cloned suddenly
16:03:34 <dan408_> here
16:03:36 <tflink> :-D
16:03:41 <dan408_> 25% here
16:03:53 <dan408_> building packages
16:04:02 <Viking-Ice> jreznik_n9, is that clone number 9 ?
16:04:15 <kparal> welcome everyone. let's start
16:04:16 <dan408_> where is adamw?
16:04:17 * tflink assumes that it is his phone
16:04:30 <kparal> dan408_: vacation day in Canada
16:04:36 <dan408_> ah veteran's day
16:04:37 <dan408_> k
16:04:44 <kparal> #topic Previous meeting follow-up
16:04:50 <tflink> dan408_: armistice day in canada, as far as I know
16:04:54 <dan408_> same thing
16:04:59 <kparal> #info  adamw to finally finish drafting revised partitioning criteria
16:05:00 <dan408_> different name
16:05:12 <tflink> I don't believe this has been done
16:05:18 <dan408_> nope
16:05:27 <tflink> lack of available time
16:05:29 <kparal> he's so lazy, let's fire him
16:05:32 <kparal> .fire adamw
16:05:32 <zodbot> adamw fires adamw
16:05:39 <dan408_> no lets hire dan408 fulltime
16:05:56 <dan408_> he'll file everything as blocker bugs
16:06:05 <kparal> ok, another one
16:06:08 <kparal> #info  adamw to push security criterion into 'production' after waiting a few more days for feedback
16:06:13 <kparal> this was done
16:06:13 <tflink> as far as I know, this is done
16:06:37 <kparal> #info  adamw to push security criterion into 'production' after waiting a few more days for feedback  -- done
16:06:57 <kparal> ok, that's the previous week
16:07:11 <kparal> #topic Fedora 18 Beta status / mini blocker review
16:07:26 <kparal> so, first of all, Beta has been unfrozen
16:08:01 <kparal> the next Beta Change Deadline seems to be 2012-11-13
16:08:05 <dan408_> thank god
16:08:06 <kparal> which is tomorrow
16:08:11 <dan408_> please push that back
16:08:22 <kparal> I thought it was unfrozen for two weeks?
16:08:34 <kparal> jreznik might know more
16:08:48 <kparal> anyway, we're not frozen at the moment
16:08:50 <Viking-Ice> hm I thought so also
16:08:54 <jreznik> kparal: fesco agreed to freeze tentative tmrw
16:09:10 <kparal> jreznik: so tomorrow you will decide whether to continue unfrozen or not?
16:09:13 <jreznik> slip for two weeks
16:09:26 <jreznik> kparal: in case of no objections, freeze is tmrw
16:09:28 <tflink> jreznik: so we need to voice concerns about re-freezing today, if we have any?
16:09:34 <jreznik> tflink: yep
16:09:45 <tflink> bah, I thought we had another week
16:09:45 <kparal> #info Beta was unfrozen, on 2012-11-13 there will be another Beta freeze if there are no objections
16:10:00 <tflink> jreznik: do you know of a fesco ticket off hand?
16:10:22 <jreznik> tflink: no, that was more - compromise - unfreeze for week but slip two weeks
16:10:23 <nirik> theres not one, feel free to file a new one... but please be specific.
16:10:37 <jreznik> tflink: file a ticket in case you think it's needed
16:10:41 <jreznik> I'
16:10:43 <Viking-Ice> was not a week to short time
16:10:48 <Viking-Ice> <sigh>
16:10:58 * tflink is still concerned about fedup
16:11:04 * Viking-Ice to
16:11:07 <jreznik> the only concern now is fedup and it's really hard to get any updates :(((
16:11:23 <Guest85807> There was already updates backed up, so it was more than a week's worth of updates.
16:11:30 * jreznik is writing another mail to david as did not receive any input from will
16:11:50 <tflink> jreznik: yeah, I'm planning to poke for status on a few bugs today
16:11:59 <Viking-Ice> I would not be surprised if will took this as an two week unfreeze like the rest of us
16:12:22 <jreznik> tflink: I'm trying too, got some response
16:12:39 <Guest85807> Since fedup is blocking things, I think updates will get through.
16:12:42 <tflink> Viking-Ice: there's plenty to be done, I doubt that anyone is sitting around for the week or two
16:12:57 <tflink> Guest85807: I think that jreznik was talking about status updates from the fedup devel(s)
16:12:58 <Viking-Ice> yup
16:13:51 <jreznik> the thing is more when is the last time to file the ticket so fesco could vote, nirik?
16:14:02 <jreznik> and I'll nag to get more input from fedup side :(
16:14:28 <nirik> jreznik: tomorrow morning sometime I guess?
16:14:28 * jreznik is really fed up from fedup communication
16:14:46 * kparal notes it is a great project name
16:15:39 <kparal> #info fedup status is still largely unknown
16:15:53 <jreznik> well, I'll try to get an update and in case there would be no way how to get fedup ready, I'll file the ticket to not freeze
16:16:46 <kparal> ok, thanks jreznik. anything else to the topic, or should we move to the mini-blocker review?
16:17:48 <jreznik> just the question is - what's the criteria we consider fedup not a problem...
16:18:24 <tflink> jreznik: you mean how done does fedup need to be before it doesn't block release from a QA perspective?
16:18:54 <kparal> jreznik: the criteria says:  For each one of the release-blocking package sets ('minimal', and the package sets for each one of the release-blocking desktops), it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria.
16:18:54 * nirik notes that freeze also doesn't mean there are no blockers.
16:19:16 <tflink> the cli would need to work for F17 -> F18 upgrades in most situations, the initramfs used would need to be created by releng (less of a QA issue, though)
16:19:47 <jreznik> nirik: yep, definitely but we froze mostly because of fedup - if there's no change in fedup state...
16:19:54 <dan408_> sorry wasn't paying attention
16:19:58 <jreznik> but still I'd prefer to continue with Beta
16:19:59 <dan408_> are we pushing back the change deadline?
16:20:00 <tflink> AFAIK, releng won't take much of anything outside the initramfs being built in lorax. This will require a change to that code which I don't believe has been done
16:20:03 <jreznik> email written
16:20:26 <kparal> when I think about it, I think it should be sufficient to at least one of GUI/CLI method to work for Beta. but that would have to be discussed properly
16:20:38 <jreznik> tflink: I asked dgilmore last week and wwoods have not talk to him yet...
16:21:02 <tflink> kparal: GUI isn't going to be done for beta
16:21:23 <kparal> tflink: ah, ok
16:21:37 <jreznik> tflink: and then we have that blocker bug, our systemd guys do not know the part, I sent an email to lennart, but I don't see him online to ping...
16:21:38 <dan408_> change deadline? anyone?
16:21:42 <Viking-Ice> fedup with and or cli/gui
16:21:48 <nirik> dan408_: nothing is changing right now.
16:21:51 <dan408_> k
16:22:04 <kparal> jreznik: he has some weird irc nick, mezcalero or similar
16:22:09 <jreznik> kparal: I know
16:22:20 <tflink> jreznik: yeah, I was going to ask if anything was needed in the major blocker bug
16:23:32 <jreznik> so we need this bug sorted out + releng stuff should not be difficult, we just need wwoods be working with relengs... otherwise the blocker situation is not bad
16:23:38 <tflink> BTW, if you decide to test fedup, please read the testing wiki page: https://fedoraproject.org/wiki/QA%3AFedora_18_Upgrade_Testing
16:23:40 <jreznik> (even looking on proposed ones)
16:24:07 <tflink> knowing that it isn't going to work right now
16:24:18 <tflink> not without system recovery, anyways
16:24:43 <jreznik> due to the unmount/sync bug, right
16:24:57 <tflink> yeah
16:25:04 <tflink> leads to a non-bootable upgraded system
16:25:12 <tflink> until the kernel and/or initramfs are redone
16:25:35 * tflink should probably detail instructions for that in the wiki page
16:26:08 <Viking-Ice> kparal, Lennart goes under poettering formaly known as mezcalero
16:27:19 <tflink> ok, are we ready for some blocker review, then?
16:27:40 <kparal> tflink: do you have your magic scripts ready?
16:27:45 <jreznik> Viking-Ice: chamaeleo :)
16:27:51 <jreznik> tflink: yep
16:28:07 <tflink> magic scripts?
16:28:26 * tflink really needs to update the blocker meeting SOP - another item for the TODO list :-/
16:28:34 <tflink> #topic (874276) 'Reclaim space' button never goes active on guided space reclaim dialog when installing in German, French, possibly others (18.24, 18.26)
16:28:37 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=874276
16:28:40 <tflink> #info Proposed Blocker, anaconda, VERIFIED
16:29:19 <kparal> should we skip verified bugs?
16:29:48 <kparal> it's already fixed anyway, and anaconda 18.28 is pending stable
16:29:58 <tflink> sorry, wasn't looking for that in the proposed blockers
16:30:07 <tflink> #undo
16:30:07 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x120c4190>
16:30:08 <tflink> #undo
16:30:08 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2cd6d910>
16:30:10 <tflink> #undo
16:30:10 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1698d3d0>
16:30:13 <tflink> #topic (872833) ValueError: Cannot remove non-leaf device 'fedora'
16:30:13 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=872833
16:30:13 <tflink> #info Proposed Blocker, anaconda, ASSIGNED
16:32:11 <kparal> so, there is a problem with creating LVs in existing VGs in custom mode
16:32:12 <tflink> this looks like a tb when trying to reuse a partition?
16:32:42 <tflink> kparal: not sure that the first reporter was trying to do that
16:32:58 <kparal> I'm referring to comment 21
16:33:10 <tflink> yeah, I think that's different from the original reporter
16:33:12 <kparal> dlehman: discussing 872833
16:34:09 <kparal> I see
16:34:23 * dlehman wonders if all reproducers involve adding a mountpoint with no size spec
16:34:49 <kparal> comment 19 is a really simple reproducer
16:35:01 <Viking-Ice> hmm should not 868505 be a proposed blocker as well?
16:35:01 <kparal> it could be related to having empty size spec
16:36:10 <kparal> so, this bug seems pretty easy to hit
16:36:17 <dlehman> yes, it's triggered by empty size spec
16:36:47 <kparal> and it seems to violate " Rejecting obviously invalid operations without crashing "
16:36:57 <kparal> or " Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types "
16:36:57 <Viking-Ice> yup
16:37:27 <kparal> not providing a size is not strictly invalid operation
16:38:01 <kparal> so if this is the real cause, I think this should be a Beta blocker
16:38:38 <tflink> proposed #agreed 872833 - AcceptedBlocker - Violates the following F18 beta release criterion: "The installer's custom partitioning mode must be capable of the following ... Rejecting obviously invalid operations without crashing"
16:38:53 <tflink> I really dislike the formatting of the new partitioning release criterion
16:39:12 <tflink> but that's a small concern, I suppose
16:39:27 <dlehman> there are two pieces: 1) magic handling of empty size spec is broken and 2) error handling in the path where #1 manifests is not completely correct
16:40:03 <kparal> dlehman: do you agree this should be fixed for Beta?
16:40:21 <dlehman> yes, absolutely
16:40:46 <kparal> tflink: hey, and you can vote too, the fact that you handle the voting system doesn't mean you don't have a vote :)
16:40:48 <kparal> ack
16:41:22 * kparal pokes everyone around
16:41:23 <tflink> kparal: I know, I do vote. I just tend not to when everyone seems to be going the same direction
16:41:33 <Viking-Ice> ack
16:42:18 <pschindl1> ack
16:42:37 <tflink> #agreed 872833 - AcceptedBlocker - Violates the following F18 beta release criterion: "The installer's custom partitioning mode must be capable of the following ... Rejecting obviously invalid operations without crashing"
16:42:51 <tflink> #topic (873762) [zh_CN] [zh_TW] installer hangs in Installation Summary when keyboard spoke clicked
16:42:54 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=873762
16:42:56 <tflink> #info Proposed Blocker, anaconda, POST
16:44:02 <tflink> how many languages does this affect?
16:45:00 <kparal> two variations of chinese
16:45:49 <kparal> since the translation coverage is high, it's reasonable to assume we have lots of Chinese users
16:46:04 <kparal> it can affect other languages too, we just don't know about it
16:46:14 <tflink> yeah, that was what I was wondering about
16:46:26 <tflink> but I suspect that both chinese variants are almost enough to block
16:46:32 <tflink> at the very least, I'm +1 NTH
16:46:56 <Viking-Ice> +1 blocker
16:47:21 <tflink> any other votes?
16:47:35 <kparal> since it is a showstopper, I think +1 blocker is more appropriate
16:48:01 <Viking-Ice> yeah and kinda affects the major of the population off the planet  :)
16:48:10 <Guest85807> +1 blocker
16:48:14 <Viking-Ice> mean on the planet
16:48:50 <kparal> Guest85807: maybe you can rename to your FAS name, so that you're a bit less anonymous? :)
16:48:58 <kparal> thanks
16:49:20 <brunowolff> I forgot to authenticate and didn't nptice I had gotten changed to a guest
16:49:20 * kparal pokes jskladan pschindl1 mkrizek
16:49:24 <mkrizek> +1 blocker
16:50:08 <pschindl1> +1 blocker
16:50:17 <tflink> proposed #agreed 873762 - AcceptedBlocker - Violates the following F18 alpha release criterion for Chinese users (zh_cn, zh_tw) - "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria  must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode ..."
16:51:29 <tflink> ack/nak/patch?
16:51:32 <Viking-Ice> ack
16:51:33 <pschindl1> ack
16:51:35 <mkrizek> ack
16:51:36 <kparal> hmm, the installer actually hangs. is this the best criterion?
16:51:49 <tflink> patch?
16:52:05 <tflink> it hangs during install, right?
16:52:21 <tflink> oh, I might have misread this
16:52:23 <kparal> tflink: I think it hangs on the hub screen
16:52:27 <kparal> so maybe " The installer must be able to complete an installation using the text, graphical and VNC installation interfaces "
16:52:45 <tflink> yeah, I was reading "installation summary" as the screen when pkgs etc. are being installed
16:52:47 <Viking-Ice> comment 4 it hangs
16:53:36 <tflink> proposed #agreed 873762 - AcceptedBlocker - Violates the following F18 alpha release criterion for Chinese users (zh_cn, zh_tw) - "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces"
16:53:44 <kparal> ack
16:53:46 <Viking-Ice> ack
16:54:24 <mkrizek> ack
16:54:37 <tflink> yeah, I was reading "installation summary" as the screen when pkgs etc. a
16:54:42 <tflink> wow, I missed
16:54:51 <tflink> #agreed 873762 - AcceptedBlocker - Violates the following F18 alpha release criterion for Chinese users (zh_cn, zh_tw) - "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces"
16:55:01 <tflink> sorry, getting pulled into a discussion about fedup
16:55:12 <tflink> #topic (875003) after setting invalid installation source, "closest mirror" is broken
16:55:16 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=875003
16:55:18 <tflink> #info Proposed Blocker, anaconda, NEW
16:55:57 <Viking-Ice> +1 nth
16:56:52 <Viking-Ice> kparal, this does just affect those that type invalid repo right
16:57:04 <Viking-Ice> btw which criteria is this supposed to affect
16:57:24 <kparal> Viking-Ice: yes, you have to provide invalid repo to cause this bug
16:57:49 <Viking-Ice> if people arent going to be paying attention during the blocker bug meeting we can just as well stop it now
16:57:50 <kparal> but afterwards, reverting to closest mirror breaks package selection
16:58:02 <kparal> comment 9 says how to fix it, I didn't know
16:58:35 <Viking-Ice> so there is a workaround
16:58:58 <kparal> there is always a workaround, don't provide invalid repos :)
16:59:03 <Viking-Ice> ;)
16:59:07 <tflink> I'm not sure about blocker, though
16:59:20 <Viking-Ice> I'm +1 nth
16:59:23 <tflink> if you mistype the repo, you could restart the installation
16:59:30 <tflink> even if there was no workaround
16:59:38 <Viking-Ice> yup
16:59:44 <kparal> tflink: actually I think if you mistype the repo and then correct it, it works
16:59:55 <kparal> tflink: it's broken just for the "revert to closest mirror" use case
17:00:02 <kparal> from what I understand from comment 9
17:00:10 <Viking-Ice> which criteria is this supposed to affect?
17:00:13 <kparal> so I'm also more inclined to just +1 nth now
17:00:13 <tflink> then -1 blocker, +0.5 NTH
17:00:24 <mkrizek> -1 blocker
17:00:33 <kparal> Viking-Ice: well I assumed almost any, like " The installer must be able to use at least one of the HTTP or FTP remote package source options "
17:01:11 <Viking-Ice> yeah but none of them mentioned closest mirror has to work
17:01:32 <brunowolff> -1 blocker
17:01:34 <kparal> Viking-Ice: no, it's not exactly written out that way
17:01:44 <kparal> let's vote on NTH as well
17:01:55 <tflink> I'm not so sure about NTH, now that I think about it harder
17:02:06 <Viking-Ice> there is the risk factor
17:02:13 <tflink> the workaround is OK, worst case, you need to reboot and restart the install
17:02:21 <Viking-Ice> yeah
17:02:44 <tflink> but assuming that one reads the release notes/commonbugs, you'd be able to figure out that you need to fix the typo
17:03:04 <kparal> well, that workaround applies for many bugs accepted as nth, even as blockers. but I understand the concerns, it's late in the cycle
17:03:26 <brunowolff> I don't think I'd want to take an update with just a fix for this, but don't feel so strongly about having a fix for this pulled in with some other blocker fix.
17:04:07 <tflink> any other thoughts?
17:04:19 <tflink> I'm slightly -1 NTH on this
17:04:37 <Viking-Ice> yeah changing to -1 nth
17:04:49 <tflink> I think that the odds of getting a user on beta who is using a custom repo location, types it wrong and doesn't read the docs is not so bad
17:04:58 <tflink> not so likely, rather
17:05:02 <mkrizek> I am for -1 NTH as well
17:05:04 <kparal> alright
17:05:26 <kparal> tflink: oh, should I be doing the secretary?
17:06:24 <tflink> proposed #agreed 875003 - RejectedBlocker, RejectedNTH - While an annoyance, this does not seem to be likely or severe enough to justify blocker or NTH status. A relatively painless workaround exists.
17:06:34 <tflink> kparal: if you'd like, sure. otherwise, I'll do it after the meeting
17:06:38 * herlo asks how long this meeting is planned to go on. Usually FAmSCo meets here at this time.
17:06:58 <kparal> herlo: ouch, sorry
17:07:00 <tflink> herlo: sorry, we can wrap up
17:07:10 <kparal> let's finish the voting and move to #fedora-qa
17:07:13 <kparal> ack
17:07:14 <Viking-Ice> or just move to QA ( as I always say )
17:07:15 <Viking-Ice> ack
17:07:19 <tflink> ack/nak/patch?
17:07:25 <mkrizek> ack
17:07:27 <herlo> well, do you guys normally go on this long? Or are we bumping up against each other?
17:07:37 * herlo is happy to move to another room if necessary
17:07:37 <tflink> #agreed 875003 - RejectedBlocker, RejectedNTH - While an annoyance, this does not seem to be likely or severe enough to justify blocker or NTH status. A relatively painless workaround exists.
17:07:54 <tflink> herlo: depends on the time of year and if we're trying to reveiw blocker bugs or not
17:07:54 <kparal> herlo: normally we go longer, but we had 2 hours before summer time ended
17:08:11 <kparal> ok, let's move to #fedora-qa
17:08:13 <herlo> kparal: okay, thanks. We'll discuss in our meeting to move to another room as well.
17:08:21 <kparal> #endmeeting