#fedora-meeting: Fedora QA meeting

Meeting started by adamw at 16:01:14 UTC (full logs).

Meeting summary

  1. roll call (adamw, 16:01:20)
  2. previous meeting follow-up (adamw, 16:05:09)
    1. "viking-ice to let docs team know about advanced storage for release notes" - viking-ice isn't around and we don't see anything in the docs@ archives, better check in with him later (adamw, 16:09:47)

  3. Fedora 18 Final status and blocker review (adamw, 16:10:11)
  4. (892621) Anaconda FC18-TC4 does not present BIOS RAID as available storage (tflink, 16:12:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892621 (tflink, 16:13:00)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:13:02)
    3. AGREED: 892621 - AcceptedBlocker - Violates the following F18 final release criterion: "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (tflink, 16:16:47)

  5. (892494) deleting existing LV doesn't free space to allow creation of new LV (tflink, 16:16:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892494 (tflink, 16:17:02)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:17:04)
    3. 892394 has been marked as a duplicate of 892269 which is also proposed as a blocker. Moving discussion to that bug (tflink, 16:30:08)

  6. (892269) Free space calculation interferes with creation and resizing of LV within existing VG after shrinking existing LV (tflink, 16:30:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892269 (tflink, 16:30:24)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:30:27)
    3. Blocker Votes: (+1) tflink, Viking-Ice, dan408 (-1) adamw, dlehman, kparal, jreznik, nirik, Martix (tflink, 16:49:12)
    4. NTH Votes: (+1) nirik, jreznik, Martix, dlehman, kparal (-1) tflink, Viking-Ice (tflink, 16:51:30)
    5. AGREED: 892269 - RejectedBlocker AcceptedNTH - While this is a blocker in principle, the currently proposed fix was judged too risky to take this late in the release process. A tested fix would be considered past freeze if a less risky fix is proposed (tflink, 16:51:51)

  7. (892188) anaconda in manual partitioning cannot 'reformat' previous / if previous /home is a subvol on the same btrfs partition (tflink, 16:52:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892188 (tflink, 16:52:22)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:52:24)
    3. AGREED: 892188 - RejectedBlocker RejectedNTH - This is not a regression from F17 and this isn't something that you should be doing inside the installer anyways - reformatting of btrfs subvols should be done outside anaconda. Risk/reward ratio judged not enough to take a fix this late as NTH. (tflink, 16:58:20)

  8. (892669) slow NIC and local kickstart -> anaconda crash (tflink, 16:59:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892669 (tflink, 16:59:32)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:59:32)
    3. AGREED: 892669 - RejectedBlocker AcceptedNTH - The combination of install media w/ embedded ks, no packages and slow network startup is too much of a corner case to block release over since reasonable workarounds exist (add packages to media, use remote ks). However, a tested fix would be considered for pulling before release. (tflink, 17:07:03)

  9. (892046) IndexError: list index out of range (tflink, 17:07:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892046 (tflink, 17:07:12)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:07:12)
    3. https://btrfs.wiki.kernel.org/index.php/FAQ#if_your_device_is_small (Martix, 17:14:48)
    4. AGREED: 892046 - RejectedBlocker AcceptedNTH - This only occurs when doing something that you probably don't want to do in custom partitioning (in this case, specifying size for a btrfs subvol instead of a quota) so it isn't enough to be a blocker. However, a tested fix would be considered for inclusion before release. (tflink, 17:23:31)

  10. (892196) Anaconda cannot create new subvols on an existing multi-disk btrfs volume (works for single-disk btrfs volumes) (tflink, 17:24:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892196 (tflink, 17:24:12)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:24:14)
    3. AGREED: 892196 - RejectedBlocker AcceptedNTH - This is rather nasty for people who have multi-disk btrfs volumes but it seems like too much of a corner case to block release over. However, a tested fix would be considered for inclusion before release. (tflink, 17:30:12)

  11. (875291) custom partitioning loses focus (tflink, 17:30:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=875291 (tflink, 17:30:26)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:30:26)
    3. AGREED: 875291 - RejectedBlocker AcceptedNTH - While this does cause problems during installation, it doesn't do any irreversable changes to the system and thus, is not a blocker for F18 final. However, a tested fix would be considered for inclusion before release. (tflink, 17:41:09)

  12. (892120) Click on Cancel in confirm dialog for Quit on network setting, rebooting system (tflink, 17:45:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=892120 (tflink, 17:45:53)
    2. Proposed NTH, anaconda, POST (tflink, 17:45:55)
    3. AGREED: 892120 - AcceptedNTH - This shouldn't happen, can't be fixed with an update post-release and sounds like a reasonable, low-risk fix. Once tested, it would be considered for inclusion before release. (tflink, 17:48:58)

  13. (886685) grub2 fails to boot when /boot partition is lvm on multipath device (tflink, 17:49:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886685 (tflink, 17:49:23)
    2. Proposed NTH, grub2, ON_QA (tflink, 17:49:25)
    3. AGREED: 866685 RejectedNTH - this only affects installs to LVM-on-multipath on OpenFirmware systems. OpenFirmware is mostly used on ppc64 systems, very rarely on i386/x86_64, though it is theoretically possible. Secondary arches can pull in pkgs outside the PA blocker process and a fix for this bug isn't critical for PA. This is too risky to pull in as NTH for F18 this late and thus, rejected as NTH. (adamw, 18:00:32)

  14. Fedora 18 Final status / planning (adamw, 18:05:31)
    1. http://fedoraproject.org/wiki/FedUp (tflink, 18:07:46)
    2. http://dl.fedoraproject.org/pub/fedora/linux/development/18/<arch>/os/ (tflink, 18:14:56)
    3. use --instrepo http://dl.fedoraproject.org/pub/fedora/linux/development/18/<arch>/os for testing fedup (adamw, 18:15:57)
    4. next blocker review currently scheduled for wednesday, may move up to tomorrow if needed (more blockers emerge today) (adamw, 18:23:13)

  15. open floor (adamw, 18:23:53)
    1. follow-up: "viking-ice to let docs team know about advanced storage for release notes" - this was done, install guide points advanced storage users to kickstart (adamw, 18:24:42)


Meeting ended at 18:29:37 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (205)
  2. tflink (195)
  3. Viking-Ice (89)
  4. kparal (68)
  5. Martix (54)
  6. nirik (31)
  7. jreznik (25)
  8. dan408 (22)
  9. jreznik_n9 (14)
  10. rbergeron (9)
  11. maxamillion (7)
  12. zodbot (6)
  13. Southern_Gentlem (2)
  14. jskladan (1)
  15. satellit (1)
  16. vhumpa (1)


Generated by MeetBot 0.1.4.