15:00:13 <adamw> #startmeeting Fedora QA meeting
15:00:13 <zodbot> Meeting started Mon Apr 22 15:00:13 2013 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:18 <adamw> #meetingname fedora-qa
15:00:18 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:20 <adamw> #topic roll call
15:00:26 * pschindl is here
15:00:31 <tflink> rolls?
15:00:32 * satellit_e listening
15:00:34 * mkrizek is here
15:00:51 * Southern_Gentlem is lurking
15:01:46 <adamw> forward roll!
15:01:55 <adamw> backward roll!
15:01:58 * nirik is lurking around.
15:01:58 <adamw> barrel roll!
15:02:17 <tflink> adamw: successful dodge!
15:02:20 <adamw> cheese roll!
15:02:44 * brunowolff is here
15:03:14 * jreznik is here but has to leave earlier, in 30 minutes... expects being fired
15:03:35 <brunowolff> You guys made me hungry, now I need to go get some food.
15:04:18 <adamw> just don't get the barrel rolls
15:04:22 <adamw> they're off
15:04:32 <adamw> #topic previous meeting follow-up
15:05:01 <adamw> #info adamw to send out another call for UEFI testing with TC6 - that was done, we got quite a lot of data
15:05:17 <adamw> it's interesting how many people will test something specific if you send out an email call but don't usually do validation testing...
15:05:29 <adamw> jreznik - "jreznik to follow up on status of Translations (l10n) test day"
15:05:31 <dan408> here but not here
15:05:42 * jreznik tried to spread it around "social" networks and it worked
15:06:37 <jreznik> L10n results are available in the Test Day wiki page - under provide results column
15:06:41 <jreznik> #link https://fedoraproject.org/wiki/Test_Day:2013-04-11_Translation_%28l10n%29#FUAs_Application_List
15:07:28 <jreznik> 19 languages (de, es, it, fr, pt-br, ru, ja, ko, zh-cn, zh-tw, as, gu, hi, kn, ml, mr, or, te and ta) were covered
15:07:36 <adamw> great, thanks
15:07:53 <adamw> #info jreznik to follow up on status of Translations (l10n) test day - this was done, event was successful
15:08:13 <adamw> #topic Fedora 19 Alpha recap
15:08:42 <adamw> welp, not a whole lot to say here really - we got 19 signed off, and I think it was a pretty low-stress cycle
15:08:53 * kparal arrives late
15:09:28 <dan408> yep
15:09:30 * j_dulaney waves
15:09:38 <adamw> i've already done the commonbugs page, might be one or two proposed left
15:10:11 <jreznik> adamw: thanks, I've checked it, looks good
15:10:14 <adamw> #info 19 Alpha is signed off and ready to go
15:10:32 <adamw> #info adamw has added most nominated issues to https://fedoraproject.org/wiki/Common_F19_bugs
15:10:49 <adamw> if anyone can think of any other bugs that ought to go on the common bugs page, please add the CommonBugs keyword
15:12:02 <adamw> any other thoughts on alpha? I couldn't really come up with much, it seemed to go off pretty well in all honesty
15:12:12 <adamw> seems like all the process changes etc worked fine
15:12:41 <adamw> anyone have any notes on how the NTH -> FE transition is going, automatic blockers, new criteria etc?
15:12:51 <j_dulane1> Trying this again
15:12:54 <brunowolff> UEFI sucks. Hopefully by f20 support will be mature enough we won't have a lot of problems with it.
15:13:04 <dan408> im having issues with the netinstall
15:13:04 <tflink> agreed that it seemed to go well outside of the UEFI fun times
15:13:08 <dan408> but this is on vbox
15:13:14 <dan408> i will try on hardware tonight
15:13:20 <dan408> along with uefi
15:13:26 <dan408> haven't got around to it, sorry
15:13:54 * satellit_e is cinnamon fixed?
15:13:58 <dan408> no
15:14:15 <dan408> gnome 3.8 broke cinnamon
15:14:20 <dan408> it's being worked on by upstream
15:14:33 <kparal> adamw: I'd remove one of the blocker/FE aliases from bugzilla. they're making the alias really long
15:14:40 <kparal> see https://bugzilla.redhat.com/show_bug.cgi?id=922935
15:14:47 <kparal> Blocks: AlphaFreezeException/F19Alpha-accepted/F19AlphaFreezeExcept
15:14:48 * jreznik likes how NTH->FE was handled, automatic blockers and the new criteria are more understable and readable than before, +1 to QA team!
15:14:48 <tflink> yeah, I've noticed that as well
15:14:59 <adamw> kparal: i'm only intending to keep the 'old-style aliases' for f19
15:15:02 <kparal> I think we can safely remove "*-accepted"
15:15:07 <kparal> ok
15:15:10 <jreznik> kparal: it's long but only transition time
15:15:10 <adamw> as a backwards-compatibility thing
15:15:33 <kparal> adamw: well, I guess nobody else than us really has some scripts
15:15:37 <kparal> to work with blocker bugs
15:15:49 <adamw> kparal: more just backwards compatibility with people's brains :)
15:16:04 <tflink> do we have scripts that depend on aliases?
15:16:10 <adamw> unfortunately we can't tell from bugzilla mails which alias they used to nominate a bug so i've no idea if people are using the old ones, or the new ones, or the IDs
15:16:15 <kparal> tflink: maybe some stats scripts
15:16:44 <j_dulaney> adamw: I use IDs
15:17:08 <kparal> and when I look at 919374, I see "Blocks: AlphaBlocker/F19Alpha/F19AlphaBlocker". is one of those also a compatibility name?
15:17:20 <adamw> #info tracker bug aliases are kind of long at present (kparal): the old-style aliases are only going to be used for f19 (adamw)
15:17:29 <adamw> kparal: F19Alpha
15:17:40 <jreznik> adamw: so the question is - was alpha enough transition period for people to get used to it or do we want to stick with it for f19 as the whole... also proposals via web should help now
15:17:49 <kparal> ok, so for F20 we will have just two words
15:18:14 <adamw> kparal: right - going forward, while a release is 'current' that release's tracker bugs will have two aliases, after release, just one
15:18:35 <adamw> jreznik: if it's a big deal we could switch now, probably
15:18:49 <adamw> i was planning on switching for f20
15:18:52 * kparal doesn't have a strong opinion on this
15:20:00 * j_dulaney doesn't care
15:20:29 * jreznik is ok with change after f20, yes, it's long, but not for forever
15:21:45 <adamw> ok, i guess i'll stick with the plan then
15:21:49 <adamw> any more notes on Alpha?
15:22:10 <kparal> I'd like to say it's great to see anaconda to "just work"
15:22:18 * kparal hopes the trend will continue
15:22:56 <dan408> kparal: if anaconda is "just working" for you then you need to try some different scenarios
15:23:35 <adamw> dan408: not everyone is hitting the net install bug. i think we've established that pretty well.
15:23:40 <adamw> fwiw i haven't seen it in any of my tests either.
15:23:47 <dan408> right
15:23:52 <adamw> anyhoo
15:23:57 <jreznik> and it's great stuff from our usability labs is coming to anaconda - if you're interested, I have amazing report from it
15:24:28 <kparal> dan408: I compare it relatively to the previous releases
15:24:47 <dan408> there's only one previous release compare it to since it was rewritten, 18
15:25:01 <dan408> so yeah compared to 18 it's obviously a lot better
15:25:20 <dan408> i didnt like that the done button was moved from the bottom right to the top left
15:25:32 <dan408> and i had issues on the software spoke that others confirmed
15:25:52 <dan408> so yeah if you're just going through and doing an "automatic partitioning" gnome 3 install it goes through wonderfully
15:25:59 <dan408> if that's all we care about then great
15:26:25 <jreznik> dan408: I can forward you the report, not saying it's perfect but it's great the feedback is considered and anaconda guys saw that people alive by theirs own eyes, it helps a lot, compared to bug report
15:26:32 <dan408> sure
15:26:39 <dan408> you have my info
15:26:57 <dan408> i have a long list of things
15:28:10 <jreznik> and btw. thank you all in #fedora-qa for a work on alpha!
15:28:19 <adamw> +1
15:28:30 <tflink> +eleventymilliion
15:28:48 <tflink> typos, even :)
15:29:02 <adamw> alrighty then
15:29:07 <adamw> #info vote of thanks to all Alpha testers
15:29:17 <adamw> #topic Beta planning / release criteria
15:29:27 <adamw> so, next up comes Beta
15:30:05 <adamw> we may have some FUN BONUS TESTING before Beta, btw - dlehman is merging some new volume management UI into custom partitioning that he wants tested. so we're working on getting images to test that
15:30:25 <adamw> #info we may have some bonus testing to do on new custom partitioning volume management UI before Beta validation gets underway
15:30:26 <dan408> a new volume management ui?
15:30:39 <dan408> that would be interesting as that was one of my biggest annoyances
15:30:54 <adamw> yeah, for handling LVM and btrfs containers
15:31:16 <dan408> anything about making standard partitioning easier?
15:31:19 <adamw> it should be a better UI plus allow some stuff that you can't do in the current way
15:31:24 <adamw> it's just about containers.
15:31:46 <dan408> could we possibly get some love there please?
15:32:31 <j_dulaney> adamw: Is Anaconda with new UI in updates-testing?
15:32:43 <adamw> no.
15:32:48 <j_dulaney> adamw: Or, do I have to go somewhere funky for it?
15:33:06 <adamw> "so we're working on getting images to test that"
15:33:40 <j_dulaney> adamw: Kind of hard to put together an image if I don't have the Anaconda I'm supposed to be testing ...
15:34:08 <adamw> what image are you putting together?
15:34:35 <j_dulaney> I figure at the least a Live so I can test said Anaconda
15:35:00 <adamw> just be patient. it's coming.
15:35:02 * jreznik has to leave now for an hour, will re-read backlog, urgent things -> ping me
15:35:24 <j_dulaney> adamw: It's Finals week. Patience is in short supply :)
15:35:33 <dan408> lol
15:35:42 <adamw> i was only trying to give a heads-up about something that's coming, not trying to send everyone off to build images and whatknot
15:36:28 <j_dulaney> Ah, my misunderstanding
15:37:56 <adamw> ok, so the other thing on my list is to get the new-format beta criteria finished
15:38:07 <adamw> the current draft is https://fedoraproject.org/wiki/User:Adamwill/Draft_beta_criteria_sandbox
15:38:17 <adamw> i need to add references to that at least
15:38:56 <adamw> #action adamw to complete Beta criteria update
15:39:12 <adamw> if anyone has comments/suggestions on the current sandbox (where it differs from the 'old' beta criteria) they'd be welcome
15:39:18 <adamw> does anyone have anything else for beta planning?
15:40:13 <tflink> we should probably look at and re-enable the iscsi tests
15:40:32 <tflink> IIRC, that used to be beta
15:41:48 <dan408> so im doing a tc6 netinstall now over uefi
15:41:48 <adamw> ah yeah. there's only one
15:41:53 <dan408> with secure boot
15:41:55 <adamw> i can easily re-add it to the matrix
15:41:55 <dan408> on my desktop
15:41:57 <dan408> will report back
15:42:09 <adamw> #action adamw to add iscsi test case back to the matrix
15:42:14 <martix> sorry I'm late, I've forgoten
15:42:15 <pjones> I'm not actually 100% sure net install + sb + uefi is even /expected/ to work.
15:42:25 <tflink> also look into graphical upgrades
15:42:32 <dan408> pjones: already hit my first wall yes
15:42:33 <tflink> I don't know if that code is finished, though
15:42:40 <adamw> pjones: hmm? why not?
15:43:02 <pjones> adamw: shim doesn't have any code to fetch grub over the network...
15:43:24 <dan408> grub is included in the image
15:43:28 <adamw> pjones: oh. by "net install" i think he just meant 'from boot.iso with remote repositories'
15:43:32 <pjones> ooooh, okay
15:43:34 <pjones> nevermind, yeah
15:43:41 <adamw> not pxe or something
15:43:42 <dan408> the first error i got was "secure boot is not enabled"
15:43:43 <pjones> right
15:43:53 <dan408> so i had to go in to the bios and turn on windows uefi
15:43:53 <pjones> dan408: that's not an error, it just means you have SB turned off.
15:43:57 <adamw> dan408: can you please debug/liveblog your installs somewhere other than a meeting?
15:44:03 <dan408> sorry
15:44:06 <adamw> thanks
15:44:37 <dan408> well it works
15:44:38 <dan408> fyi
15:44:49 <adamw> so, anyhow: for the record, the first beta review meeting is in two days
15:45:00 <tflink> it is?
15:45:05 <adamw> the first Beta TC is scheduled for next tuesday
15:45:11 <adamw> tflink: that's what the schedule says.
15:45:13 * tflink needs to pay more attention to that schedule
15:45:23 <adamw> The Almighty Schedule! All hail the Almighty Schedule!
15:45:24 <tflink> that seems odd - release is tuesday
15:45:41 <nirik> did it perhaps not move out a week for the slip?
15:45:46 <tflink> I was hoping to have a bit of time to get the tracking app into production before the meetings started up
15:45:54 <adamw> we don't have to do one.
15:46:14 <adamw> looks like there are six proposed blockers and no proposed FE.
15:46:22 <j_dulaney> Are there any bugs listed as blocking beta?
15:46:32 <j_dulaney> nvm
15:46:34 <tflink> which means that it would probably be wise to do a meeting this week
15:48:08 <adamw> #info first blocker review meeting is scheduled for 04-23, Beta TC1 for 04-30
15:48:25 <tflink> adamw: 4-24, no?
15:48:35 <tflink> for the blocker meeting
15:48:39 <adamw> d'oh
15:48:41 <adamw> #undo
15:48:41 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x11788b90>
15:48:44 <adamw> #info first blocker review meeting is scheduled for 04-24, Beta TC1 for 04-30
15:49:13 <adamw> anything else on beta?
15:49:33 <tflink> it'll be interesting to see if this helps - I suspect that the schedule wasn't slipped but I'm also not sure that moving the blocker review meetings and first TC up is a bad thing
15:49:59 <j_dulaney> +1
15:50:43 <j_dulaney> Well, I have to go
15:50:55 <adamw> #topic Test days
15:51:19 <j_dulaney> I have to practice for my recital this evening; wish me luck! It's only 90% of my grade ...
15:51:32 <adamw> any report on last week's test days, martix?
15:51:49 <kparal> 5 minutes ago he said he had to go
15:52:37 <kparal> I've already sent him an email, I'm afraid the upcoming graphics test days are becoming as monstrous events as the gnome test day
15:52:50 <kparal> too many test cases, it puts people off
15:52:56 <kparal> I suppose
15:53:33 <kparal> video acceleration or hybrid graphics or wayland or game testing can be all separate events
15:53:47 <kparal> and we could get wider audience with more focused test days
15:54:25 <kparal> but I don't have any hard data. I just know I enjoyed the smaller test days more than the huge ones we've seen lately
15:54:53 <adamw> ah, missed that
15:55:42 <adamw> #info power management test day went off well - http://pm-blog.yarda.eu/2013/04/fedora-19-power-management-test-day.html
15:56:19 <adamw> #info freeIPA test day also seems to have gone well, lots of results in the matrix (including useful bug reports)
15:56:35 <adamw> #info upcoming is graphics test week - everyone please come out and test
16:00:00 <adamw> #topic open floor
16:00:08 <adamw> just as we hit the 1hr mark - anything for open floor?
16:00:36 <dan408> i'd like to move 906031 to beta blocker or nth or something
16:00:41 <adamw> so, propose it
16:00:41 <tflink> we're planning to start the process of moving the blocker tracking app to production later this week
16:00:44 <dan408> k
16:00:46 <adamw> this isn't a review meeting
16:01:10 <dan408> proposed.
16:01:38 <tflink> there are a couple of minor fixes that we're waiting on but if everything goes well, the migration should be complete in the next week
16:02:03 <tflink> there will be downtime with the migration but I'll send out a notice before that happens
16:05:17 <adamw> #info blocker proposal webapp should go into production this week
16:05:20 <adamw> anything else?
16:06:43 <tflink> nothing from me
16:06:57 <adamw> okay - schroedinger's cat is holding the fuse
16:07:07 <adamw> ...OR IS IT?!
16:08:21 <adamw> thanks for coming, folks
16:08:23 <adamw> #endmeeting